cvscedega Fehlermeldung

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
duplex
Newbie
Newbie
Beiträge: 27
Registriert: 13. Jun 2004, 10:39
Wohnort: Essen

cvscedega Fehlermeldung

Beitrag von duplex » 18. Dez 2004, 13:00

Hallo,

ich versuche cedega (die CVS-Version) zum Laufen zu bringen. Ich habe dazu ein Script benutzt, welches mir die lästige Handarbeit abnimmt.

Nach der erfolgreichen Installation habe ich versucht, mehrere Spiele zu installieren, allerdings immer ohne Erfolg mit der gleichen Fehlermeldung.

Gegooglet habe ich bereits, aber anscheinend bin ich der einzige mit diesem Problem?!

Hier der Output nach "cvscedega setup.exe":

-------------------------------------------------------------------------------------------
err:module:BUILTIN32_dlopen failed to load .so lib for builtin lz32.dll: /usr/li
b/cvscedega/lib/liblz32.so: undefined symbol: dllname
err:module:PE_fixup_imports Module (file) lz32.dll (which is needed by version.d
ll) not found
err:module:load_library can't load version.dll
wine: Unhandled exception, starting debugger...
Using wine_path: wine
00000001:00000002: create process 'H:\setup.exe'/0x400fa938 @00000000 (0<0>)
00000001:00000002: create thread I @00000000
GNU gdb 6.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i586-suse-linux".
Using host libthread_db library "/lib/tls/libthread_db.so.1".
00000001:00000002: loads DLL ntdll.dll @4004f000 (0<0>)
00000001:00000002: exception code=80000003
00000001:00000002: exception code=c0000005
[New Thread 2]
0x0000504a in ?? ()
trace: 98 => 80
* 1 Thread 2 (Running, priority normal) 0x0000504a in ?? ()
#0 0x0000504a in ?? ()
#1 0x404b56fc in __wine_spec_VER_init () at ver.spec.c:292
#2 0x404b2c6a in _init () from /usr/lib/cvscedega/lib/libversion.so
#3 0x4000d16c in call_init () from /lib/ld-linux.so.2
#4 0x4000d252 in _dl_init_internal () from /lib/ld-linux.so.2
#5 0x40311fb7 in dl_open_worker () from /lib/tls/libc.so.6
#6 0x4000cda6 in _dl_catch_error () from /lib/ld-linux.so.2
#7 0x40311740 in _dl_open () from /lib/tls/libc.so.6
#8 0x4035004b in dlopen_doit () from /lib/libdl.so.2
#9 0x4000cda6 in _dl_catch_error () from /lib/ld-linux.so.2
#10 0x40350415 in _dlerror_run () from /lib/libdl.so.2
#11 0x4034fff2 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#12 0x401f4bac in wine_dlopen (filename=0x804e131 "libversion.so", flag=2,
---Type <return> to continue, or q <return> to quit---
error=Variable "error" is not available.
) at port.c:582
#13 0x40117d8d in wine_dll_load (filename=0x406d2668 "version.dll",
error=0x406d2550 "\004&m@\f\177", errorsize=256) at loader.c:110
#14 0x400c5abd in BUILTIN32_dlopen (name=0x406d2668 "version.dll")
at builtin32.c:44
#15 0x400c5c04 in BUILTIN32_LoadLibraryExA (
path=0x403602d0 "C:\\WINDOWS\\SYSTEM32\\VERSION.dll", flags=0)
at builtin32.c:140
#16 0x40082fe5 in MODULE_LoadLibraryExA (libname=0x425fe2 "VERSION.dll",
hfile=0, flags=0) at module.c:1568
#17 0x40086ad9 in PE_fixup_imports (wm=0x40360240) at pe_image.c:303
#18 0x400871b8 in PE_CreateModule (hModule=4194304, filename=Variable "filename" is not available.
)
at pe_image.c:708
#19 0x400cc959 in start_process_pthread (param=Variable "param" is not available .
) at process.c:429
#20 0x403449dd in start_thread () from /lib/tls/libpthread.so.0
#21 0x402e1ffa in clone () from /lib/tls/libc.so.6
Wine-gdb> quit
The program is running. Exit anyway? (y or n) y
-------------------------------------------------------------------------------------------

Hat jemand ne Idee / ein paar Tips für mich?

Danke schonmal.
Tim


Edit: Habe ich völlig vergessen:
Mein System: SuSe 9.1, Kernel 2.6.5, Geforce 4 TI 4200

Werbung:
duplex
Newbie
Newbie
Beiträge: 27
Registriert: 13. Jun 2004, 10:39
Wohnort: Essen

Beitrag von duplex » 18. Dez 2004, 17:07

Ich habe es mittlerweile hinbekommen.

Das Problem lag an dem fehlerhaften (?) Compiler gcc.
Die Version 3.3.4 hat cvscedega anscheinend fehlerhaft compiliert, obwohl es keine Fehlermeldung ausgegeben hat.

Ich habe diesen dann deinstalliert und einen älteren Compiler installiert. Zu finden unter: http://portal.suse.de/sdb/de/2003/06/gcc33_release.html

Notwendig waren der C-Präprozessor, der C-Compiler, und der c++-compiler.

Anschließend müsste dann cvscedega richtig compiliert werden und laufen.

Jetzt kann man auch wieder den aktuellen Compiler installieren.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste