probs mit wine rack und /dev/dsp

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Gast

probs mit wine rack und /dev/dsp

Beitrag von Gast » 15. Feb 2004, 01:19

wenn ich bei transgaming (auf wine rack cd for suse 9.0) den soundtest starte, werde ich mit einer fehlermeldung abgespeist, die da lautet: /dev/dsp nicht richtig konfiguriert. Doch ich habe sound und alsa 1.0.2 läuft prob.los, plz. help, will doch auch endlich mit sound cs spielen, ist sonst fasst unmöglich zu gewinnen....

mfg mihau alias michiSPO

Werbung:
Benutzeravatar
Klaus
Newbie
Newbie
Beiträge: 34
Registriert: 17. Jan 2004, 17:12

Beitrag von Klaus » 15. Feb 2004, 01:38

Hallo michiSPO

Da muss ich dich leider endtäuschen :cry:

Transgaming funzt (nach meiner info) nur mit OSS und nicht mit alsa.

d.h. du müsstest entweder statt den alsa-modulen die oss-mods installen (was ich dir bei SuSE nicht unbedingt anraten würde) oder auf den Sound verzichten.


Gruß


Klaus
Wenn du glaubst es geht nicht mehr, kommt von irgendwo ein Linux her. :)

Gast

don't know why

Beitrag von Gast » 15. Feb 2004, 12:07

we installiere/start ich denn die ossmodule? alsa stopp ich doch mit 'rcalsasound'. wie starte ich oss?

mfg michi

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

SuSE und OSS

Beitrag von der_schreiner » 15. Feb 2004, 16:12

Bei SUSE LINUX 9.0 Professinal wird der OSS Treiber automatisch installiert, denn meine Programme wie TeamSpeak und XMMS (habe ich auf OSS gestellt) laufen über OSS einwandfrei.

Lege die DVD/CD von SuSE ein, und suche im Installtionsbreich von Yast nach OSS und installiere die Packete.

Gast

habe nun auf OSS umgestellt...

Beitrag von Gast » 15. Feb 2004, 17:56

...naja, zum mindestens in kcontrol unter sound+multimedia/soundsystem. xmms habe ich auch hinbekommen, so dass er musik erklingen lässt und im mc klappt soundtechnisch auch alles, halt nur nicht mein trasgaming von der wine rack cd. jetzt sagt er mir aber nichts mehr mit /dev/dsp sondern : Es kann kein Sound abgespielt werden, möglicherweise ist ihre soundkarte nicht richtig installiert worden. naja bin langsam am aufgeben, aber vielleicht hat ja doch noch jemand eine gute idee.

mfg michiSPO

ps.: Quake III Arena läuft auf Linux (ohne Wine Rack) hammer geil, werde es nie auf Windows zocken....

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Probiers mal mit..

Beitrag von der_schreiner » 15. Feb 2004, 18:21

Probiers mal mit dem Packet "libao", welches sich auf der SuSE LINUX 9.0 DVD 1 befinden sollte. Dies sollte den Bereich OSS regeln.

Hoffentlich hilft das weiter. :?: :!:

Gast

libao war schon installiert....

Beitrag von Gast » 15. Feb 2004, 18:45

libao war schon installiert, habe aber noch die libao-arts.rpm dazugenommen, naja, und was soll ich sagen.... leider immernoch das selbe problem

Gast

Beitrag von Gast » 15. Feb 2004, 19:06

ist aber auch gleich auf allen drei rechnen (alle suse 9.0 pro) das gleiche, hat es denn überhaupt schon jm zum laufen gebracht?

mfg michael

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Ja

Beitrag von der_schreiner » 15. Feb 2004, 21:54

Bei mir läufts problemlos, allerdings kann nur ein Programm die Soundkarte ansteuern, dh. Game Sound oder TeamSpeak z.B. (Soundblaster PCI 128)

Gast

Beitrag von Gast » 15. Feb 2004, 22:07

wie sehe ich denn, welche programme auf die soundkarte zugreifen? denke es liegt an OSS, aber mangels wissen kann ich tux nicht anweisen, oss-module anstatt alsa zu verwenden, hilfe wäre toll, mfg michael

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Frage

Beitrag von der_schreiner » 16. Feb 2004, 18:36

Drücke mal CTRL-ESC und schaue ob ein Programm Namens "knotify" gestartet wird (Hat ein Note als Zeichen) beende diesen Prozess und schaue ob es dann geht. Falls ja, lösche alle Packete die damit zusammenhängen, das Ding macht nur stress, seit ich es gelöscht habe geht es mir besser!! :D

Gast

Beitrag von Gast » 19. Feb 2004, 18:56

kann nicht an knotify liegen, da winerack auch unter gnome und blackbox genausowenig funzt. und wenn ich knotify kicken wollte, müßte ich die kdelibs3 entfernen, und das bringts glaub ich nicht... wie heißt denn die binary, die den knotify prozess hervorruft?

Kannst du mir denn genau erklären, was genau du installiert/deinstalliert, modifiziert, etc. hast, um winerack zum laufen zu kriegen? Quasi ein komplettes HOWTO... von Grundinstallation "Standartsystem" bis zum lauffähigen Winerack MIT sound?

Herzlichen Dank im Vorraus

michiSPO

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Am besten...

Beitrag von der_schreiner » 20. Feb 2004, 17:47

Hab nur einen kleinen Tipp:

Mache ein Online Update und wähle das Verzeichnis der CD (vorher mounten) er sollte alles nötige installieren, dass ist alles was ich gemacht habe. :idea:

Gast

Beitrag von Gast » 22. Feb 2004, 11:25

naja, hat alles nichts gebracht, naja, dafür läuft meine wlan karte (ohne emulator). weiß, es gehört nicht hierher, freue mich trotzdem riesig....


werde es einfach nochmal auf nn paar anderen rechnern versuchen, und dann wohl entnervt aufgeben müssen, trotzdem vielen dank

euer michiSPO

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

WineX

Beitrag von der_schreiner » 22. Feb 2004, 14:10

ich habe im Ortner /opt/kde3/ alle Dateien mit dem Namen knotify gelöscht (basteln), aber ist sicherlich keine gute Lösung, da ich die Soundeinstellungen nach jedem Neustart neu einstellen muss. Ich denke ich kann die mit dem WineRack nicht weiterhelfen, aber alternativ kannst du dir die CVS Version von WineX ziehen und diese komplieren (WineX 3.3), diese Version kann sowieso mehr emulieren als die ältere, das Problem ist dann nur, dass du kein point2play hast und einiges mehr zu basteln hast, beim installieren und konfigurieren von Games.

Gast

Beitrag von Gast » 22. Feb 2004, 18:31

danke für deine hilfe, basteln ist für mich glaube ich kein problem, wenn doch finde ich im forum wohl genug anleitungen.

Ist vorallendingen schade, dass ich anderen dann nicht zeigen kann, wie einfach es z.b geht, warcraft III oder cs zu installieren.

für mich selbst ist nur cs wichtig, alle anderen meiner favourits können direkt unter linux gespielt werden (loki -schnief- und idsoft sei dank).

also, wenn mir noch irgenwann ne löung meines probs über den weg läuft, werde ich sie hier posten.

mfg michiSPO

P.S.: Das Programm knotify finde ich richtig ätzend, seitdem ich gemerkt habe, dass dieses und der konqueror dafür verantwortlich ist, dass ich ab und zu meine gemounteten cds nicht wieder aus dem laufwerk bekomme. Also werde ich es trotzdem löschen, auch wenn es für das andere nichts bringt.

Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Ja, ausser

Beitrag von der_schreiner » 25. Feb 2004, 21:27

Ausser das man kein Startsound und sonstige nervige Geräusche hat, muss man auf nichts verzichten, wenn man "knotify" löscht, zumindest geht bei mir alles andere noch.

gerd1354

etvl. Lösung...

Beitrag von gerd1354 » 8. Mai 2004, 18:33

Hallo!
Habe auch das Problem, das bei Point2Play meine Soundkarte gar nicht erkannt wird. Habe aber trotzdem Warcraft 3 mit Sound zum laufen bekommen.
Ich starte winex nicht über Point2play, sondern über die Kommandozeile mit dem Befehl:
winex -use-pthreads yes -winver winme /pfad/zur/exe
Damit kann man das Spiel installieren und starten.
Nun zum Soundproblem:
Ich habe aus der Config von Wine ( /home/Benutzer/.wine/config) folgende Zeilen in die config von WineX kopiert ( /home/Benutzer/.transgaming/config) und diese noch etwas angepasst:

[WinMM]
; Uncomment the "Drivers" line matching your sound setting.

"Drivers" = "wineoss.drv" ; default for most common configurations
;"Drivers" = "winearts.drv" ; for KDE
;"Drivers" = "winealsa.drv" ; for ALSA users
;"Drivers" = "winejack.drv" ; for Jack sound server
;"Drivers" = "winenas.drv" ; for NAS sound system
;"Drivers" = "wineaudioio.drv" ; for Solaris machines
;"Drivers" = "" ; to disable sound
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

[dsound]
;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
;"HELmargin" = "5"
;; HEL only: Number of waveOut fragments ahead to queue to driver.
;"HELqueue" = "5"
;; Max number of fragments to prebuffer
;"SndQueueMax" = "28"
;; Min number of fragments to prebuffer
;"SndQueueMin" = "12"
;; Forces emulation mode (using wave api)
;"HardwareAcceleration" = "Emulation"
;; Sets default playback device (0 - number of devices - 1)
"DefaultPlayback" = "0" ; use first device (/dev/dsp)
;"DefaultPlayback" = "1" ; use second device (/dev/dsp1)
;"DefaultPlayback" = "2" ; use third device (/dev/dsp2)
;; Sets default capture device (0 - number of devices - 1)
"DefaultCapture" = "0" ; use first device (/dev/dsp)
;"DefaultCapture" = "1" ; use second device (/dev/dsp1)
;"DefaultCapture" = "2" ; use third device (/dev/dsp2)

[wineoss]
"UseMMap" = "Y"
"FullDuplex" = "Y"

Ich verwende ALSA mit OSS Emulation (glaube ich zumindest), d.h. das Modul snd-seq-oss sollte geladen sein. ( siehe lsmod ).
Allerdings bricht bei mir die Installation von Crimson Skies mit einer Fehlermeldung ab, das die Audiokompriemierung nicht installiert sei.
Desweiteren versuche ich gerade das Netzwerk unter winex zum laufen zu kriegen.

Hier noch meine Systemdaten:
SuSE Linux 9.0
AMD Athlon XP2000+
Soundblaster Live! 1024 Player
Abit NF7 Board mit 512 MB Ram

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast