vmware läuft einfach nicht!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
delija999
Newbie
Newbie
Beiträge: 15
Registriert: 13. Nov 2004, 21:25

vmware läuft einfach nicht!

Beitrag von delija999 » 5. Dez 2004, 13:49

cd /usr/src/linux (dieses verzeichnis habe ich gar nicht)
make cloneconfig
make prepare

wenn ich vmware starten will habe ich folg fehler:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Gtk-WARNING **: cannot open display: :0.0


wie kann ich die vmware zum laufen bringen?

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: vmware läuft einfach nicht!

Beitrag von Martin Breidenbach » 5. Dez 2004, 15:53

delija999 hat geschrieben:cd /usr/src/linux (dieses verzeichnis habe ich gar nicht)
make cloneconfig
make prepare
Wozu machst Du dann make cloneconfig und make prepare ? Installiere doch erstmal die Kernelquellen.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

delija999
Newbie
Newbie
Beiträge: 15
Registriert: 13. Nov 2004, 21:25

Beitrag von delija999 » 5. Dez 2004, 21:39

welche genau? sorry aber ich bin ein anfänger.
sind die auf der cd oder muß ich es aus dem net saugen?

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 5. Dez 2004, 21:59

Bei der VMware-Installation (vmware-config.pl) werden Kernelmodule installiert.

Kernelmodule müssen auf den jeweils laufenden Kernel angepaßt werden.

Um das selber zu machen müssen die Kernel-Quellen installiert werden.

Welche Linux-Version hast Du ? Bei SuSE heißt das Paket kernel-source oder so ähnlich. Geh im Yast auf 'Software installieren' und gib als Suchbegriff 'Kernel' ein.

Bei SuSE 9.1 Personal sind die Kernelquellen nicht dabei - die muß man dann vom SuSE FTP Server laden.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

delija999
Newbie
Newbie
Beiträge: 15
Registriert: 13. Nov 2004, 21:25

Beitrag von delija999 » 6. Dez 2004, 22:13

ich habs geschaft die vmware zum laufen zu bringen nur beim booten kontrolliert die vm nur mein floppy und nicht mein dvd-laufwerk. ich habs probiert zu ändern (in vm und im boot sector von der win vm) und nicht geschaft.
wie kann ich es ändern daß die vm von der cd bootet?

axel-vmware
Newbie
Newbie
Beiträge: 16
Registriert: 14. Sep 2004, 17:06

Beitrag von axel-vmware » 7. Dez 2004, 09:55

Vielleicht hilft bei VM unter Settings beim DVD-Laufwerk die "Leagcy emulation" zu aktivieren.

Gruß

Axel

Yogi Bär
Newbie
Newbie
Beiträge: 1
Registriert: 8. Dez 2004, 17:56

bekomme vmware einfach nicht zum laufen

Beitrag von Yogi Bär » 8. Dez 2004, 19:35

Hallo,
bitte um Hilfe
habe alles gemacht, (Suse 9.2 als Host)
make cloneconfig
make prepare

nun kommt vmware-config.pl

Building the vmon module.
...
/tmp/vmware-conig0/vmmon-only/linux/hostif.c: In Function 'MapCrossPage'
/tmp/vmware-conig0/vmmon-only/linux/hostif.c:566: error: 'PAGE_KERNEL_EXECUTABLE' undeclared (first use in this function)
/tmp/vmware-conig0/vmmon-only/linux/hostif.c:566: error: (Each undeclared identifier is reported ly once
/tmp/vmware-conig0/vmmon-only/linux/hostif.c:566: error: for each function it appears in.)
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/hostif.o] Error 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
make[1]: Leaving directory '/usr/src/linux-2.6.8-24'
make: *** [vmmon.ko] Error2
make: Leaving directory '/tmp/vmware-config0/vmmon-only
Unable to build the vmmon module
Execution aborted

wäre sehr dankbar über Hilfe
schonmal danke im voraus
joi

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 8. Dez 2004, 20:35

Hast Du 32bit oder 64bit Version ?

Ich kann Dir zu dem Fehler leider nix spezielles sagen - bei mir lief es einfach so ohne besonderen Widerstand.

Eventuell hilft der vmware-any-any Patch (siehe links)
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast