Teil-LÖSUNG - Sound LTSP 4.1 - Suse 9.2

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

tomtom
Newbie
Newbie
Beiträge: 10
Registriert: 18. Nov 2004, 23:55

Teil-LÖSUNG - Sound LTSP 4.1 - Suse 9.2

Beitrag von tomtom » 19. Nov 2004, 00:28

-LTSP 4.1 normal einrichten.

- ltsp.conf:

[wsxxx]
SOUND = Y
SOUND_DAEMON = esd (wichtig!)

- XMMS & XINE auf esound/esd einstellen (bei xmms u.U. nachinstallieren, xine bringt esd standardmäßig mit)

- Bei Verwendung von KDE, im Kontrollzentrum das Soundsystem (artsd) abschalten.

Nachteil bzw. warum nur Teillösung:
1. Andere Programme oder Spiele geben keinen Sound ab.
2.Der "normale" Mixer funktioniert nicht. In den Programmen kann man die Lautstärke zwar nur etwas verzögert einstellen, aber immerhin.
3. Es sollte lt. ltsp.org auch mit der Verwendung von artsd funktionieren. Dann würden alle Systemklänge und sehr wahrscheinlich auch die meisten Programme/Spiele unter KDE mit Sound funktionieren. Ich konnte jedoch trotz viel "rumschrauben" keine Lösung finden.

Achtung:
- getestete Karte: Soundblaster PCI 64
- Soundblaster AWE 64 ISA und FM801 (billige PCI-Karte) konnten auch mit manuellen Einstellungen nicht zum Laufen gebracht werden.

Hoffe, ich konnte dem Ein oder Anderen helfen.

Mfg

Tom

Ps. Ach ja, wenn der Client ca. 400 Mhz und eine einigermaßen ordentliche Graka (min. 16MB, besser 32MB) hat, laufen Videos über Xine im Vollbild flüssig und ohne Fehlermeldung.

Werbung:
tomtom
Newbie
Newbie
Beiträge: 10
Registriert: 18. Nov 2004, 23:55

Nachtrag

Beitrag von tomtom » 20. Nov 2004, 20:36

Hi nochmal,

Fortemedia = fm801 (PCI Billigkarte) - läuft
Soundblaster AWE 64 ISA - läuft

Diese Karten werden vom Sounddaemon nicht erkannt. Manuelle Einstellungen in der lts.conf:

AWE 64:

MODULE_01 = sound
MODULE_02 = uart401
MODULE_03 = "sb irq=5 dma=1 dma16=5"
SOUND = Y
SOUND_DAEMON = esd

FM801:

MODULE_01 = sound
MODULE_02 = forte
SOUND = Y
SOUND_DAEMON = esd

Achtung: Die Reihenfolge der Module ist wichtig! Desweiteren darf die Endung ".so" nicht angegeben werden (steht in der alten Sound-Readme anderst drin). Die Liste der unterstützten Karten ist im Verzeichnis: /opt/ltsp/i386/lib/modules/2.4.26-ltsp-2/kernel/drivers/sound
ersichtlich.

So long

Tom

Gast

Sound mit arts

Beitrag von Gast » 23. Nov 2004, 15:39

Also Sound mit arts läuft auch ganz ok. Hat den Vorteil, dass auch die ganzen Soundspielereien unter KDE wie zBsp. Systemnachrichten funktionieren.
Vorgehensweise ist im Sound-Howto http://www.bravegnuworld.com/~rjune/lts ... -arts.html beschrieben. Die einzige kitzekleine Gemeinheit ist, dass man arts neu kompilieren muss, um nas-support hineinzubekommen.
Ansonsten tuts, und der xine-player hat auch Ton-Ausgabe.

techie
Newbie
Newbie
Beiträge: 11
Registriert: 23. Nov 2004, 15:22

Beitrag von techie » 23. Nov 2004, 15:41

Hups, war noch nicht eingelogged. Obige Post kommt von mir :oops:

tomtom
Newbie
Newbie
Beiträge: 10
Registriert: 18. Nov 2004, 23:55

wie nas kompilieren

Beitrag von tomtom » 25. Nov 2004, 21:21

@techie

wie hast Du NAS installiert bekommen? Ich scheitere schon an den benötigten Tools: "imake" und "xmkmf".

Am besten wäre ein SRPM, oder?

cu

Tom

techie
Newbie
Newbie
Beiträge: 11
Registriert: 23. Nov 2004, 15:22

Beitrag von techie » 26. Nov 2004, 11:48

nas habe ich als source runtergeladen und selbst kompiliert. Lief soweit ich mich erinnern kann normal durch. Kann dir für Suse 9.2 aber auch das rpm bereitstellen wenn du willst - habe es mit checkinstall erzeugt. Checkinstall ist im übrigen sehr zu empfehlen.
Für arts habe ich mittlerweile ebenfalls ein rpm erstellt, das den nas support schon drin hat. Interesse?

tomtom
Newbie
Newbie
Beiträge: 10
Registriert: 18. Nov 2004, 23:55

nas & arts rpm für suse 9.2

Beitrag von tomtom » 26. Nov 2004, 12:41

Die RPMs wären echt super! Kannst Du die hier verlinken?

Nur zum Verständnis, wo hast die Tools bekommen, die in der README zu NAS verlangt werden? "imake" und das andere Dingsbums gibts weder auf den Suse-CDs noch bei rpmseek.

Ein normales "make" bringt nur Fehler (zuviel zum posten, da passt was grundsätzlich nicht).

cu

Tom

Gast

Beitrag von Gast » 26. Nov 2004, 15:14

2. Do "xmkmf" to create the initial Makefile.

For Unixware 7, use:

"imake -DUseInstalled -I/usr/lib/X11/config"
Also du braucvhst nur xmkmf, und ads ist glaub ich in den X11 Developer rpms dabei. Ich gucks aber nochmal nach. Die rpms poste ich heute abend.


Gast

Beitrag von Gast » 9. Dez 2004, 09:19

Hallo
Ich habe gerade auch SuSE 9.2 und LTSP 4.1 installiert. Ich hab Linux Erfahrung, bin aber mit dem LTSP neu.
Natürlich hätte ich auch gern Sound auf den Clients. Es fehlen mir aber dazu noch ein paar Zusammenhänge. Was also ist genau zu tun:

auf dem Server:
-arts deinstallieren
-arts-devel deinstallieren
- dafür diese 4 obigen packete installieren
(wofür ist eigentlich arts-gmcop)
offene Fragen:
- muss das sound-script aus dem LTSP installiert werden, das da in /etc/profile eingehängt wird?
- muss man im KDE irgendwas einstellen?

auf dem Client:
- lts.conf: hier hab ich nach obigen Muster die Soundkarte eingebunden.
MODULE_01 = sound
MODULE_02 = opl3
SOUND = Y
SOUND_SERVER = ? (wo ist dieser Parameter dokumentiert?)

Beim booten bekomme ich auf dem Client die Fehlermeldung " /dev/dsp : device not found", es giebt nur /dev/dspW.

Giebt es noch Einstellungen auf dem Client (z.B. Kontrollzentrum)?

Was ist noch zu tun, damit ich auf den Clients KDE-Sound bekomme? Wie läuft das dann mit z.B. mplayer?

Welche debugging tools habe ich, wenn z.B. eine Anwendung mplayer keinen Sound bringt?

Ich freue mich über Antworten. Ich mache dann gern auch ein kleines HOWTO daraus. Leider ist der Sound Bereich vom LTSP nicht sio gut dokumentiert.

Danke Eddy

techie
Newbie
Newbie
Beiträge: 11
Registriert: 23. Nov 2004, 15:22

Beitrag von techie » 9. Dez 2004, 18:17

Dritter Post von oben :
Also Sound mit arts läuft auch ganz ok. Hat den Vorteil, dass auch die ganzen Soundspielereien unter KDE wie zBsp. Systemnachrichten funktionieren.
Vorgehensweise ist im Sound-Howto http://www.bravegnuworld.com/~rjune/lts ... -arts.html beschrieben. Die einzige kitzekleine Gemeinheit ist, dass man arts neu kompilieren muss, um nas-support hineinzubekommen.
Ansonsten tuts, und der xine-player hat auch Ton-Ausgabe
Lies Dir das Howto durch, da steht alles genau drin. Da Du die Pakete von mir verwenden möchtest, trägst Du in der Config
SOUND_DAEMON=nasd
ein.
Sound Server lässt Du weg, das wird von NAS automatisch über die DISPLAY Variable gesetzt: automatisch bedeutet, daß da wo die Bildschirmausgabe erfolgt auch der Sound hingeschickt wird.

arts-gmcop wird nicht unbedingt benötigt - nur wenn Du es schon vorher installiert hattest, brauchst Du die aktualisierte Version von mir.

Wenn Du nicht klar kommst, poste einfach nochmal.

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Dummy-Howto für SOUND

Beitrag von Marc » 18. Dez 2004, 18:31

Hallo techie und TomTom,

ich wurschtel nun schon seit geraumer Zeit mit unterschiedlichsten Anleitungen rum und komme aber zu keinem Ergebnis.
Vielleicht könntet ihr mir nochmals helfen.

Da bei mir der esound (esd) nicht funktioniert, - bekomme ich nicht gestartet, da irgendwas in der esd.conf stört - habe ich mich nun an nasd ran gemacht.

[ "-terminate" verhindert in esd.conf den Start des Daemons und auskommentieren bringt auch keine Lösung.]

NAS durch das rpm von techie installiert (danke) . Konnte den Dienst aber auch nicht starten, weil ich nicht weiß wie?
Hier gehen meine Probleme weiter...
Brauche ich die libaudiooss??
Ist die Installationsreihenfolge wichtig?

Fragen über Fragen....
Kann da nicht einer von euch eine Dummy-Anleitung schreiben?

Danke für eure Hilfe und die viele Vorarbeit.
Gruß
Marc

Gast

Beitrag von Gast » 18. Dez 2004, 20:55

Kann da nicht einer von euch eine Dummy-Anleitung schreiben?
Ich dachte das hätte ich schon getan?! Eigentlich ist alles erledigt, wenn Du die RPMs installiert hast. Kannst Du denn jetzt schon im KDE Kontrollzentrum als Soundausgabe NAS auswählen? Wenn nicht, hast Du die Pakete vermutlich nicht installiert.

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Beitrag von Marc » 19. Dez 2004, 13:18

Hallo,
Zitat:
Kann da nicht einer von euch eine Dummy-Anleitung schreiben?
Ich dachte das hätte ich schon getan?!
Für manche User kann es nicht einfach genug sein! :oops:
Ich habe alle Pakete über konquerer/yast installiert und habe nach wie vor das gleiche Problem....
NAS taucht unter Kontrollzentrum>Soundsystem>Hardware leider nicht auf.
Ich habe aber dort schon mal Sound im Netzwerk angehakt.
Auch über den Runlevel-Editor kann ich NAS nicht aktivieren....
,weil der dort nicht geführt wird.
Wie starte ich den nas-Daemon von der Konsole aus?
Ein rcnasd status oder start ergibt: Command not found.

Wie beschrieben habe ich noch immer ein esound-Problem.
"Starting esound to run as persistent daemon, you must not have -terminate in /etc/esd.conf"
Kann mir da vielleicht mal einer seine funktionierende esd.conf schicken???

Hoffentlich könnt ihr helfen...

Gruß
Marc

techie
Newbie
Newbie
Beiträge: 11
Registriert: 23. Nov 2004, 15:22

Beitrag von techie » 19. Dez 2004, 13:36

Der nasd startet sich von selbst. Da muß nix von hand gestartet werden. Wenn Du im KDE Kontrollzentrum als Soundsystem nicht "Netzwerk Audiosystem" auswählen kannst, sind die Pakete nicht installiert. Mache folgendes:
Am Server:
init 2
cd <da sind die rpm pakete von mir und sonst nix>
rpm -i --force *.rpm
init 5

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

nasd installiert

Beitrag von Marc » 19. Dez 2004, 14:08

Hallo techie,
zunächst mal denke für die Geduld...

nun zu meinem Problem.
nasd konnt eich installieren und aktivieren unter Kontrolcenter.
Leider stürzt der Soundserver artsd ab.
Folgende Fehlermeldung erhalte ich....

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1083968960 (LWP 8602)]
[KCrash handler]
#7 0x407f2f73 in strlen () from /lib/tls/libc.so.6
#8 0x40120a0b in Arts::AudioIONAS::open (this=0x808a6b8) at char_traits.h:143
#9 0x40129fbc in Arts::AudioSubSystem::open (this=0x8086dd8)
at audiosubsys.cc:372
#10 0x4012a142 in Arts::AudioSubSystem::check (this=0x8086dd8)
at audiosubsys.cc:352
#11 0x08057e7d in main (argc=17, argv=0xbfffe434) at reference.h:118

Folglich kann das Aufrufen des Soundservers über den MPlayer nicht funktionieren.
Ich habe auch eine Idee voan es liegt.
Ich habe ja zunächst die arts-Dateien via Yast deinstalliert um deine neu zu installieren.
Bei der Abhängigkeitsprüfung habe ich die abhängigen oder dranhängenden Dateien nicht(!) gelöscht, weil ich Sorge hatte, das komplette System zu zerschießen. Ich hätte jede Menge kde-Verbindungen deinstallieren müssen.

Was meinst du?

Gruß
Marc

techie
Newbie
Newbie
Beiträge: 11
Registriert: 23. Nov 2004, 15:22

Beitrag von techie » 19. Dez 2004, 14:25

Die Pakete von mir sind lediglich neu erstellte SuSe rpms, also solltest Du in yast keinerlei Probleme mit unerfüllten Abhängigkeiten haben. Also prüfe in yast, ob alle Paketabhängigkeiten erfüllt sind, klicke bei den Paketnamen, die Du von mir geladen hast, auf Details, und prüfe, ob die "Bauzeit" unter technische Daten 12/04 ist. Dann weist Du, dass meine Pakete installiert sind. Danach starte den Rechner neu. Logge dich über dein Terminal wie gewohnt am Server ein, und schalte im Kontrollzentrum dann auf NAS und Netzwerksound um. Da gibt es ein Knopf "Sound testen" oder so ähnlich, bevor du damit nicht eine Tonausgabe hinbekommst, brauchst Du es mit externen Programmen erst gar nicht versuchen.
Da Du jetzt vermutlich schon ziemlich viel getestet hast, versuche lege einen neuen Benutzer mit yast an und logge Dich unter diesem neuen Benutzernamen ein. Wichtig: Die ganzen Einstellungen nimmst Du von deinem Terminal aus vor, nicht am Server!

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Beitrag von Marc » 19. Dez 2004, 15:02

Hi Techie,
Die Pakete von mir sind lediglich neu erstellte SuSe rpms, also solltest Du in yast keinerlei Probleme mit unerfüllten Abhängigkeiten haben. Also prüfe in yast, ob alle Paketabhängigkeiten erfüllt sind, klicke bei den Paketnamen, die Du von mir geladen hast, auf Details, und prüfe, ob die "Bauzeit" unter technische Daten 12/04 ist. Dann weist Du, dass meine Pakete installiert sind.
gemacht!
Danach starte den Rechner neu.
Jetzt auch gemacht! - Ist ja wie bei Windows.... :wink:
Logge dich über dein Terminal wie gewohnt am Server ein, und schalte im Kontrollzentrum dann auf NAS und Netzwerksound um.
Und dann bekomme ich wieder die oben gemeldete Fehlermeldung.
Da gibt es ein Knopf "Sound testen" oder so ähnlich, bevor du damit nicht eine Tonausgabe hinbekommst, brauchst Du es mit externen Programmen erst gar nicht versuchen.
Das Problem ist, ich habe keine Soundkarte im Server. Ist halt ein richtiger(!) Server. :roll:
Da Du jetzt vermutlich schon ziemlich viel getestet hast, versuche lege einen neuen Benutzer mit yast an und logge Dich unter diesem neuen Benutzernamen ein. Wichtig: Die ganzen Einstellungen nimmst Du von deinem Terminal aus vor, nicht am Server!
Stimmt!
Bin auch schon ein wenig genervt. Umso dankbarer bin ich für deine Unterstützung.
Aber wenn der Soundserver streikt, dann brauche ich auch keinen neuen Benutzer anlegen.
Ich radiere nochmals deine Dateien und die abhängigen Dateien vom System...
Mal sehen wie weit ich dann komme.

Bis später
Marc

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Beim Deinstallieren kein Hinweis

Beitrag von Marc » 19. Dez 2004, 15:09

Hallo Techie,

jetzt versteh ich die Linux-Welt nicht mehr.
Beim Löschen deiner rpms via Yast wurden keine Abhängigkeiten angezeigt. Ist das normal????

Naja, ich bügel deine rpms nochmals über.
Werde schon sehen, was passiert.
Hast du einen Vorschlag bezüglich der esd.conf - Fehlermeldung, bzw. kannst du mir deine esd.conf mal senden?

Danke und Gruß aus Kleve

Marc

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Beim Deinstallieren kein Hinweis

Beitrag von Marc » 19. Dez 2004, 15:15

Hallo Techie,

jetzt versteh ich die Linux-Welt nicht mehr.
Beim Löschen deiner rpms via Yast wurden keine Abhängigkeiten angezeigt. Ist das normal????

Habe feststellen müssen, das Yast arts einfach mitinstalliert, wenn ich nas*.rpm installiere. Mache das nochmals händisch auf der Konsole.

Naja, ich bügel deine rpms nochmals über.
Werde schon sehen, was passiert.
Hast du einen Vorschlag bezüglich der esd.conf - Fehlermeldung, bzw. kannst du mir deine esd.conf mal senden?

Danke und Gruß aus Kleve

Marc

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste