Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[HOWTO] GMX-Mediacenter (1GB) als Laufwerk mounten

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

[HOWTO] GMX-Mediacenter (1GB) als Laufwerk mounten

Beitrag von Snubnose » 10. Okt 2004, 17:08

Hallo !!! Dankenswerterweise hat GMX das quota für User auf 1 GB hochgesetzt. Seitdem lohnt es sich wirklich diesen Platz als Backup/Sharespace zu verwenden. Dadurch dass GMX dazu auch noch die Schnittstelle WEBDAV kann dies relativ simpel ins M$ Windows / Linux eingebunden werden.
Hier das Linux-Howto: (mit SuSE 9.1, Kernel 2.6 getestet)
Benötigt wird das davfs2 - http://dav.sourceforge.net/
Die Binaries dort bringen nichts da sie kein SSL-Support haben was aber für GMX gebraucht wird.
WICHTIG: ab und zu sind hier Zeilenumbrüche die nicht da sein dürften - ich bitte darauf zu achten....
Also laden wir uns die Sourcen:

Code: Alles auswählen

cd /tmp
md davfs
cd davfs
wget http://osdn.dl.sourceforge.net/sourceforge/dav/davfs2-0.2.2.tar.gz
tar -xzvf davfs2-0.2.2.tar.gz
cd davfs2-0.2.2/
Da sich einige Dinge geändert haben mit dem 2.6er Kernel muss man die sourcen noch patchen:

Code: Alles auswählen

wget "http://sourceforge.net/tracker/download.php?group_id=26275&atid=386749&file_id=98033&aid=1010491" -O patch.diff
patch -p1 < patch.diff
./autogen.sh
dann geht es ans kompilieren:
benötigte Pakete (neben den Standardentwicklungstools:)
openssl-devel
neon

Code: Alles auswählen

./configure --with-ssl
make
su
make install
ln -s /usr/local/sbin/mount.davfs /bin/mount.davfs
Okay, jetzt können wir das verwenden, einfach nur mit

Code: Alles auswählen

mkdir /mnt/gmx
mount.davfs https://mediacenter.gmx.net /mnt/gmx/ -o username=USERNAME\@gmx.de,password=PASSWORD,gid=users,mode=755,nolocks=1
das ganze mounten

Werbung:
Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

Beitrag von Snubnose » 29. Okt 2004, 08:29

soo, hier ein kleiner Post - ich denke der Thread ist erhaltungswert und ich weiss nicht wann leere Threads gelöscht werden....

p.s.: beim davfs2 funktioniert die rename funktion nicht...

Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe » 5. Dez 2005, 21:40

mittlerweile ist die Version 0.2.6 von davfs2 draußen. Ich habe die sources ohne den Patch mit dem Kernel 2.6.11.4-21.9 wunder kompilieren können.

Einige Dinge muss man aber von Hand machen:

Symlink setzen
weicht von der oberen Beschreibung ab (sbin statt bin)

Code: Alles auswählen

ln -s /usr/local/sbin/mount.davfs /sbin/mount.davfs 
Ordner /var/run/mount.davfs/ erstellen
hier wird die PID abgelegt
als root

Code: Alles auswählen

# mkdir /var/run/mount.davfs
# chown root.users /var/run/mount.davfs
# chmod 1774 /var/run/mount.davfs
Tipps

Man kann den mount-Befehl vereinfachen:

~/.davfs2/secrets anlegen
in dieser Datei können Zugangskennung sowie Passwort abgelegt werden.
- im Home-Verzeichnis den versteckten Ordner namens .davfs2 erstellen,
- man kopiere die /usr/local/share/davfs2/secrets.template in das vorhin erstellte Verzeichnis
- umbenennen der Datei in secrets
- in der Datei sind Beispieleintragungen vorhanden, an diesen orientierend eintragen:

Code: Alles auswählen

https://mediacenter.gmx.net    1234567            deinpasswort
1234567 ist die Kundennummer von gmx
beim Passwort die Sonderregel mit Sonderzeichen beachten (steht in der Datei!)
diese Datei ist nicht verschlüsselt! Benutzung auf eigene Gefaht


fstab bearbeiten
in die /etc/fstab eintragen:

Code: Alles auswählen

https://mediacenter.gmx.net	/mnt/gmx	davfs	user,noauto 0 0
nun sollte ein

Code: Alles auswählen

mount /mnt/gmx 
den mediacenter von gmx mounten können!

PS. ich hoffe ich habe keinen Schritt vergessen, im Falle melden.
Das ganze ist auch in der Readme von davfs2 nachzulesen, die aber etwas unstruckturiert geschrieben ist. Manche Handarbeit, die man angäblich nur mit den Binär-Dateien machen muss, ist auch für die Kompilierer notwendig.

Gruß pawe
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

GMX Mediencenter

Beitrag von dma67 » 6. Dez 2005, 00:58

Hallo,
ich habe die Tage das System auf meinem neuen Asus aufgesetzt und versucht wieder GMX-Mediencenter einzubinden.
Vor ca. 1 Monat klappte es ohne Probleme und mit davfs2-0.2.6 - nun versuchte ich heute dasselbe Spiel - ohne Erfolg.
Vor 4 Tagen habe ich KDE 3.5 aufgespielt - alles ohne Probleme. Kann das die Ursache für die Probleme mit davs2 sein?
bei

Code: Alles auswählen

./configure --with-ssl
bekomme ich:

Code: Alles auswählen

configure: incompatible neon library version 0.24.4: wanted 0.24
configure: error: could not find neon

bzw.

Code: Alles auswählen

configure: incompatible neon library version 0.24.7: wanted 0.24
configure: error: could not find neon


Tja, das ist darauf zurückzuführen dass ich neon 0.24.7 (und neon-devel selbstverständlich auch) und dann die Version 0.24.4 installierte - in der Hoffnung, dass davsf2 das als 0.24-Version akzeptiert. Weiter downgroaden geht es nicht, dann ist es nur 0.23.9 - und es schreit danach, vieles zu deinstallieren - was ich natürlich nicht riskieren wollte. Bei meiner Suse-Distri (10.0) ist es standardmäßig 0.24.7 bis Suse 9.1 sogar....

Ich habe jetzt keine Idee mehr,wie das umzugehen ist.
Weiß jemand Rat???

Danke!

Darius


2nd Edition. Alles klar!!!!

Ich habe eine
davfs2-0.2.6-0.1.i386.rpm
gefunden.
Yast-Installation ergibt:

libcrypt.so.5
libssl.so.5

sind erforderlich....

Diese sind in
openssl-0.9.7f-7.10.i686.rpm
openssl-devel-0.9.7f-7.10.i386.rpm

Die kann man wiederum nicht installieren, da -zig Abhängigkeiten vorhnden sind mit den neuesten openssl-0.9.7g ....

Also GMX-Mediencenter unmöglich unter Suse 10.0??? :-(
Gruß

Darius

Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe » 6. Dez 2005, 17:15

also ich habe SuSE 9.3

bei mir sind installiert:

Code: Alles auswählen

paul@notebook:~> rpm -q neon
neon-0.24.7-6.1
paul@notebook:~> rpm -q openssl
openssl-0.9.7e-3.2
und die dazugehörigen devel-Pakete

versuch mal openssl über apt oder smart zu installieren. Viele Abhängigkeiten lösen sich in Luft auf.

Falls es wirklich nicht klappt (mal pessimistisch gedacht): alternativ kannst du Mediacenter unter Konqueror nutzen. Es ist halt nicht gemountet, aber sonst sind alle Funktionen da.
im Konqueror in die Adressenzeile eingeben:

Code: Alles auswählen

webdavs://mediacenter.gmx.net 
Enter drücken => du wirst aufgefordert deine Kundennummer und Passwort einzugeben => Mediacenter wird angezeigt! :wink:

Gruß pawe
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

GMX Mediencenter

Beitrag von dma67 » 6. Dez 2005, 17:39

Hi Pawe, so habe ich es auch gemacht.
Mounten will ich das gar nicht. Ein Link im Konqui ist ausreichend, um ab und zu ein paar Dateien auf die sichere Seite zu ziehen, wenn alles in die Grütze geht.
Openssl und Neon hatte ich ja auch schon und es ging eben nicht diese downzugraden - aber wenn ich um die 50 Abhängigkeiten auflössen muss, wenn alles läuft - wegen GMX will ich nicht riskieren. Ich habe cadaver und noch irgendwas dazu getan und wie du beschreiben hast, mich eingeloggt.
Die Frage ist nur: ist es eine SSL-Verbindung?
Ist ja egal - wer meine Adressen lesen will, kann es gerne tun ;-)
Danke pawe!
gruß
darius
Gruß

Darius

bommel
Member
Member
Beiträge: 158
Registriert: 14. Jun 2005, 16:07

Beitrag von bommel » 6. Dez 2005, 17:57

pawe hat geschrieben: webdavs://mediacenter.gmx.net
Kann man dem Aufruf auch irgendwie gleich den Usernamen und das Passwort mit auf die Reise geben?
So das die Anmeldung vollautomatisch abläuft?

bommel...

Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

GMX Mediencenter

Beitrag von dma67 » 6. Dez 2005, 18:07

also ich habe KDE Wallet am laufen - der macht das.
Gruß

Darius

Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Re: GMX Mediencenter

Beitrag von pawe » 6. Dez 2005, 18:39

dariuszmarek hat geschrieben: Die Frage ist nur: ist es eine SSL-Verbindung?
Ja!
wenn du webdavs://media... benutzt => SSL
bei webdav://media... => kein SSL
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!

joka
Member
Member
Beiträge: 94
Registriert: 17. Mai 2005, 23:33
Wohnort: München

WebDAV Clients

Beitrag von joka » 10. Feb 2006, 00:48

bommel hat geschrieben:
pawe hat geschrieben: webdavs://mediacenter.gmx.net
Kann man dem Aufruf auch irgendwie gleich den Usernamen und das Passwort mit auf die Reise geben?
So das die Anmeldung vollautomatisch abläuft?

bommel...
Ergänzung für GNOME-User: Der Zugriff auf das GMX-Mediacenter geht auch mit Nautilus, allerdings mit der URL davs://1234567@mediacenter.gmx.net/Meine%20Dokumente *
oder mit Datei->Mit Server verbinden->(Sicheres WebDAV auswählen)
Username und Password merkt sich auf Wunsch der GNOME-Schlüsselbund.

Außerdem ist auf der SuSE-10.0-DVD noch ein FTP-ähnlicher Kommandozeilen-Client "cadaver" enthalten für die Nutzung in Shell-Skripten, der dav und davs beherrscht. Aufruf z.B. mit

Code: Alles auswählen

cadaver https://mediacenter.gmx.net
User und Password könnten wie bei FTP in ~/.netrc hinterlegt werden.

*) 1234567 steht für die Kundennummer. Ohne Verzeichnis klappts bei mir nicht, da hat Nautilus noch ein kleines Problem.
MacBook 2,1: CD 2.16GHz / Intel 945GM / 2GB RAM / 160GB HDD / OS X 10.6 / Scientific Linux 6 (GNOME2)
EeePC 701: Scientific Linux 6 (Server & WLAN-Router)

bigdadyx
Member
Member
Beiträge: 77
Registriert: 1. Feb 2006, 23:43

Beitrag von bigdadyx » 11. Feb 2006, 13:02

Hi Leute, ich hab auch Suse 10.

in der konsole macht er nach dem wget befehl folgendes:

Code: Alles auswählen

Auflösen des Hostnamen »osdn.dl.sourceforge.net«.... fehlgeschlagen: Temporärer Fehler bei der Namensauflösung.
danach ist aber vorbei, dann meldet mir die KOnsole, dass sie inaktiv ist, komm nicht weiter, woran liegt es?

thx

f33l
Newbie
Newbie
Beiträge: 33
Registriert: 6. Jan 2006, 13:30
Wohnort: Baden-Württemberg

Beitrag von f33l » 11. Apr 2006, 16:37


Benutzeravatar
Alaska
Newbie
Newbie
Beiträge: 12
Registriert: 6. Jun 2006, 11:21
Wohnort: Passau

Beitrag von Alaska » 16. Jun 2006, 18:16

sorry wenn ich diesen alten thread jetzt mal ausgrabe.......ich hab das ganze mit suse 10.1 ganz easy hinbekommen über den Desktop:

klick auf Arbeitsplatz -> klick auf Netzwerkordner -> klick auf Netzwerkordner hinzufügen -> alles ausfüllen, dann speichern und das Passwort im Dialog eingeben. Dann ist alles erledigt und man kann sich ganz leicht eine Verknüpfung auf den Desktop legen.

bye

Alaska

Benutzeravatar
Traube
Member
Member
Beiträge: 75
Registriert: 10. Okt 2004, 22:45
Kontaktdaten:

Beitrag von Traube » 21. Jul 2006, 23:06

Hallo Alaska!
Ich habe es genauso gemacht, wie du es aufgelistet hast!

Ich habe folgendes eingegeben und es kam auch ein Dialog, indem ich das Passwort eingeben musste.

Code: Alles auswählen

Name: gmx-mc
Benutzer: Username
Server: mediacenter.gmx.net 
Port: 80
Ordner: /gmx-mc/

Aber ich bekomme folgende Fehlermeldung!

Code: Alles auswählen

Die Verbindung mit den Server kann nicht hergestellt werden. Bitte überprüfen Sie die Einstellungen und versuchen Sie es erneut.
Hat da jemand eine Idee?

Danke!
Gruß
Traube
Suse10.1

Benutzeravatar
Alaska
Newbie
Newbie
Beiträge: 12
Registriert: 6. Jun 2006, 11:21
Wohnort: Passau

Beitrag von Alaska » 23. Jul 2006, 22:08

ich weiss von einigen dass es bei ihnen nur unverschlüsselt klappt.........vielleicht liegt es daran. solange du keine sensiblen daten im mediacenter ablegst dürfte das keine probleme machen.....

bye

Alaska

Kindergartenleiter
Newbie
Newbie
Beiträge: 5
Registriert: 11. Aug 2006, 19:18
Wohnort: nahe Münster / NRW
Kontaktdaten:

Beitrag von Kindergartenleiter » 11. Aug 2006, 19:28

Hallo,
ich habe (unter Suse 10.1) eine Verknüpfung recht schnell erstellen so können:

klick auf Arbeitsplatz -> klick auf Netzwerkordner -> klick auf Netzwerkordner hinzufügen -> alles ausfüllen, dann speichern und das Passwort im Dialog eingeben. Dann ist alles erledigt und man kann sich ganz leicht eine Verknüpfung auf den Desktop legen.

Name: GMX-Mediacenter
Benutzer: kundennummer
Server: mediacenter.gmx.net
Port: 80
Ordner: /

Oder direkt eine Verknüpfung zu einer URL:
webdavs://kundennummer@mediacenter.gmx.net:443/
erstellen.

Gruß
Andreas

freesurface
Newbie
Newbie
Beiträge: 2
Registriert: 16. Aug 2006, 23:50
Wohnort: Stuttgart

Beitrag von freesurface » 17. Aug 2006, 00:17

Hallo,

bevor ich hier mit Problemen anfange, vielleicht erstmal ein kleiner Bericht was funktioniert. Ich benutze Suse 10.0 64 bit und möchte das 1und1 mediacenter mit sagenhaften 15 GB Platz mittels webdav einbinden.

Es funktioniert:
Ein Netzwerkordner erstellen
mittels webdav://... über den konquorer drauf zugreifen
ich kann mit cadaver darauf zugreifen
tja und ich habe mir auch ein davfs2 rpm installiert und kann als root das mediacenter mounten und dann in der bash darauf zugreifen.

Nur als normaler user bekomme ich das nicht gebacken. Ich habe mir schon die verschiedensten Seiten angeschaut und alle möglichen Anweisungen befolgt. Es geht nicht und ich weiß nicht warum

Also hier in Kürze was ich gemacht habe:
davfs2-0.2.5-1mdk.x86_64.rpm via YAST installiert
Mountpoint \mnt\1und1 erstellt
und als root das Mediacenter https://mediacenter.1und1.de gemountet.
Eingabe einer Authentifzierung und eines Passwortes.
die secrets Datei und fstab angepasst, nun kann ich als root direkt 1&1 mit mount 1und1 mounten.

Und nun zum User. Es steht ja hier bereits. Man muss in der fstab den Mountpoint eintragen. Das sieht bei mir so aus:

Code: Alles auswählen

https://mediacenter.1und1.de   /mnt/1und1   davfs2   users,noauto       0 0 
und dann versuche ich zu mounten:

Code: Alles auswählen

genk@terra:/mnt> mount 1und1/
/sbin/mount.davfs2: fstab does not allow you to mount
        https://mediacenter.1und1.de on /mnt/1und1.
Ich weiß, dass der fstab-Eintrag gelesen und ausgewertet wird. Denn wenn ich daran rumexperimentiere, geht entweder gar nichts oder ich bekomme ne Meldung, dass die Parameter für mount.davfs2 nicht stimmen.
Und ich gehöre auch der Gruppe users an.

Aber hier bin ich kurz davor zum allerallererstenmal bei Linux zu kapitulieren und aufzugeben. Sieht jemand zufällig ganz spontan einen Fehler oder hat jemand ähnliche Probleme?

Das mounten als user wäre für mich ne schicke Sache, da ich hauptsächlich in der bash arbeite und Backupdateien per Skript gerne ins mediacenter schieben würde.

freesurface
Newbie
Newbie
Beiträge: 2
Registriert: 16. Aug 2006, 23:50
Wohnort: Stuttgart

Beitrag von freesurface » 18. Aug 2006, 13:05

... und nun klappt auch das mounten mittels davfs2. Ich habe erstmal das rpm wieder deinstalliert und dann die Sache selbst kompiliert. Zusätzlich musste ich die Neon-lib auch noch selbst erstellen. Aber danach funtkionierte alles wie im README beschrieben und auch der normale user kann nun mittels

Code: Alles auswählen

 mount /mnt/1und1 
mounten.

Bei meiner Recherche habe ich dann noch die folgende Seite gefunden:
http://noedler.de/projekte/wdfs/.
Allerdings nicht ausprobiert. Bei funktionierts wie es sein soll und das reicht.

micha97
Newbie
Newbie
Beiträge: 1
Registriert: 11. Aug 2005, 12:58

GMX-Mediacenter (1GB) als Laufwerk mounten - Fehlermeldung!?

Beitrag von micha97 » 18. Sep 2007, 08:32

Hallo liebe Fachleute,
nach dem HOWTO habe ich davfs2 für mein gmx-mediacenter eingerichtet und bekomme trotzdem diese Fehlermeldung:

linux-tcc3:/home/micha # mount /mnt/gmx
Could not contact server:
401 Unauthorized
WebDAV Server error
linux-tcc3:/home/micha #

Kann mir jemand helfen!? - Vielen Dank für Euer Bemühen!

Gruß micha

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 18. Sep 2007, 09:09

Fehlermeldung ist ja schon mal ganz gut.
Aber es fehlen noch die Einstellungen, die du getätigt hast.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste