Probleme mit kernel 2.6.5 unter SuSE 9.1

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
nico
Newbie
Newbie
Beiträge: 3
Registriert: 23. Sep 2004, 02:57

Probleme mit kernel 2.6.5 unter SuSE 9.1

Beitrag von nico » 23. Sep 2004, 04:52

Hallo,
Ein Vanilla Kernel 2.6.5 lief unter SuSE 9.1 (SuSE 9.0 mit Update auf 9.1) ohne Probleme. Nach einer Neuinstallation von SuSE 9.1 gibt es nun diverse Probleme. Die Konfiguration des Kernels hat sich nicht geändert.

Die letzten Zeilen während dem Bootvorgang lauten:

Starting service kdmchmod: Beim Setzen der Zugriffsrechte für /dev/tty0: Das Dateisystem ist nur lesbar
chmod: Beim Setzen der Zugriffsrechte für /dev/xconsole: Das Dateisystem ist nur lesbar
failed services in rnlevel 5: random resmgr nfsboot smppd powersaved kbd nscd cron xdm
skipped services in runlevel 5: smbfs powersaved splash
blogd: no message logging because /var file system is not accessible

Danach folgt ein login:
KDE läßt sich nicht starten.

Wo könnte die Ursache für dieses Verhalten liegen?

Gruß Nico

Werbung:
Benutzeravatar
JINX
Newbie
Newbie
Beiträge: 22
Registriert: 1. Aug 2004, 13:58
Kontaktdaten:

Beitrag von JINX » 12. Okt 2004, 15:42

gib mal beim booten als Option
acpi=off ein.
Kpowersave scheint ja probleme zu haben. Möglich, dass SuSE 9.0 die APM-Tabellen Deines BIOS sauber erkannte, dies beim Update an 9.1 erkannte.
Die Basisinstallation von 9.1 jedoch ACPI statt APM nimmt und da das BIOS kein ACPI unterstützt, gibt kpowersave eine Fehlermeldung aus.

Sofern Du dich in der Konsole anmelden kannst, kannst Du probieren den KDE nach login manuel zu starten durch: startx
Es gibt drei Wahrheiten:
Meine Wahrheit,
deine Wahrheit
und die Wahrheit.

MEPROXSOFT - go for IT

Gast

Beitrag von Gast » 12. Okt 2004, 17:57

Ich denke da ist ein paar Meldungen weiter vorne schon etwas schiefgegangen. Das Dateisystem scheint nur read-only gemountet zu sein. Daher will vermutlich auch KDE nicht so richtig. Du musst also mal in der boot.msg (die ja leider nicht gespeichert wird, da /var nicht schreibbar ist) ein wenig weiter vorne nachsehen, was der Grund dafür ist.

Normalerweise läuft der Vanilla-Kernel recht gut mit SuSE 9.1 (hab ich auch schon genutzt). Daher wäre sonst mein Tip den Kernel unter dem frischen 9.1 nochmal zu kompilieren.

nico
Newbie
Newbie
Beiträge: 3
Registriert: 23. Sep 2004, 02:57

Beitrag von nico » 15. Okt 2004, 16:53

Danke für Eure Hinweise. Bis jetzt konnte ich mein Problem aber noch nicht lösen.
#JINX
* Die Bootoption acpi=off ergibt keine Änderung.
* startx führt zu folgenden Meldungen:
Fatal: cannot change permissions of TTY: Read-only file system
startx
tee:/root/.X.err:Read-only file system
/usr/X11R6/bin/startx: line201: cannot create temp file for here document:
Read-only file system

#abisko00
<Normalerweise läuft der Vanilla-Kernel recht gut mit SuSE 9.1 (hab ich auch <schon genutzt). Daher wäre sonst mein Tip den Kernel unter dem frischen <9.1 nochmal zu kompilieren.

Ich habe den Vanilla-Kernel unter SuSE 9.1 inzwischen mehrmals kompiliert.

<Ich denke da ist ein paar Meldungen weiter vorne schon etwas <schiefgegangen. Das Dateisystem scheint nur read-only gemountet zu sein.

Das Problem, daß das Dateisystem Read-only gemountet ist, erscheint während des Bootens immer wieder. Warum?

<Daher will vermutlich auch KDE nicht so richtig. Du musst also mal in der <boot.msg (die ja leider nicht gespeichert wird, da /var nicht schreibbar ist) <ein wenig weiter vorne nachsehen, was der Grund dafür ist.

Kann ich während des Bootvorgangs an einer beliebigen Stelle eine Pause einfügen?

Gast

Beitrag von Gast » 15. Okt 2004, 17:11

Das Problem, daß das Dateisystem Read-only gemountet ist, erscheint während des Bootens immer wieder. Warum?
Das ist schwierig zu sagen, auf jeden Fall ist ein sehr früher Schritt schon in die Hose gegangen. Ich hatte diese Meldung immer weil meine /etc/fstab einen Fehler hatte (durch die Kernelumstellung ist aus /dev/hdx auf einmal /dev/sdx geworden, weshalb das Filesystem aus Sicherheitsgründen read-only gemountet wurde (sonst zerschiesst es dir beim booten möglicherweise irgendwelche Daten). Nur sollte in einem solchen Fall eigentlich der Bootvorgang abbrechen.
Kann ich während des Bootvorgangs an einer beliebigen Stelle eine Pause einfügen?
Du kannst mal probieren, ob du den Screen mit der Pause-Taste anhalten kannst.

nico
Newbie
Newbie
Beiträge: 3
Registriert: 23. Sep 2004, 02:57

Beitrag von nico » 22. Okt 2004, 16:00

Endlich konnte ich "mein" Kernel Problem lösen.
Ich habe in der fstab den Eintrag,
/dev/hda7 / reiserfs user_xattr 1 1
den SuSE erzeugt hat, gegen
dev/hda7 / reiserfs defaults 1 1
getauscht. Mir ist noch nicht ganz klar, was user_xattr bedeutet und warum es damit nur mit dem Vanilla Kernel Probleme gab; aber das finde ich auch noch heraus.

Du kannst mal probieren, ob du den Screen mit der Pause-Taste anhalten kannst.
Funktioniert leider nicht. Die Pause Taste (wie auch jede andere Taste) scheint während des Bootvorgangs keinerlei Funktion zu besitzen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast