Kernel 2.6.8.1 +USB & Soundprobleme

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Miami_TEC_Nec
Newbie
Newbie
Beiträge: 20
Registriert: 22. Apr 2004, 15:08
Wohnort: Hannover

Kernel 2.6.8.1 +USB & Soundprobleme

Beitrag von Miami_TEC_Nec » 17. Sep 2004, 01:22

Hallo zusammen,

hab folgendes Problem:

hab heute auf meinem Rechner SuSE 9.1 Pro installiert.
Danach ein paar Updates gemacht( insbesondere Treiber).

Beim bei installieren meiner Grafikkarte (Radeon 9800SE) gab es dann Probleme.
OK. dann hab i nach einer lösung dafür im I-Net gesucht, und siehe da...
Man muss nur den 2.6.8.1-Kernel haben, dann sollen auch die neuen Treiber von ATI mit 3D-Unterstützung gehen!

Kernel runtergeladen, entpackt in /usr/src/linux-x.x.x.x ,usw...
den weg kennt ihr ja :)

so, nachdem ich den Kernel dann kompilliert habe und GRUB gesagt habe was er damit zu tun hat, kam der erste Testboot :)
Es ging :), Grafik war da, nur:
1. Sound ist aus obwohl er im Kernel eingeschaltet ist
2. Meine USB-Mouse von Logitech geht auch nicht

dann hab i versucht wenigstens die Maus zum laufen zu kriegen...
Nix zu machen... hab auch ehrlich keine ahnung wie i das beheben soll :(

Dann hab i mir den Sound vorgeknüpft...
Ebenfalls nix zu machen... Beim booten sagt er das der kernel nicht "bereit" für sound sei... :shock:

seit heute mittag hocke i vor diesem problem jetzt und mir fällt einfach keine Lösung mehr ein *KoppAmRauchenSei* !
Und alles was i beim googeln anklicken konnte ist schon angeklickt :)

wäre hilfe echt dankbar!!

cu miami
/root, rock, reggea

Werbung:
Gast

Beitrag von Gast » 17. Sep 2004, 09:43

Ich fürchte, dass in diesem Fall ein "...den weg kennt ihr ja" nicht ausreicht.

Wie bist du beim Klonen der Konfiguration vorgegangen, was hast du verändert?

Miami_TEC_Nec
Newbie
Newbie
Beiträge: 20
Registriert: 22. Apr 2004, 15:08
Wohnort: Hannover

Beitrag von Miami_TEC_Nec » 17. Sep 2004, 12:46

also hab das ganze nach einer Anleitung ausm I-Net gemacht.

1. tar xvfz linux-2.6.8.1
2. ln -s /usr/src/linux2.6.8.1 /usr/src/linux
3. im verzeichnis /linux-2.6.8.1 dann "make xconfig" eingegeben
4. die Config durchgearbeitet
5. dann "make modules make modules_install" eingegeben
6. die datei "/usr/src/linux-2.6.8.1/arch/i386/boot/bzimage" ins verzeichnis "/boot/grub" kopiert
7. die datei menu.lst editiert
8. und dann nen neustart

hab nachdem i damm festgestellt hab das es nicht geht schritt 1-6 wiederholt nur dies mal alles was sound, usb und mäuse angeht mit einem "*" markiert...

und dann ging es wieder nicht dann jede einzelne option, wenn ich nicht wusste wozu sie gut ist, bei google nachgeschaut und dementsprechend deaktiviert oder auf "M" oder auf "*" gesetzt...

irgendwas falsch?
war wirklich nach anleitung!!

thx
/root, rock, reggea

Gast

Beitrag von Gast » 17. Sep 2004, 13:44

Das bedeutet, du hast deine Konfiguration auf den Defaul-Werten aufgebaut. Besser ist, die Konfiguration des SuSE-Kernels als Grundlage zu verwenden (Kernel klonen). Gimpel hat dazu eine hervorragende Anleitung geschrieben (hier im Forum unter 'Wichtig')

Gast

Beitrag von Gast » 17. Sep 2004, 20:55

Miami_TEC_Nec hat geschrieben:also hab das ganze nach einer Anleitung ausm I-Net gemacht.

1. tar xvfz linux-2.6.8.1
2. ln -s /usr/src/linux2.6.8.1 /usr/src/linux
3. im verzeichnis /linux-2.6.8.1 dann "make xconfig" eingegeben
4. die Config durchgearbeitet
5. dann "make modules make modules_install" eingegeben
6. die datei "/usr/src/linux-2.6.8.1/arch/i386/boot/bzimage" ins verzeichnis "/boot/grub" kopiert
7. die datei menu.lst editiert
8. und dann nen neustart

hab nachdem i damm festgestellt hab das es nicht geht schritt 1-6 wiederholt nur dies mal alles was sound, usb und mäuse angeht mit einem "*" markiert...

und dann ging es wieder nicht dann jede einzelne option, wenn ich nicht wusste wozu sie gut ist, bei google nachgeschaut und dementsprechend deaktiviert oder auf "M" oder auf "*" gesetzt...

irgendwas falsch?
war wirklich nach anleitung!!

thx
Hi
ich schätze die hast make prepare und make bzImage vergessen (oder einfach nicht aufgeführt). Hast du OSS (alt/ausgedient) aus dem Kernel rausgehauen und dafür ALSA genommen?
Wenn nein - dann würde ich es damit mal probieren. Hast du auch wirklich alles für die usb maus eingebaut?. zieh sie mal aus
gib dann tail -f /var/log/messages ein und steck sie wieder ein - was bekommst du für meldungen? Hattest du vorher auch schon ne usb maus?

Gruß }-Tux-{

Ps. mach es am Besten nachdem Super-Guten-Gimpel-Kernel-Bau-Howto :wink: <--- damit klappt es bestimmt

Miami_TEC_Nec
Newbie
Newbie
Beiträge: 20
Registriert: 22. Apr 2004, 15:08
Wohnort: Hannover

Beitrag von Miami_TEC_Nec » 18. Sep 2004, 01:54

hi,
hab es mal nach der anleitung von Gimpel probiert und es hätte fast geklappt!
wenn nicht bei make rpm ein fehler bei der erstellung der rpm aufgetreten wäre!

probiere es einfach nochmal!

vielleicht geht es ja heute :)
/root, rock, reggea

Gast

Beitrag von Gast » 18. Sep 2004, 08:52

Hi
was kam denn für ein Fehler?

Gruß }-Tux-{

Gast

Beitrag von Gast » 18. Sep 2004, 15:59

Du muss nicht zwangsläufig eine rpm erstellen. Meiner Meinung nach macht das beim Kernel eher mehr Probleme, als dass es hilft. Ich installiere den Kernel immer 'klassisch' durch Kopieren der bzImage, also so wie du es oben schon beschrieben hast.

Miami_TEC_Nec
Newbie
Newbie
Beiträge: 20
Registriert: 22. Apr 2004, 15:08
Wohnort: Hannover

Beitrag von Miami_TEC_Nec » 20. Sep 2004, 14:30

@Tux

Habe OSS mal rausgenommen und dafür dann ALSA reingenommen...
Ergebnis war das geliche..
kein Sound!

und was die mouse angeht, die hatte i auch schon verher!

und das kommt bei raus wenn ich die Mouse rausziehe und dann wieder rein stecke:

linux:~ # tail -f /var/log/messages
Sep 20 14:26:36 linux kernel: usb 2-1: USB disconnect, address 3
Sep 20 14:26:36 linux /etc/hotplug/usb.agent[4950]: need a device for this command
Sep 20 14:26:57 linux kernel: usb 2-1: new low speed USB device using address 4
Sep 20 14:26:57 linux kernel: usb 2-1: Product: USB-PS/2 Optical Mouse
Sep 20 14:26:57 linux kernel: usb 2-1: Manufacturer: Logitech
Sep 20 14:26:57 linux /etc/hotplug/usb.agent[5010]: need a device for this command
Sep 20 14:26:57 linux kernel: input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:02.1-1


und trotzdem geht sie net :(

und was die Anleitung angeht von Gimpel...
alles schön und gut, doch i machs doch lieber wie vorher( und so wie es abisko00 macht)
und kopiere lieber alles von hand :)
dann kann i den kernel wenigstens booten :)
/root, rock, reggea

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste