modprobe Problem

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Printe
Newbie
Newbie
Beiträge: 13
Registriert: 3. Mai 2004, 15:13

modprobe Problem

Beitrag von Printe » 3. Sep 2004, 16:37

Mahlzeit!

Habe vor einiger Zeit über YOU einfach ein kernelupdate laufen lassen und nun tauchen im /var/log/messages doch komische Sachen auf.

modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.21-215-athlon/modules.dep (No such file or directory)

Dann bin ich natürlich in /lib/modules/ gegangen und hab mal geschaut woran das liegen könnte. Und da gibt gar kein directory "2.4.21-215-athlon" sondern nur eines "2.4.21-234-athlon" und darin liegt auch die Datei modules.dep!

Wie bringe ich nun meinem Kernel bei, dass er dort suchen soll!?


Bin überhaupt erst hinter dieses Problem gekommen, weil ich Probleme habe snort ans laufen zu bekommen. Snort spuckt mir immer folgenden Fehler aus:

FATAL ERROR: OpenPcap() device eth0 open:
socket: Address family not supported by protocol

Vielleicht hat das eine ja nix mit dem anderen zu tun, aber ich wäre für jede Hilfe dankbar!


Printe

Werbung:
Gast

Beitrag von Gast » 3. Sep 2004, 16:41

Mir scheint, da ist das Update in die Hose gegangen. Was spuckt denn 'uname -r' für eine Kernelversion aus?

Ich denke, das Beste ist den Kernel nochmal frisch zu installieren, oder wieder die alte Version einzuspielen.

EDIT: Hast du irgendwelche Treiber nachträglich eingebunden/installiert hast? Dann kann es sein, dass du die erneut installieren musst, da die Module durch das Kernelupdate nicht mehr stimmen bzw. gelöscht wurden.

Benutzeravatar
Printe
Newbie
Newbie
Beiträge: 13
Registriert: 3. Mai 2004, 15:13

Beitrag von Printe » 3. Sep 2004, 17:56

also uname -r spuckt folgendes aus:

2.4.21-215-athlon

Wie finde ich in Yast denn den Kernelpatch, der installiert wurde??

Gast

Beitrag von Gast » 3. Sep 2004, 18:07

Also stimmen die Module nicht mit dem laufenden Kernel überein. Das führt natürlich zu Problemen. Entweder du versuchst nochmal YOU laufen zu lassen und hoffst, dass es dieses Mal klappt, oder du lädst dir das entsprechende Kernel rpm vom Server runter und installierst es von Hand.

ftp://ftp.gwdg.de/linux/suse/ftp.suse.c ... 3.i586.rpm

Benutzeravatar
Printe
Newbie
Newbie
Beiträge: 13
Registriert: 3. Mai 2004, 15:13

Beitrag von Printe » 8. Sep 2004, 12:03

package k_athlon-2.4.21-243 is already installed

und nu?

Gast

Beitrag von Gast » 8. Sep 2004, 12:08

Gute Frage! Man kann mit der Option --force installieren, dann werden alte Pakete einfach überschrieben.

Benutzeravatar
Printe
Newbie
Newbie
Beiträge: 13
Registriert: 3. Mai 2004, 15:13

Beitrag von Printe » 8. Sep 2004, 12:41

so, habe das Paket nun mit rpm -ihv --force k_athlon-2.4.21-243.i586.rpm installiert:

butan060:~/install # rpm -ihv --force k_athlon-2.4.21-243.i586.rpm
Preparing... ########################################### [100%]
/lib/modules/scripts/nvidia.sh: line 30: /usr/X11R6/bin/xsload: No such file or directory
1:k_athlon ########################################### [100%]
/lib/modules/scripts/nvidia.sh: line 30: /usr/X11R6/bin/xsload: No such file or directory
Changing symlink /boot/vmlinuz from vmlinuz-2.4.21-243-athlon to vmlinuz-2.4.21-243-athlon
Changing symlink /boot/initrd from initrd-2.4.21-243-athlon to initrd-2.4.21-243-athlon
Root device: /dev/hda3 (mounted on / as ext3)
Module list: jbd ext3
Kernel version: 2.4.21-243-athlon (i386)
Kernel image: /boot/vmlinuz-2.4.21-243-athlon
Initrd image: /boot/initrd-2.4.21-243-athlon
Shared libs: none
Modules: kernel/fs/jbd/jbd.o kernel/fs/ext3/ext3.o
Using grub, re-install of bootloader not required.

bloß, wenn ich nun folgendes mache:

butan060:/ # uname -r
2.4.21-215-athlon

steht da wieder der 215er kernel! tja was mache ich wohl falsch??

Benutzeravatar
Printe
Newbie
Newbie
Beiträge: 13
Registriert: 3. Mai 2004, 15:13

Beitrag von Printe » 8. Sep 2004, 13:15

ok ein reboot hat mir hier die lösung gebracht!

butan060:~ # uname -r
2.4.21-243-athlon

mal sehen ob nun alles schön rund läuft!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste