LTSP und die Client CD-Rom Laufwerke mit Supermount

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
chrisltsp41
Member
Member
Beiträge: 51
Registriert: 31. Aug 2004, 20:19

LTSP und die Client CD-Rom Laufwerke mit Supermount

Beitrag von chrisltsp41 » 31. Aug 2004, 20:36

Mahlzeit,

so nu habe ich nach 3 Tagen sucherrei die schnauze VOLL!! Sorry aber ich finde manche sachen die man im Internet findet sind total überzogen und falsch dargestellt.

wirklich gute Lösungen wirklich nur hier....

doch zu meinem prob habe ich keine Lösung gefunden..

Mein 1. Problem -aber selbst gelöst

ein Client Rechner hat an der USB schnittstelle /dev/usb/lp0 einen Epson C70 angeschlossen dieser muss auch weiter genutzt werden - aber wie??

Lösung:

[pc_20] # PCname
MODULE_01 = usb-ohci
MODULE_02 = printer
PRINTER_0_DEVICE = /dev/usb/lp0
PRINTER_0_TYPE = S
PRINTER_0_PORT = 9100

Damit wirklich jeder damit was anfangen kann....

SuSE 9.0 mit LTSP
So nu aber zu meinem Prob....

Ich möchte gerne die Lokalen CD-ROM Laufwerke und Diskettenlaufwerke der Client' s nutzen.

Lösungsansatz :
http://www.ltsp.org/localdev.txt

Mein Problem :

Wenn ich das nutzen möchte brauche ich den supermount patch.... OK kein Problem.....

Patch installiert nu muss ich doch

dem Kernel auch sagen das er dieses Feature nutzt

cd /usr/src/linux
dann
menu xconfig

dann bekomme ich ein auswahl Menu
wähle FILE System

und setze den supermount automount ......

ok.
dann

make dep
make clean
make bzImage
make modules
make modules_install

so jetzt müsste ich doch einen eigen erstellen kernel haben oder? doch was mache ich falsch?

Ich bin schon soweit vorgeschritten das beim booten der clients die Fehlermeldung kommt:

/tmp/cdrom - file exist cannot create you are root?

oder so ähnlich.....

syslogd meldet noch auf den clients das er nicht auf IP:514 zugreifen könne ......


HELP!

Werbung:
joebar
Newbie
Newbie
Beiträge: 14
Registriert: 6. Aug 2004, 21:20

Beitrag von joebar » 3. Sep 2004, 09:10

Hallo chrisltsp,

soweit alles richtig, Du musst danach aber noch den Kernel mit initrd konfigurieren, ist in der LTSP Doku beschrieben und mit dem ltsp_initrd_kit problemlos (download auf der LTSP Seite). Danach hast Du des fertige vmlinuz File.

Jetzt kommt noch ein Schritt der leider nicht in der Anleitung steht, die neuen Module weden nämlich in das Verzeichnis /lib/modules/(Kernelversion) kopiert und dieses Verzeichnis musst Du dann in /opt/ltsp/i386/lib/modules kopieren. Danach funzt es.

Gruss
Gerd

chrisltsp41
Member
Member
Beiträge: 51
Registriert: 31. Aug 2004, 20:19

So nu bin ich schon ein stückel weiter...

Beitrag von chrisltsp41 » 6. Sep 2004, 18:39

das problem mit dem syslogd ist beseitigt - denn eine einstllung in der startvariabelen beseitigt den fehler....

syslogd "-r" - ist wichtig damit der Server auch informationen annimmt.

Code: Alles auswählen

Du musst danach aber noch den Kernel mit initrd konfigurieren, ist in der LTSP Doku beschrieben und mit dem ltsp_initrd_kit problemlos (download auf der LTSP Seite). Danach hast Du des fertige vmlinuz File. 
 
OK muss ich dann nochmal schauen..... Aber ersteinmal

DANKE!

erwin123321

Beitrag von erwin123321 » 8. Sep 2004, 14:09

es geht auch mit submount - ohne kernelpatch.

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste