Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

manfred darf nicht in Datenbank

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
mampfi
Hacker
Hacker
Beiträge: 670
Registriert: 17. Mär 2004, 19:33
Wohnort: München

manfred darf nicht in Datenbank

Beitrag von mampfi » 20. Aug 2004, 22:50

Ich hab einen user in mysql angelegt mit

grant all on adressen.*to manfred identified by 'manfred';

Wenn ich als user manfred von der Linux-Kommandozeile mysql starten will, dann kriege ich folgenden Kommentar.

Access denied for user: 'manfred@localhost' (Using password: NO)
Programmieren macht Spaß und ärgert gleichzeitig

Werbung:
litemaster
Member
Member
Beiträge: 127
Registriert: 10. Aug 2004, 11:51

Re: manfred darf nicht in Datenbank

Beitrag von litemaster » 21. Aug 2004, 12:25

mampfi hat geschrieben:Ich hab einen user in mysql angelegt mit

grant all on adressen.*to manfred identified by 'manfred';

Wenn ich als user manfred von der Linux-Kommandozeile mysql starten will, dann kriege ich folgenden Kommentar.

Access denied for user: 'manfred@localhost' (Using password: NO)
Da er das Passwort gar nicht abfragt ("Using password: NO"), manfred aber ein Passwort hat ("identified by 'manfred'") wird der Zugriff verweigert. :shock:

Starte mysql mit der Option -p, dann wird das Passwort am Prompt abgefragt

Code: Alles auswählen

> mysql --user manfred -p
Enter password:
oder direkt mit Angabe des Passwortes

Code: Alles auswählen

> mysql --user manfred -pmanfred
(hier darf zwischen dem '-p' und dem Passwort kein Leerzeichen sein, beim '--user' hingegen schon. :P)

Wenn du nach der Grant-Operation ein FLUSH PRIVILEGES; gemacht hast, sind die Zugriffstabellen aktualisiert und Manfred kommt rein. :)

mampfi
Hacker
Hacker
Beiträge: 670
Registriert: 17. Mär 2004, 19:33
Wohnort: München

Danke

Beitrag von mampfi » 21. Aug 2004, 16:37

Danke funzt jetzt.

Vielleicht hab den Doppelstrich vergessen beim "-user".
Programmieren macht Spaß und ärgert gleichzeitig

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste