kernel 2.6.8.1 und K3b/cdrecord ----> user & brennen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

kernel 2.6.8.1 und K3b/cdrecord ----> user & brennen

Beitrag von Gimpel » 16. Aug 2004, 10:35

hi leutz!

nach dem der rc4 des 2.6.8er kernel so astrein funktioniert hat, konnte man mit freude auf den stable release warten

2.6.8 gabs ja nur einen tag lang, aufgrund eines nls patches kam sofort version 2.6.8.1 raus

hier mal der erste erfahrungs-bericht:

testsystem war bei mir debian sarge, der fazit:

funzt alles wunderbar, nur k3b verweigert dem normalen user den dienst und erkennt den ide-brenner nur als normales laufwerk, wobei dann bei den einstellungen zu lesen ist:

brennt cd's: nein
brennt cdrw's: ja <---- ???

hat den hier auch schon jemand getestet und hat ähnliches zu berichten?
logfiles wälzen hat nix gebracht, der boot log is fehlerfrei, die messages ebenso...

der changelog für den 2.6.8.1 is ja nur ein paar zeilen lang, den für den 2.6.8er werd ich jetzt dann mal etwas überfliegen..
kann ja eigentlich nur an einer änderung im modulhandling der scsi-emulation liegen, mit der k3b (test war mit der neuesten version 0.11.14) nicht mehr klar kommt, oder ist es doch ein bug im kernel?

gentoo scheint das problem in seinen gentoo-dev-sources-2.6.8 gelöst oder nie gehabt zu haben. hier noch ein paar erfahrungsberichte dazu..

gruß!
Zuletzt geändert von Gimpel am 15. Sep 2004, 17:40, insgesamt 2-mal geändert.
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 16. Aug 2004, 11:36

Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild


Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 17. Aug 2004, 12:43

BINGO!!!

hier die lösung:
http://marc.theaimsgroup.com/?l=linux-k ... 604538&w=2

...eine zeile auskommentieren ----> neu bauen ----> passt!



greets!
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Benutzeravatar
Hans-Peter
Newbie
Newbie
Beiträge: 19
Registriert: 20. Aug 2004, 16:53
Wohnort: Frankfurt am Main
Kontaktdaten:

Beitrag von Hans-Peter » 20. Aug 2004, 16:58

Gimpel hat geschrieben:BINGO!!!
hier die lösung:
http://marc.theaimsgroup.com/?l=linux-k ... 604538&w=2

...eine zeile auskommentieren ----> neu bauen ----> passt!
greets!
...und was muss der geneigte Halbprofi da genau machen? :D
Gruß
Hans-Peter
http://www.kluge-ffm.de
OpenSuSE 10.3

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 20. Aug 2004, 17:23

...eine zeile auskommentieren ----> neu bauen
:wink:

welche steht im patch...

ABER: es gibt noch probs mit audio-cd's! die brenn ich nie, daher: mir wurscht...
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 15. Sep 2004, 13:01

EDIT EDIT

ok.. mittlerweile is 2.6.9-rc2 raus

das prob oben is kein prob, sondern ein feature! sprich man muss cdrecord patchen und k3b aus cvs nehmen, damit das wieder funzt

quelle: hier
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 15. Sep 2004, 19:50

K3b 0.11.15 released

This is basicly a fix for kernel versions >= 2.6.9. The writer detection should work again although I still experienced problems with 2.6.9-rc2 which I don't think are caused by K3b. So it is still recommended to stick to kernel version 2.6.7 or use one of the patches to revert to the "old" scsi command handling.
:wink:


...funzt wieder...mit gepatchten cdrtools.. alles einwandfrei
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste