Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Leap 15.2 zickt rum

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

BeastXXL
Member
Member
Beiträge: 226
Registriert: 6. Feb 2010, 10:51

Re: Leap 15.2 zickt rum

Beitrag von BeastXXL »

Hallo susejunky,

OK, vorweg die Anmerkung, dass ich das Problem nur über das GUI gelöst habe.

Bei Yast -> System -> Netzwerkeinstellungen gibt es immer die Checkbox "IPv6 aktivieren". Egal, ob der Netzwerkaufbau über den NetworkManager- oder den Wicked-Dienst stattfindet.
Diese Checkbox war bereits abgewählt, also IPv6 deaktiviert.
Meine Lösung besteht nun also darin, entweder (mit dem NetworkManager-Dienst) diese Checkbox anzuwählen, also IPv6 zu aktivieren, oder auf den wicked-Dienst zu wechseln (egal, ob die Checkbox für IPv6 aktiv ist oder nicht).

Deine Nachfrage hat mir noch eine weiter Lösung gezeigt (Danke dafür):
susejunky hat geschrieben: 5. Apr 2021, 13:11 Was meinst Du mit "unter NetworkManager"? Hast Du im betroffenen NetworkManager-Verbindungsprofil aus /etc/Networkmanager/system-connections

Code: Alles auswählen

[ipv6]
method=ignore
eingestellt?
Wie ich schon schrieb, habe ich es über das GUI gemacht.

Code: Alles auswählen

method=ignore
erinnert mich an das Einstellungsfenster bei dem NetworkManager-Applet im Systemabschnitt der Kontrollleiste (Rechtsklick). Wenn dort auf dem Reiter "IPv6" bei Methode -->Ignorieren eingestellt und (ganz wichtig) danach ein Neustart gemacht wird, dann ist das Problem auch behoben. Selbst, wenn (wie oben beschrieben) unter Yast/Netzwerkeinstellungen der NetworkManager-Dienst ausgewählt und die Checkbox für IPv6 abgewählt ist.
Diese Konfiguration ist gerade bei mir eingestellt und das Fenster Anzeige und Monitor bzw. Nachtfarben öffnet sich sofort.

Ansonsten habe ich bei den Netzwerkeinstellungen (egal ob bei Yast oder dem Applet) rein gar nichts verändert.

Danke nochmal für die Hilfe.
Dual-Boot: WIN10 (64Bit), openSUSE Leap 15.2 (x86_64 GNU/Linux), Grub2, KDE, AMD Radeon RX580, AMD Ryzen 3600, 32 GB RAM
Sauerland
Guru
Guru
Beiträge: 4027
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von Sauerland »

Ich habs in Grub schon ausgeschaltet:
cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.11.10-lp152.3.gfa5dcf1-default root=UUID=ed232525-8358-4aeb-9182-4254c864594f splash=verbose quiet showopts ipv6.disable=1 mitigations=auto
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
admine
Administrator
Administrator
Beiträge: 8928
Registriert: 15. Feb 2004, 21:13

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von admine »

Sauerland hat geschrieben: 5. Apr 2021, 14:21 Ich habs in Grub schon ausgeschaltet:
Und ich in /etc/sysctl.conf

Code: Alles auswählen

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
Was ist nun eigentlich das Bessere oder lässt sich das nicht so einfach sagen?
Btw. das "ignorieren" im NetworkManager hat bei mir nichts gebracht. IPv6-Adressen wurden vergeben und auch an den Router weitergegeben.
Aber "ignorieren" ist eben nicht "deaktivieren" ... denk ich :roll:
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5536
Registriert: 23. Sep 2008, 17:09

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von josef-wien »

admine hat geschrieben:net.ipv6.conf.all.disable_ipv6 = 1
Diese Zeile reicht, wie Dir

Code: Alles auswählen

grep . /proc/sys/net/ipv6/conf/*/disable_ipv6
beweist. Der Weg über sysctl hat den Vorteil, daß sowohl die jeweilige Einstellung im laufenden Betrieb geändert werden kann als auch für die einzelnen Anschlüsse unterschiedliche Werte vergeben werden können. Mit dem Kernel-Parameter
Sauerland hat geschrieben:ipv6.disable=1
schafft man vollendete Tatsachen, die im laufenden Betrieb nicht veränderbar sind, da ipv6 üblicherweise direkt im Kernel enthalten (und nicht als Modul realisiert) ist.
admine
Administrator
Administrator
Beiträge: 8928
Registriert: 15. Feb 2004, 21:13

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von admine »

josef-wien hat geschrieben: 5. Apr 2021, 17:38 Mit dem Kernel-Parameter schafft man vollendete Tatsachen, die im laufenden Betrieb nicht veränderbar sind, da ipv6 üblicherweise direkt im Kernel enthalten (und nicht als Modul realisiert) ist.
Das ist natürlich wahr. Danke dir :)
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
BeastXXL
Member
Member
Beiträge: 226
Registriert: 6. Feb 2010, 10:51

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von BeastXXL »

IPv6 sowohl über GRUB aus auch über sysctl zu deaktivieren hatte ich auch schon gelesen und mir die Frage gestellt, welcher Weg wohl "besser" sei. Mit der Antwort von josef-wien ist diese Frage auch beantwortet. Danke.
Aber diesen Weg wollte ich mir noch aufheben, denn vorher (und bevor ich meine oben beschriebene Lösung gefunden hatte) wollte ich etwas überprüfen.

Da ich wusste, dass unter YAST -> Netzwerkeinstellungen IPv6 abgewählt war und so IPv6 gar nicht zur Verfügung stehen sollte (warum gibt es sonst diese Checkbox?), wurde über eben dieses IPv6 versucht eine Verbindung aufzubauen. Warum?
Ich versuchte

Code: Alles auswählen

> ip addr show | grep inet6
und zu meiner Überraschung tauchte eine Liste mit 5 od. 6 Einträgen auf. Jetzt, nachdem (wie oben beschrieben) Methode -> Ignorieren eingestellt ist, gibt es keine Antwort.
Ich habe diesen Befehl nicht ausprobiert als ich auf den wicked-Dienst umgestellt hatte.
Dual-Boot: WIN10 (64Bit), openSUSE Leap 15.2 (x86_64 GNU/Linux), Grub2, KDE, AMD Radeon RX580, AMD Ryzen 3600, 32 GB RAM
Sauerland
Guru
Guru
Beiträge: 4027
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von Sauerland »

Hiernach hab ich mich immer gehalten, ist zwar schon alt, aber.....
https://forums.opensuse.org/showthread. ... use-11-2-a

Daher folgert für mich:
Yast macht nicht das, was man eigentlich erwartet.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
admine
Administrator
Administrator
Beiträge: 8928
Registriert: 15. Feb 2004, 21:13

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von admine »

josef-wien hat geschrieben: 5. Apr 2021, 17:38
admine hat geschrieben:net.ipv6.conf.all.disable_ipv6 = 1
Diese Zeile reicht, wie Dir

Code: Alles auswählen

grep . /proc/sys/net/ipv6/conf/*/disable_ipv6
beweist.
Muss scheinbar nicht so sein:

Code: Alles auswählen

grep . /proc/sys/net/ipv6/conf/*/disable_ipv6
/proc/sys/net/ipv6/conf/all/disable_ipv6:1
/proc/sys/net/ipv6/conf/default/disable_ipv6:1
/proc/sys/net/ipv6/conf/eth0/disable_ipv6:0
/proc/sys/net/ipv6/conf/lo/disable_ipv6:1
/proc/sys/net/ipv6/conf/wlan2/disable_ipv6:0
/proc/sys/net/ipv6/conf/wwan0/disable_ipv6:1

Code: Alles auswählen

ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 8c:04:ba:0d:39:c0 brd ff:ff:ff:ff:ff:ff
3: wlan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 92:4a:b5:2c:78:b2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.179.4/24 brd 192.168.179.255 scope global dynamic noprefixroute wlan2
       valid_lft 21566sec preferred_lft 21566sec
    inet6 fe80::904a:b5ff:fe2c:78b2/64 scope link 
       valid_lft forever preferred_lft forever
Und so nach dem Eintrag der 3 Zeilen und sysctl -p

Code: Alles auswählen

grep . /proc/sys/net/ipv6/conf/*/disable_ipv6
/proc/sys/net/ipv6/conf/all/disable_ipv6:1
/proc/sys/net/ipv6/conf/default/disable_ipv6:1
/proc/sys/net/ipv6/conf/eth0/disable_ipv6:1
/proc/sys/net/ipv6/conf/lo/disable_ipv6:1
/proc/sys/net/ipv6/conf/wlan2/disable_ipv6:1
/proc/sys/net/ipv6/conf/wwan0/disable_ipv6:1

Code: Alles auswählen

ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 8c:04:ba:0d:39:c0 brd ff:ff:ff:ff:ff:ff
3: wlan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 92:4a:b5:2c:78:b2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.179.4/24 brd 192.168.179.255 scope global dynamic noprefixroute wlan2
       valid_lft 21151sec preferred_lft 21151sec
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5536
Registriert: 23. Sep 2008, 17:09

Re: [gelöst] Leap 15.2 zickt rum

Beitrag von josef-wien »

Das ist seltsam. Wenn nur "all" mit "1" definiert ist, werden zwar "default" und "lo" (sowie "wwan0") auf "1" gesetzt, während "eth0" und "wlan2" jeweils "0" enthalten. Werden dagegen "all", "default" und "lo" mit "1" definiert, ist überall "1" enthalten. Aber ich muß nicht alles verstehen ...
Antworten