Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] NAS wird per NFS beim Booten nicht sofort eingebunden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

[Gelöst] NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Mit meinem neuen Lenovo T14s (AMD) habe ich unter Leap 15.2 ein weiteres Problem: Unser Synology NAS wird z.B. mit

Code: Alles auswählen

NFS-Freigaben
Server           Entferntes Verzeichnis  Einhängepunkt         NFS-Version    Optionen
192.168.21.20    /volume1/music          /home/ralf/NAS-music  Irgendeins     soft,timeo=1,bg
eingebunden.
Das funktionierte unter Leap 15.1 mit dem alten Rechner T470s einwandfrei. Ebenso funktioniert es auf dem Desktop mit Leap 15.2 am selben Netz (alles drahtgebunden per Ethernet).

Der Fehler äußert sich so: Als user sehe ich mit Dolphin nur einen leeren Ordner NAS-music. Wenn ich mit dem Dateimanager - Super User Modus unter "Orte - Netzwerk" die Einbindung anklicke, dann geht es, d.h. der Ordner ist erreichbar. Beim Desktop ist der Ordner des NAS direkt nach dem Login erreichbar.
Bei beiden Rechnern - Desktop und T14s - ist die Firewall inaktiv. Beide Rechner und das NAS hängen an einer Fritzbox.

Diese Art der Einbindung per NFS hat über Jahre hinweg mit verschiedenen Rechnern und Linux-Versionen immer funktioniert.

Was habe ich da falsch konfiguriert?
Zuletzt geändert von navi-cc am 5. Jan 2021, 19:18, insgesamt 1-mal geändert.
stka
Moderator
Moderator
Beiträge: 3336
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von stka »

Schau mal in deine Log-Files, sowohl auf dem Client als auch auf den Server ob du dort Fehlermeldungen sehen kannst. Die poste bitte mal hier.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Hier ist hoffentlich der interessante Abschnitt aus der /var/log/messages:

Code: Alles auswählen

2020-12-20T22:40:57.827596+01:00 localhost systemd[1]: Starting Locale Service...
2020-12-20T22:40:57.919176+01:00 localhost kernel: [   11.557907] NFS: Registering the id_resolver key type
2020-12-20T22:40:57.919209+01:00 localhost kernel: [   11.557916] Key type id_resolver registered
2020-12-20T22:40:57.919212+01:00 localhost kernel: [   11.557917] Key type id_legacy registered
2020-12-20T22:40:57.933835+01:00 localhost systemd[1]: home-ralf-NAS\x2dmusic.mount: Mount process exited, code=exited status=32
2020-12-20T22:40:57.934119+01:00 localhost systemd[1]: Failed to mount /home/ralf/NAS-music.
2020-12-20T22:40:57.934229+01:00 localhost systemd[1]: home-ralf-NAS\x2dmusic.mount: Unit entered failed state.
2020-12-20T22:40:57.934322+01:00 localhost systemd[1]: home-ralf-NAS\x2dvideo.mount: Mount process exited, code=exited status=32
2020-12-20T22:40:57.934406+01:00 localhost systemd[1]: Failed to mount /home/ralf/NAS-video.
2020-12-20T22:40:57.934729+01:00 localhost systemd[1]: home-ralf-NAS\x2dvideo.mount: Unit entered failed state.
2020-12-20T22:40:57.934822+01:00 localhost systemd[1]: home-ralf-NAS.mount: Mount process exited, code=exited status=32
2020-12-20T22:40:57.934970+01:00 localhost systemd[1]: Failed to mount /home/ralf/NAS.
2020-12-20T22:40:57.935145+01:00 localhost kernel: [   11.572323] NFS4: Couldn't follow remote path
2020-12-20T22:40:57.935154+01:00 localhost kernel: [   11.572330] FS-Cache: Duplicate cookie detected
2020-12-20T22:40:57.935155+01:00 localhost kernel: [   11.572338] FS-Cache: O-cookie c=000000009dd2023a [p=000000005eb75c78 fl=222 nc=0 na=1]
2020-12-20T22:40:57.935158+01:00 localhost kernel: [   11.572339] FS-Cache: O-cookie d=00000000dc3362e7 n=000000004e900f00
2020-12-20T22:40:57.935160+01:00 localhost kernel: [   11.572341] FS-Cache: O-key=[16] '040000000200000002000801c0a81514'
2020-12-20T22:40:57.935161+01:00 localhost kernel: [   11.572347] FS-Cache: N-cookie c=00000000d078f0a3 [p=000000005eb75c78 fl=2 nc=0 na=1]
2020-12-20T22:40:57.935163+01:00 localhost kernel: [   11.572348] FS-Cache: N-cookie d=00000000dc3362e7 n=00000000ad44008f
2020-12-20T22:40:57.935165+01:00 localhost kernel: [   11.572349] FS-Cache: N-key=[16] '040000000200000002000801c0a81514'
2020-12-20T22:40:57.935166+01:00 localhost kernel: [   11.572354] FS-Cache: Duplicate cookie detected
2020-12-20T22:40:57.935168+01:00 localhost kernel: [   11.572358] FS-Cache: O-cookie c=000000009dd2023a [p=000000005eb75c78 fl=222 nc=0 na=1]
2020-12-20T22:40:57.935170+01:00 localhost kernel: [   11.572359] FS-Cache: O-cookie d=00000000dc3362e7 n=000000004e900f00
2020-12-20T22:40:57.935171+01:00 localhost kernel: [   11.572359] FS-Cache: O-key=[16] '040000000200000002000801c0a81514'
2020-12-20T22:40:57.935173+01:00 localhost kernel: [   11.572364] FS-Cache: N-cookie c=000000009ea1f8b3 [p=000000005eb75c78 fl=2 nc=0 na=1]
2020-12-20T22:40:57.935174+01:00 localhost kernel: [   11.572365] FS-Cache: N-cookie d=00000000dc3362e7 n=000000007b834149
2020-12-20T22:40:57.935176+01:00 localhost kernel: [   11.572365] FS-Cache: N-key=[16] '040000000200000002000801c0a81514'
2020-12-20T22:40:57.935178+01:00 localhost kernel: [   11.572455] NFS4: Couldn't follow remote path
2020-12-20T22:40:57.935180+01:00 localhost kernel: [   11.572506] NFS4: Couldn't follow remote path
2020-12-20T22:40:57.935182+01:00 localhost kernel: [   11.572597] NFS4: Couldn't follow remote path
2020-12-20T22:40:57.935668+01:00 localhost systemd[1]: home-ralf-NAS.mount: Unit entered failed state.
2020-12-20T22:40:57.935829+01:00 localhost systemd[1]: home-ralf-NAS\x2dphoto.mount: Mount process exited, code=exited status=32
2020-12-20T22:40:57.935952+01:00 localhost systemd[1]: Failed to mount /home/ralf/NAS-photo.
2020-12-20T22:40:57.936171+01:00 localhost systemd[1]: home-ralf-NAS\x2dphoto.mount: Unit entered failed state.
2020-12-20T22:40:57.943373+01:00 localhost dbus-daemon[1433]: [system] Successfully activated service 'org.freedesktop.locale1'





Sauerland
Guru
Guru
Beiträge: 3880
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von Sauerland »

IPV6 mal deaktiviert?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Gerade in den Netzwerkeinstellungen in yast deaktiviert. Keine Verbesserung.
Im Desktop ebenfalls mit Leap 15.2 aber Kernel 5.3.18 geht das aber, auch mit aktiviertem IPv6.
Sauerland
Guru
Guru
Beiträge: 3880
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von Sauerland »

Wie verbindest du dich denn mit dem Netzwerk?
Yast/wicked oder Netzwerkmanager?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 808
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von spezi »

sind denn die entsprechenden Dienste in der Diensteverwaltung aktiviert?
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
stka
Moderator
Moderator
Beiträge: 3336
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von stka »

Hast du mal versucht die options einfach auf "defaults" zu setzen? Ob dann ein mounten möglich ist. Was passiert wenn du von Hand als root moutest, eventuell mal mit debuglevel?
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Sauerland hat geschrieben: 21. Dez 2020, 16:39 Wie verbindest du dich denn mit dem Netzwerk?
Yast/wicked oder Netzwerkmanager?
network manager
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

spezi hat geschrieben: 21. Dez 2020, 18:22 sind denn die entsprechenden Dienste in der Diensteverwaltung aktiviert?
Da bin ich noch nie dran gewesen. Sind so eingestellt, wie sie bei der Installation waren. Welche hier wichtigen Dienste sollten denn welchen Status haben?
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

stka hat geschrieben: 21. Dez 2020, 20:33 Hast du mal versucht die options einfach auf "defaults" zu setzen? Ob dann ein mounten möglich ist. Was passiert wenn du von Hand als root mountest, eventuell mal mit debuglevel?
defaults bringt keine Veränderung :-(
Da ich auf der Kommandozeile nicht trittsicher bin: Wie lautet das Kommando?
Sauerland
Guru
Guru
Beiträge: 3880
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von Sauerland »

Poste mal als root:

Code: Alles auswählen

systemctl status NetworkManager-wait-online.service
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 808
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von spezi »

sicher nfs und natürlich, vergesse ich besonders gern, rpcbind :ops: . Die sollten beim Systemstart dasein.
Das Thema Synology NFS Konfiguration ist auch ganz nützlich.
Bei mir sieht das, allerdings verwende ich autofs, so aus:

Code: Alles auswählen

musik        -fstype=nfs4,rsize=32768,wsize=32768,intr,tcp,timeo=300,rw      meinNas:/volume1/music
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
stka
Moderator
Moderator
Beiträge: 3336
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von stka »

Mach doch mal ein "ss -tlpn" auf der Konsole deines NFS-Servers und poste mal das Ergebnis. Wenn "ss" vorhanden ist, dann ein "netstat -tlpn".
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Sauerland hat geschrieben: 21. Dez 2020, 23:19 Poste mal als root:

Code: Alles auswählen

systemctl status NetworkManager-wait-online.service
Hier ist es:

Code: Alles auswählen

● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; vendor preset: disabled)
   Active: active (exited) since Tue 2020-12-22 13:24:32 CET; 8h ago
     Docs: man:nm-online(1)
  Process: 1494 ExecStart=/bin/bash -c if [ ${NM_ONLINE_TIMEOUT} -gt 0 ]; then /usr/bin/nm-online -s -q --timeout=${NM_ONLINE_TIMEOUT} ; else /bin/true ; fi (code=exited, status=0/SUCCESS)
 Main PID: 1494 (code=exited, status=0/SUCCESS)
    Tasks: 0
   CGroup: /system.slice/NetworkManager-wait-online.service

Dec 22 13:24:26 localhost systemd[1]: Starting Network Manager Wait Online...
Dec 22 13:24:32 localhost systemd[1]: Started Network Manager Wait Online.
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

spezi hat geschrieben: 22. Dez 2020, 00:26 sicher nfs und natürlich, vergesse ich besonders gern, rpcbind :ops: . Die sollten beim Systemstart dasein.
Das Thema Synology NFS Konfiguration ist auch ganz nützlich.
Bei mir sieht das, allerdings verwende ich autofs, so aus:

Code: Alles auswählen

musik        -fstype=nfs4,rsize=32768,wsize=32768,intr,tcp,timeo=300,rw      meinNas:/volume1/music
nfs ist nun auf "Bei Systemstart" und zeigt als Status "Aktiv (Beendet)". Soll das so?
Das brachte leider keinen Erfolg.
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 808
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von spezi »

Ist ok. Und rpcbind?
Hat der Notebook User Berechtigungen auf den gemeinsamen Ordner vom Nas?
Zuletzt geändert von spezi am 22. Dez 2020, 22:53, insgesamt 2-mal geändert.
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Beim Systemstart Aktiv (läuft)
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 808
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von spezi »

ist auch ok.
Hat der Notebook User Berechtigungen auf den gemeinsamen Ordner vom Nas?
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
navi-cc
Member
Member
Beiträge: 185
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: NAS wird per NFS beim Booten nicht sofort eingebunden

Beitrag von navi-cc »

Ja. Lesen/Schreiben. NAS: Synology DS718+
Antworten