Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Bereitschaftsmodus funktioniert nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

[Gelöst] Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Hallo allerseits,ich nutze Linux Mint 20 Cinnamon.
Vorher Mint 19, nun ein paar Infos zum System:

Code: Alles auswählen

inxi -Fz
System:
  Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 
  Distro: Linux Mint 20 Ulyana 
Machine:
  Type: Laptop System: LENOVO product: INVALID v: INVALID serial: <filter> 
  Mobo: LENOVO model: VIUU4 v: 31900002 WIN serial: <filter> UEFI: LENOVO 
  v: B0CNA0WW date: 09/30/2016 
Battery:
  ID-1: BAT0 charge: 25.2 Wh condition: 25.2/28.5 Wh (88%) 
CPU:
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 800 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
  Device-2: AMD Sun LE [Radeon HD 8550M / R5 M230] driver: radeon v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: ati,modesetting,radeon 
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.0.8 
Audio:
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-48-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3160 driver: iwlwifi 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 111.79 GiB used: 32.98 GiB (29.5%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 840 Series size: 111.79 GiB 
Partition:
  ID-1: / size: 109.04 GiB used: 32.95 GiB (30.2%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: radeon temp: 36 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 205 Uptime: 2h 54m Memory: 7.69 GiB used: 1.99 GiB (25.8%) 
  Shell: bash inxi: 3.0.38 
Das Problem mit dem Bereitschaftsmodus äußert sich darin das der Rechner zwar in den Bereitschaftsmodus geht sobald der Deckel geschlossen wird aber sofort bei der geringsten Bewegung der Maus welche über USB angeschlossen ist wieder aufwacht.Dies hat unter Linux Mint 19 zuverlässig funktioniert,ich habe nun verschiedenste Kernel ausprobiert was aber nicht half.Vielleicht hat jemand einen Lösungsansatz wie dies zu bewerkstelligen ist.
Zuletzt geändert von Jeean am 29. Sep 2020, 19:39, insgesamt 1-mal geändert.
Gräfin Klara
Hacker
Hacker
Beiträge: 580
Registriert: 23. Jun 2008, 20:51

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Gräfin Klara »

Jeean hat geschrieben: 29. Sep 2020, 11:19 ...Vielleicht hat jemand einen Lösungsansatz wie dies zu bewerkstelligen ist.
Es gibt mehrere Möglichkeiten, das zu bewerkstelligen.
Zuerst solltest du im BIOS nachsehen, ob sich dort unter "ACPI" oder "Wakeup" die mouse konfigurieren läßt.
Wenn nicht, dann wäre eine udev rule wohl die beste Lösung.
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Danke für den Vorschlag.leider ist im Bios/Uefi welches doch sehr beschnitten ist keinerlei solche Einstellung zu finden.
Gräfin Klara
Hacker
Hacker
Beiträge: 580
Registriert: 23. Jun 2008, 20:51

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Gräfin Klara »

Jeean hat geschrieben: 29. Sep 2020, 17:34 Danke für den Vorschlag.leider ist im Bios/Uefi welches doch sehr beschnitten ist keinerlei solche Einstellung zu finden.
ok, dann probieren wir es mit udev

Code: Alles auswählen

# lsusb
?
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Code: Alles auswählen

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 8087:07dc Intel Corp. 
Bus 001 Device 004: ID 5986:0652 Acer, Inc Lenovo EasyCamera
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Gräfin Klara
Hacker
Hacker
Beiträge: 580
Registriert: 23. Jun 2008, 20:51

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Gräfin Klara »

Code: Alles auswählen

Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Ist das die mouse?
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Ja
Gräfin Klara
Hacker
Hacker
Beiträge: 580
Registriert: 23. Jun 2008, 20:51

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Gräfin Klara »

Jeean hat geschrieben: 29. Sep 2020, 18:03Ja
ok

Code: Alles auswählen

# ls -la /etc/udev/rules.d
?
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Das ergibt:

Code: Alles auswählen

ls -la /etc/udev/rules.d
insgesamt 8
drwxr-xr-x 2 root root 4096 Apr 22 11:04 .
drwxr-xr-x 4 root root 4096 Jul 30 21:44 ..
Gräfin Klara
Hacker
Hacker
Beiträge: 580
Registriert: 23. Jun 2008, 20:51

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Gräfin Klara »

ok

Erstelle eine Textdatei (als root)
/etc/udev/rules.d/90-acpi.rules

mit dem Inhalt
ACTION=="add", DRIVERS=="usb", SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTR{power/wakeup}="disabled"

Code: Alles auswählen

# udevadm control --reload-rules
Ausprobieren
Kein Erfolg?
Neustart
Kein Erfolg?
Dann müssen wir genauer hinsehen
Jeean
Newbie
Newbie
Beiträge: 6
Registriert: 29. Sep 2020, 11:05

Re: Bereitschaftsmodus funktioniert nicht mehr

Beitrag von Jeean »

Ich habe eine Textdatei mit dem Namen:90-acpi.rules erstellt. Dann der Befehl mit sudo voran sonst kommt no permission.
Kein Erfolg,Neustart und es funktioniert so wie es soll.... nochmal Neustart,sicher is sicher :D
Funktioniert super,ganz großes Dankeschön an die Gräfin ;)
Antworten