Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[aufgegeben] PC startet ab und zu nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Freddie62
Guru
Guru
Beiträge: 1580
Registriert: 24. Jan 2006, 14:21

[aufgegeben] PC startet ab und zu nicht

Beitrag von Freddie62 » 15. Jun 2020, 19:37

Seit einiger Zeit startet mein PC (OS-Tumbleweed, Kernel: 5.6.12-1-default) ab und zu nicht mehr, bzw. wirft beim Starten Fehlermeldungen bezüglich PCI und USB aus:

Code: Alles auswählen

# journalctl --system |grep error
Jun 15 19:02:36 Testrechner kernel: uhci_hcd 0000:01:07.0: host system error, PCI problems?
Jun 15 19:02:36 Testrechner kernel: usb usb2: can't read configurations, error -108
Jun 15 19:02:36 Testrechner kernel: uhci_hcd: probe of 0000:01:07.0 failed with error -108
Jun 15 19:02:36 Testrechner kernel: uhci_hcd 0000:01:07.1: host system error, PCI problems?
Jun 15 19:02:36 Testrechner kernel: usb usb3: can't set config #1, error -108
Dies geschah(geschieht auch mit älteren Kerneln. Ab und zu gibt es dann eine "kernel-panic", dann bleibt mir nur noch das Ausschalten. Meist startet er danach durch, die Fehlermeldungen jedoch bleiben. Mich wundert allerdings die Meldung zu USB3. Es ist zwar ab und zu eine USB3 Disk angeschlossen, aber der PC selbst hat nur USB2.
Leider finde ich zu diesem Thema nur ältere Threads, die auf Bugs in alten Kerneln hinweisen.
Hat jemand eine Idee, wie ich das retten kann, oder muß ich ernsthaft darüber nachdenken, den PC zu ersetzen?
Als Hardware verwende ich ein Asus M3N78 Mainboard mit einem AMD Athlon(tm) 7750 Dual-Core Processor, 8GB RAM und einer Nvidia Geforce GT730.
Ich weiß, die Hardware ist etwas älter, aber noch läuft sie .... :D

CU Freddie
Zuletzt geändert von Freddie62 am 21. Jun 2020, 12:20, insgesamt 1-mal geändert.
4 X Tumbleweed, Kernel: 5.4.10-1-default, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Tumbleweed-X64, Kernel: 5.4.10-1-default, LXDE

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7523
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: PC startet ab und zu nicht

Beitrag von spoensche » 15. Jun 2020, 21:02

Poste mal die Ausgabe von

Code: Alles auswählen

lspci -nnk
Stöpsel mal alle USB Geräte ab und boote dann mal.

Tritt das Problem weiterhin auf?

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2234
Registriert: 24. Okt 2005, 14:04

Re: PC startet ab und zu nicht

Beitrag von Heinz-Peter » 15. Jun 2020, 22:04

Hallo @Freddie62,

in anderen Foren lese ich viel von Problemen mit dem Kernel. Vor allem mit dem kernel 5.7. Der alte 5.6 sollte eigentlich noch Fehlerfrei sein. Ich hätte mit einem älteren Kernel versucht.

Grüße
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5422
Registriert: 23. Sep 2008, 17:09

Re: PC startet ab und zu nicht

Beitrag von josef-wien » 15. Jun 2020, 22:54

Zusätzlich zu spoensche noch:

Code: Alles auswählen

dmesg | grep -i usb
P. S. Die Numerierungen des Kernel haben nichts mit der USB-Version zu tun.

Freddie62
Guru
Guru
Beiträge: 1580
Registriert: 24. Jan 2006, 14:21

Re: PC startet ab und zu nicht

Beitrag von Freddie62 » 19. Jun 2020, 19:26

Bin leider in letzter Zeit selten am PC. Heute habe ich ihn mal wieder angemacht, da dachte ich, das wird wohl nicht mehr gehen, aber nach dem 12-ten Startversuch ist er endlich durchgestartet.
Bei den gescheiterten Start-Versuchen kommen jede Menge Zahlen und Meldungen, z.B.: NMI-Watchdog: Watchdog detected hard LOCKUP on cpu 0 oder 1, später dann Kernel panic - not syncing hard LOCKUP. Das kommt recht früh, direkt beim booten. Hier die Ausgaben:

Code: Alles auswählen

# dmesg | grep -i usb
[    4.581877] ACPI: bus type USB registered
[    4.581905] usbcore: registered new interface driver usbfs
[    4.581915] usbcore: registered new interface driver hub
[    4.607162] usbcore: registered new device driver usb
[    4.618091] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.635757] uhci_hcd: USB Universal Host Controller Interface driver
[    4.635976] uhci_hcd 0000:01:07.0: new USB bus registered, assigned bus number 1
[    4.636100] usb usb1: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.06
[    4.636102] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.636103] usb usb1: Product: UHCI Host Controller
[    4.636105] usb usb1: Manufacturer: Linux 5.6.12-1-default uhci_hcd
[    4.636106] usb usb1: SerialNumber: 0000:01:07.0
[    4.636250] hub 1-0:1.0: USB hub found
[    4.637955] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.639375] ehci-pci 0000:00:02.1: new USB bus registered, assigned bus number 2
[    4.654826] ehci-pci 0000:00:02.1: USB 2.0 started, EHCI 1.00
[    4.654890] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.06
[    4.654892] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.654893] usb usb2: Product: EHCI Host Controller
[    4.654894] usb usb2: Manufacturer: Linux 5.6.12-1-default ehci_hcd
[    4.654895] usb usb2: SerialNumber: 0000:00:02.1
[    4.655032] hub 2-0:1.0: USB hub found
[    4.655253] uhci_hcd 0000:01:07.1: new USB bus registered, assigned bus number 3
[    4.655352] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.06
[    4.655354] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.655355] usb usb3: Product: UHCI Host Controller
[    4.655356] usb usb3: Manufacturer: Linux 5.6.12-1-default uhci_hcd
[    4.655357] usb usb3: SerialNumber: 0000:01:07.1
[    4.655450] hub 3-0:1.0: USB hub found
[    4.660977] ehci-pci 0000:00:04.1: new USB bus registered, assigned bus number 4
[    4.678552] ehci-pci 0000:00:04.1: USB 2.0 started, EHCI 1.00
[    4.678622] usb usb4: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.06
[    4.678623] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.678625] usb usb4: Product: EHCI Host Controller
[    4.678626] usb usb4: Manufacturer: Linux 5.6.12-1-default ehci_hcd
[    4.678627] usb usb4: SerialNumber: 0000:00:04.1
[    4.678781] hub 4-0:1.0: USB hub found
[    4.679441] ehci-pci 0000:01:07.2: new USB bus registered, assigned bus number 5
[    4.694455] ehci-pci 0000:01:07.2: USB 2.0 started, EHCI 1.00
[    4.694523] usb usb5: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.06
[    4.694525] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.694526] usb usb5: Product: EHCI Host Controller
[    4.694527] usb usb5: Manufacturer: Linux 5.6.12-1-default ehci_hcd
[    4.694529] usb usb5: SerialNumber: 0000:01:07.2
[    4.694677] hub 5-0:1.0: USB hub found
[    4.722637] hub 1-0:1.0: USB hub found
[    4.750584] hub 3-0:1.0: USB hub found
[    4.752712] ohci-pci 0000:00:02.0: new USB bus registered, assigned bus number 6
[    4.812790] usb usb6: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.06
[    4.812792] usb usb6: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.812794] usb usb6: Product: OHCI PCI host controller
[    4.812795] usb usb6: Manufacturer: Linux 5.6.12-1-default ohci_hcd
[    4.812796] usb usb6: SerialNumber: 0000:00:02.0
[    4.813081] hub 6-0:1.0: USB hub found
[    4.820593] ohci-pci 0000:00:04.0: new USB bus registered, assigned bus number 7
[    4.880529] usb usb7: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.06
[    4.880532] usb usb7: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.880534] usb usb7: Product: OHCI PCI host controller
[    4.880535] usb usb7: Manufacturer: Linux 5.6.12-1-default ohci_hcd
[    4.880536] usb usb7: SerialNumber: 0000:00:04.0
[    4.881038] hub 7-0:1.0: USB hub found
[   72.833368] usb 7-1: new low-speed USB device number 2 using ohci-pci
[   73.067381] usb 7-1: New USB device found, idVendor=046d, idProduct=c046, bcdDevice=27.20
[   73.067384] usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   73.067387] usb 7-1: Product: USB Optical Mouse
[   73.067389] usb 7-1: Manufacturer: Logitech
[   73.112568] usbcore: registered new interface driver usbhid
[   73.112570] usbhid: USB HID core driver
[   73.123555] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:04.0/usb7/7-1/7-1:1.0/0003:046D:C046.0001/input/input14
[   73.123872] hid-generic 0003:046D:C046.0001: input,hidraw0: USB HID v1.10 Mouse [Logitech USB Optical Mouse] on usb-0000:00:04.0-1/input0

Code: Alles auswählen

# lspci -nnk
00:00.0 RAM memory [0500]: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller [10de:0754] (rev a2)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
00:01.0 ISA bridge [0601]: NVIDIA Corporation MCP78S [GeForce 8200] LPC Bridge [10de:075c] (rev a2)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
00:01.1 SMBus [0c05]: NVIDIA Corporation MCP78S [GeForce 8200] SMBus [10de:0752] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: nForce2_smbus
	Kernel modules: i2c_nforce2, nv_tco
00:01.2 RAM memory [0500]: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller [10de:0751] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
00:01.3 Co-processor [0b40]: NVIDIA Corporation MCP78S [GeForce 8200] Co-Processor [10de:0753] (rev a2)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
00:01.4 RAM memory [0500]: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller [10de:0568] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
00:02.0 USB controller [0c03]: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller [10de:077b] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci
00:02.1 USB controller [0c03]: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller [10de:077c] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:04.0 USB controller [0c03]: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller [10de:077d] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci
00:04.1 USB controller [0c03]: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller [10de:077e] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:06.0 IDE interface [0101]: NVIDIA Corporation MCP78S [GeForce 8200] IDE [10de:0759] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: pata_amd
	Kernel modules: pata_amd, pata_acpi, ata_generic
00:07.0 Audio device [0403]: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio [10de:0774] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:8290]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:08.0 PCI bridge [0604]: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge [10de:075a] (rev a1)
00:09.0 SATA controller [0106]: NVIDIA Corporation MCP78S [GeForce 8200] AHCI Controller [10de:0ad4] (rev a2)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: ahci
00:0a.0 Ethernet controller [0200]: NVIDIA Corporation MCP77 Ethernet [10de:0760] (rev a2)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
	Kernel driver in use: forcedeth
	Kernel modules: forcedeth
00:10.0 PCI bridge [0604]: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge [10de:0778] (rev a1)
	Kernel driver in use: pcieport
00:12.0 PCI bridge [0604]: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge [10de:075b] (rev a1)
	Kernel driver in use: pcieport
00:18.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration [1022:1200]
00:18.1 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map [1022:1201]
00:18.2 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller [1022:1202]
00:18.3 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control [1022:1203]
	Kernel modules: k10temp
00:18.4 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control [1022:1204]
01:07.0 USB controller [0c03]: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038] (rev 62)
	Subsystem: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038]
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
01:07.1 USB controller [0c03]: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038] (rev 62)
	Subsystem: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller [1106:3038]
	Kernel driver in use: uhci_hcd
	Kernel modules: uhci_hcd
01:07.2 USB controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 65)
	Subsystem: VIA Technologies, Inc. USB 2.0 Controller [1106:3104]
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 730] [10de:1287] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:84f5]
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia
02:00.1 Audio device [0403]: NVIDIA Corporation GK208 HDMI/DP Audio Controller [10de:0e0f] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:84f5]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
Danke fürs Nachsehen.

CU Freddie
4 X Tumbleweed, Kernel: 5.4.10-1-default, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Tumbleweed-X64, Kernel: 5.4.10-1-default, LXDE

mkossmann
Member
Member
Beiträge: 181
Registriert: 3. Aug 2009, 19:07

Re: PC startet ab und zu nicht

Beitrag von mkossmann » 19. Jun 2020, 20:43

Bei solchen Problemen sollte man nicht nur die Digitaltechnik (Motherboard/CPU/GPU/RAM) im Blick haben sondern auch das Netzteil, das möglicherweise aufgrund gealterter Kondensatoren keine stabile Versorgungsspannungen mehr liefert. Hast du schon eine Sichtkontrolle gemacht, ob du auf dem Motherboard oder im Netzteil ( bitte nicht aufschrauben) aufgeblähte Kondensatoren findest ?

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5422
Registriert: 23. Sep 2008, 17:09

Re: PC startet ab und zu nicht

Beitrag von josef-wien » 20. Jun 2020, 00:13

Wenn die optische und die Riech-Kontrolle nichts ergeben, könntest Du den Hauptspeicher testen. Wenn es öfter erst nach einer Anzahl von Startversuchen funktioniert, könnte irgendein Bauteil (den Du wohl nicht finden wirst) nur mehr bei entsprechender Wärme vernünftig arbeiten. Ein Problem durch Linux scheint mir bei den Symptomen eher unwahrscheinlich zu sein.

Freddie62
Guru
Guru
Beiträge: 1580
Registriert: 24. Jan 2006, 14:21

Re: PC startet ab und zu nicht

Beitrag von Freddie62 » 21. Jun 2020, 12:20

So etwas befürchte ich auch. Ich habe gerade noch versucht, ein BIOS-Update zu machen (Original-Bios von 2010). Er findet noch nicht mal mehr den USB-Stick im Update-Utility, obwohl er im BIOS selbst angezeigt wird. Dieser PC hat ohnehin irgendwelche Problem mit dem MB, da Audio nur für einige Zeit nach einem BIOS-Update ging. Irgendwann habe ich dann auf Audio verzichtet. USB (Maus) macht auch immer mehr Probleme. Die sind gleich, ob mit neuer oder alter Maus: Es sieht fast so aus, als ob die linke Maustaste ab und zu aussetzt. Na ja, ich habe das Ding vor ca. 7 Jahren auf dem Wertstoffhof gefunden ....
Dann gibt's eben einen Neuen!
Danke trotzdem für die Hilfe.

CU Freddie
4 X Tumbleweed, Kernel: 5.4.10-1-default, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Tumbleweed-X64, Kernel: 5.4.10-1-default, LXDE

Antworten