Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] WakeOnLAN nicht möglich mit Network Manager

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 465
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

[gelöst] WakeOnLAN nicht möglich mit Network Manager

Beitrag von f.gruber » 13. Nov 2019, 10:29

Hallo,
ich habe festgestellt, dass WakeOnLAN nur funktioniert, wenn wicked für die Steuerung des Netzwerks eingestellt ist.
Sobald ich (mit YAST) umstelle auf den NetworkManager, kann ich diesen Rechner nicht mehr per WakeOnLan starten.

Ich bin bei allen Rechnern - nicht nur Notebooks - deswegen auf den NetworkManager umgestiegen, da dann der Rechner um einiges schneller bootet.
Gibt es eine Möglichkeit, WakeOnLan bei Verwendung des NetworkManagers zu nutzen?

Sysinfo: openSUSE Leap in der aktuellen Version.
Zuletzt geändert von f.gruber am 16. Nov 2019, 09:50, insgesamt 1-mal geändert.
Gruß
Ferdinand

Werbung:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 656
Registriert: 19. Sep 2014, 18:22

Re: WakeOnLAN nicht möglich mit Network Manager

Beitrag von susejunky » 15. Nov 2019, 09:48

Hallo f.gruber,
f.gruber hat geschrieben:
13. Nov 2019, 10:29
... ich habe festgestellt, dass WakeOnLAN nur funktioniert, wenn wicked für die Steuerung des Netzwerks eingestellt ist.
Sobald ich (mit YAST) umstelle auf den NetworkManager, kann ich diesen Rechner nicht mehr per WakeOnLan starten.
damit WakeOnLan (WOL) funktioniert müssen
  • das Motherboard des aufzuweckenden Rechners WOL unterstützen und ggf. eine entsprechende Option im UEFI/BIOS aktiviert sein.
  • die Netzwerkkarte und der zugehörige Treiber WOL unterstützen
Da bei Deinem System WOL mit wicked funktioniert, sollten diese Voraussetzungen erfüllt sein.

Wenn Du NetworkManager verwendest, hast Du unter /etc/NetworkManager/system-connections eine Verbindungsdatei für die kabelgebundene Verbindung angelegt? Falls ja, beinhaltet diese eine Definition

Code: Alles auswählen

wake-on-lan=
mögliche Werte siehe

Code: Alles auswählen

$ man nm-settings
Gibt es auf Deinem System eine Datei /etc/NetworkManager/conf.d/x.conf (x.conf = beispielhaft) mit einer Definition

Code: Alles auswählen

[connection]
ethernet.wake-on-lan=
Viele Grüße

susejunky

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 465
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: WakeOnLAN nicht möglich mit Network Manager

Beitrag von f.gruber » 16. Nov 2019, 09:49

Danke für den Hinweis auf die Konfigurationsdatei des Network Managers

Ich konnte es jetzt so lösen:

Code: Alles auswählen

nmcli connection
NAME       UUID                                  TYPE      DEVICE 
LAN Kabel  e0aacc25-a365-37fe-89be-47f8a60c77f6  ethernet  eth0  
dann

Code: Alles auswählen

nmcli connection modify "LAN Kabel" ethernet.wake-on-lan magic
und einen cronjob:

Code: Alles auswählen

@reboot ethtool -s eth0 wol g
Gruß
Ferdinand

Antworten