Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Yast

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
H1A
Member
Member
Beiträge: 69
Registriert: 26. Dez 2016, 15:24

[Gelöst] Yast

Beitrag von H1A » 24. Okt 2019, 19:29

hallo,
wie in meinem anderen thread angeführt, habe ich photofilmstrip über yast installiert.
nur das programm lies sich nicht starten.....
danach habe ich in der softwareaktuallisierung mehrere updates die ich durchlaufen lies.
dann kam noch eins, das sich aber über desktop nicht installieren ließ, also habe ich yast gestartet.....
und da kam die ernüchterung......
mir fehlen in yast alle einträge zur software installierung.....
yast beginnt erst bei hardware....

frage:
wie kann das sein und wie kann ich die einträge wieder bekommen?

zudem, wie kann ich dieses update problem lösen, das seither immer aufpoppt.

Code: Alles auswählen

libqt5-qtwebengine-5.10.1-lp150.3.4.2.x86_64 requires libQt5Quick.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided 
vorab schon ein danke für hilfe
volker
Zuletzt geändert von H1A am 25. Okt 2019, 19:55, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 597
Registriert: 19. Sep 2014, 18:22

Re: Yast

Beitrag von susejunky » 24. Okt 2019, 20:55

Hallo H1A,
H1A hat geschrieben:
24. Okt 2019, 19:29
... wie in meinem anderen thread angeführt,
welcher ???
H1A hat geschrieben:
24. Okt 2019, 19:29
... danach habe ich in der softwareaktuallisierung mehrere updates die ich durchlaufen lies.
softwareaktuallisierung ist was (yast, zypper, rpm, ...)???
H1A hat geschrieben:
24. Okt 2019, 19:29
... dann kam noch eins, das sich aber über desktop nicht installieren ließ,
Was wolltest Du genau tun?

Zeige bitte die Ergebnisse (inkl. der Befehlszeile) folgender Befehle (als Administrator in einer Konsole ausführen)

Code: Alles auswählen

# zypper lr -uEP

Code: Alles auswählen

# zypper se -si yast2-
Viele Grüße

susejunky

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5368
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Yast

Beitrag von tomm.fa » 24. Okt 2019, 21:47

Und um welche Version von openSUSE/SUSE geht es?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

H1A
Member
Member
Beiträge: 69
Registriert: 26. Dez 2016, 15:24

Re: Yast

Beitrag von H1A » 25. Okt 2019, 09:47

die version ist suse leap 15.1

Code: Alles auswählen

H1A hat geschrieben: ↑
24. Okt 2019, 19:29
... wie in meinem anderen thread angeführt,
unter multimedia ffdiaporama

Code: Alles auswählen

H1A hat geschrieben: ↑
24. Okt 2019, 19:29
... danach habe ich in der softwareaktuallisierung mehrere updates die ich durchlaufen lies.
über yast

Code: Alles auswählen

H1A hat geschrieben: ↑
24. Okt 2019, 19:29
... dann kam noch eins, das sich aber über desktop nicht installieren ließ,
über software aktualisieren icon, in der unteren kontrollleiste

Code: Alles auswählen

zypper lr -uEP
#  | Alias                               | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                                                 
---+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------------------
10 | packman.inode.at-suse               | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   15      | http://packman.inode.at/suse/openSUSE_Leap_15.1/                                    
16 | repo-update-non-oss                 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   20      | http://download.opensuse.org/update/leap/15.1/non-oss/                              
14 | repo-source-non-oss                 | Source Repository (Non-OSS)                             | Ja        | (r ) Ja         | Ja             |   21      | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/            
12 | repo-oss                            | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja             |   22      | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                       
11 | repo-non-oss                        | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             |   24      | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                   
13 | repo-source                         | Source Repository                                       | Ja        | (r ) Ja         | Ja             |   25      | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/                
 4 | openSUSE_Leap_15.1                  | Multimedia                                              | Ja        | (r ) Ja         | Ja             |   26      | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.1/      
 7 | openSUSE_Leap_15.1_3                | Graphics                                                | Ja        | (r ) Ja         | Ja             |   27      | http://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.1/              
 8 | openSUSE_Leap_15.1_4                | Mozilla                                                 | Ja        | (r ) Ja         | Ja             |   28      | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1                
 9 | opensuse-guide.org-repo             | Libdvdcss Repository                                    | Ja        | (r ) Ja         | Ja             |   30      | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                  
 5 | openSUSE_Leap_15.1_1                | Photo                                                   | Ja        | (r ) Ja         | Ja             |   31      | http://download.opensuse.org/repositories/multimedia:/photo/openSUSE_Leap_15.1/     
 6 | openSUSE_Leap_15.1_2                | Libs multimedia                                         | Ja        | (r ) Ja         | Ja             |   40      | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.1/      
 1 | download.nvidia.com-leap            | nVidia Graphics Drivers                                 | Ja        | (r ) Ja         | Ja             |   60      | https://download.nvidia.com/opensuse/leap/15.1                                      
 2 | http-download.opensuse.org-7fe4f052 | openSUSE:Leap:15.0:Update                               | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/update/leap/15.0/oss/                                  
 3 | http-download.opensuse.org-a57dc070 | home:frispete:python                                    | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/repositories/home:/frispete:/python/openSUSE_Leap_15.0/

Code: Alles auswählen

zypper se -si yast2-
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                       | Typ   | Version                             | Arch   | Repository               
---+----------------------------+-------+-------------------------------------+--------+--------------------------
i+ | yast2-alternatives         | Paket | 4.0.0-lp151.2.2                     | x86_64 | Haupt-Repository         
i+ | yast2-apparmor             | Paket | 4.1.7-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-auth-client          | Paket | 4.1.2-lp151.2.3.1                   | noarch | (Systempakete)           
i+ | yast2-auth-server          | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-control-center       | Paket | 4.1.7-lp151.1.2                     | x86_64 | Haupt-Repository         
i+ | yast2-control-center-qt    | Paket | 4.1.7-lp151.1.2                     | x86_64 | Haupt-Repository         
i+ | yast2-core                 | Paket | 4.1.0-lp151.1.5                     | x86_64 | Haupt-Repository         
i+ | yast2-country-data         | Paket | 4.1.13-lp151.2.3.1                  | x86_64 | (Systempakete)           
i+ | yast2-firewall             | Paket | 4.1.12-lp151.1.1                    | noarch | Haupt-Repository         
i+ | yast2-ftp-server           | Paket | 4.1.6-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-hardware-detection   | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-journal              | Paket | 4.1.5-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-logs                 | Paket | 4.1.72-lp151.2.10.1                 | x86_64 | (Systempakete)           
i+ | yast2-nfs-common           | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-nfs-server           | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-pam                  | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-perl-bindings        | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-pkg-bindings         | Paket | 4.0.13-lp150.2.13.1                 | x86_64 | openSUSE:Leap:15.0:Update
i+ | yast2-printer              | Paket | 4.1.1-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-proxy                | Paket | 4.1.1-lp151.2.3.1                   | noarch | (Systempakete)           
i+ | yast2-python3-bindings     | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-qt-branding-openSUSE | Paket | 15.1-lp151.2.2                      | noarch | Haupt-Repository         
i+ | yast2-ruby-bindings        | Paket | 4.1.4-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-samba-client         | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-scanner              | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-security             | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-services-manager     | Paket | 4.1.14-lp151.1.1                    | noarch | Haupt-Repository         
i+ | yast2-slp                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-snapper              | Paket | 4.1.2-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-sound                | Paket | 4.1.1-lp151.1.9                     | x86_64 | Haupt-Repository         
i+ | yast2-support              | Paket | 4.1.1-lp151.2.3.1                   | noarch | (Systempakete)           
i+ | yast2-sysconfig            | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-tftp-server          | Paket | 4.1.7-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-theme                | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-theme-breeze         | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-theme-oxygen         | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-trans-de             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository         
i+ | yast2-trans-de             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository         
i+ | yast2-trans-en             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository         
i+ | yast2-trans-stats          | Paket | 2.19.0-lp151.2.1                    | noarch | Haupt-Repository         
i+ | yast2-transfer             | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-vpn                  | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-x11                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-xml                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
i+ | yast2-ycp-ui-bindings      | Paket | 4.1.0-lp151.1.4                     | x86_64 | Haupt-Repository       
ich hoffe, daß mir jemand eine lösung anbieten kann, damit die fehlenden einträge wieder in yast sind und ich die letzten 3 repositories wieder löschen kann.

vielen dank vorab
volker

abgdf
Guru
Guru
Beiträge: 3254
Registriert: 13. Apr 2004, 21:15

Re: Yast

Beitrag von abgdf » 25. Okt 2019, 14:13

Ich verstehe noch nicht ganz Dein Problem: Kannst Du die Softwareverwaltung von YaST2 nicht mehr starten?

Sauerland
Guru
Guru
Beiträge: 3563
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Yast

Beitrag von Sauerland » 25. Okt 2019, 17:17

Und die Prioritäten würde ich auch einmal zurücksetzen......
Sowie:
multimedia-libs und Packman beissen sich meist
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 597
Registriert: 19. Sep 2014, 18:22

Re: Yast

Beitrag von susejunky » 25. Okt 2019, 17:32

Hallo H1A,
H1A hat geschrieben:
25. Okt 2019, 09:47
...
die version ist suse leap 15.1
Du hast aber noch zwei Repositories aus 15.0 aktiviert !
H1A hat geschrieben:
25. Okt 2019, 09:47
...

Code: Alles auswählen

zypper lr -uEP
#  | Alias                               | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                                                 
---+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------------------
...
 2 | http-download.opensuse.org-7fe4f052 | openSUSE:Leap:15.0:Update                               | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/update/leap/15.0/oss/                                  
 3 | http-download.opensuse.org-a57dc070 | home:frispete:python                                    | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/repositories/home:/frispete:/python/openSUSE_Leap_15.0/
um zu verhindern, dass Pakete aus unterschiedlichen openSUSE-Versionen installiert werden, solltest Du diese beiden Repositories deaktivieren (es sei denn, Du kannst tatsächlich genau beurteilen, was Du da tust).

Ob und in welchem Umfang Du Dein System mit diesen beiden Repositories eventuell bereits "durcheinander gebracht hast" ist schwer zu sagen.

Die parallele Verwendung von http://download.opensuse.org/repositori ... Leap_15.1/ und http://packman.inode.at/suse/openSUSE_Leap_15.1/ kann ebenfalls zu Problemen führen. Wenn Du nicht ganz sicher beurteilen kannst, wie diese beiden Repositories zusammenspielen, dann deaktiviere http://download.opensuse.org/repositori ... Leap_15.1/ und verwende ausschließlich Packman.
H1A hat geschrieben:
25. Okt 2019, 09:47
...

Code: Alles auswählen

zypper se -si yast2-
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                       | Typ   | Version                             | Arch   | Repository               
---+----------------------------+-------+-------------------------------------+--------+--------------------------
i+ | yast2-alternatives         | Paket | 4.0.0-lp151.2.2                     | x86_64 | Haupt-Repository         
...
i+ | yast2-pam                  | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository         
i+ | yast2-perl-bindings        | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository         
...
i+ | yast2-ycp-ui-bindings      | Paket | 4.1.0-lp151.1.4                     | x86_64 | Haupt-Repository 
ich hoffe, daß mir jemand eine lösung anbieten kann, damit die fehlenden einträge wieder in yast sind
Dass die Softwareverwaltung in Deinem Yast-Control-Center nicht mehr angezeigt wird, dürfte daran liegen, dass das Paket yast2-packager bei Dir anscheinend nicht installiert ist.

Code: Alles auswählen

#zypper in yast2-packager
als Administrator in einer Konsole sollte das beheben.

Viele Grüße

susejunky

Sauerland
Guru
Guru
Beiträge: 3563
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Yast

Beitrag von Sauerland » 25. Okt 2019, 17:40

yast2-pkg-bindings | Paket | 4.0.13-lp150.2.13.1 | x86_64 | openSUSE:Leap:15.0:Update
wäre auch noch falsch
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

H1A
Member
Member
Beiträge: 69
Registriert: 26. Dez 2016, 15:24

Re: Yast

Beitrag von H1A » 25. Okt 2019, 18:31

so, bin soeben dahinter gegangen und habe zuerst den zypperbefehl ausgeführt.....
danach war im yast wieder die paketverwaltung vorhanden, außer der online aktuallisierung und noch einige andere (siehe unten)

dann hab ich die ganzen repos gelöscht, die es mir beim install von photofilmstrip geladen hat.
zudem habe ich auch nvidia gelöscht, da ich mich nicht auch noch damit rumschlagen will.

hier die neuen ausgaben:

Code: Alles auswählen

zypper se -si yast2-    
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                       | Typ   | Version                             | Arch   | Repository      
---+----------------------------+-------+-------------------------------------+--------+-----------------
i+ | yast2-alternatives         | Paket | 4.0.0-lp151.2.2                     | x86_64 | Haupt-Repository
i+ | yast2-apparmor             | Paket | 4.1.7-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-auth-client          | Paket | 4.1.2-lp151.2.3.1                   | noarch | (Systempakete)  
i+ | yast2-auth-server          | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-control-center       | Paket | 4.1.7-lp151.1.2                     | x86_64 | Haupt-Repository
i+ | yast2-control-center-qt    | Paket | 4.1.7-lp151.1.2                     | x86_64 | Haupt-Repository
i+ | yast2-core                 | Paket | 4.1.0-lp151.1.5                     | x86_64 | Haupt-Repository
i+ | yast2-country-data         | Paket | 4.1.13-lp151.2.3.1                  | x86_64 | (Systempakete)  
i+ | yast2-firewall             | Paket | 4.1.12-lp151.1.1                    | noarch | Haupt-Repository
i+ | yast2-ftp-server           | Paket | 4.1.6-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-hardware-detection   | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-journal              | Paket | 4.1.5-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-logs                 | Paket | 4.1.72-lp151.2.10.1                 | x86_64 | (Systempakete)  
i+ | yast2-nfs-common           | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-nfs-server           | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-packager             | Paket | 4.1.41-lp151.1.1                    | x86_64 | Haupt-Repository
i+ | yast2-pam                  | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-perl-bindings        | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-pkg-bindings         | Paket | 4.1.2-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-printer              | Paket | 4.1.1-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-proxy                | Paket | 4.1.1-lp151.2.3.1                   | noarch | (Systempakete)  
i+ | yast2-python3-bindings     | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-qt-branding-openSUSE | Paket | 15.1-lp151.2.2                      | noarch | Haupt-Repository
i+ | yast2-ruby-bindings        | Paket | 4.1.4-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-samba-client         | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-scanner              | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-security             | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-services-manager     | Paket | 4.1.14-lp151.1.1                    | noarch | Haupt-Repository
i+ | yast2-slp                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-snapper              | Paket | 4.1.2-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-sound                | Paket | 4.1.1-lp151.1.9                     | x86_64 | Haupt-Repository
i  | yast2-storage-ng           | Paket | 4.1.83-lp151.1.1                    | x86_64 | Haupt-Repository
i+ | yast2-support              | Paket | 4.1.1-lp151.2.3.1                   | noarch | (Systempakete)  
i+ | yast2-sysconfig            | Paket | 4.1.2-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-tftp-server          | Paket | 4.1.7-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-theme                | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-theme-breeze         | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-theme-oxygen         | Paket | 4.2.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-trans-de             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository
i+ | yast2-trans-de             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository
i+ | yast2-trans-en             | Paket | 84.87.20190511.bc4a9329cc-lp151.1.1 | noarch | Haupt-Repository
i+ | yast2-trans-stats          | Paket | 2.19.0-lp151.2.1                    | noarch | Haupt-Repository
i+ | yast2-transfer             | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-vpn                  | Paket | 4.1.0-lp151.1.1                     | noarch | Haupt-Repository
i+ | yast2-x11                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-xml                  | Paket | 4.1.0-lp151.1.1                     | x86_64 | Haupt-Repository
i+ | yast2-ycp-ui-bindings      | Paket | 4.1.0-lp151.1.4                     | x86_64 | Haupt-Repository

Code: Alles auswählen

 zypper lr -uEP      
#  | Alias                   | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                                            
---+-------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------------------------------------------------------------------------------
 6 | packman.inode.at-suse   | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   15      | http://packman.inode.at/suse/openSUSE_Leap_15.1/                               
12 | repo-update-non-oss     | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   20      | http://download.opensuse.org/update/leap/15.1/non-oss/                         
10 | repo-source-non-oss     | Source Repository (Non-OSS)                             | Ja        | (r ) Ja         | Ja             |   21      | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/       
 8 | repo-oss                | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja             |   22      | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                  
 7 | repo-non-oss            | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             |   24      | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/              
 9 | repo-source             | Source Repository                                       | Ja        | (r ) Ja         | Ja             |   25      | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/           
 1 | openSUSE_Leap_15.1      | Multimedia                                              | Ja        | (r ) Ja         | Ja             |   26      | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.1/ 
 3 | openSUSE_Leap_15.1_3    | Graphics                                                | Ja        | (r ) Ja         | Ja             |   27      | http://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.1/         
 4 | openSUSE_Leap_15.1_4    | Mozilla                                                 | Ja        | (r ) Ja         | Ja             |   28      | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1           
 5 | opensuse-guide.org-repo | Libdvdcss Repository                                    | Ja        | (r ) Ja         | Ja             |   30      | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                             
 2 | openSUSE_Leap_15.1_1    | Photo                                                   | Ja        | (r ) Ja         | Ja             |   31      | http://download.opensuse.org/repositories/multimedia:/photo/openSUSE_Leap_15.1/

was mir auffällt, im gegensatz zu yast auf meinem laptop, fehlen trotzdem noch etliche einträge jetzt.

z.b. onlineaktual. - zusatz produkte

unter hardware:

hardware infos - system tastaturlayout

in system sind nur 3 einträge gegenüber 10 auf dem laptop......ect

frage:
kann ich mit einem befehlsatz das komplt. yast neu aktivieren oder einspielen?

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 597
Registriert: 19. Sep 2014, 18:22

Re: Yast

Beitrag von susejunky » 25. Okt 2019, 19:07

Hallo H1A,
H1A hat geschrieben:
25. Okt 2019, 18:31
... was mir auffällt, im gegensatz zu yast auf meinem laptop, fehlen trotzdem noch etliche einträge jetzt.

z.b. onlineaktual. - zusatz produkte

unter hardware:

hardware infos - system tastaturlayout

in system sind nur 3 einträge gegenüber 10 auf dem laptop......ect

frage:
kann ich mit einem befehlsatz das komplt. yast neu aktivieren oder einspielen?
einige der Yast-Elemente werden zusammen mit den Softwarepaketen installiert, für deren Konfiguration sie benötigt werden; d.h. wenn auf Deinem System kein EMail-Server installiert ist, wird auch sehr wahrscheinlich nicht das zugehörige Konfigurationsmodul in Yast verfügbar sein.

Wenn Dir tatsächlich ein Modul fehlt, suche in Yast nach "yast2-" und installiere aus der angezeigten Liste das, was fehlt / was Du benötigst.

Viele Grüße

susejunky

H1A
Member
Member
Beiträge: 69
Registriert: 26. Dez 2016, 15:24

Re: Yast

Beitrag von H1A » 25. Okt 2019, 19:43

ok, dann werd ich mal sehen.....
vielen dank an all die mitstreiter deren hilfe ich bekam.
bis zum nächsten mal.... :D
grüße
volker

btw:
mein anderer thread in multimedia darf weiter bedient werden, da das mit dem photofilmstrip nicht in frage kommt nach der katastrophe jetzt.

abgdf
Guru
Guru
Beiträge: 3254
Registriert: 13. Apr 2004, 21:15

Re: Yast (Gelöst)

Beitrag von abgdf » 26. Okt 2019, 14:38

Dieses hier müßte Dir die distributionsfremden Pakete auf Deinem System auflisten:

Code: Alles auswählen

#!/bin/bash

yourdist="15.1"

for i in $(rpm -qa); do
    a=$(rpm -qi "$i" | grep "Distribution")
    if test -z "$(echo $a | grep $yourdist)"; then
        echo "$i"
        echo "$a"
        echo
    fi
done
Ganz interessant: Zeigt bei mir die Pakete an, die ich selbst kompiliert hab'. Hatte ich gar nicht erwartet, ist aber logisch.

Antworten