Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

HP Laptop bootet nicht in grub

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2060
Registriert: 24. Okt 2005, 14:04

Re: HP Laptop bootet nicht in grub

Beitrag von Heinz-Peter » 5. Sep 2019, 12:14

josef-wien hat geschrieben:
5. Sep 2019, 12:02
Heinz-Peter hat geschrieben:
5. Sep 2019, 11:53
Das hilft überhaupt nichts.
Dann lasse es sein.

Gruß
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Werbung:
klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 16:45

Hallo,

Code: Alles auswählen

linux-5xu6:~ # efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0000,0003,2002,2004
Boot0000* Notebook Hard Drive - SAMSUNG MZNLN256HAJQ-000H1      BBS(HD,Notebook Hard Drive - SAMSUNG MZNLN256HAJQ-000H1,0x0)..................................."..............................`q|.......A.........................
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)     PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x26ce2674,0xac8,0x1e84)RC
Boot0003* USB Hard Drive - VendorCoProductCode  BBS(7,USB Hard Drive - VendorCoProductCode,0x500)..................M.......K...O..................................X.C|.......A.....................
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
linux-5xu6:~ # 
irgendwer hat meinen Eintrag 1 wieder überschrieben. Evtl. weil ich im BIOS von Legacy auf UEFI umgeschaltet hatte. Werde das nochmals testen.

Zur Bestätigung nochmals:

Legacy ON --> FreeDOS
Legacy OFF --> No OS found

Wohl nicht ganz unwichtige Frage ist soll ehr mit Legacy ON oder OFF testen?

DAnke.

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 16:49

Aus einer Google Suche

Code: Alles auswählen

linux-5xu6:~ # dmidecode -t0 | grep -Ei "BIOS boot|UEFI"
                BIOS boot specification is supported
                UEFI is supported


Im BIOS stelle ich ja ob ich legacy an oder aus haben will. Aber muss ich dem Installer irgendwie bei der Installation sagen ob ich bios oder uefi will?

Code: Alles auswählen

linux-5xu6:~ # efibootmgr -c -d /dev/sda -p 3 -L "openSUSE neu" -l /EFI/opensuse/grub.efi
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,2001,0000,0003,2002,2004
Boot0000* Notebook Hard Drive - SAMSUNG MZNLN256HAJQ-000H1
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)
Boot0003* USB Hard Drive - VendorCoProductCode
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot0002* openSUSE neu
WAs ist das mit der GUID?

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2060
Registriert: 24. Okt 2005, 14:04

Re: HP Laptop bootet nicht in grub

Beitrag von Heinz-Peter » 5. Sep 2019, 17:25

Wohl nicht ganz unwichtige Frage ist soll ehr mit Legacy ON oder OFF testen?
Legacy OFF ist die richtige Einstellung.
Im BIOS stelle ich ja ob ich legacy an oder aus haben will. Aber muss ich dem Installer irgendwie bei der Installation sagen ob ich bios oder uefi will?
Diese Frage kann ich nicht beantworten. Die Leap 15 Version habe ich nicht installiert. Eigentlich sollte die Installationsroutine das erledigen.
WAs ist das mit der GUID?
Grob gesagt ist das die neue Partition Tabelle. Die alte hatte 4 Primäre Partitionen. Die GUID hat über 100. Suche nach GUID im wiki.

Gruß
Zuletzt geändert von Heinz-Peter am 5. Sep 2019, 17:32, insgesamt 1-mal geändert.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 17:32

So ich habe jetzt nochmal getestet (schreibe jetzt nur den Fall für Legacy off, Legacy on ist aber im prinzip genauso):

1. System gebootet (über den Umweg der Installationsmedien), dann

Code: Alles auswählen

linux-5xu6:~ # efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,2002,2004
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)     PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x26ce2674,0xac8,0x1e84)RC
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
linux-5xu6:~ # 
2. Neuen Eintrag hinzugefügt für mein Partition, wie zuvor beschrieben

Code: Alles auswählen

linux-5xu6:~ # efibootmgr -c -d /dev/sda -p 3 -L "openSUSE neu" -l /EFI/opensuse/grub.efi               
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,2001,2002,2004
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot0000* openSUSE neu
linux-5xu6:~ # efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,2001,2002,2004
Boot0000* openSUSE neu  HD(3,MBR,0xe3605dcd,0xfa0800,0xfa000)/File(\EFI\opensuse\grub.efi)
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)     PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x26ce2674,0xac8,0x1e84)RC
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
linux-5xu6:~ # efibootmgr -O
BootCurrent: 0001
Timeout: 0 seconds
No BootOrder is set; firmware will attempt recovery
Boot0000* openSUSE neu
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
linux-5xu6:~ # efibootmgr -o 0,1,0,2001,2002
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,0000,2001,2002
Boot0000* openSUSE neu
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
linux-5xu6:~ # efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,0000,2001,2002
Boot0000* openSUSE neu  HD(3,MBR,0xe3605dcd,0xfa0800,0xfa000)/File(\EFI\opensuse\grub.efi)
Boot0001* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)     PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x26ce2674,0xac8,0x1e84)RC
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
linux-5xu6:~ # 

Insbesondere die letzte Ausgabe von efibootmgr -v beachten, dort steht mein openSuse neu drin.

3. Laptop ohne Installationsmedium gebootet --> gleicher Fehler wie immer
4. Laptop mit Hilfe von Installationsmedium gebootet und

Code: Alles auswählen

linux-5xu6:~ # efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001,2002,2004
Boot0000* USB Hard Drive (UEFI) - VendorCoProductCode (VendorCoProductCode)     PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x26ce2674,0xac8,0x1e84)RC
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
linux-5xu6:~ # 
Sprich mein Eintrag openSuse neu ist weg. Irgendwer hat ihn überschrieben.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5309
Registriert: 23. Sep 2008, 17:09

Re: HP Laptop bootet nicht in grub

Beitrag von josef-wien » 5. Sep 2019, 17:59

Die meisten meiner Fragen warten noch auf eine Antwort.

Wie ich Dein UEFI einschätze, hält es sich überhaupt nicht an die gültigen Spezifikationen, sondern führt ein komsumentenfeindliches Eigenleben. Da wirst Du wohl HP fragen müssen, was wo einzutragen ist, um eine Datei "irgendetwas.efi" auf der EFI-Systempartition auszuführen.

Schafft es Dein UEFI, vom Installationsmedium im "Legacy Boot"-Modus zu starten? Im Erfolgsfall hast Du ein Boot-Menü mit Funktionstasten am unteren Rand. Eventuell kannst Du bei "UEFI Boot Order" die dritte Zeile deaktivieren (die fünfte mit dem vorangestellten Rufzeichen sieht mir nach "deaktiviert" aus).

P. S. Bei der Fehlermeldung von efibootmgr hat wohl ein Entwickler über seine Verhältnisse codiert. UEFI ist sowohl bei einer msdos-Partitionentabelle als auch bei einer GPT möglich.

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 18:12

Hallo,

ich sehe keine Frage die ich nicht beantwortet habe. Welche habe ich übersehen?
Schafft es Dein UEFI, vom Installationsmedium im "Legacy Boot"-Modus zu starten? Im Erfolgsfall hast Du ein Boot-Menü mit Funktionstasten am unteren Rand.
Was genau meinst du hier? Legacy enabled schalten und dann die Installation nochmals durchführen? Legacy ON ist der default in meinem BIOS, d.h. die Installation wird wohl in dem Modus durchgelaufen sein. Ich kann die Installation aber nochmals machen wenn es das ist was du meinst.

Eventuell kannst Du bei "UEFI Boot Order" die dritte Zeile deaktivieren (die fünfte mit dem vorangestellten Rufzeichen sieht mir nach "deaktiviert" aus).
Richtig, die Hilfe sagt ! ist deaktiviert. Ich selber kann im BIOS aber keine Einträge deaktivieren.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5309
Registriert: 23. Sep 2008, 17:09

Re: HP Laptop bootet nicht in grub

Beitrag von josef-wien » 5. Sep 2019, 18:55

klaus-dieter hat geschrieben:Welche habe ich übersehen?
Fast den gesamten ersten Absatz meines Beitrags von 11:31 Uhr.

klaus-dieter hat geschrieben:die Installation nochmals durchführen?
So weit sind wir noch nicht. Ich will vorerst wissen, ob Du überhaupt zum Menü mit den Funktionstasten kommst. Das Installationsmedium kann von einem korrekten UEFI auf zwei Arten gestartet werden: Einmal im "UEFI boot"-Modus (da hat das Menü keine Funktionstasten, damit hast Du bisher gearbeitet) und einmal im "Legacy Boot"-Modus (dann agiert das UEFI so wie früher das BIOS).

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 19:20

Welche Angaben sind hinter in den 3 Eintragungen des "OS Boot Manager" hinterlegt?
Er sucht sich, nach welchen Regeln auch immer, die .efi Dateien in /boot/efi/EFI heraus. Z.B. habe ich eine von meinen Linux efi Dateien umkopiert nach bootmgfw.efi, das wird jetzt als dieser Microsoft-Eintrag angezeigt.
Wie waren diese Daten im Originalzustand?
Vor der ersten Installation habe ich nicht ins BIOS geschaut, nach der Installation waren die Einträge so wie jetzt, bis auf den Dummy MS Eintrag.
Welche Daten gibt es auf /boot/efi/EFI noch außer "opensuse"?
Es gibt noch:
a) Microsoft folder - von mir angelegt für den Dummy Eintrag
b) boot folder, dort liegen diverse efi Dateien drin.

Ich habe die Dummy MS Einträge jetzt entfernt, damit gibt es den Microsoft Folder nicht mehr. Macht aber keinen Unterschied.
Sind Deine Bilder von 09:18 Uhr aktuell?
Im Prinzip ja, habe an der Reihenfolge der 3 Einträge gespielt und der MS Eintrag ist jetzt weg da ich bootmgfw.efi gelöscht habe.
Ich will vorerst wissen, ob Du überhaupt zum Menü mit den Funktionstasten kommst. Das Installationsmedium kann von einem korrekten UEFI auf zwei Arten gestartet werden: Einmal im "UEFI boot"-Modus (da hat das Menü keine Funktionstasten, damit hast Du bisher gearbeitet) und einmal im "Legacy Boot"-Modus (dann agiert das UEFI so wie früher das BIOS).
Ich bin mir nicht ganz sicher was für ein Menu mit Funktionstasten du meinst. Vielleicht beantwortet das deine Frage:

a) Egal ob ich legacy on oder off habe wenn der USB Stick drin ist sehe ich das normale openSuse Menu mit Boot from Hard Disk, Installation, Upgrade, More

b) Im BIOS Hilfe Text steht auch wenn man Legacy anschaltet hat UEFI immer Vorrang. Da er per UEFI meinen Stick findet versucht er wohl gar nichts mehr im Legacy Mode. Wenn der USB Stick nicht drin ist (bei Legacy on) findet er wohl nichts in UEFI, findet dann aber über legacy das FreeDOS.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5333
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: HP Laptop bootet nicht in grub

Beitrag von tomm.fa » 5. Sep 2019, 19:43

klaus-dieter hat geschrieben:
5. Sep 2019, 19:20
Ich bin mir nicht ganz sicher was für ein Menu mit Funktionstasten du meinst. Vielleicht beantwortet das deine Frage:

a) Egal ob ich legacy on oder off habe wenn der USB Stick drin ist sehe ich das normale openSuse Menu mit Boot from Hard Disk, Installation, Upgrade, More
Und siehst du bei diesem Menü („normale openSuse Menu mit Boot from Hard Disk, Installation, Upgrade, More“) am unteren Bildschirmrand, von links nach rechts aufgeführt, F1, F2, F3 etc.? Wenn nicht, dann ist UEFI aktiv, sind diese „Funktionstasten“ zu sehen, dann läuft die Installation über Legacy Boot.

klaus-dieter hat geschrieben:
Eventuell kannst Du bei "UEFI Boot Order" die dritte Zeile deaktivieren (die fünfte mit dem vorangestellten Rufzeichen sieht mir nach "deaktiviert" aus).
Richtig, die Hilfe sagt ! ist deaktiviert. Ich selber kann im BIOS aber keine Einträge deaktivieren.
Einträge selbst markieren, verschieben und löschen sollte eigentlich möglich sein, hatte aber noch keinen Rechner von HP. Funktioniert meist über die Tasten +, - , X, Entf (oder Löschen) usw., englisches Tastaturlayout beachten.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 19:49

Nein, da steht kein F1, F2, etc. Also immer im UEFI Modus.

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2060
Registriert: 24. Okt 2005, 14:04

Re: HP Laptop bootet nicht in grub

Beitrag von Heinz-Peter » 5. Sep 2019, 22:05

Hallo @klaus-dieter,

was für Optionen bittet dein UEFI, sehe Foto wenn unter UEFI Boot Order die Zeile USB Diskette on Key/USB Hard Disk ausgewählt wird. Einfach die Zeile markieren und mit Enter-Taste bestätigen. Eigentlich sollte am Anfang der Zeile Hard Disk stehen, es steht aber USB und von USB bootet er auch.

Gruß
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

klaus-dieter
Hacker
Hacker
Beiträge: 405
Registriert: 10. Jun 2004, 04:50

Re: HP Laptop bootet nicht in grub

Beitrag von klaus-dieter » 5. Sep 2019, 22:26

Die Zeile kann man nicht auswählen. Ich übersetzte sie mit "Irgendein Speichermedium mit USB".

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5333
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: HP Laptop bootet nicht in grub

Beitrag von tomm.fa » 5. Sep 2019, 22:29

Heinz-Peter hat geschrieben:
5. Sep 2019, 22:05
was für Optionen bittet dein UEFI, sehe Foto wenn unter UEFI Boot Order die Zeile USB Diskette on Key/USB Hard Disk ausgewählt wird. Einfach die Zeile markieren und mit Enter-Taste bestätigen. Eigentlich sollte am Anfang der Zeile Hard Disk stehen, es steht aber USB und von USB bootet er auch.
Dort werden sehr wahrscheinlich, da kein Untermenü wie bei OS boot Manager vorhanden, keine Optionen erscheinen. Und nein, in dieser Zeile sollte Hard Disk nicht an erster Stelle stehen, dann wäre die dort aufgeführte USB Hard Disk ja keine USB Hard Disk mehr.
Es ist ein Diskettenlaufwerk oder eine Festplatte gemeint, welche (extern) über USB an den Rechner angeschlossen werden.

Zu lange für den Text gebraucht.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5309
Registriert: 23. Sep 2008, 17:09

Re: HP Laptop bootet nicht in grub

Beitrag von josef-wien » 5. Sep 2019, 22:55

klaus-dieter hat geschrieben:Er sucht sich, nach welchen Regeln auch immer, die .efi Dateien in /boot/efi/EFI heraus.
Ich verstehe das so, daß Du dort keinerlei Eintragungen gemacht hast, sondern nur Dateien auf der EFI-Systempartition kopiert bzw. umbenannt hast. Was Du wie dort speichern mußt, damit es auch gestartet werden kann, wird höchstens HP sagen können. Das ist das schrecklichste UEFI, von dem ich bisher gelesen habe.

klaus-dieter hat geschrieben:Im BIOS Hilfe Text steht auch wenn man Legacy anschaltet hat UEFI immer Vorrang.
Das bedeutet dann, daß Du keine Chance hast, das Installationsmedium im "Legacy Boot"-Modus zu starten. Diese Möglichkeit scheidet also aus.

Mit fällt jetzt nur noch ein, das installierte System mit der Boot-Option

Code: Alles auswählen

noefi
zu starten, die EFI-Systempartition aus /etc/fstab zu entfernen, alle GRUB2-EFI-Pakete zu entfernen, danach die normalen GRUB2-Pakete zu installieren, GRUB2 einzurichten und sicherzustellen, daß die EFI-Systempartition leer ist. Ob aber die openSUSE-Automatismen da mitspielen, kann ich nicht beurteilen (und da ich weder openSUSE noch GRUB2 verwende, kann ich dabei nicht helfen). Beim Neustart ist "Legacy Boot" zu aktivieren.

Nachtrag: Alternativ könntest Du eine Neuinstallation versuchen, bei der Du die Boot-Option noefi im Boot-Menü des Installationsmediums angibst ("E" drücken und am Ende der mit "linuxefi" beginnenden Zeile eintippen).

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2060
Registriert: 24. Okt 2005, 14:04

Re: HP Laptop bootet nicht in grub

Beitrag von Heinz-Peter » 6. Sep 2019, 17:51

klaus-dieter hat geschrieben:
5. Sep 2019, 22:26
Die Zeile kann man nicht auswählen. Ich übersetzte sie mit "Irgendein Speichermedium mit USB".
Wir verstehen uns nicht. Ich kann im UEFI die Boot Reihenfolge ändern. Das heißt ich kann (ich habe zwei FP) FP eins auswählen dann wird kein Grub-Menü angezeigt und nur Windows gebootet auf der zweiten wird dann Grub2 mit Grub-Menü gefunden.
Bei dir findet UEFI den USB Speicher, nicht aber die Festplatte. WARUM?
1. Auf der FP ist kein Boot Code installiert.
2. Die boot Reihenfolge ist falsch und dein UEFI durchsucht nicht alle angeschlossenen Medien auf Boot-Code, deswegen der Vorschlag, die Bootreihenfolge zu ändern.

Ich hätte jetzt eine Ubuntu DVD (kein USB) besorgt und neu installiert um einfach Sicherheit zu haben, liegt am UEFI oder an dem Boot-USB Stick. Eine DVD kannst auch vor der Installation auf Fehler überprüfen.

Wichtig ist auch die Vorbereitung. Deine Probleme sind mir nicht fremd. Auch ich hatte Probleme nach Suse Installation vor paar Jahren, erst durch ein Zufall bin ich in Grub-Menü damals gekommen. Die Lösung war damals, nach dem Neustart die Tastenkombination Strg+Alt+Dell zu drücken.

Mich wurde interessieren was passiert wenn die Grub Konfiguration neu geschrieben wird, siehe mein Beitrag: klick, ob Grub überhaupt findet die FP.

Zu der Vorbereitung werde ich noch meine Ordner durchsuchen und eine Anleitung hier posten.

Edit: Nach der Anleitung habe ich selber installiert klick
Es geht auch genauer klick

Gruß
Zuletzt geändert von Heinz-Peter am 6. Sep 2019, 22:03, insgesamt 1-mal geändert.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5309
Registriert: 23. Sep 2008, 17:09

Re: HP Laptop bootet nicht in grub

Beitrag von josef-wien » 6. Sep 2019, 18:53

Du hast das Problem immer noch nicht erkannt. Sein UEFI hält sich überhaupt nicht an die Spezifikation, sondern führt ein benutzerfeindliches Eigenleben. Sein UEFI kann zwar problemlos die Datei /EFI/opensuse/grub.efi auf dem Installationsmedium ausführen, aber es weigert sich beharrlich, die Datei /EFI/opensuse/grub.efi auf der internen Festplatte auszuführen (GRUB2-EFI auf dem Installationsmedium ist aber problemlos in der Lage, das zu tun, und dieser Umweg ist derzeit seine einzige Möglichkeit, das installierte LInux zu starten).

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2060
Registriert: 24. Okt 2005, 14:04

Re: HP Laptop bootet nicht in grub

Beitrag von Heinz-Peter » 6. Sep 2019, 20:10

Warten wir doch einfach auf die Antwort von @klaus-dieter.
Das Problem erkennen ist eine Sache und eine andere das Problem lösen oder nach der Lösung suchen. Bei mir war das vor paar Jahren die Tastenkombination Strg+Alt+Dell.
Was bei ihm ist hat bis jetzt keiner gefunden.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5333
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: HP Laptop bootet nicht in grub

Beitrag von tomm.fa » 6. Sep 2019, 23:19

Ich würde auch mal im BIOS/UEFI bei den Sicherheitseinstellungen (Security) hereinschauen, ob dort etwas angepasst werden muss, auch wenn Secure Boot deaktiviert wurde. Auch mal, als Root/su ausgeführt, die Ausgabe von

Code: Alles auswählen

dmidecode -t 0,2,3,13
hier vorführen, weil „HP-Laptop“ ist einfach zu allgemein.

Heinz-Peter hat geschrieben:
6. Sep 2019, 20:10
Warten wir doch einfach auf die Antwort von @klaus-dieter.
Das Problem erkennen ist eine Sache und eine andere das Problem lösen oder nach der Lösung suchen. Bei mir war das vor paar Jahren die Tastenkombination Strg+Alt+Dell.
Was bei ihm ist hat bis jetzt keiner gefunden.
Jedenfalls wurde schon ein Ansatz gefunden, dass UEFI/BIOS „ignoriert“ anscheinend die interne Festplatte, da hilft auch keine Änderung oder Neuinstallation von GRUB2, da der Startvorgang schon zuvor abbricht/umgelenkt wird.

So (ähnlich) sollte es aussehen und auch so bleiben:

Code: Alles auswählen

/usr/sbin/efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,3002,3003,300A,300E,300F,3010,3000,2001,2002,2003
Boot0000* opensuse-secureboot   HD(1,MBR,0x7b0b5a72,0x800,0xfa000)/File(\EFI\opensuse\shim.efi)
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC
Boot3000* Floppy Disk Drive:    FJ  
Boot3002* Drive1 HDD:   FJ  
Boot3003* Drive2 HDD:   FJ  
Boot300A* Drive3 NVMe:  FJ  
Boot300E* NETWORK:      FJ  
Boot300F* USB HDD:      FJ  
Boot3010* USB CD/DVD:   FJ
Dieses ist bei klaus-dieter nicht der Fall.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5309
Registriert: 23. Sep 2008, 17:09

Re: HP Laptop bootet nicht in grub

Beitrag von josef-wien » 7. Sep 2019, 00:05

klaus-dieter hat geschrieben:
5. Sep 2019, 19:20
Z.B. habe ich eine von meinen Linux efi Dateien umkopiert nach bootmgfw.efi, das wird jetzt als dieser Microsoft-Eintrag angezeigt.
Nur so eine Idee: Auf der EFI-Systempartition gibt es 4 Dateien mit der Endung ".efi". Das UEFI hat aber nur zwei Eintragungen angelegt (und eine dritte nach Deinem Kopiervorgang). Vielleicht wurde die "falsche" Datei kopiert bzw. das UEFI wählt zwei "falsche" Dateien für seine Eintragungen aus.

Antworten