Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Zeichen verschwinden bei Java / Openoffice

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Zeichen verschwinden bei Java / Openoffice

Beitrag von goeba » 20. Jun 2018, 07:36

Hallo,
ein merkwürdiges Problem, das bei mir auftritt, konnte ich gestern einkreisen.

- ich verwende LibreOffice Writer, alles normal
- ich starte ein Java-Programm (in diesem Fall die Entwicklungsumgebung Greenfoot)

Beobachtung: Im Editor von Greenfoot sind viele Zeichen nicht sichtbar, einfach weiß

Wenn ich umgekehrt zuerst Greenfoot starte (Writer läuft noch nicht), danach Writer, dann sind bei Writer viele Zeichen weiß.

Das jeweils zuerst gestartete Programm läuft normal, bei dem anderen fehlen Zeichen.

System: Leap 42.3, KDE. Das Problem tritt auch bei anderen Rechnern als meinem eigenen auf.

Ich vermute, dass das irgendwie mit Java und Fonts zusammenhängt, evtl. einem Font-Cache oder so.

Hat jemand eine Idee???

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von whois » 20. Jun 2018, 08:37

Hi

Ich fahre hier zwar keine Suse aber...
Nur mal Interessehalber was kommt hierbei raus.

Code: Alles auswählen

pkg-config --list-all | grep gtk
cu

goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von goeba » 20. Jun 2018, 16:26

Code: Alles auswählen

gtk+-x11-3.0                        GTK+ - GTK+ Graphical UI Library
gtksourceview-3.0                   gtksourceview - Source code editing widget
javascriptcoregtk-1.0               JavaScriptCoreGTK+ - GTK+ version of the JavaScriptCore engine
gtk-sharp-2.0                       Gtk - Gtk
gtk-doc                             gtk-doc - API documentation generator
gtk+-broadway-3.0                   GTK+ - GTK+ Graphical UI Library
gtk+-unix-print-2.0                 GTK+ - GTK+ Unix print support
gtk+-unix-print-3.0                 GTK+ - GTK+ Unix print support
gtk-dotnet-2.0                      Gtk.DotNet - .NET Extensions for Gtk
gtk+-2.0                            GTK+ - GTK+ Graphical UI Library (x11 target)
clutter-gtk-1.0                     clutter-gtk - GTK+ integration for Clutter
gtk+-3.0                            GTK+ - GTK+ Graphical UI Library
gtk+-x11-2.0                        GTK+ - GTK+ Graphical UI Library (x11 target)


spoensche
Moderator
Moderator
Beiträge: 7402
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von spoensche » 20. Jun 2018, 20:30

Starte mal beide Programme per Konsole. Siehst du in der Ausgabe etwas aufälliges? Poste doch mal beide Ausgaben.

Sauerland
Guru
Guru
Beiträge: 3248
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von Sauerland » 20. Jun 2018, 20:38

Irgend ein besonderes Plasma Theme installiert?
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von goeba » 20. Jun 2018, 23:04

Beim Starten von Greenfoot kommt:

Code: Alles auswählen

Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=gasp
(diese Option habe ich eingefügt, da die Fonts schlecht aussahen in Java-Programmen, seitdem sehen sie sehr gut aus).

Bei Writer kommt sonst nichts auf der Konsole.

Das Problem trat jetzt, wo ich die Programme von der Konsole startete, aber nicht wieder auf.

Ich verwende als Theme Opensuse, als Besonderheit muss wohl gelten, dass ich die KDE Openbox - Session verwende, nicht die normale KWIN Session.

Die Font Probleme traten aber vorher schon auf, also bevor ich die JAVA-Option für die Fonts einfügte und bevor ich auf Openbox umgestiegen bin.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von whois » 21. Jun 2018, 09:10

goeba hat geschrieben:
20. Jun 2018, 23:04

Das Problem trat jetzt, wo ich die Programme von der Konsole startete, aber nicht wieder auf.
Das schreit ja praktisch nach einem gtk Problem.
Leider habe ich hier keine Möglichkeit das zu verifizieren.
Mal sehen ob sich im Netz was findet.

spoensche
Moderator
Moderator
Beiträge: 7402
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von spoensche » 21. Jun 2018, 17:52

Sieh dir mal https://wiki.archlinux.org/index.php/Ja ... ment_fonts an. Du kannst ja mal mit den Optionen experimentieren. Die Option gasp ist ausschließlich für Java Programme. Von Programmen, die Java nur als Backend verwenden (LibreOffice) werden sie ignoriert.

Möglicherweise liegt genau hier das Problem, weil Java versucht die Fonts selbst zu Rendern und sorgt bei LibreOffice dafür, das die Zeichen nicht sichtbar sind.

goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von goeba » 21. Jun 2018, 19:57

Von dieser Seite hatte ich die Antialiasing-Einstellung.

Es ist halt verhext: An dem Tag, als ich den Faden eröffnete, konnte ich das Problem reproduzieren und erinnerte mich bei dieser Gelegenheit, dass es vorher schon aufgetreten war, auch an anderen Computern, die ich betreue.

Ich weiß auch sicher, dass da ebenfalls Libreoffice und Java gleichzeitig benutzt worden waren.

Nur jetzt bekomme ich das Problem aktuell nicht mehr reproduziert, seltsam.

Welche Option würdest Du denn statt gasp nehmen? In Libreoffice werden die Fonts aber qualitätvoll gerendert, dafür brauchte ich die Option nicht. In Java sah es hingegen unschön aus.

spoensche
Moderator
Moderator
Beiträge: 7402
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von spoensche » 22. Jun 2018, 18:21

Da das Problem Angst vor uns hat und geflüchtet ist, kannst du deinen Wert auch beibehalten.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von whois » 23. Jun 2018, 06:12

spoensche hat geschrieben:
22. Jun 2018, 18:21
Da das Problem Angst vor uns hat und geflüchtet ist, kannst du deinen Wert auch beibehalten.
Der ist gut. :D

Nur mal so zur Info du benutzt durchgehend KDE nehme ich an oder?

goeba
Hacker
Hacker
Beiträge: 253
Registriert: 23. Nov 2015, 13:48

Re: Zeichen verschwinden bei Java / Openoffice

Beitrag von goeba » 23. Jun 2018, 16:26

Gelegentlich XFCE (und zwar dann, wenn KDE mich mal wieder nervt).

Zuletzt fast durchgehend KDE mit Openbox als Windowmanager.

Teilweise off-topic:

Ich bin von dem, was geboten wird, KDE Fan, aber KDE läuft (jedenfalls bei meinem Rechner) nicht absolut stabil bzw. hat Macken, die einen gelegentlichen Neustart erfordern.

Die Macke, die mich mal wieder XFCE hat benutzen lassen war, dass unter KDE die Fensterdekorationen gelegentlich "verschmiert" aussehen, also die Schrift verwischt.

Das Problem tritt nur auf, wenn ich das Compositing abstelle. Wenn ich das Compositing aber nicht abstelle, habe ich erstens ruckelnde Videos (Compositing verträgt sich nicht zusammen mit der Intel No-tear Option, und nur diese Option verschafft mir ruckelfreie Videos, da mein Rechner für Vsync über Compositor offenbar zu langsam ist), zweitens friert der Rechner dann gelegentlich ein.

Unter Xfce treten diese Probleme nicht auf. Dafür aber funktionieren diverse Spiele im Vollbildmodus (Supertux zum Beispiel) nicht unter Xfce ...

Also zurück zu KDE, aber mit Openbox. Da treten all diese Probleme nicht auf. Einzig unschön ist, dass hier die Windows-Taste nicht das Startmenü offnet (das würde man vermutlich irgendwie hinbekommen, wenn man das direkt in Openbox konfiguriert).

Alles lief also wirklich perfekt, bis dann diese Fonts verschwanden ... und zwar an diesem Tag reproduzierbar, immer das zuerst gestartete Programm funktionierte, das nächste nicht, am nächsten Tag war das Problem dann weg ...

Antworten