Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]Automatisches löschen von /tmp files funktioniert nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
dietterle65
Hacker
Hacker
Beiträge: 295
Registriert: 19. Mai 2007, 21:18

[gelöst]Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von dietterle65 » 8. Feb 2018, 20:12

Hallo,

openSUSE Leap 42.3 | Linux 4.4.104-39-default x86_64

In leap 42.2 hatte ich nach dieser Anleitung , https://linux-club.de/wiki/opensuse/Tip ... d-tmpfiles,
dass automatische löschen der tmpfiles eingerichtet.
Nach dem Update auf das aktuelle leap 42.3 funktioniert das nicht mehr.

Was hat sich geändert?
Ich möchte die beiden Ordner /tmp, /var/tmp, wieder beim Start löschen lassen.

mfg
dietterle65
Zuletzt geändert von dietterle65 am 9. Feb 2018, 20:55, insgesamt 1-mal geändert.
Lenovo T61
Linux 3.11.6-4-desktop x86_64
System: openSUSE 13.1 (x86_64)
KDE: 4.11.3
Betonklotz:
openSUSE Leap 42.3 | Linux 4.4.104-39-default x86_64

Werbung:
Sauerland
Guru
Guru
Beiträge: 3162
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von Sauerland » 8. Feb 2018, 20:18

Ob sich was geändert hat, weiss ich nicht.
Aber ohne den Inhalt der /etc/tmpfiles.d/tmp.conf kann man auch nicht mehr sagen......
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Benutzeravatar
dietterle65
Hacker
Hacker
Beiträge: 295
Registriert: 19. Mai 2007, 21:18

Re: Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von dietterle65 » 8. Feb 2018, 20:21

Code: Alles auswählen

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

# See tmpfiles.d(5) for details

# Clear tmp directories separately, to make them easier to override
# SUSE policy: we don't clean those directories
d /tmp 1777 root root 2d
d /var/tmp 1777 root root 7d

# Exclude namespace mountpoints created with PrivateTmp=yes
x /tmp/systemd-private-%b-*
X /tmp/systemd-private-%b-*/tmp
x /var/tmp/systemd-private-%b-*
X /var/tmp/systemd-private-%b-*/tmp
Lenovo T61
Linux 3.11.6-4-desktop x86_64
System: openSUSE 13.1 (x86_64)
KDE: 4.11.3
Betonklotz:
openSUSE Leap 42.3 | Linux 4.4.104-39-default x86_64

Benutzeravatar
dietterle65
Hacker
Hacker
Beiträge: 295
Registriert: 19. Mai 2007, 21:18

Re: Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von dietterle65 » 9. Feb 2018, 20:54

Lösung:

https://forums.opensuse.org/showthread. ... 8ea0da9b23

Code: Alles auswählen

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

# See tmpfiles.d(5) for details

# Clear tmp directories separately, to make them easier to override
# SUSE policy: we don't clean those directories
D /tmp 1777 root root 2d
D /var/tmp 1777 root root 7d

# Exclude namespace mountpoints created with PrivateTmp=yes
x /tmp/systemd-private-%b-*
X /tmp/systemd-private-%b-*/tmp
x /var/tmp/systemd-private-%b-*
X /var/tmp/systemd-private-%b-*/tmp
Funktioniert!
Lenovo T61
Linux 3.11.6-4-desktop x86_64
System: openSUSE 13.1 (x86_64)
KDE: 4.11.3
Betonklotz:
openSUSE Leap 42.3 | Linux 4.4.104-39-default x86_64

dzug
Guru
Guru
Beiträge: 2097
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: [gelöst]Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von dzug » 22. Feb 2018, 10:56

Geht die Lösung auch für einen "Doofen" wie mich.
Ich Meine: Was haste Gemacht?
Von den Befehlen habe ich keine Ahnung.
Vom Englisch auch nicht.
Gruss dzug.
Mein System:15.0+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim
sdb2=swap
sdc1 /daten
sdd1/daten1
sde=Backup
Laptop Toshiba Satellite/C660 15.0 und 15.1

Sauerland
Guru
Guru
Beiträge: 3162
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [gelöst]Automatisches löschen von /tmp files funktioniert nicht mehr

Beitrag von Sauerland » 22. Feb 2018, 18:21

dzug hat geschrieben:
22. Feb 2018, 10:56
Geht die Lösung auch für einen "Doofen" wie mich.
Ich Meine: Was haste Gemacht?
Von den Befehlen habe ich keine Ahnung.
Vom Englisch auch nicht.
Gruss dzug.
Alte Version:

Code: Alles auswählen

d /tmp 1777 root root 2d
d /var/tmp 1777 root root 7d
Neue Version:

Code: Alles auswählen

D /tmp 1777 root root 2d
D /var/tmp 1777 root root 7d
Man beachte die Groß- und Kleinschreibung des ersten Buchstabens........
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste