Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]Beim Systemstart Wartezeit vom 90s

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
bayernherz
Hacker
Hacker
Beiträge: 452
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

[gelöst]Beim Systemstart Wartezeit vom 90s

Beitrag von bayernherz » 6. Feb 2018, 16:38

hallo community,
nachdem ich eine Probeinstallation von Debian 9.3 auf einem USB-Stick gemacht habe,
habe ich auch ohne Stick eine Wartezeit beim Systemstart von ca 90s.
dabei wird folgende Meldung angezeigt:

Code: Alles auswählen

A start job is running for dev-disk-by/.......
Ich verwende:

Code: Alles auswählen

Linux Bayernherz.by 4.15.1-2.g9df97e2-default #1 SMP PREEMPT Sun Feb 4 19:20:08 UTC 2018 (9df97e2) x86_64 x86_64 x86_64 GNU/Linux
mit openSuse Leap 42.2 + KDE 5.8.6

Würde mich über einen Hinweis freuen. :wink:

grüsse aus dem nachmittaglichen Oberbayern
vom bayernherz :thumbs:
Zuletzt geändert von bayernherz am 7. Feb 2018, 19:54, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von Sauerland » 6. Feb 2018, 17:19

Dann poste mal die ganze Fehlermeldung sowie:

Code: Alles auswählen

cat /proc/cmdline

Code: Alles auswählen

cat /etc/fstab
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

bayernherz
Hacker
Hacker
Beiträge: 452
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von bayernherz » 6. Feb 2018, 17:51

hallo community,

Code: Alles auswählen

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.15.1-2.g9df97e2-default root=UUID=eb6deb8c-0a0e-41df-931f-0f8840a1df7a video=1920x1080 resume=/dev/sda2 splash=silent quiet showopts

Code: Alles auswählen

cat /etc/fstab
UUID=eb6deb8c-0a0e-41df-931f-0f8840a1df7a /                    ext4       acl,user_xattr        1 1
UUID=9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69 swap                 swap       defaults              0 0
UUID=5595e363-f1cb-4b6d-90ed-543f7f17066d /home                ext4       acl,user_xattr        1 2
UUID=e77f5138-f7dc-41f7-9f06-b7a910f17b0b /userData            ext4       defaults              1 2
viele grüsse aus dem abendlichen Oberbayern
vom bayernherz :thumbs:

Nachtrag:
Die komplette Fehlermeldung lautet im /var/log/boot.log

Code: Alles auswählen

A start job is running for dev-disk-by\x2duuid-9fe97a9c\x2d4b91\x2d4336\x2dbb6e\x2de1d0afd1aa69.device (1min 29s / 1min 30s)

Sauerland
Guru
Guru
Beiträge: 3087
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von Sauerland » 6. Feb 2018, 21:02

Hast du es einmal ohne den resume= Eintrag versucht?
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

bayernherz
Hacker
Hacker
Beiträge: 452
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von bayernherz » 7. Feb 2018, 10:21

hallo community,
Sauerland hat geschrieben:
Hast du es einmal ohne den resume= Eintrag versucht?
Bin nach Deiner Anleitung
https://www.opensuse-forum.de/thread/85 ... %C3%BCgen/ verfahren !
Hat leider keine Auswirkung.

Ich habe nochmals im /var/log/boot.log gesucht:

Code: Alles auswählen

[     *] A start job is running for dev-disk-by\x2duuid-9fe97a9c\x2d4b91\x2d4336\x2dbb6e\x2de1d0afd1aa69.device (1min 29s / 1min 30s)
[ TIME ] Timed out waiting for device dev-disk-by\x2duuid-9fe97a9c\x2d4b91\x2d4336\x2dbb6e\x2de1d0afd1aa69.device.
[DEPEND] Dependency failed for /dev/disk/by-uuid/9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69.
[DEPEND] Dependency failed for Swap.
Ich denke es ist ein Problem der Partion swap.

Leider habe ich ich im Moment keinen Ansatz, was sich bei der Debian Test-Installation auf dem USB-Stick verstellt haben könnte ?

viele grüsse aus dem morgendliche Oberbayern
vom bayernherz :thumbs:

Gräfin Klara
Hacker
Hacker
Beiträge: 314
Registriert: 23. Jun 2008, 20:51

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von Gräfin Klara » 7. Feb 2018, 12:30

Dein Eintrag in /etc/fstab
UUID=9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69

stimmt mit log
[DEPEND] Dependency failed for /dev/disk/by-uuid/9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69

überein. Das ist gut.

Bleibt nur noch meine Vermutung, dass das fs nicht existiert.
Deshalb (wir nehmen an, dein swap_device nennt sich /dev/sda6):
# swapoff /dev/sda6
# mkswap /dev/sda6
# swapon /dev/sda6

Wahrscheinlich funktioniert es dann
Gruß
Gräfin Klara

towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von towo » 7. Feb 2018, 13:29

Bleibt nur noch meine Vermutung, dass das fs nicht existiert.
Wohl eher daß die UUID von Swap anders ist!

blkid hätte das verraten.

Und nach mkswap gibts dann auch wieder eine neue UUID und das Problem würde bleiben, solange die fstab und der resume-Eintrag nicht geändert wird.
Signatur nach Diktat spazieren gegangen

Bild

Gräfin Klara
Hacker
Hacker
Beiträge: 314
Registriert: 23. Jun 2008, 20:51

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von Gräfin Klara » 7. Feb 2018, 13:47

towo hat geschrieben:
7. Feb 2018, 13:29
Bleibt nur noch meine Vermutung, dass das fs nicht existiert.
Wohl eher daß die UUID von Swap anders ist!

blkid hätte das verraten.

Und nach mkswap gibts dann auch wieder eine neue UUID und das Problem würde bleiben, solange die fstab und der resume-Eintrag nicht geändert wird.
Absolut richtig.
Vielleicht hat er ein mkswap schon hinter sich und eine alte fstab

bayernherz
Hacker
Hacker
Beiträge: 452
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von bayernherz » 7. Feb 2018, 16:21

hallo community,

Code: Alles auswählen

fdisk -l
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0004c468

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1  *         2048  62910463  62908416   30G 83 Linux
/dev/sda2        62910464  79681535  16771072    8G 82 Linux swap / Solaris
/dev/sda3        79681536 499107839 419426304  200G  f W95 Ext'd (LBA)
/dev/sda5        79683584 205518847 125835264   60G 83 Linux
/dev/sda6       205520896 497018879 291497984  139G 83 Linux


Disk /dev/sdb: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 2D84F535-9F87-43A2-9034-3648C51F8226

Device         Start       End   Sectors   Size Type
/dev/sdb1       2048    206847    204800   100M EFI System
/dev/sdb2     206848    239615     32768    16M Microsoft reserved
/dev/sdb3     239616 498020351 497780736 237.4G Microsoft basic data
/dev/sdb4  498020352 500117503   2097152     1G Windows recovery environment
/dev/sda5 ist mein home Verzeichnis und /dev/sda6 eine zusätzliche Datenpartion.
/dev/sdb ist eine zusätzliche SSD mit WIN10 :igitt:
Zeige ich nicht gern vor, aber wird für Steuererklärungen gebraucht.
Die Partionen /dev/sdax verwenden kein UEFI

Code: Alles auswählen

blkid
/dev/sda1: LABEL="system" UUID="eb6deb8c-0a0e-41df-931f-0f8840a1df7a" TYPE="ext4" PTTYPE="dos" PARTUUID="0004c468-01"
/dev/sda2: UUID="ae97a2a4-3e0a-49ef-ba18-5a33a8a62f55" TYPE="swap" PARTUUID="0004c468-02"
/dev/sda5: LABEL="home" UUID="5595e363-f1cb-4b6d-90ed-543f7f17066d" TYPE="ext4" PARTUUID="0004c468-05"
/dev/sda6: LABEL="UserData" UUID="e77f5138-f7dc-41f7-9f06-b7a910f17b0b" TYPE="ext4" PARTUUID="0004c468-06"
/dev/sdb1: LABEL="ESP" UUID="BA37-48C8" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="913ea46d-64dc-4e81-99dc-5e93ccf1d415"
/dev/sdb2: PARTLABEL="Microsoft reserved partition" PARTUUID="1c6161ad-1a8c-4dbe-9f15-7ca5f20faf40"
/dev/sdb3: LABEL="Acer" UUID="BE683D60683D191B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="19958166-c5e9-4ecb-8384-b882a11aad37"
/dev/sdb4: LABEL="Recovery" UUID="10BA3F27BA3F092C" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a3ea3ec0-7db4-44f2-b36f-58f3339f7b3c"
Das Problem ist erst nach der Debian-installation auf USB-Stick aufgetreten !

viele grüsse aus den nachmittaglichen Oberbayern
vom bayernherz :thumbs:

towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von towo » 7. Feb 2018, 16:26

Und wenn Du jetzt mal die Ausgaben richtig lesen würdest, würdest Du sehen, daß Swaü einme andere UUID hat, als bei dir in der fstab steht!
Signatur nach Diktat spazieren gegangen

Bild

bayernherz
Hacker
Hacker
Beiträge: 452
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von bayernherz » 7. Feb 2018, 17:51

hallo community,
towo hat geschrieben:
Und wenn Du jetzt mal die Ausgaben richtig lesen würdest, würdest Du sehen, daß Swaü einme andere UUID hat, als bei dir in der fstab steht!
Ja, habe ich im Thread vor weiter schon in der /var/log/boot.log gesehen, das der Fehler von der swap Partion zu kommen scheint.
Wie kann ich den Fehler richten ?
fstab

Code: Alles auswählen

UUID=eb6deb8c-0a0e-41df-931f-0f8840a1df7a /                    ext4       acl,user_xattr        1 1
UUID=9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69 swap                 swap       defaults              0 0
UUID=5595e363-f1cb-4b6d-90ed-543f7f17066d /home                ext4       acl,user_xattr        1 2
UUID=e77f5138-f7dc-41f7-9f06-b7a910f17b0b /userData            ext4       defaults              1 2
UUID=ae97a2a4-3e0a-49ef-ba18-5a33a8a62f55 swap                 swap       defaults              0 0
Die neue UUID von Hand in die fstab eintragen ?
Oder gff. noch an anderen Stellen ? :-?

viele grüsse aus dem abendliche Oberbayern
vom bayernherz :thumbs:

towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von towo » 7. Feb 2018, 17:55

Die neue UUID von Hand in die fstab eintragen ?
Da kein Heinzelmänchen vorbeikommen wird, der das für Dich macht, wird Dir wohl nichts andees übrig bleiben, oder?
Oder gff. noch an anderen Stellen ?
Na was denkst Du? Klar muß das überall da gemacht werden, wo es jetzt falsch drin steht, is ja wohl logisch.

Mal im Ernst, 7 Jahre Linux aber so einfach Dinge immer noch nicht drauf?
Signatur nach Diktat spazieren gegangen

Bild

rolandb
Hacker
Hacker
Beiträge: 404
Registriert: 31. Jan 2014, 17:11

Re: Beim Systemstart Wartezeit vom 90s

Beitrag von rolandb » 7. Feb 2018, 18:56

towo hat geschrieben:
7. Feb 2018, 17:55
Mal im Ernst, 7 Jahre Linux aber so einfach Dinge immer noch nicht drauf?
Und bei Dir sind das schon 14 Jahre, in denen du mkswap bzw. man mkswap immer noch nicht kennst. ;)

Als root:

Code: Alles auswählen

mkswap -U 9fe97a9c-4b91-4336-bb6e-e1d0afd1aa69 /dev/sda2
lautet die Ein-Zeilen-Lösung.
Und entferne bitte wieder den 2. SWAP-Partitionseintrag aus deiner /etc/fstab.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast