Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Leap 42.2 KDE kein Sound

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 26. Feb 2017, 21:01

Hallo,

Ich habe keine Soundausgabe.
Lediglich über meine Stereoanlage erhalte ich Sound, nicht jedoch über meinen Monitor.
Was kann ich tun?
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Werbung:
Sauerland
Guru
Guru
Beiträge: 3659
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 KDE kein Sound

Beitrag von Sauerland » 26. Feb 2017, 21:44

Monitor anschließen?
Sound auf den Monitor umschwenken?
Stichwort pavucontrol.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 26. Feb 2017, 22:36

Monitor ist angeschlossen.
Pavucontrol installiert. Umschwenken hilft nicht
"Stumm" wird unter der Soundanzeige angezeigt obwohl nicht auf Stumm geschaltet ist
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 26. Feb 2017, 22:43

In pavucontrol erscheint im Reiter "Ausgabegeräte" nur "Speakers" und "Analoge Kopfhörer (unplugged)" als Auswahl
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Leap 42.2 KDE kein Sound

Beitrag von tomm.fa » 26. Feb 2017, 22:53

Der Monitor ist per HDMI mit der Grafikkarte verbunden und diese ist was für eine?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 26. Feb 2017, 22:58

NVIDIA Geforce 640 GT mit dem G04 Treiber
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5421
Registriert: 23. Sep 2008, 17:09

Re: Leap 42.2 KDE kein Sound

Beitrag von josef-wien » 26. Feb 2017, 23:06

Der erste Teil der Frage von tomm.fa wurde nicht beantwortet. Außerdem:

Code: Alles auswählen

cat /proc/asound/{cards,modules}

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 26. Feb 2017, 23:11

Per HDMI angeschlossen.. ja

Code: Alles auswählen

cat /proc/asound/{cards,modules}
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7310000 irq 33
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 0 snd_hda_intel
 1 snd_hda_intel
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Sauerland
Guru
Guru
Beiträge: 3659
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 KDE kein Sound

Beitrag von Sauerland » 27. Feb 2017, 07:03

linux-freund hat geschrieben:
26. Feb 2017, 22:43
In pavucontrol erscheint im Reiter "Ausgabegeräte" nur "Speakers" und "Analoge Kopfhörer (unplugged)" als Auswahl
Ist denn unter Konfiguration die HDMI Soundkarte konfiguriert?
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 27. Feb 2017, 16:54

Konfiguration:

GK107 HDMI Audio Controller
Profil: Digital Stereo (HDMI) Output (unplugged)

Internes Audio
Profil: Analog Stereo Duplex
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 27. Feb 2017, 17:24

Hier lag der Fehler.

Nach Umstellung von
GK107 HDMI Audio Controller
Profil: Digital Stereo (HDMI) Output (unplugged)

auf

GK107 HDMI Audio Controller
Profil: Digital Stereo (HDMI2) Output

klappt es.

Danke für den Hinweis Sauerland.
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 2. Mär 2017, 17:06

Jetzt konnte ich zwar wie den Sound über den Monitor aktivieren, allerdings kommen dennoch keine Systemsounds aus dem Monitor.
Wenn ich zB Kapman spiele höre ich nichts.
Wenn ich dann während des Spielens den Pulse-Audio-Lautstärkeregler aktiviere geht Kapman auf Pause und ich kann dort nichts ändern.

Wie kann ich denn generell die Systemsounds über den Monitor aktivieren?
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Sauerland
Guru
Guru
Beiträge: 3659
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 KDE kein Sound

Beitrag von Sauerland » 2. Mär 2017, 19:19

pavucontrol???
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 2. Mär 2017, 20:35

Ja.. so habe ich das unter 13.1 auch immer gehandhabt.
Nur jetzt sehe ich dort keine Möglichkeiten mehr was ich noch anders einstellen könnte aber es kommt trotzdem kein Systemsound
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 2. Mär 2017, 20:42

Um die Problematik nochmal genauer zu beschreiben:

Wenn ich ein Video über VLC abspiele kann ich den Pulseaudio-Regler öffnen und einen beleibigen Ausgabekanal anwählen.
Funktioniert sowohl über Hifi-Anlage als auch über Monitor.

Die Ausgabe über den Monitor scheint aber nicht die favorisierte Einstellung zu sein, da ich zB bei Kapman keinen Sound über den Monitor habe.
Wenn ich bei Kapman dann - wie oben beim VLC beschrieben - den Pulseaudio-Regler anwähle geht Kapman automatisch in den Pause-Mode so dass unter Ausgabe keine Einstellungsoption mehr für Kapman vorhanden ist.
Auch erhalte ich keine Ausgabe für generelle Systemklänge wie Starten, Runterfahren..
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Sauerland
Guru
Guru
Beiträge: 3659
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 KDE kein Sound

Beitrag von Sauerland » 2. Mär 2017, 21:56

Systemeinstellungen---Hardware----Multimedia----Audio und Video

Was ist dort als Backend eingestellt?

Gerätepriorität:
Zieh dein HDMI an erste Stelle in den dir genehmen Ausgabestellen.......
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
linux-freund
Member
Member
Beiträge: 158
Registriert: 17. Sep 2014, 22:11

Re: Leap 42.2 KDE kein Sound

Beitrag von linux-freund » 3. Mär 2017, 15:56

Habe jetzt überall unter Ausgabe die Monitorausgabe an erste Stelle gezogen.
Ergebnis: YouTube wird automatisch über Monitor ausgegeben.
Systemklänge nein
Kapman nein

Backend: Phonon GStreamer
HP Pavilion: Intel Quad-Core i5-4440 3.10 GHz, NVIDIA Geforce 640 GT, 12 GB RAM, 1TB HDD
Sony Vaio SVF-15N2L2ES: Intel Core i5 1.60 GHz, 508 GB HDD, 4 GB DDR3-RAM, Intel HD Graphics 4400
Beide openSUSE Leap 42.2 + Windows10

Antworten