Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Qemu git und 1.6.1 Fehler beim kompilieren ....

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
BdMdesigN
Member
Member
Beiträge: 188
Registriert: 6. Mai 2005, 13:00
Kontaktdaten:

[Gelöst] Qemu git und 1.6.1 Fehler beim kompilieren ....

Beitrag von BdMdesigN » 18. Nov 2013, 23:23

Moin Moin,

Ich hoffe nach dem Forumumbau, das ich die richtige Rubrik erwischt habe.

Nun zum eigentlichen Problem:

Ich will Qemu aus der git Quelle per rpm-make kompilieren und erhalte bei der ./configure diesen Fehler:

ERROR: User requested feature libusb
configure was not able to find it


Ich benutze dazu diesen Befehl:

Code: Alles auswählen


./configure --prefix=/usr --libdir=/usr/lib64 --sysconfdir=/etc --audio-drv-list=alsa --enable-virtfs --enable-libusb

Die libusb Pakete liegen in folgenden Versionen vor:
  • libusb-0_1-4 0.1.13-53.1-x86_64
  • libusb-0_1-4-32bit 0.1.13-53.1-x86_64
  • libusb-1_0-0 1.0.9-38.1-x86_64
  • libusb-1_0-0-32bit 1.0.9-38.1-x86_64
  • libusb-1_0-devel 1.0.9-38.1-x86_64
  • libusb-1_0-devel-32bit 1.0.9-38.1-x86_64
  • libusb-compat-devel 0.1.4-53.1-x86_64
Könnte hier ein Konflikt mit der libusb-0_1-4 und der libusb-1_0-0 vorliegen?

OS = opensuse 12.3 Kernel 3.12.0-1.1.ge8fa6b4
Zuletzt geändert von BdMdesigN am 19. Nov 2013, 04:47, insgesamt 1-mal geändert.
System: OpenSuSE 13.1 Kernel 3.13.2-6-default
Bild
Anfangs-Systeme: Commodore VC 20, C64, Amiga Workbench 1.3 (A500 & A4000), RedHat 5.0.2 & SuSE 7.2

Werbung:
Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3160
Registriert: 25. Aug 2004, 02:13

Re: Qemu git und 1.6.1 Fehler beim kompilieren ....

Beitrag von robi » 19. Nov 2013, 03:19

BdMdesigN hat geschrieben: Die libusb Pakete liegen in folgenden Versionen vor:
  • libusb-0_1-4 0.1.13-53.1-x86_64
  • libusb-0_1-4-32bit 0.1.13-53.1-x86_64
  • libusb-1_0-0 1.0.9-38.1-x86_64
  • libusb-1_0-0-32bit 1.0.9-38.1-x86_64
  • libusb-1_0-devel 1.0.9-38.1-x86_64
  • libusb-1_0-devel-32bit 1.0.9-38.1-x86_64
  • libusb-compat-devel 0.1.4-53.1-x86_64
Könnte hier ein Konflikt mit der libusb-0_1-4 und der libusb-1_0-0 vorliegen?
Nach kurzem Blick ins GIT, vermute ich ehr, das configure dort will mindestens Version 1.0.13 und du hast aber nur 1.0.9

robi

Benutzeravatar
BdMdesigN
Member
Member
Beiträge: 188
Registriert: 6. Mai 2005, 13:00
Kontaktdaten:

Re: Qemu git und 1.6.1 Fehler beim kompilieren ....

Beitrag von BdMdesigN » 19. Nov 2013, 03:57

Wo hast Du das gefunden?
Die 1.0.13 ist doch noch nicht verfügbar.

[edit]

Ok hab die Stelle gefunden, nun bleibt aber die Frage ob nun libusbx (verfügbar bis 1.0.17) oder die libusb (Verfügbar 1.0.9) gemeint ist.

[/edit]

[edit2]

Danke für den Schubs in die richtige Richtung.
Ich musste nur diese Repositorie http://download.opensuse.org/repositori ... nSUSE_12.3 einbinden und auf die libusbx switchen.

[/edit2]
System: OpenSuSE 13.1 Kernel 3.13.2-6-default
Bild
Anfangs-Systeme: Commodore VC 20, C64, Amiga Workbench 1.3 (A500 & A4000), RedHat 5.0.2 & SuSE 7.2

Antworten