Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] System wartet auf Laufwerk, dass es nicht gibt

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

[gelöst] System wartet auf Laufwerk, dass es nicht gibt

Beitrag von Knobi.697 » 30. Apr 2011, 14:40

Moin!

Habe openSuse 11.4 installiert. Beim Booten bekomme ich folgende Meldungen:
waiting for dev /dev/sdb6 to appear.
Nach kurzer Wartezeit fragt er mich:
Want me to fall back to dev/disk/by-id/ata-samsung.... und die ganze ID von der samsung festplatte.
Mit ja geht es dann weiter und alles läuft.
Ich habe nur kein sdb6 laufwerk, die samsung-festplatte ist als sdc in der Liste und das dev/sdb ist ein usb-stick, welcher auch funktioniert. Kann ich das irgendwie irgendwo beseitigen?

Knobi
Zuletzt geändert von Knobi.697 am 30. Apr 2011, 22:44, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
P6CNAT
Advanced Hacker
Advanced Hacker
Beiträge: 1014
Registriert: 24. Jul 2006, 14:26
Wohnort: Mainhausen

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von P6CNAT » 30. Apr 2011, 14:49

Hi,

die Laufwerke stehen in /etc/fstab.
Mache davon eine Sicherungskopie und lösche die Zeile mit dem nicht existierenden Laufwerk oder kommentiere sie aus.
Du kannst auch mal diese Datei hier posten.

Gruß
Georg
openSUSE Leap 42.3 64 Bit
KDE-Plasma 5.8.7
CPU: AMD A8-5500 mit integrierter GPU Typ AMD Radeon HD 7560D

Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von Knobi.697 » 30. Apr 2011, 14:59

Dank für die Hilfe!
Meine fstab:
/dev/disk/by-id/ata-SAMSUNG_SP2504C_S0C3J1HLA00235-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_SP2504C_S0C3J1HLA00235-part6 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-SAMSUNG_SP2504C_S0C3J1HLA00235-part7 /home ext4 defaults 1 2
/dev/disk/by-id/ata-WDC_WD3200JB-00KFA0_WD-WCAMR1733961-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
Es sollte sein: sdc5 swap
sdc6 /
sdc7 /home
Und von sdb6 steht hier nichts...
Knobi

edit: Habe es ausprobiert: gleiche Fehlermeldung und konnte mich nicht im KDE einloggen. Sagte, dass /home nicht vorhanden ist o.ä.

Benutzeravatar
P6CNAT
Advanced Hacker
Advanced Hacker
Beiträge: 1014
Registriert: 24. Jul 2006, 14:26
Wohnort: Mainhausen

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von P6CNAT » 30. Apr 2011, 15:36

Hi,

mist, habe beim mir jetzt auch gesehen, dass in der fstab gar nicht soo viel steht wie bei Unix Systemen.
Meine Laufwerksbezeichnungen habe ich noch in einer mtab gefunden. Aber diese Datei sagt mir nichts und die sieht ein bisschen komplizierter aus.

Gruß
Georg
openSUSE Leap 42.3 64 Bit
KDE-Plasma 5.8.7
CPU: AMD A8-5500 mit integrierter GPU Typ AMD Radeon HD 7560D

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5082
Registriert: 23. Sep 2008, 17:09

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von josef-wien » 30. Apr 2011, 16:24

Da steht wohl etwas Falsches in /boot/grub/menu.lst.

Benutzeravatar
wirrwarr
Hacker
Hacker
Beiträge: 328
Registriert: 24. Okt 2010, 15:13

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von wirrwarr » 30. Apr 2011, 18:25

P6CNAT hat geschrieben:edit: Habe es ausprobiert: gleiche Fehlermeldung und konnte mich nicht im KDE einlogge
Mache die Änderung wieder rückgängig. Wenn Du dich wieder einloggen kannst gib in der Konsole als root
folgende Befehle ein

Code: Alles auswählen

fdisk -l

Code: Alles auswählen

blkid
Ich weiß jetzt leider nicht welchen Grub opensuse 11.4 verwendet. Auf Verdacht

Code: Alles auswählen

cat /boot/grub//menu.lst
Gruß wirrwarr
Bitte gelegentliche Leichtsinns und Schreibfehler übersehen.
Ich habe ADHS.

Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von Knobi.697 » 30. Apr 2011, 21:19

Habe ich gemacht, Beim neustart gleicher Fehler.

Also fdisk -l gab folgendes:
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x100b218d

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 625139711 312568832 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
1 heads, 63 sectors/track, 15504336 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x019178db

Device Boot Start End Blocks Id System
/dev/sdb1 * 63 976768127 488384032+ 7 HPFS/NTFS/exFAT

Disk /dev/sdc: 1007 MB, 1007681536 bytes
65 heads, 32 sectors/track, 946 cylinders, total 1968128 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdc1 * 32 1968127 984048 b W95 FAT32

Disk /dev/sdd: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1c3c1c3c

Device Boot Start End Blocks Id System
/dev/sdd2 * 206848 488396799 244094976 f W95 Ext'd (LBA)
/dev/sdd5 208896 4417535 2104320 82 Linux swap / Solaris
/dev/sdd6 4419584 46364670 20972543+ 83 Linux
/dev/sdd7 46364672 488376319 221005824 83 Linux

Disk /dev/sde: 1026 MB, 1026555392 bytes
129 heads, 16 sectors/track, 971 cylinders, total 2004991 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x5d720b2e

Device Boot Start End Blocks Id System
/dev/sde1 * 16 2004990 1002487+ b W95 FAT32
blkid:
/dev/sda1: UUID="20A8A4E0A8A4B626" TYPE="ntfs"
/dev/sdb1: LABEL="Expansion Drive" UUID="D068567068565576" TYPE="ntfs"
/dev/sdc1: LABEL="AGILENT" UUID="927D-71EA" TYPE="vfat"
/dev/sdd5: UUID="0ef5493d-8ea7-4a4f-ac39-3b006bae9dc2" TYPE="swap"
/dev/sdd6: UUID="de9a3722-6780-4a7d-8328-ef586658db02" TYPE="ext4"
/dev/sdd7: UUID="3a218fb1-5795-464c-a90c-2c1d99acc983" TYPE="ext4"
/dev/sde1: LABEL="FLASHPEN" UUID="62A2-1591" TYPE="vfat"
und cat /boot/grub//menu.lst:
# Modified by YaST2. Last modification on Fri Apr 29 14:03:37 BST 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
root (hd0,5)
kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdb6 resume=/dev/disk/by-id/ata-SAMSUNG_SP2504C_S0C3J1HLA00235-part5 splash=silent quiet showopts vga=0x317
initrd /boot/initrd-2.6.37.6-0.5-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.5
root (hd0,5)
kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/sdb6 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
initrd /boot/initrd-2.6.37.6-0.5-desktop

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
map (hd1) (hd0)
map (hd0) (hd1)
rootnoverify (hd1,0)
makeactive
chainloader +1
Warum steht da bei kernel /boot.... root=/dev/sdb6/? Müsste da nicht sdd6 stehen?

Das passt hier vorne und hinten nicht. Im yast partitionierer stehr sdc6 für /, also müsste das doch auch die boot partition im bootloader sein?!? Warum sagt blkid sdd6?
Knobi

Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von Knobi.697 » 30. Apr 2011, 21:47

Also habe es im boot-loader auf sdc6 gesetzt und das System startet ohne Fehler.
Woher kommt das mit den verschiedenen einträgen? Woher stammen die Daten, die blkid anzeigt? Muss ich da etwas ändern?

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5082
Registriert: 23. Sep 2008, 17:09

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von josef-wien » 30. Apr 2011, 22:24

Knobi.697 hat geschrieben:habe es im boot-loader auf sdc6 gesetzt
1. Lesestoff: http://www.linux-club.de/viewtopic.php? ... 8&#p689018
2. Ändere den menu.lst-Eintrag daher auf: root=/dev/disk/by-id/ata-SAMSUNG_SP2504C_S0C3J1HLA00235-part6

Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

Re: System wartet auf Laufwerk, dass es nicht gibt

Beitrag von Knobi.697 » 30. Apr 2011, 22:43

Danke auch für den Lesestoff, werde es ändern!

Knobi

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast