Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] /lib/modules/2.6.38-08-generic not found

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4270
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

[solved] /lib/modules/2.6.38-08-generic not found

Beitrag von framp » 21. Apr 2011, 22:05

Vielleicht erinnert sich jemand an diesen Thread. Da hatte ich schon mal Probleme nach einem SW Update. Jetzt habe ich wieder einen gewagt vorzunehmen - und habe jetzt keine Netzwerkverbindung mehr. Ich dachte mir schon dass es wieder ein Problem auf dem System geben wird :zensur:

Warum poste ich das nicht im Netzwerkforum? Ganz einfach: Es wird beim booten in /var/log/messages gemeckert, dass /lib/modules/2.6.38-08-generic nicht gefunden wird. Dass erst nach dem KernelUpdate.

Allerdings finde ich dieses Verzeichnis auf dem gebooteten System. Der vorherige Kernel war /lib/modules/2.6.38-01-generic. Die Frage ist, warum /lib/modules/2.6.38-08-generic gesucht und nicht gefunden wird wird obwohl es sich auf der gebooteten Platte befindet.
Zuletzt geändert von framp am 22. Apr 2011, 14:54, insgesamt 1-mal geändert.

Werbung:
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: /lib/modules/2.6.38-08-generic not found

Beitrag von josef-wien » 21. Apr 2011, 22:54

Wird wirklich ein Verzeichnis gesucht oder doch Dateien? Sieht der Inhalt des Kernel-Verzeichnisses normal aus? Ist das Modul für die Netzwerkkarte dabei? Ist es auch in modules.dep enthalten? Hast Du vielleicht einen "unvollständigen" Kernel erwischt?

Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4270
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: /lib/modules/2.6.38-08-generic not found

Beitrag von framp » 21. Apr 2011, 23:54

josef-wien hat geschrieben:Wird wirklich ein Verzeichnis gesucht oder doch Dateien? Sieht der Inhalt des Kernel-Verzeichnisses normal aus? Ist das Modul für die Netzwerkkarte dabei? Ist es auch in modules.dep enthalten? Hast Du vielleicht einen "unvollständigen" Kernel erwischt?
Ich sehe schon ... ich muss Butter bei de Fische bringen. Da kein Netzwerk läuft muss ich alle hilfreichen Infos per USB Stick xferren ... :zensur:
Welche Infos sind hilfreich ausser fsdisk -l ?

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: /lib/modules/2.6.38-08-generic not found

Beitrag von revealed » 22. Apr 2011, 06:51

Du hast den neueren Kernel nicht als multiversion installiert, damit du den alten noch wahlweise starten kannst?

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: /lib/modules/2.6.38-08-generic not found

Beitrag von josef-wien » 22. Apr 2011, 12:55

fdisk wird da nichts nützen. Beantworte einmal meine Fragen (außer der letzten, bei der wirst Du Dich schwer tun).

Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4270
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: /lib/modules/2.6.38-08-generic not found

Beitrag von framp » 22. Apr 2011, 14:53

Ich habe jetzt alle grubs auf den Platten gelöscht. Jetzt installiere ich 11.4 und nur einen grub auf einer Platte :roll: . Das 11.2 ist ja auch schon etwas älter.

spoensche
Moderator
Moderator
Beiträge: 7393
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: [solved] /lib/modules/2.6.38-08-generic not found

Beitrag von spoensche » 22. Apr 2011, 21:13

Das Verzeichnis existiert aber oder? Die initrd wird wohl nocht ganz mitbekommen haben, das sich etwas geändert hat. Boote mal von einer Live-CD und mach mal folgendes:

Code: Alles auswählen

mount /dev/root11.4 /mnt
Bei sep. /usr Part. mount /dev/usr11.4 /mnt/usr

chroot /mnt /bin/bash

mkinitrd -k /boot/aktuelles-vmlinuz-image -i /boot/initrd

Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4270
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: [solved] /lib/modules/2.6.38-08-generic not found

Beitrag von framp » 22. Apr 2011, 21:30

spoensche hat geschrieben:Das Verzeichnis existiert aber oder? Die initrd wird wohl nocht ganz mitbekommen haben, das sich etwas geändert hat. Boote mal von einer Live-CD und mach mal folgendes:...
Danke für den Hinweis. Allerdings läuft jetzt inzwischen auf dem Server ein neu installiertes 11.4 . Die RAID sync für die Daten läuft noch :roll:

Aber Dein Hinweis zeigt schon in die richtige Richtung - irgendwas ist beim automatischen upgrade in die Hose gegangen und es wurde immer noch das alte /lib/modules gesucht.

Antworten