Noch ein paar kleine Fragen zu LTSP!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
alex0815
Newbie
Newbie
Beiträge: 16
Registriert: 8. Jul 2004, 19:16
Wohnort: Berlin
Kontaktdaten:

Noch ein paar kleine Fragen zu LTSP!

Beitrag von alex0815 » 12. Jul 2004, 01:12

Ich habe jetzt so ziemlich jeden LTSP-Thread hier im Forum gelesen. Leider konnte ich zwei letzte Probleme noch nicht beseitigen.

1. Obwohl ich meinen Fontserver aktiviert habe und der Client auch damit arbeiten kann (wenn XFS nicht erreichbar ist, startet X gar nicht erst), sind die Schriften immernoch ziemlich krieselig bzw. viele meiner Schriften fehlen.
Ich habe schon die /etcX11/fs/config angepasst, aber nichts hat geholfen.
Allerdings habe ich NICHTS an den Fontpath-Einstellungen zwischen der config und der XF86config herumkopiert. Die waren nämlich in beiden Dateien gleich.

Woran kann das noch liegen, bzw. wie kann ich meine ganzen TTF- und anderen Schriftarten auch am X-Terminal nutzen?

2. Mein Server startet wie eingestellt im Runlevel 5. Trotzdem startet er das grafische Login nicht mehr. In welcher Datei muss ich die Änderung durchführen, damit das ganze richtig hochfährt?

- Ausserdem würde mich rein informell noch interessieren, ob der Sound-Support bei LTSP4 installiert ist und (nach einschlägiger Forenaussage hier) nur nicht funktioniert, oder ob er erst gar nicht im LTSP4 drinne ist.
- Wie schaut es aus, wenn ich z.B. JOE (Joes Own Editor) auf dem Terminal benutzen möchte? Ich hab ja keinen Compiler um es rein zu installieren. Oder muss ich da einen anderen Weg gehen (evtl. ganz primitiv das Binary in den LTSP-Pfad kopieren?)?
- Hat jemand von euch eigentlich schon den viel gepriesenen NX-Server am Laufen? Evtl. Sogar mit LTSP? Kann man das selber irgendwie "reintüdeln"?

Werbung:
Gast

Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von Gast » 12. Jul 2004, 10:31

alex0815 hat geschrieben:1. Obwohl ich meinen Fontserver aktiviert habe und der Client auch damit arbeiten kann (wenn XFS nicht erreichbar ist, startet X gar nicht erst), sind die Schriften immernoch ziemlich krieselig bzw. viele meiner Schriften fehlen.
- In der XF86Config:

Code: Alles auswählen

Section "Files"
  FontPath     "unix/:7100"
Die anderen Pfade brauchst Du nicht mehr
- In der /etc/X11/fs/config die Zeile mit

Code: Alles auswählen

no-listen = tcp
auskommentieren (#) und in der Sektion catalogue die Fontpaths einfügen
-Fontserver in Yast-Runleveleditor starten
-In der /opt/ltsp/i386/etc/lts.conf unter [Default] einfügen:

Code: Alles auswählen

USE_XFS = Y
Schau dann mal in die /var/log/fs-errors, außer regelmäßigen

Code: Alles auswählen

/usr/X11R6/bin/xfs notice: terminating
sollte da nichts drin stehen.

Andreas

alex0815
Newbie
Newbie
Beiträge: 16
Registriert: 8. Jul 2004, 19:16
Wohnort: Berlin
Kontaktdaten:

Beitrag von alex0815 » 12. Jul 2004, 11:58

Also das klappt bei mir nicht.
Ich habe jetzt alle Einträge so gemacht, wie du es gesagt hast.
Trotzdem habe ich jetzt (auch auf dem Server) nur ganz wenige Schriftarten und die meisten davon sind unscharf...

Ich poste am Besten mal meine Config-Dateien...

XF86Config von /etc/X11 auf dem Server:

Section "Files"
# FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/local"
# FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/Type1"
# FontPath "/usr/X11R6/lib/X11/fonts/URW"
# FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
# FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
# FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
# FontPath "/usr/X11R6/lib/X11/fonts/truetype"
# FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/CID"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
# FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/xtest"
# FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 28-60
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
Option "DPMS"
VendorName "--> LCD"
VertRefresh 40-60
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
Modeline "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "3D Rage Pro AGP 1X/2X"
BusID "1:0:0"
Driver "ati"
Identifier "Device[0]"
VendorName "ATI"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
Config von /etc/X11/fs/config auf dem Server:

# if you omit "no-listen = tcp" you can use xfs over the network
# if you add entries like
# FontPath "tcp/hostname:7100"
# into /etc/X11/XF86config. Increases the security risk!

#no-listen = tcp
port = 7100
client-limit = 10
clone-self = on
use-syslog = on
deferglyphs = 16

catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/japanese:unscaled,
/usr/X11R6/lib/X11/fonts/baekmuk:unscaled,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/URW,
/usr/X11R6/lib/X11/fonts/Speedo,
/usr/X11R6/lib/X11/fonts/CID,
/usr/X11R6/lib/X11/fonts/PEX,
/usr/X11R6/lib/X11/fonts/cyrillic,
/usr/X11R6/lib/X11/fonts/latin2/misc,
/usr/X11R6/lib/X11/fonts/latin2/75dpi,
/usr/X11R6/lib/X11/fonts/latin2/100dpi,
/usr/X11R6/lib/X11/fonts/latin2/Type1,
/usr/X11R6/lib/X11/fonts/latin7/75dpi,
/usr/X11R6/lib/X11/fonts/kwintv,
/usr/X11R6/lib/X11/fonts/truetype,
/usr/X11R6/lib/X11/fonts/uni,
/usr/X11R6/lib/X11/fonts/ucs/misc,
/usr/X11R6/lib/X11/fonts/ucs/75dpi,
/usr/X11R6/lib/X11/fonts/ucs/100dpi,
/usr/X11R6/lib/X11/fonts/hellas/misc,
/usr/X11R6/lib/X11/fonts/hellas/75dpi,
/usr/X11R6/lib/X11/fonts/hellas/100dpi,
/usr/X11R6/lib/X11/fonts/hellas/Type1,
/usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/local,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/URW,
/usr/X11R6/lib/X11/fonts/Speedo,
/usr/X11R6/lib/X11/fonts/PEX,
/usr/X11R6/lib/X11/fonts/cyrillic,
/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled,
/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/latin2/Type1,
/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/baekmuk:unscaled,
/usr/X11R6/lib/X11/fonts/japanese:unscaled,
/usr/X11R6/lib/X11/fonts/kwintv,
/usr/X11R6/lib/X11/fonts/truetype,
/usr/X11R6/lib/X11/fonts/uni:unscaled,
/usr/X11R6/lib/X11/fonts/CID,
/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled,
/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled,
/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/hellas/Type1,
/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled,
/usr/X11R6/lib/X11/fonts/xtest,
/opt/kde3/share/fonts


# in decipoints
default-point-size = 120
default-resolutions = 75,75,100,100

# font cache control, specified in KB
cache-hi-mark = 2048
cache-low-mark = 1433
cache-balance = 70

Gast

Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von Gast » 12. Jul 2004, 15:22

alex0815 hat geschrieben:Ich habe jetzt alle Einträge so gemacht, wie du es gesagt hast. Trotzdem habe ich jetzt (auch auf dem Server) nur ganz wenige Schriftarten und die meisten davon sind unscharf...
Was sagt denn die /var/log/fs-errors ?
Wie war das vorher auf den Server und auf dem Client?
Nimm mal versuchsweide den Fontserver aus der /opt/ltsp/i386/etc/lts.conf raus, der Client hat dann (da selber X-Server) seine eigenen Fonts, die i.O. sein sollten. Stimmt das?
Hattest Du Pfade in der XF86Config selber hinzugefügt oder geändert?
Ich vermute, daß er in der fs-errors einiges zu meckern hat. Die Pfade, die er dort moniert, kann er nicht nutzen und die übrigen sind wohl zu wenig.

Andreas

alex0815
Newbie
Newbie
Beiträge: 16
Registriert: 8. Jul 2004, 19:16
Wohnort: Berlin
Kontaktdaten:

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von alex0815 » 12. Jul 2004, 15:38

Was sagt denn die /var/log/fs-errors ?
Wie war das vorher auf den Server und auf dem Client?
Nimm mal versuchsweide den Fontserver aus der /opt/ltsp/i386/etc/lts.conf raus, der Client hat dann (da selber X-Server) seine eigenen Fonts, die i.O. sein sollten. Stimmt das?
Hattest Du Pfade in der XF86Config selber hinzugefügt oder geändert?
Ich vermute, daß er in der fs-errors einiges zu meckern hat. Die Pfade, die er dort moniert, kann er nicht nutzen und die übrigen sind wohl zu wenig.
fs-Errors sagt dies hier (unter anderem):
/usr/X11R6/bin/xfs notice: ignoring font path element /usr/X11R6/lib/X11/fonts/xtest (unreadable)
Was ich sonst noch gemacht hab, kann man in meinem letzten Post ganz gut sehen. Am Server habe ich in der XF86Config die ganzen Pfade auskommentiert und diese dafür in der /etc/X11/fs/config eingetragen.
Dann hat es auch auf dem Server die beschriebenen Probleme gegeben. Vorher gab es die nicht.
Zur Not würde ich ja auch die ganzen Fonts in das LTSP-Verzeichnis kopieren. Aber das erscheint mir "unsauber" deswegen würde ich gerne wissen, wo ich meinen Fehler habe...

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von schweer » 12. Jul 2004, 18:12

alex0815 hat geschrieben: Aber das erscheint mir "unsauber" deswegen würde ich gerne wissen, wo ich meinen Fehler habe...
Es muss tcp/<xfs-server-name>:7100 statt unix/:7100 heißen

wolfgang

alex0815
Newbie
Newbie
Beiträge: 16
Registriert: 8. Jul 2004, 19:16
Wohnort: Berlin
Kontaktdaten:

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von alex0815 » 12. Jul 2004, 19:49

schweer hat geschrieben:
alex0815 hat geschrieben: Aber das erscheint mir "unsauber" deswegen würde ich gerne wissen, wo ich meinen Fehler habe...
Es muss tcp/<xfs-server-name>:7100 statt unix/:7100 heißen

wolfgang
Muss es denn der Name sein oder geht auch die IP-Adresse???

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von schweer » 12. Jul 2004, 20:00

alex0815 hat geschrieben:Muss es denn der Name sein oder geht auch die IP-Adresse???
Das geht natürlich auch.

wolfgang

Gast

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von Gast » 12. Jul 2004, 20:38

schweer hat geschrieben:Es muss tcp/<xfs-server-name>:7100 statt unix/:7100 heißen
Du hast recht, wenn eine Rechner einen externen Fontserver nutzt. Wenn der Fontserver aber auf dem selben Rechner läuft, ist unix/:7100 richtig.
Die Clients bekommen das ja über die lts.conf mitgeteilt. Wenn dort ein eigenes Linux werkeln würde wie bei meinem thintune, kommt dann dort Deine Terminologie zum tragen, weil der benutzte Fontserver auf dem Server und nicht auf dem thintune läuft.

Andreas

Gast

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von Gast » 12. Jul 2004, 20:54

alex0815 hat geschrieben: fs-Errors sagt dies hier (unter anderem):
/usr/X11R6/bin/xfs notice: ignoring font path element /usr/X11R6/lib/X11/fonts/xtest (unreadable)
Was heißt hier "unter anderem", was denn noch?
alex hat geschrieben:Am Server habe ich in der XF86Config die ganzen Pfade auskommentiert und diese dafür in der /etc/X11/fs/config eingetragen.
Dann hat es auch auf dem Server die beschriebenen Probleme gegeben. Vorher gab es die nicht.
Naja..., da hast Du aber doch ein bißchen mehr gemach! ;-)
In der XF86Config hast Du 30 Pfade auskommentiert und in der config des Fontservers erscheinen plötzlich ganze 56 Pfade.
Schreib bitte nur die Pfade der XF86Config in die config des Fontservers, die vorher in der XF86Config funktionierten, bitte auch auf die Reihenfolge achten!
Die Ergänzung von Schriften ist nicht mit einfachen kopieren der Fonts in ein Verzeichnis getan.

Andreas

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von schweer » 12. Jul 2004, 21:08

andtolle hat geschrieben:
schweer hat geschrieben:Es muss tcp/<xfs-server-name>:7100 statt unix/:7100 heißen
Du hast recht, wenn eine Rechner einen externen Fontserver nutzt. Wenn der Fontserver aber auf dem selben Rechner läuft, ist unix/:7100 richtig.
Die Clients bekommen das ja über die lts.conf mitgeteilt. Wenn dort ein eigenes Linux werkeln würde wie bei meinem thintune, kommt dann dort Deine Terminologie zum tragen, weil der benutzte Fontserver auf dem Server und nicht auf dem thintune läuft.

Andreas
Hallo Andreas,

auf den Clients läuft ja ein eigenes X und das kann einen externen xfs benutzen; die Einstellung USE_XFS=YES in lts.conf bewirkt, dass solch eine tcp/... Zeile in die zur Laufzeit des Client erzeugte XF86Config des Client geschrieben wird. Wenn man für den Client selbst eine (statische) XF86Config bereitstellt, dann muss auch dort eine tcp/.. Zeile enthalten sein.

Aber Du hast schon Recht: Es ging ja um seinen Server.

wolfgang

alex0815
Newbie
Newbie
Beiträge: 16
Registriert: 8. Jul 2004, 19:16
Wohnort: Berlin
Kontaktdaten:

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von alex0815 » 12. Jul 2004, 21:21

So - ich habe nun in die XF86Config die Zeile tcp/192.168.0.109:7100 eingefügt.
Ausserdem sind in der XF86Config keine weiteren FontPath aktiv.

Jedenfalls verstehe ich die vorherigen Posts so, dass ich das so machen muss... :)

Nun guckt also X beim Starten auf dem FontServer der unter der 192.168.0.109:7100 nach den Fonts die unter der /etc/X11/fs/config eingetragen sind, richtig???

Was ist eigentlich mit den FontPath die hinten noch ein :unscaled oder :scaled hintendranstehen haben? Müssen die ebenfalls genaus so in die fs/config eingetragen werden?

Gruss

Alex

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Titel: Re: Noch ein paar kleine Fragen zu LTSP!

Beitrag von schweer » 12. Jul 2004, 22:09

alex0815 hat geschrieben:Was ist eigentlich mit den FontPath die hinten noch ein :unscaled oder :scaled hintendranstehen haben? Müssen die ebenfalls genaus so in die fs/config eingetragen werden?
Hallo Alex,

ja - genau so. Und zwar immer der Eintrag mit :unscaled vor dem ansonsten gleichen ohne diesen Zusatz.

wolfgang

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast