Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Beendet: LTSP5 für alte Hardware

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
cochise.geronimo
Member
Member
Beiträge: 70
Registriert: 17. Mai 2009, 16:37

Beendet: LTSP5 für alte Hardware

Beitrag von cochise.geronimo » 12. Dez 2009, 16:24

Hallo!

Beim Testen mit LTSP5/OpenSuSE11.2 fällt mir auf, dass LTSP5 im Vergleich zu LTSP4 erhebliche Anforderungen an die Client-Hardware stellt.

Eines der Argumente für den Einsatz von Terminalservern ist doch, dass ältere und schwächere Hardware weiter genutzt werden kann. Wir bekommen immer wieder gebrauchte Rechner von Eltern und Firmen geschenkt. Wir haben bei uns als Clients zB PI-Rechner, 133 MHz-Taktrate mit 64 MB RAM im Einsatz. Diese laufen unter LTSP4 flott.
Ein Boote unter LTSP5 geht nicht. Auch etwas neuere Rechner mit 256 MB RAM booten nicht durch.

Gebootet wird LTSP5 von:
IGEL-Winestra ThinClients mit 128 MB RAM. Ein Arbeiten mit IceWM als Windowmanger ist quälend, mit KDE3/4 unmöglich.
Dann habe ich es einmal von einem Notebook mit 1 GB RAM gebootet und da läuft selbst KDE3/4. Auch ein eingesteckter USB-Stick sowie Sound klappten auf Anhieb.

Der eigentliche Bootvorgang dauert bei LTSP5 ca 5-8 mal länger als bei LTSP4.

Gibt es Möglichkeiten auch ältere und schwächere Hardware zur Mitarbeit zu bewegen?

Gruß
Zuletzt geändert von cochise.geronimo am 16. Dez 2009, 15:23, insgesamt 1-mal geändert.

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7395
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: LTSP5 für alte Hardware

Beitrag von spoensche » 12. Dez 2009, 20:48

cochise.geronimo hat geschrieben: Gibt es Möglichkeiten auch ältere und schwächere Hardware zur Mitarbeit zu bewegen?
Wenn hat sich höchstens die Anforderungen an die Grafikkarte geändert. Alle anderen Operationen werden auf dem Server ausgeführt und nicht auf dem Client.

Deaktiviere mal sämtliche Effekte der grafischen Oberfläche, dann sollte es funktionieren.

Die von dir verwendete Konfiguration und Serverhardware wäre für die Problemlösung sehr hilfreich.

cochise.geronimo
Member
Member
Beiträge: 70
Registriert: 17. Mai 2009, 16:37

Re: LTSP5 für alte Hardware

Beitrag von cochise.geronimo » 13. Dez 2009, 11:58

Hallo!

Serverhardware: Dual-Prozessorboard mit 2x QuadCore 2,8 GHz Prozessoren, 16 GB-RAM, SAS-Festplatte mit 15K RPM, GBit-Lan
Betriebssystem: OpenSuSE11.2
Clients: Alles Mögliche an Alt-Rechnern

Installiert habe ich via Yast die LTSP5-Pakete sowie Easy-LTSP.

Kann es sein, dass ich für die Clients spezielle Kernel benötige? In einem Ubuntu-Forum fand ich den Hinweis auf ltsp-build-client.


cu

spoensche
Moderator
Moderator
Beiträge: 7395
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: LTSP5 für alte Hardware

Beitrag von spoensche » 13. Dez 2009, 16:21

cochise.geronimo hat geschrieben: Kann es sein, dass ich für die Clients spezielle Kernel benötige? In einem Ubuntu-Forum fand ich den Hinweis auf ltsp-build-client.
Einen ähnlichen Hinweis findest du auch unter http://en.opensuse.org/LTSP. (KIWI-LTSP etc.)

cochise.geronimo
Member
Member
Beiträge: 70
Registriert: 17. Mai 2009, 16:37

Re: LTSP5 für alte Hardware

Beitrag von cochise.geronimo » 15. Dez 2009, 15:49

Hallo!

Ich habe die Kiwi-LTSP-Software komplett gelöscht und nach Anleitungen auf dem Link noch einmal installiert.
Das Ergebnis ist unverändert.
In der Zeit, in der 1 Client mit LTSP5 bootet, haben 20 andere LTSP4.2 gebootet, sich angemeldet und diverse Applikationen gestartet.
Unter 512 MB-RAM für einen Client läuft nichts.

Mein Fazit: LTSP5 und OpenSuSE kann man getrost in die Tonne treten.

cu

spoensche
Moderator
Moderator
Beiträge: 7395
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: LTSP5 für alte Hardware

Beitrag von spoensche » 15. Dez 2009, 23:57

cochise.geronimo hat geschrieben:Mein Fazit: LTSP5 und OpenSuSE kann man getrost in die Tonne treten.
Meiner Meinung nach ein sehr schlechtes Fazit, ohne den Ursachen für die Performanceprobleme auf den Grund zu gehen. (z.B. Flaschenhals im Netzwerk, Plattenperformance der einzigen Festplatte des Servers).

Es wäre hilfreich und informativ, wenn du mal posten würdest, wie deine LTSP, deine Netzwerk, die GUI- und die Client- Konfiguration aussieht bzw. welche Einstellungen du dort verwendest.


PS:

Bevor man ein Fazit abgibt sollten Analysen durchgeführt werden um das Fazit zu festigen bzw. Gründe dafür angeben zu können.

cochise.geronimo
Member
Member
Beiträge: 70
Registriert: 17. Mai 2009, 16:37

Re: LTSP5 für alte Hardware

Beitrag von cochise.geronimo » 16. Dez 2009, 15:23

Hallo!

Mein Fazit ist schon begründet!

1. Der LTSP4.2-Server läuft gut und schnell, LTSP5 hingegen schlecht bis gar nicht.
2. Ich habe heute morgen auf derselben Maschine des LTSP5-Servers (Dualboot) LTSP5 unter Ubuntu Karmic Koala installiert und konfiguriert. Das alles in der ersten großen Pause mithin 15 Minuten. Und, es läuft Out-of-the-Box gut und schnell.

Ich bedanke mich für eure Hilfestellungen und schließe für mich diesen Thread ab.

cu

spoensche
Moderator
Moderator
Beiträge: 7395
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Beendet: LTSP5 für alte Hardware

Beitrag von spoensche » 19. Dez 2009, 22:26

Bezüglich der Konfiguration der Client Images gibt es zwischen openSuSE und Ubuntu einige Unterschiede. Die KIWI Images sind ein wenig aufwändiger und umfangreicher.

Das Out of the box wirst du hoffentlich noch in Punkto Absicherung etc. trimmen und scharf stellen.

Antworten