autologin funktioniert nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
ratibor
Member
Member
Beiträge: 87
Registriert: 11. Apr 2004, 23:08
Wohnort: Koblenz

autologin funktioniert nicht mehr

Beitrag von ratibor » 16. Nov 2009, 15:29

Hallo,

In Ermangelung der Dokumentation (siehe mein anderer Beitrag) wende ich mich hilfesuchend an Euch:
in unserem Jugendraum habe ich einen ltsp-Server (LTSP5) mit derzeit drei Clients, habe aber noch zwei Rechner, die ich gerne als Clients einbinden möchte. Ich habe versuchsweise einen davon angeschlossen und, nachdem ich die MAC-Adresse der Netzwerkkarte hatte, versucht, diesen in das System einzubinden. Hat auch weitestgehend funktioniert, nur logt sich nun keiner der Clients mehr automatisch ein, was vorher ohne Probleme lief.

meine dhcpd.conf sieht so aus:

Code: Alles auswählen

#
# Default LTSP dhcpd.conf config file.
#

authoritative;

subnet 192.168.2.0 netmask 255.255.255.0 {
    range 192.168.2.100 192.168.2.110;
    option domain-name "homebase";
#    option domain-name-servers 192.168.2.1;
    option broadcast-address 192.168.2.255;
    option routers 192.168.2.1;
    next-server 192.168.2.100;
#    get-lease-hostnames true;
    option subnet-mask 255.255.255.0;
    option root-path "192.168.2.100:/opt/ltsp/i386";

   host erni {
	#filename "/ltsp/i386/vmlinuz";
	server-name "kermit";
	hardware ethernet 00:08:54:07:C0:68;
	fixed-address 192.168.2.101;
	}

   host bert {
	#filename "/ltsp/i386/vmlinuz";
	server-name "kermit";
	hardware ethernet 00:08:54:07:C0:67;
	fixed-address 192.168.2.102;
	}

   host grobi {
	#filename "/ltsp/i386/pxelinux.0";
	server-name "kermit";
	next-server 192.168.2.100;
	hardware ethernet 00:10:22:FE:68:56;
	fixed-address 192.168.2.103;
	}

   host lilo {
	#filename "/ltsp/i386/vmlinuz";
	server-name "kermit";
	hardware ethernet 00:C0:9F:7A:BC:EA;
	fixed-address 192.168.2.104;
	}

   host tifi {
	#filename "/ltsp/i386/vmlinuz";
	server-name "kermit";
	hardware ethernet 00:30:05:79:E2:6F;
	fixed-address 192.168.2.105;
	}

    if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        filename "/ltsp/i386/pxelinux.0";
    } else {
        filename "/ltsp/i386/nbi.img";
    }
}
die lts.conf so:

Code: Alles auswählen

# This is the default lts.conf file for ltsp 5.
# For more information about valid options please see: 
# /usr/share/doc/ltsp-client/examples/lts-parameters.txt.gz
# in the client environment

[default] 
    SERVER = 192.168.2.100
    XSERVER = auto
    XDM_SERVER = 192.168.2.100
    X_MOUSE_PROTOCOL   = "PS/2"
    X_MOUSE_DEVICE     = "/dev/psaux"
    X_MOUSE_RESOLUTION = 400
    X_MOUSE_BUTTONS    = 3
    XKBLAYOUT = de
    #USE_NFS_SWAP = Y
    SOUND=False
    LDM_SESSION="/usr/bin/startkde"
    #SCREEN_01 = startx
    RUNLEVEL = 5
    #LOCALDEV=False
    #CONFIGURE_X=False
    X_COLOR_DEPTH=16


[00:08:54:07:c0:68]
    X_MODE_0 = 1024x768
    #LDM_SESSION="/usr/bin/startkde"
    LDM_AUTOLOGIN = True
    LDM_USERNAME = "gast1"
    LDM_PASSWORD = "gast1+"
    LDM_DIREKTX = True
    NBD_SWAP = True

[00:08:54:07:c0:67]
    X_MODE_0 = 1024x768
    #LDM_SESSION="/usr/bin/startkde"
    LDM_AUTOLOGIN = True
    LDM_USERNAME = "gast2"
    LDM_PASSWORD = "gast2+"
    LDM_DIREKTX = True
    NBD_SWAP = True

[00:10:22:FE:68:56]
    USE_LOCAL_SWAP = True
    X_MODE_0 = 1024x768
    LDM_AUTOLOGIN = True
    LDM_USERNAME = "gast3"
    LDM_PASSWORD = "gast3+"
    #LDM_SESSION="/usr/bin/startkde"
    LDM_DIREKTX = True

[00:C0:9F:7A:BC:EA]
    X_MODE_0 = 1024x768
    #LDM_SESSION="/usr/bin/startkde"
    LDM_AUTOLOGIN = True
    LDM_USERNAME = "gast2"
    LDM_PASSWORD = "gast2+"
    LDM_DIREKTX = True
    NBD_SWAP = True

[00:30:05:79:E2:6F]
    #USE_LOCAL_SWAP = True
    X_MODE_0 = 1024x768
    #LDM_SESSION="/usr/bin/startkde"
    LDM_AUTOLOGIN = True
    LDM_USERNAME = "gast4"
    LDM_PASSWORD = "gast4+"
    #LDM_DIREKTX = True
Ziel ist, dass sich jeder Client mit einem eigenen User automatisch unter kde einlogt. Die User sind alle angelegt, die Rechner mit den entsprechenden IP sind dem Server bekannt. Wie gesagt, es hat alles ja schon mal funktioniert (den 4. Client habe ich inzwischen wieder aus dem System entfernt).

Außerdem gehen mir so langsam die Namen aus der Sesamstraße aus, mit denen ich die Rechner benennen kann ;-)

Gruß
Wolfgang

Werbung:
ratibor
Member
Member
Beiträge: 87
Registriert: 11. Apr 2004, 23:08
Wohnort: Koblenz

Re: autologin funktioniert nicht mehr

Beitrag von ratibor » 2. Dez 2009, 16:07

Gibt es so etwas wie ein Startprotokoll für die Clients? Wenn ja, wo finde ich dies?
Vieleicht gibt mir das einen Hinweis auf den Fehler.

Gruß
Wolfgang

ratibor
Member
Member
Beiträge: 87
Registriert: 11. Apr 2004, 23:08
Wohnort: Koblenz

Re: autologin funktioniert nicht mehr

Beitrag von ratibor » 9. Dez 2009, 17:20

ich habe testweise die Datei lts.conf umbenannt in .lts.conf (quasi als wäre sie gelöscht worden). Der Client startet trotzdem wie gehabt bis zum login-screen ohne zu meckern. Wie macht der das? gibt es irgendwo eine versteckte zweite lts.conf? oder greifen die clients gar nicht automatisch auf diese Datei zu?

Ich brauche da wirklich Hilfe, immerhin muss ich derzeit jeden Tag die Clients von Hand auf kde einstellen und dann einloggen.

Gruß
Wolfgang

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste