Problem mit externer Festplatte

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Senekha
Member
Member
Beiträge: 110
Registriert: 9. Feb 2005, 17:35

Problem mit externer Festplatte

Beitrag von Senekha » 8. Nov 2009, 13:07

Hallo,

habe mir eine externe 500 GB Festplatte geholt, welche über eSATA und USB verfügt, leider ist es mir bis jetzt nicht gelungen unter Linux auf die Festplatte zuzugreifen, sie wird zwar angezeigt aber zugreifen kann ich darauf nicht, weder mit USB noch mit eSATA. Unter Windows (auf dem selben Rechner) gibts dagegen keinerlei Probleme weder mit eSATA noch mit USB. Ich vermute mal, dassss irgendwo ein entsprechender Eintrag in einer config Datei fehlt?

Gruß Senekha

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Problem mit externer Festplatte

Beitrag von lOtz1009 » 8. Nov 2009, 13:19

Öffne mal ein Root-Terminal und führe

Code: Alles auswählen

tail -f /var/log/messages
aus. Dann die Platte anstöpseln. Die Meldungen dann bitte posten.
Was sagt

Code: Alles auswählen

fdisk -l
zu der Platte?
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Senekha
Member
Member
Beiträge: 110
Registriert: 9. Feb 2005, 17:35

Re: Problem mit externer Festplatte

Beitrag von Senekha » 8. Nov 2009, 19:25

Code: Alles auswählen

tail -f /var/log/messages
hat folgendes ausgespuckt:

Code: Alles auswählen

Nov  8 18:56:55 suse kernel: usb 4-1: reset high speed USB device using ehci_hcd and address 2
Nov  8 19:13:02 suse su: (to root) hotte on /dev/pts/1
Nov  8 19:13:52 suse kernel: ata7: exception Emask 0x10 SAct 0x0 SErr 0x4050000 action 0xe frozen
Nov  8 19:13:52 suse kernel: ata7: irq_stat 0x00000040, connection status changed
Nov  8 19:13:52 suse kernel: ata7: SError: { PHYRdyChg CommWake DevExch }
Nov  8 19:13:52 suse kernel: ata7: hard resetting link
Nov  8 19:13:59 suse kernel: ata7: link is slow to respond, please be patient (ready=0)
Nov  8 19:14:00 suse kernel: ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Nov  8 19:14:00 suse kernel: ata7.00: ATA-8: SAMSUNG HD501LJ, CR100-10, max UDMA7
Nov  8 19:14:00 suse kernel: ata7.00: 976773168 sectors, multi 0: LBA48 NCQ (depth 31/32)
Nov  8 19:14:00 suse kernel: ata7.00: configured for UDMA/133
Nov  8 19:14:00 suse kernel: ata7: EH complete
Nov  8 19:14:00 suse kernel: scsi 6:0:0:0: Direct-Access     ATA      SAMSUNG HD501LJ  CR10 PQ: 0 ANSI: 5
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] 976773168 512-byte hardware sectors: (500 GB/465 GiB)
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Write Protect is off
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Mode Sense: 00 3a 00 00
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] 976773168 512-byte hardware sectors: (500 GB/465 GiB)
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Write Protect is off
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Mode Sense: 00 3a 00 00
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov  8 19:14:00 suse kernel:  sdg: sdg1
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: [sdg] Attached SCSI disk
Nov  8 19:14:00 suse kernel: sd 6:0:0:0: Attached scsi generic sg9 type 0
Bei

Code: Alles auswählen

fdisk -l
kam folgendes heraus:

Code: Alles auswählen

Disk /dev/sdg: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc774eb80

   Device Boot      Start         End      Blocks   Id  System
/dev/sdg1               1       60801   488384001    7  HPFS/NTFS
hoffe das hilft weiter

Gruß Senekha

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Problem mit externer Festplatte

Beitrag von lOtz1009 » 8. Nov 2009, 19:31

Und wenn du mal versuchst die Platte manuell zu mounten?

Code: Alles auswählen

mount -t ntfs-3g /dev/sdg1 /mountpunkt
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Senekha
Member
Member
Beiträge: 110
Registriert: 9. Feb 2005, 17:35

Re: Problem mit externer Festplatte

Beitrag von Senekha » 8. Nov 2009, 19:45

OK, danke für den Tip, manuell mounten funktioniert tadellos, bleibt nur die Frage, ob man das irgendwie automatisieren kann?

Gruß Senekha

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Problem mit externer Festplatte

Beitrag von lOtz1009 » 8. Nov 2009, 19:47

Welche Distribution und welches Desktopenvironment dazu benutzt du?
Zumindest unter KDE4.3 und XFCE 4.6 funktioniert das hier einwandfrei.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Senekha
Member
Member
Beiträge: 110
Registriert: 9. Feb 2005, 17:35

Re: Problem mit externer Festplatte

Beitrag von Senekha » 8. Nov 2009, 19:58

Oh sorry ich vergaß, Suse 11.1 64Bit, KDE 4.1.3, sollte ich vielleicht mal updaten.

Gruß Senekha

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Problem mit externer Festplatte

Beitrag von lOtz1009 » 8. Nov 2009, 20:14

Ich meine mit KDE 4.1 gabs mit Automount ein paar Probleme.
4.3 ist um einiges stabiler und flüssiger, ein Update ist eigentlich auch relativ easy-to-go.
Nur drauf achten, dass du nicht das Factory-Repo benutzt, sondern entweder das KDE4:Stable oder KDE:43 (Passende Repos gibts unter http://www.linux-club.de/viewtopic.php?f=24&t=105966)
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Senekha
Member
Member
Beiträge: 110
Registriert: 9. Feb 2005, 17:35

Re: Problem mit externer Festplatte

Beitrag von Senekha » 9. Nov 2009, 10:23

allles klar, danke für die Hinweise. Wenn ich richtig informiert bin, kommt ja in wenigen Tagen Suse 11.2 raus, vielleicht warte ich auch solang und nehm die dann, da ist ja der KDE 4.3 bereits enthalten. Außerdem wirds mal wieder Zeit für ne Neuinstallation, sonst komm ich noch ganz aus der Übung. :D :lol:

Gruß Senekha

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Yahoo [Bot] und 2 Gäste