[gelöst]zusätzliche Festplatte wird nicht erkannt

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

[gelöst]zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 4. Nov 2009, 11:05

Hallo Ihr Lieben,

wieder einmal kämpfe ich mit mangelndem Linux-Wissen und Hardware, die nicht erkannt wird. Und zwar habe ich eine zweite Festplatte ganz normal eingesteckt und mit Windows läuft sie auch einwandfrei (betreibe XP und openSUSE 11.0 (i586) nebeneinander auf einem Rechner). Nun möchte ich mit suse auf diese neue Platte zugreifen können (darauf sind nur einige Dateien, kein Betriebssystem), um mir benötigte Dateien rüberziehen und bearbeiten zu können. Sie wird aber anscheinend noch nicht mal erkannt (hoffe, das war auch der richtige Befehl):

fdisk -l

Platte /dev/sda: 80.0 GByte, 80026361856 Byte
255 Köpfe, 63 Sektoren/Spuren, 9729 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0xbe69be69

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 4440 35656267 7 HPFS/NTFS
/dev/sda2 4440 9729 42491894 f W95 Erw. (LBA)
/dev/sda5 4973 5234 2104515 82 Linux Swap / Solaris
/dev/sda6 5235 7056 14635183+ 83 Linux
/dev/sda7 7057 9729 21470841 83 Linux

Platte /dev/sdb: 40.0 GByte, 40027029504 Byte
255 Köpfe, 63 Sektoren/Spuren, 4866 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0xbb3ebb3e

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdb1 * 1 4865 39078081 7 HPFS/NTFS


Wie kann ich die einbinden, dass sie automatisch erkannt wird?

Liebe Grüße, bilimbi
Zuletzt geändert von bilimbi am 6. Nov 2009, 14:43, insgesamt 1-mal geändert.

Werbung:
G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 4. Nov 2009, 11:14

Hallo bilimbi,

aber es werden doch zwei Platten erkannt? /dev/sda dürfte Deine Systemplatte sein, /dev/sdb die zweite?

Du mußt sie vermutlich nur noch "mounten", also einbinden.

Dazu einen Mountpunkt erstellen:

Code: Alles auswählen

mkdir /mnt/beliebiger_name
Und anschließend einbinden:

Code: Alles auswählen

mount -t ntfs-3g /dev/sdb1 /mnt/gleicher_name_wie_oben
Dann solltest Du das Ding im Zugriff haben.

Soll das bei jedem Hochfahren immer der Fall sein, muß der Eintrag in die fstab (/etc/fstab).

Gruß Greg

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 4. Nov 2009, 14:27

Hallo Greg,

vielen Dank für Deine Antwort; ich werde das zeitnah ausprobieren und dann Bescheid geben, ob's funktioniert hat.

Wenn sie jedesmal gemountet werden soll (und das wäre natürlich wünschenswert) - wohin genau muss ich das in der fstab schreiben? Soweit ich verstanden habe, ist das keine ausführbare Datei, sondern eine zum Lesen?

Liebe Grüße, bilimbi

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von lOtz1009 » 4. Nov 2009, 14:32

Trags einfach in die fstab ein. Eigentlich ist sie recht selbsterklärend. Schau's dir einfach mal an. Falls du nicht weiterkommst schreib nochmal und dann wirds passend gemacht.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 4. Nov 2009, 16:35

Hi bilimbi,
wohin genau muss ich das in der fstab schreiben
Wichtig ist eigentlich nur, daß der Eintrag unterhalb des Eintrages der Partition steht, auf der sich Dein Mountpoint befindet, im konkreten Falle also unterhalb des Eintrages für die Root-Partition (/). Wenn Du den Eintrag für /dev/sdb1 unterhalb aller bereits bestehenden Einträge für die einzelnen Partitionen auf /dev/sda vornimmst, machst Du nichts falsch.

Der Eintrag dürfte für Dich schlußendlich so aussehen (unter der Bedingung, daß das manuelle Mounten mit dem von mir genannten Befehl erfolgreich war):

Code: Alles auswählen

/dev/sdb1 /mnt/dein_gewählter_name     ntfs-3g     users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
Probier's mal aus: Manuelles Mounten klappte? Dann Eintrag (als root) in /etc/fstab vornehmen, anschließend zunächst manuell ausbinden:

Code: Alles auswählen

umount /mnt/dein_gewählter_name
Und automatisch mounten lassen:

Code: Alles auswählen

mount -a
Wenn dann Deine Platte im Zugriff ist, wird sie dies auch nach einem Neustart wieder sein.

Gruß Greg

josef-wien
Guru
Guru
Beiträge: 4914
Registriert: 23. Sep 2008, 17:09

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von josef-wien » 4. Nov 2009, 22:58

G aus W hat geschrieben:/dev/sdb1
Die Verwendung des Gerätenamens ist keine gute Idee, er ist nicht dauerhaft und kann beim nächsten Systemstart anders sein. Verwende die Geräte-ID (/dev/disk/by-id/...) oder die UUID (/dev/disk/by-uuid/...) oder (wenn Du die Eindeutigkeit gewährleisten kannst) die Volume-Kennung (/dev/disk/by-label/...).

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 5. Nov 2009, 20:21

Hallo zusammen,

sorry für die Verzögerung, aber hier das Ergebnis: leider hat das manuelle Mounten nicht geklappt. Auf den Befehl "mkdir /mnt/f (beliebigen Namen habe ich durch f ersetzt) ist der Terminal gleich wieder auf die Anmeldung zurückgesprungen. Weil ich nicht sicher war, ob das vielleicht doch richtig ist, habe ich mit dem nächsten Befehl weitergemacht (mount -t ntfs-3g /dev/sdb1 /mnt/f) und daraufhin kam eine ellenlange Hilfe-Meldung, welchen Befehl ich für was bräuchte, Verzeichnisbäume woanders einhängen und haste nicht gesehen... :???:

Vielen Dank übrigens auch für den Hinweis von Josef wegen UUID - aber: wo finde ich das denn? Ich hab' mich soviel mit Linux-Software beschäftigt und echt viel gelernt, aber dieses Terminal-Gedöns, das verstehe ich einfach nicht so recht.

Viele Grüße, bilimbi

P.S: ich habe jetzt gerade gesehen, dass jetzt ein Ordner im Konqueror existiert unter /mnt/f, der ist aber leer. Und dann habe ich einen Ordner gefunden unter /home/eltern/sdb - ebenfalls leer (also von den Daten, die unter Windows nachweislich auf der zweiten Platte drauf sind, ist gar nichts zu sehen). Ist das jetzt richtig so, nur falsch eingehängt oder hat das eine mit dem anderen gar nichts zu tun???

josef-wien
Guru
Guru
Beiträge: 4914
Registriert: 23. Sep 2008, 17:09

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von josef-wien » 5. Nov 2009, 22:37

bilimbi hat geschrieben:und daraufhin kam eine ellenlange Hilfe-Meldung
Ohne diese Meldung werden wir aber nicht weiterkommen. Hast Du den Befehl als root ausgeführt?
bilimbi hat geschrieben:UUID - aber: wo finde ich das denn?
Da gibt es eine Reihe von Möglichkeiten. Du kannst Dir die genannten Verzeichnisse anschauen und feststellen, wohin die darin enthaltenen Verknüpfungen zeigen. Du kannst den Befehl

Code: Alles auswählen

/sbin/udevadm info --export-db | egrep 'N: sd|S: disk' | egrep -v 'by-path|int13'
ausführen (mit udevadm bin ich nicht wirklich vertraut, daher dieser etwas umständliche Befehl). Wenn Du nur die UUID ermitteln willst, führst Du den Befehl

Code: Alles auswählen

/sbin/blkid -L
aus. Bei diesen Möglichkeiten wollen wir es einmal bewenden lassen.
bilimbi hat geschrieben:/mnt/f, der ist aber leer
Das ist natürlich, denn es ist ja nichts eingehängt.
bilimbi hat geschrieben:/home/eltern/sdb - ebenfalls leer
Diesen Ordner mußt Du auch irgendwann angelegt haben.
bilimbi hat geschrieben:dieses Terminal-Gedöns
Ich bin auch kein Freund der Konsole, aber für einige Dinge ist sie einfach der bessere Weg. Also über das Menü eine Konsole öffnen (oder Alt-F2 und das Wort konsole eingeben), wenn notwendig mit dem Befehl su als root anmelden und frisch ans Werk.

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 6. Nov 2009, 09:08

Hi bilimbi,

auch von mir noch kurz:
sorry für die Verzögerung, aber hier das Ergebnis: leider hat das manuelle Mounten nicht geklappt. Auf den Befehl "mkdir /mnt/f (beliebigen Namen habe ich durch f ersetzt) ist der Terminal gleich wieder auf die Anmeldung zurückgesprungen.
Wie josef-wien schon sagt: normales Verhalten. Bei Konsolenbefehlen ist es nicht selten so, daß "keine Meldung" ein gutes Zeichen ist, weil eine Meldung nur im Falle eines Fehlers erfolgt. Der Ordner wurde, wie Du schon gesehen hast, korrekt angelegt.
Weil ich nicht sicher war, ob das vielleicht doch richtig ist, habe ich mit dem nächsten Befehl weitergemacht (mount -t ntfs-3g /dev/sdb1 /mnt/f) und daraufhin kam eine ellenlange Hilfe-Meldung, welchen Befehl ich für was bräuchte, Verzeichnisbäume woanders einhängen und haste nicht gesehen..
Und hier kann es eigentlich nur ein Vertipper gewesen sein, dann kommt nämlich die von Dir genannte Hilfe-Nachricht. Die kannst Du z.B. mit "mount -h" anzeigen und beschreibt Dir den Mount-Befehl (schadet nichts, das mal zu lesen...) ;)
Probier's einfach nochmal. Das Verzeichnis brauchst Du nicht neu anlegen, das besteht ja nun. Einfach den Mount-Befehl nochmal (als root) korrekt eingeben.

Ansonsten gehe ich mit josef-wien konform, was die Verwendung der Geräte-ID als Kennung anbelangt. Ich wollte es für Dich nur nicht schwerer als nötig machen - solange Du keine weitere Platte einbaust, dürften die Bezeichnungen /dev/sda und /dev/sdb schon konstant bleiben, aber josef-wien hat freilich recht - lieber gleich richtig angewöhnen.

Was mir noch einfällt (unwahrscheinlich, aber theoretisch möglich): Ist ntfs-3g bei Dir am Ende gar nicht installiert? Was sagt (als root) "rpm -qa | grep ntfs"?

Gruß Greg

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 6. Nov 2009, 12:00

Hallo zusammen,

@Josef
Ohne diese Meldung werden wir aber nicht weiterkommen. Hast Du den Befehl als root ausgeführt?
Ja, als root ausgeführt. Dumm ist jetzt nur, dass ich die Meldung nicht notiert habe. Sie kommt jetzt natürlich auch nicht mehr, da der Ordner bereits erstellt wurde. Es war ein eher allgemein gehaltener Hilfetext, mit welchen Kurzzeichen (-l -a etc.) welche Funktion verknüpft ist - was ich aber natürlich nicht verstanden habe, weil immer noch zuwenig Hintergrundwissen.

Wegen der/des UUID kommt folgendes heraus
/sbin/udevadm info --export-db | egrep 'N: sd|S: disk' | egrep -v 'by-path|int13'
N: sda
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663
N: sda1
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663-part1
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663-part1
S: disk/by-uuid/72E06669E066340F
N: sda2
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663-part2
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663-part2
N: sda5
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663-part5
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663-part5
S: disk/by-uuid/62644131-61ee-469d-97a8-1e87d590b9fd
N: sda6
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663-part6
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663-part6
S: disk/by-uuid/1961fb7e-c548-455d-ad77-8bca7a508df5
N: sda7
S: disk/by-id/scsi-SATA_WDC_WD800BB-00CWD-WMA8E3057663-part7
S: disk/by-id/ata-WDC_WD800BB-00CAA1_WD-WMA8E3057663-part7
S: disk/by-uuid/d457090e-9f80-4b24-8892-44f414fb5d2a
N: sdb
S: disk/by-id/scsi-SATA_QUANTUM_FIREBAL194074130287
S: disk/by-id/ata-QUANTUM_FIREBALLP_AS40.0_194074130287
N: sdb1
S: disk/by-id/scsi-SATA_QUANTUM_FIREBAL194074130287-part1
S: disk/by-id/ata-QUANTUM_FIREBALLP_AS40.0_194074130287-part1
S: disk/by-uuid/481CC2D21CC2B9E8
S: disk/by-label/Schiwis
Und ich glaube, hier ist die letzte Position "S: disk/by-label/Schiwis" die gesuchte Platte. Wäre die UUID jetzt die Zeile darüber (481CC2D21CC2B9E8)?

Nach Ausführen des Befehls /sbin/blkid -L kam das hier heraus:
/sbin/blkid: invalid option -- 'L'
blkid 1.0.0 (12-Feb-2003)
usage: blkid [-c <file>] [-ghl] [-o format] [-s <tag>] [-t <token>]
[-v] [-w <file>] [dev ...]
-c cache file (default: /etc/blkid.tab, /dev/null = none)
-h print this usage message and exit
-g garbage collect the blkid cache
-s show specified tag(s) (default show all tags)
-t find device with a specific token (NAME=value pair)
-l lookup the the first device with arguments specified by -t
-v print version and exit
-w write cache to different file (/dev/null = no write)
dev specify device(s) to probe (default: all devices)
Das ist wieder so eine Hilfemeldung, oder nicht?
Diesen Ordner mußt Du auch irgendwann angelegt haben.
Und ich dachte, das wäre die SDB, also vielleicht diese zweite Platte. Den hab' ich aber bestimmt unbeabsichtigt angelegt. Ein richtiger Linux-Kenner schlägt sowieso die Hände über dem Kopf zusammen, wenn er mein Gestricke hier sieht...

@Greg:

Der Vertipper kann sein. Also neuer Versuch, der folgendes nach sich zieht:
mount -t ntfs-3g /dev/sdb1 /mnt/f
ntfs-3g-mount: mount failed: Das Gerät oder die Ressource ist belegt
???
Ist ntfs-3g bei Dir am Ende gar nicht installiert? Was sagt (als root) "rpm -qa | grep ntfs"?
Tja, das weiß ich nicht. Wikipedia spuckt aus, dass es sich um einen Treiber handelt, der es ermöglicht auf Windows-Partitionen zuzugreifen und auch zu schreiben. Bislang kann ich auf meine (1.)Windows-Platte zugreifen, aber nicht darauf schreiben. Der Befehl gibt folgendes
rpm -qa | grep ntfs
ntfsprogs-1.13.1-80.1
ntfs-3g-1.2506-5.1
ntfs-3g ist also installiert, interpretiere ich das richtig?

Wie macht Ihr übrigens diesen senkrechten Strich in Eure Befehle? Ich musste ihn jetzt woanders rauskopieren, weil ich ihn nicht auf der Tastatur finde.

Kann ich sonst noch irgendwas an Infos zum System beisteuern das Euch hilft anstatt dass ich nur blöde Fragen stelle?

Liebe Grüße, bilimbi

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von lOtz1009 » 6. Nov 2009, 12:07

bilimbi hat geschrieben:Wie macht Ihr übrigens diesen senkrechten Strich in Eure Befehle?
Liegt auf der Taste neben LShift. Bei <>. Aktivieren mit STRG+ALT+Taste oder ALTGr+Taste ;)
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 6. Nov 2009, 12:19

Hi bilimbi,

hoi-hoi, so viele Fragen... ;)

Mal der Reihe nach:

Die Frage nach dem senkrechten Strich hat lOtz schon beantwortet.

ntfs-3g ist installiert und damit die Voraussetzung für's Mounten gegeben.

Die Hilfemeldung kam auch nicht, was ich als Beleg dafür werte, daß Dein erster Versuch an einem Vertipper gescheitert ist.

Was mich jetzt am meisten interessiert: Hast Du den Mount-Befehl in korrekter Form mehr als einmal eingegeben? Also evtl. einmal, und als "keine Meldung" kam, nochmal? Und dann kam die von Dir geschriebene Meldung? Der Mount-Befehl ist noch so ein Kandidat für "keine Meldung = gute Nachrichten: alles ok".

Gib doch bitte mal ein einfaches "mount" (als root) ein und zeig mal, was dabei rauskommt.

Gruß Greg

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 6. Nov 2009, 13:13

Hallo,

@IOtz: herzlichen Dank!

@Greg:
Hast Du den Mount-Befehl in korrekter Form mehr als einmal eingegeben? Also evtl. einmal, und als "keine Meldung" kam, nochmal?
Also, ich hab's schon mehrfach versucht - gerade weil ich auch dachte, ich könnte mich vertippt haben. Aber was genau und vor allem wie oft - keine Ahnung. Zum Befehlt "mount" kommt das hier:

mount
/dev/sda6 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda7 on /home type ext3 (rw,acl,user_xattr)
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

Also da ist sdb nicht dabei, soweit ich das sehe - kann ja auch nicht, weil ich da was falsch mache.

Hilft Dir das weiter?

Grüße, bilimbi

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von lOtz1009 » 6. Nov 2009, 13:19

Du bist beim Mounten aber nicht irgendwo (Dateibrowser, Konsole) aktiv im Verzeichnis /mnt/f ?

Ansonsten mal in einem Terminal als root ausführen

Code: Alles auswählen

tail -f /var/log/messages
und dann führst du in einem zweiten Terminal den Mountbefehl aus. Vielleicht erscheinen dann im ersten Fenster ein paar Hinweise.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 6. Nov 2009, 13:25

Hi bilimbi,

so ganz kapier' ich nicht, warum Du Dir beim Mounten genau diese Fehlermeldung fängst. Ich kann diese Meldung erzeugen, wenn ich ein bereits eingebundenes Gerät nochmals versuche, auf dem gleichen Mountpunkt einzuhängen. Das scheint bei Dir aber nicht der Fall zu sein, wie Du korrekt sagst, ist /dev/sdb1 nicht gemountet.

Stell doch mal ein "umount /mnt/f" vorneweg. Kommt dann keine Meldung, wiederholst Du den Befehl "umount /mnt/f". Es sollte die Meldung kommen: "umount: /mnt/f/ ist nicht eingehängt". Ist das der Fall, mach' das gleiche auch mal mit "umount /dev/sdb1", ebenfalls bis die Meldung erscheint, es sei nicht eingehängt.

Anschließend nur einmal, und ganz korrekt (kannst es hier rauskopieren):

Code: Alles auswählen

mount -t ntfs-3g /dev/sdb1 /mnt/f
Und wenn dann eine Fehlermeldung kommt, genau diese hier posten. Nicht neu probieren!
Wenn dann keine Meldung kommt, nochmal "mount".

Gruß Greg

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 6. Nov 2009, 13:30

Hallo IOtz,
Du bist beim Mounten aber nicht irgendwo (Dateibrowser, Konsole) aktiv im Verzeichnis /mnt/f ?
Also nicht dass ich wüsste...

Es kommt das hier heraus:

tail -f /var/log/messages
Nov 6 13:06:41 linux-1ill pppd[3615]: Script /etc/ppp/ip-up finished (pid 3635), status = 0x0
Nov 6 13:06:41 linux-1ill gconfd (eltern-3758): (Version 2.22.0) wird gestartet, Prozesskennung 3758, Benutzer »eltern«
Nov 6 13:06:42 linux-1ill gconfd (eltern-3758): Die Adresse »xml:readonly:/etc/gconf/gconf.xml.mandatory« wurde an der Position 0 zu einer nur lesbaren Konfigurationsquelle aufgelöst
Nov 6 13:06:42 linux-1ill gconfd (eltern-3758): Die Adresse »xml:readwrite:/home/eltern/.gconf« wurde an der Position 1 zu einer schreibbaren Konfigurationsquelle aufgelöst
Nov 6 13:06:42 linux-1ill gconfd (eltern-3758): Die Adresse »xml:readonly:/etc/gconf/gconf.xml.defaults« wurde an der Position 2 zu einer nur lesbaren Konfigurationsquelle aufgelöst
Nov 6 13:06:42 linux-1ill gconfd (eltern-3758): Die Adresse »xml:readonly:/etc/gconf/gconf.xml.vendor« wurde an der Position 3 zu einer nur lesbaren Konfigurationsquelle aufgelöst
Nov 6 13:06:42 linux-1ill gconfd (eltern-3758): Die Adresse »xml:readonly:/etc/gconf/gconf.xml.schemas« wurde an der Position 4 zu einer nur lesbaren Konfigurationsquelle aufgelöst
Nov 6 13:06:46 linux-1ill poll.tcpip: no server configured
Nov 6 13:09:46 linux-1ill su: (to root) eltern on /dev/pts/1
Nov 6 13:23:46 linux-1ill su: (to root) eltern on /dev/pts/2
Nov 6 13:26:35 linux-1ill su: (to root) eltern on /dev/pts/3
Nov 6 13:26:51 linux-1ill ntfs-3g[3930]: Version 1.2506 integrated FUSE 27
Nov 6 13:26:51 linux-1ill ntfs-3g[3930]: Mounted /dev/sdb1 (Read-Write, label "Schiwis", NTFS 3.1)
Nov 6 13:26:51 linux-1ill ntfs-3g[3930]: Cmdline options: rw
Nov 6 13:26:51 linux-1ill ntfs-3g[3930]: Mount options: rw,silent,allow_other,nonempty,relatime,fsname=/dev/sdb1,blkdev,blksize=4096

und als ich in einem zweiten Terminalfenster den Mount-Befehl von Greg eingegeben habe, ist nichts passiert. Der Cursor ist nur wieder zur Anmeldezeile gesprungen. Ist das jetzt ein gutes Zeichen, weil kein Hilfetext kam?

Viele Grüße, bilimbi

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 6. Nov 2009, 13:31

Hi bilimbi,

doch klingt gut. Was sagt "mount" jetzt?

Gruß Greg

bilimbi
Newbie
Newbie
Beiträge: 39
Registriert: 10. Feb 2007, 23:10

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von bilimbi » 6. Nov 2009, 13:35

Hallo Greg,

Dein Posting hatte sich mit meinem Erguss überschnitten...

Ich habe das wie von Dir beschrieben ausprobiert und es hat auch genauso funktioniert, wie Du gesagt hast. Nach mount kommt jetzt

/dev/sda6 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda7 on /home type ext3 (rw,acl,user_xattr)
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb1 on /mnt/f type fuseblk (rw,allow_other,blksize=4096)

Sie ist jetzt gemountet, ja?

Muss ich noch was machen oder wie komm' ich dran an meine Daten? Bzw. da war ja auch noch was mit der fstab...

Viele Grüße, bilimbi

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von lOtz1009 » 6. Nov 2009, 13:38

Grundsätzlich kommst du an deine Daten nun im Verzeichnis /mnt/f
Soll der Datenträger bei jedem Systemstart eingebunden werden muss ein Eintrag in die fstab. Die Anleitung steht ja oben ;)
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: zusätzliche Festplatte wird nicht erkannt

Beitrag von G aus W » 6. Nov 2009, 13:38

Hallo bilimbi,

gratuliere, geschafft! Du kommst an Deine Daten. Einfach mit dem Programm Deiner Wahl auf /mnt/f zugreifen.

In die Datei /etc/fstab muß jetzt der Eintrag wie folgt: (bitte nicht abtippen - kopieren!)

Code: Alles auswählen

/disk/by-id/scsi-SATA_QUANTUM_FIREBAL194074130287-part1 /mnt/f     ntfs-3g     users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
[edit] ACHTUNG, OBIGER CODE IST FALSCH - ES FEHLT "/dev" AM ANFANG DER ZEILE.[/edit]

Nach einem Neustart ist das Verzeichnis dann sofort im Zugriff.

Gruß Greg

[edit] Verdammich, ich hab' eben im Eintrag für die fstab den fehlenden "/" vergessen. Der ist wichtig! Sorry... :ops:

Und ein PS: Kann ja sein, daß Du feststellst, daß /mnt/f gar nicht der Mountpunkt Deiner Wahl war. Angenommen, die zweite Platte enthält nichts als Fotos, und Du hättest sie gerne woanders im Zugriff, z.B. bei Deinen Dokumenten, die in Deinem Ordner "/home/eltern/Documents" liegen? Dann kannst Du z.B. einen entsprechenden Ordner anlegen ("mkdir /home/eltern/Documents/Fotos") und in der fstab statt "/mnt/f" an gleicher Stelle "/home/eltern/Documents/Fotos" schreiben. Du erkennst hier rasch einen großen Vorteil der Linux-Verzeichnisstruktur gegenüber dem starren "C:\", "D:\".
Zuletzt geändert von G aus W am 6. Nov 2009, 14:36, insgesamt 1-mal geändert.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Yahoo [Bot] und 3 Gäste