kann usb-platte nicht mounten

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

kann usb-platte nicht mounten

Beitrag von bitmeio101 » 10. Aug 2009, 10:09

guten morgen,

ich möchte gerne meine usb-festplatte mounten. es befindet sich eine xfs partition darauf. messages sagt beim anschließen der platte folgendes:

Code: Alles auswählen

Aug 10 09:49:09 Server kernel: usb 2-2: USB disconnect, address 2
Aug 10 09:49:09 Server kernel: usb 2-2.4: USB disconnect, address 4
Aug 10 09:49:22 Server kernel: usb 2-2: new high speed USB device using ehci_hcd and address 5
Aug 10 09:49:22 Server kernel: usb 2-2: new device found, idVendor=05e3, idProduct=0608
Aug 10 09:49:22 Server kernel: usb 2-2: new device strings: Mfr=0, Product=1, SerialNumber=0
Aug 10 09:49:22 Server kernel: usb 2-2: Product: USB2.0 Hub
Aug 10 09:49:22 Server kernel: usb 2-2: configuration #1 chosen from 1 choice
Aug 10 09:49:22 Server kernel: hub 2-2:1.0: USB hub found
Aug 10 09:49:22 Server kernel: hub 2-2:1.0: 4 ports detected
Aug 10 09:49:22 Server kernel: usb 2-2.4: new high speed USB device using ehci_hcd and address 6
Aug 10 09:49:22 Server kernel: usb 2-2.4: new device found, idVendor=05e3, idProduct=0723
Aug 10 09:49:22 Server kernel: usb 2-2.4: new device strings: Mfr=3, Product=4, SerialNumber=2
Aug 10 09:49:22 Server kernel: usb 2-2.4: Product: USB Storage
Aug 10 09:49:22 Server kernel: usb 2-2.4: Manufacturer: Generic
Aug 10 09:49:22 Server kernel: usb 2-2.4: SerialNumber: 000000009451
Aug 10 09:49:22 Server kernel: usb 2-2.4: configuration #1 chosen from 1 choice
Aug 10 09:49:22 Server kernel: scsi5 : SCSI emulation for USB Mass Storage devices
Aug 10 09:49:22 Server kernel: usb-storage: device found at 6
Aug 10 09:49:22 Server kernel: usb-storage: waiting for device to settle before scanning
Aug 10 09:49:23 Server kernel: scsi 5:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9451 PQ: 0 

ANSI: 0
Aug 10 09:49:23 Server kernel: sd 5:0:0:0: [sdd] Attached SCSI removable disk
Aug 10 09:49:23 Server kernel: sd 5:0:0:0: Attached scsi generic sg4 type 0
Aug 10 09:49:23 Server kernel: usb-storage: device scan complete
Aug 10 09:49:22 Server kernel: usb 2-2: new high speed USB device using ehci_hcd and address 5
Aug 10 09:49:22 Server kernel: usb 2-2: new device found, idVendor=05e3, idProduct=0608
Aug 10 09:49:22 Server kernel: usb 2-2: new device strings: Mfr=0, Product=1, SerialNumber=0
Aug 10 09:49:22 Server kernel: usb 2-2: Product: USB2.0 Hub
Aug 10 09:49:22 Server kernel: usb 2-2: configuration #1 chosen from 1 choice
Aug 10 09:49:22 Server kernel: hub 2-2:1.0: USB hub found
Aug 10 09:49:22 Server kernel: hub 2-2:1.0: 4 ports detected
Aug 10 09:49:22 Server kernel: usb 2-2.4: new high speed USB device using ehci_hcd and address 6
Aug 10 09:49:22 Server kernel: usb 2-2.4: new device found, idVendor=05e3, idProduct=0723
Aug 10 09:49:22 Server kernel: usb 2-2.4: new device strings: Mfr=3, Product=4, SerialNumber=2
Aug 10 09:49:22 Server kernel: usb 2-2.4: Product: USB Storage
Aug 10 09:49:22 Server kernel: usb 2-2.4: Manufacturer: Generic
Aug 10 09:49:22 Server kernel: usb 2-2.4: SerialNumber: 000000009451
Aug 10 09:49:22 Server kernel: usb 2-2.4: configuration #1 chosen from 1 choice
Aug 10 09:49:22 Server kernel: scsi5 : SCSI emulation for USB Mass Storage devices
Aug 10 09:49:22 Server kernel: usb-storage: device found at 6
Aug 10 09:49:22 Server kernel: usb-storage: waiting for device to settle before scanning
Aug 10 09:49:23 Server kernel: scsi 5:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9451 PQ: 0 

ANSI: 0
Aug 10 09:49:23 Server kernel: sd 5:0:0:0: [sdd] Attached SCSI removable disk
Aug 10 09:49:23 Server kernel: sd 5:0:0:0: Attached scsi generic sg4 type 0
Aug 10 09:49:23 Server kernel: usb-storage: device scan complete

wie kann ich die platte mounten? habe
mount -t xfs /dev/sdd /mnt/usb
eingeben, ohne erfolg. bekam die fehlermeldung "mount: medium not found". normal sollte auch immer eine nummer hinter stehen, für die partitionen. habe auch
mount -t xfs /dev/sg4 /mnt/usb
eingegeben, hat's auch nicht gebracht. da kam "mount: /dev/sg4 is not a block device". habe ich was falsch gemacht? bitte verurteilt mich nicht für meine mangelhaften linuxkenntnisse. bin da noch ziemlich grün hinter den ohren.

gruß sascha

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: kann usb-platte nicht mounten

Beitrag von lOtz1009 » 10. Aug 2009, 10:16

/sdd ist ja die Platte an sich. Mounten willst du ja sicherlich eine Partition darauf. /sdd1 z.B.
Was liefert denn

Code: Alles auswählen

fdisk -l
dazu?
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 10. Aug 2009, 14:19

habe 3 platten intern sda, sdb und sdc. von der usb-platte ist da nichts zu sehen

Code: Alles auswählen

Disk /dev/sda: 750.1 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x6069de5b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1045     8393931   82  Linux swap / Solaris
/dev/sda2            1046       20741   158208120   83  Linux
/dev/sda3           20742       91201   565969950   83  Linux

Disk /dev/sdb: 750.1 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8d4566cf

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       91201   732572001   83  Linux

Disk /dev/sdc: 750.1 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbbdd93cd

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1       91201   732572001   83  Linux

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7145
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: kann usb-platte nicht mounten

Beitrag von lOtz1009 » 10. Aug 2009, 14:22

Hängt die an nem Hub oder direkt am Rechner? Hat die ein separates Netzteil? Evtl. bekommt die über den Hub nicht genug Strom.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8749
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: kann usb-platte nicht mounten

Beitrag von admine » 10. Aug 2009, 14:28

Eigentlich sollte USB ja automatisch gemountet werden :roll:

Aber erkannt wird der Stick schon:

Code: Alles auswählen

Aug 10 09:49:23 Server kernel: sd 5:0:0:0: [sdd] Attached SCSI removable disk
Allerdings auch seltsam, dass da nix bei "fdisk -l" zu sehen ist.

Kannst du denn eine Partition von /dev/sdd mounten?

Code: Alles auswählen

mount -t xfs /dev/sdd1 /mnt/usb
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 10. Aug 2009, 14:42

nein, funktioniert auch nicht. bekomme dann folgende fehlermeldung:
mount: special device /dev/sdd1 does not exist

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 10. Aug 2009, 15:17

hardwaremäßig ist die auch definitiv in ordnung. läuft problemlos an, abgesehen davon wird sie ja schon erkannt, nur nicht gemountet. an anderen rechnern läuft die einwandfrei. andere platten werden in dem wechselrahmen ebensowenig gemountet.

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 24. Aug 2009, 07:11

schieb :)

towo
Moderator
Moderator
Beiträge: 3704
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: kann usb-platte nicht mounten

Beitrag von towo » 24. Aug 2009, 08:42

Wenn fdisk -l die Platte nicht sieht, gibt es nix zu Mounten, weder automatisch, nosch manuell!
Signatur nach Diktat spazieren gegangen

Bild

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 24. Aug 2009, 10:37

woran kann es denn sonst liegen?

josef-wien
Guru
Guru
Beiträge: 4899
Registriert: 23. Sep 2008, 17:09

Re: kann usb-platte nicht mounten

Beitrag von josef-wien » 24. Aug 2009, 22:21

bitmeio101 hat geschrieben:andere platten werden in dem wechselrahmen ebensowenig gemountet.
Und wenn genau da das Problem liegt? Hast Du die Platte schon einmal direkt an eine USB-Buchse angeschlossen?

Im übrigen scheint Deine Tastatur defekt zu sein, denn Großbuchstaben werden als Kleinbuchstaben ausgegeben.

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 25. Aug 2009, 07:25

Da die Platte in der messages zu sehen ist, gehe ich nicht davon aus, dass es an der Hardware liegt. Abgesehen davon kann ich den Rahmen ohne Probleme an Windows-Rechnern betreiben. Wie soll ich denn bitte eine SATA-Platte direkt an eine USB-Buchse anschließen? Wenn du den Rahmen meinst, der ist direkt an einen hinteren USB-Port angeschlossen. Habe auch schon andere ausprobiert.

Aber immerhin hast du mich auf das Tastatur-Problem hingewiesen. Das konnte ich sofort beheben. Soll ich dafür ein Howto posten?

Gruß Sascha

josef-wien
Guru
Guru
Beiträge: 4899
Registriert: 23. Sep 2008, 17:09

Re: kann usb-platte nicht mounten

Beitrag von josef-wien » 25. Aug 2009, 10:40

bitmeio101 hat geschrieben:Wie soll ich denn bitte eine SATA-Platte direkt an eine USB-Buchse anschließen?
Da waren meine Gedanken in einer falschen Richtung unterwegs. Hast Du andere USB-Datenträger, die funktionieren?

Zum Thema Windows: http://www.linux-club.de/viewtopic.php? ... =0#p644704

Eine mysteriöse Problemlösung: http://www.linux-club.de/viewtopic.php? ... 94#p640954
bitmeio101 hat geschrieben:Aug 10 09:49:22 Server kernel: usb-storage: waiting for device to settle before scanning
...
Aug 10 09:49:23 Server kernel: sd 5:0:0:0: [sdd] Attached SCSI removable disk
Bei Dir steht dazwischen nur eine einzige Zeile, bei mir sind es noch 11 weitere. Ich tippe auf ein Hardware-Problem.

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 25. Aug 2009, 11:31

Ich habe eben einen USB-Stick angeschlossen. Der wird problemlos erkannt und ich kann auch darauf zugreifen.

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: kann usb-platte nicht mounten

Beitrag von G aus W » 25. Aug 2009, 13:28

Hallo Bitmeio101,

was für eine Distribution bzw. welchen Kernel hast Du am Werkeln?

Ich hatte mal einen USB-Platten-Wechselrahmen, der wurde von älteren Kernels nicht erkannt. Ist schon 'ne Weile her, ich glaube SuSE 10.1 hat ihn nicht erkannt, ab 10.2 weiß ich nicht mehr, ab 10.3 ging's dann auf jeden Fall...

Oder (absurder Tip, aber ist mir schon passiert): Hast Du mal geschaut, ob die Platte auch wirklich "richtig" eingestöpselt ist? Bei mir hatte sich mal die Platte im Wechselrahmen gelöst und nicht mehr mit allen Pins Kontakt -> da ließ sich freilich auch nichts mehr mounten, und ich hab' schon gedacht, die Platte sei im Eimer, bis ich mal auf die Idee kam, einfach mal aufzuschrauben und zu prüfen...

Vielleicht hilft Dir einer der Tips. Ich wünsche viel Erfolg!

Gruß Greg

bitmeio101
Newbie
Newbie
Beiträge: 42
Registriert: 20. Apr 2009, 10:02

Re: kann usb-platte nicht mounten

Beitrag von bitmeio101 » 25. Aug 2009, 14:18

Es handelt sich hierbei um Suse Linux 10.3, Kernel 2.6.22.18-0.2

Wie gesagt, ich habe auch schon andere Platten in dem Rahmen gehabt, die unter Linux ebenso wenig liefen. Die Platte sitzt auch richtig in dem Rahmen drin.

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: kann usb-platte nicht mounten

Beitrag von G aus W » 25. Aug 2009, 16:01

Hallo Bitmeio101,

man könnte jetzt mal eine aktuelle Live-CD starten (z.B. OpenSUSE 11.1) und schauen, ob er unter dem neuen Kernel die Platte erkennt. Die Hardwareerkennung ist ja von Version zu Version moderner - kann sein, daß Dein Wechselrahmen von 10.3 einfach noch nicht unterstützt wird. Wenn Du es mit mehreren Platten versucht hast und keine erkannt wurde, und wenn weiterhin der gleiche Rahmen unter anderen Betriebssystemen funktioniert, ist ein Hardwaredefekt ja auszuschließen.

Gruß Greg

towo
Moderator
Moderator
Beiträge: 3704
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: kann usb-platte nicht mounten

Beitrag von towo » 25. Aug 2009, 17:18

Ich tippe da einfach mal auf incompatiblen USB2SATA Controller-chip in dem Gehäuse.
Signatur nach Diktat spazieren gegangen

Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste