Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Detailanzeige beim Bootvorgang

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
jadec5
Member
Member
Beiträge: 80
Registriert: 17. Nov 2006, 10:44
Wohnort: Wilhelmshaven

Detailanzeige beim Bootvorgang

Beitrag von jadec5 » 19. Jul 2009, 10:23

Das aktuelle openSUSE 11.1 System habe ich neu installiert. Beim Bootvorgang laufen die Detailinformationen des Bootvorgangs über den Bildschirm. Wie kann ich das abstellen?
Eintragungen:
Abschnittsname: openSUSE 11.1 - 2.6.27.23-0.1 (default)
Abschnittseinstellung: resume=/dev/disk/by-id/ata-SAMSUNG_HD161HJ_S0V3J9DQA21869-part8 splash=silent showopts
VGA-Nodus: blank (leer)

Hat einer eine Idee? Ich dachte immer splash=silent würde das bewirken. Die Eintragungen stammen von der Systeminstallation und sind nicht modifiziert worden.

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7160
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Detailanzeige beim Bootvorgang

Beitrag von lOtz1009 » 19. Jul 2009, 11:40

Nun, die splash-Option ist schonmal richtig. Trag mal einen passenden VGA-Modus ein. Für 1280x1024 wäre vga=794 oder vga=0x31a der richtige Wert. Mit

Code: Alles auswählen

hwinfo --framebuffer
kannst du dir die verfügbaren Werte anzeigen lassen, musst dann nur die 0 nach dem x weglassen. Wenn das nicht hilft, bitte noch

Code: Alles auswählen

grep "message" /boot/grub/menu.lst

Code: Alles auswählen

ls -la /boot/message
posten. Im Zweifelsfall auch die komplette /boot/grub/menu.lst
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

jadec5
Member
Member
Beiträge: 80
Registriert: 17. Nov 2006, 10:44
Wohnort: Wilhelmshaven

Re: Detailanzeige beim Bootvorgang

Beitrag von jadec5 » 19. Jul 2009, 16:56

Leider nicht das erwünschte Ergebnis. Die Schriftdarstellung ist zwar kleiner, aber nach wie vor werden die Daten angezeigt.
Hier kommt die menu.list:

# Modified by YaST2. Last modification on Mo Jul 20 16:38:05 CEST 2009
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,9)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.23-0.1 (default)
root (hd0,9)
kernel /boot/vmlinuz-2.6.27.23-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_HD161HJ_S0V3J9DQA21869-part10 resume=/dev/disk/by-id/ata-SAMSUNG_HD161HJ_S0V3J9DQA21869-part8 splash=silent showopts vga=0x368
initrd /boot/initrd-2.6.27.23-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 - 2.6.27.23-0.1
root (hd0,9)
kernel /boot/vmlinuz-2.6.27.23-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_HD161HJ_S0V3J9DQA21869-part10 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
initrd /boot/initrd-2.6.27.23-0.1-default

###Don't change this comment - YaST2 identifier: Original name: openSUSE 11.1 - 2.6.27.23-0.1 (64Bit) (/dev/sda13)###
title openSUSE 11.1 - 2.6.27.23-0.1 (64Bit) (/dev/sda13)
root (hd0,12)
configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1


jadec5
Member
Member
Beiträge: 80
Registriert: 17. Nov 2006, 10:44
Wohnort: Wilhelmshaven

Re: Detailanzeige beim Bootvorgang

Beitrag von jadec5 » 20. Jul 2009, 10:48

Alles so gemacht, wie im Link-Artikel geschrieben. Auf die Darstellung bzw. der Nichtdarstellung der Schrift hat das keine Auswirkung.
Mit VGA=0x0369 läuft die Schrift schön klein noch immer über den Bildschirm.
:???:

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7160
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Detailanzeige beim Bootvorgang

Beitrag von lOtz1009 » 20. Jul 2009, 10:53

Probier mal ob's mit nem 3-stelligen VGA= Wert besser funktioniert. http://www.linupedia.org/opensuse/Splas ... #vga-Werte

Kommt immer drauf an, welche Bildmaße im Bootsplash-Theme vorhanden sind.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Re: Detailanzeige beim Bootvorgang

Beitrag von K4m1K4tz3 » 20. Jul 2009, 11:00

Was für einen Monitor hast du denn?

Einen TFT? Was ist seine native Auflösung?

Was zeigt denn nun folgende Ausgabe?

Code: Alles auswählen

hwinfo --framebuffer
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

jadec5
Member
Member
Beiträge: 80
Registriert: 17. Nov 2006, 10:44
Wohnort: Wilhelmshaven

Re: Detailanzeige beim Bootvorgang

Beitrag von jadec5 » 20. Jul 2009, 11:29

Irgendwie scheint die VGA-Angabe das System nicht zur Unterdrückung der Darstellung zu bewegen zu sein.

Framebuffer, da stelle ich nur den Kopf der Ausgabe ein.

02: None 00.0: 11001 VESA Framebuffer
[Created at bios.463]
Unique ID: rdCR.CDg3T5ie+dA
Hardware Class: framebuffer
Model: "NVIDIA BIOS-P/N@N4219:0"
Vendor: "NVIDIA Corporation"
Device: "BIOS-P/N@N4219:0"
SubVendor: "NVIDIA"
SubDevice:
Revision: "GW-CLK@^&^&^&"
Memory Size: 14 MB

Es folgen jede Menge Werte! und dann als Abschluß:

Config Status: cfg=new, avail=yes, need=no, active=unknown

Als Monitor Samsung Syncmaster 206 BW, Grafikkarte NVIDIA 9400 Gainward.

K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Re: Detailanzeige beim Bootvorgang

Beitrag von K4m1K4tz3 » 20. Jul 2009, 11:40

jadec5 hat geschrieben:Es folgen jede Menge Werte!
Und gerade diese sind wichtig.

Dein Monitor hat eine native Auflösung von 1680 x 1050.

Bei der Ausgabe von hwinfo --framebuffer schaust du, ob diese Auflösung irgendwo steht und stellst diesen Mode in deiner menu.list ein. Sollte diese Auflösung von deiner Grafikkarte nicht unterstützt werden, dann wirst du wohl mit der Textansicht beim Booten leben müssen. Jedenfalls funktioniert bei mir auch nix anderes (jedenfalls nicht dass ich wüsste).
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7160
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: Detailanzeige beim Bootvorgang

Beitrag von lOtz1009 » 20. Jul 2009, 11:43

lOtz hat geschrieben:Probier mal ob's mit nem 3-stelligen VGA= Wert besser funktioniert. http://www.linupedia.org/opensuse/Splas ... #vga-Werte

Kommt immer drauf an, welche Bildmaße im Bootsplash-Theme vorhanden sind.
Dies probiert? Dann auch die initrd neu erstellen.
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

jadec5
Member
Member
Beiträge: 80
Registriert: 17. Nov 2006, 10:44
Wohnort: Wilhelmshaven

Re: Detailanzeige beim Bootvorgang

Beitrag von jadec5 » 20. Jul 2009, 12:08

Alles habe ich durchprobiert! VGA-Wert mit 0 und ohne 0 (0x0369 / 0x369) und Wert 795.

Nur zur Klarstellung:
Nach dem Rechnerstart laufen diese Werte durch, bis das grüne Hintergrundbild von Suse mit dem wachsenden weißen Fortschrittsbalken angezeigt wird. Nach dem Abschluß wird der Bildschirm dunkel und dann wird das Systembild angezeigt.

Es geht also um die Startphase mit den Informationen die das System erledigt (z.B. Hal Demon started).

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: Detailanzeige beim Bootvorgang

Beitrag von josef-wien » 20. Jul 2009, 12:47

Was 0x369 entspricht, weiß ich nicht, aber 795 hat eine Farbtiefe von 24 Bit. Lies meinen LINK noch einmal.

Antworten