Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Xsession: Login for xxxx is disabled?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Pinjo
Newbie
Newbie
Beiträge: 32
Registriert: 22. Mär 2007, 21:43
Wohnort: Braunschweig

[gelöst] Xsession: Login for xxxx is disabled?

Beitrag von Pinjo » 25. Jun 2009, 18:23

Hallo in die Runde.
Nachdem ich in Yast in der Rubrik Sicherheit und Benutzer eine Veränderung vorgenommen und diese nach einem Bootvorgang wieder zurückgenommen hatte, komme ich nicht mehr auf die graphische Oberfläche. Es erscheint stets die o. a. Meldung. Nach Eingabe das Passwortes werden erneut "Benutzernahme" sowie "Passwort" abgefragt. Folge: siehe o. a. Meldung.
Wie komme ich aus diesem "Hamsterrad" wieder heraus und insbesondere auf meine graph. Oberfläche.
Auch über die Konsole mit "sax2" oder "startx" bin ich nicht weiter gekommen.

(openSuse 11.1 und KDE 3.5.?)

Gruß Pinjo
Zuletzt geändert von Pinjo am 25. Jun 2009, 23:23, insgesamt 1-mal geändert.

Werbung:
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: Xsession: Login for xxxx is disabled?

Beitrag von josef-wien » 25. Jun 2009, 18:55

Wechsle zum (oder starte im) Runlevel 3 oder wechsle in eine der 6 Text-Konsolen, melde Dich als root an und führe yast aus.

P.S. Wenn Du schon herumprobieren willst (und ganz offensichtlich nicht weißt, was Du tust), dann lege einen eigenen Benutzer dafür an.

Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3160
Registriert: 25. Aug 2004, 02:13

Re: Xsession: Login for xxxx is disabled?

Beitrag von robi » 25. Jun 2009, 19:01

Währe jetzt allerdings durchaus hilfreich wenn du uns beschreiben könntest was du genau oder in etwas alles verändert hast. :???:
Wie oben josef-wien schon geschrieben hat, hilft eventuell erstmal einen neuen User anlegen. Wenn der sich dann auch nicht anmelden kann, müssen wir mal schauen was du derzeit für Einstellungen zusammengewürfelt hast.

Aber wenn du dich noch mit root auf einer Konsole anmelden kannst, kanns nicht ganz so tragisch sein. kannst du uns irgendwie die Ausgabe von

Code: Alles auswählen

cat /etc/passwd* /etc/shadow* | grep USER
hier ins Forum bringen. "USER" ist dabei der Username den du nutzt und der nicht mehr geht.
Wenn du keine Idee hast wie Ausgabe posten ohne Grafische Oberfläche gehen könnte, http://www.linupedia.org/opensuse/Hilfe ... ichts_geht

robi

Pinjo
Newbie
Newbie
Beiträge: 32
Registriert: 22. Mär 2007, 21:43
Wohnort: Braunschweig

Re: Xsession: Login for xxxx is disabled?

Beitrag von Pinjo » 25. Jun 2009, 21:24

Mit den Hinweisen von josef-wien bin ich zunächst nicht weiter gekommen, ausser dass ich auf der graphischen oberfläche von root gelandet bin. Einen eigenen Benutzer habe ich noch nicht angelegt. Mal sehen was robi zu den übermittelten Daten meint.
Hintergrund meines üblen Tuns war der Versuch, das cdrom-Laufwerk zu mounten, was nicht funktionierte. Gegoogelt und den Hinweis gefunden, dass unter Sicherheit und Benutzer die Gruppe um disk und cdron erweitert werden müsse. Getan und erneut gebootet - Fehlanzeige.
Folglich habe ich disk wieder entfernt, nochmal gebootet - und dann war`s passiert.
gruss Pinjo

Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3160
Registriert: 25. Aug 2004, 02:13

Re: Xsession: Login for xxxx is disabled?

Beitrag von robi » 25. Jun 2009, 21:49

Pinjo hat geschrieben: Mal sehen was robi zu den übermittelten Daten meint.
du hast deinem Benutzer asche das Login verboten, indem du ihm als Anmeldeshell /bin/false konfiguriert hast.
Ändere entweder als root mit einem Text-Editor die Datei /etc/passwd
und zwar die Zeile

Code: Alles auswählen

asche:x:1000:100:H. Asche:/home/asche:/bin/false
in

Code: Alles auswählen

asche:x:1000:100:H. Asche:/home/asche:/bin/bash
oder
du gibst als root folgenden Befehl ab

Code: Alles auswählen

usermod -s /bin/bash asche
oder nimm Yast dazu und setze unter Yast -> Benutzerverwaltung ->(User asche) -> Details -> Anmelde-Shell auf /bin/bash

Leider muss ich dir an dieser Stelle mitteilen das deine Passwörter für root und asche jetzt nicht mehr ganz sicher sind, da das verschlüsselte Passwort hier im Internet mit etwas Mühe geknackt werden könnte. Also entweder du änderst ganz schnell noch deine Beiträge und löscht die /etc/shadow hier raus oder du legst dir neue Passwörter zu, oder am besten Beides.
Pinjo hat geschrieben:
Hintergrund meines üblen Tuns war der Versuch, das cdrom-Laufwerk zu mounten, was nicht funktionierte. Gegoogelt und den Hinweis gefunden, dass unter Sicherheit und Benutzer die Gruppe um disk und cdron erweitert werden müsse. Getan und erneut gebootet - Fehlanzeige.
Folglich habe ich disk wieder entfernt, nochmal gebootet - und dann war`s passiert.
gruss Pinjo
Da kann man wieder mal sehen suchen ist schon richtig und wichtig aber du hättest wohl besser hier im Forum suchen sollen. ;) Die Gruppen der User wegen CD/DVD zu ändern war wohl irgendwann damals noch mit Suse 9.x oder noch länger her. Das ist mittlerweile etwas anders gelöst.

robi
Zuletzt geändert von robi am 25. Jun 2009, 21:57, insgesamt 1-mal geändert.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: Xsession: Login for xxxx is disabled?

Beitrag von josef-wien » 25. Jun 2009, 21:55

Ich wollte Dir keinen Weg zeigen, wie Du auf die grafische Oberfläche von root kommst. Ich wollte Dir zeigen, wie Du ohne grafische Oberfläche yast im Textmodus starten kannst.

Und bezüglich /bin/false brauche ich nicht mehr weiterzuschreiben, da war robi schneller.

Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3160
Registriert: 25. Aug 2004, 02:13

Re: Xsession: Login for xxxx is disabled?

Beitrag von robi » 25. Jun 2009, 22:11

Nochmal zu der Anmelde-Shell, das hast du wahrscheinlich nicht mal selbst verändert.
Da du aber die Gruppe disk dem User zugeteilt hast, hat das Yast wohl von sich aus aus Sicherheitsgründen gemacht, disk ist eine Systemgruppe erlaubt vollen Zugriff auf alle physikalischen und logischen "Block devices". Für solche User ist per Voreinstellung immer /bin/false vorgesehen.

robi

Pinjo
Newbie
Newbie
Beiträge: 32
Registriert: 22. Mär 2007, 21:43
Wohnort: Braunschweig

Re: Xsession: Login for xxxx is disabled?

Beitrag von Pinjo » 25. Jun 2009, 22:32

Hallo josef-wien, hallo robi,

für eure tatkräftige Unterstützung bei der Lösung meines Problems bedanke ich mich.
Es ist alles wieder im Lot!
Die von robi geäusserten Bedenken werde ich berücksichtigen.

Gruss Pinjo

Antworten