Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Installierte Kernelversion stimmt nicht bei uname

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: Installierte Kernelversion stimmt nicht mit uname -a überein

Beitrag von gropiuskalle » 25. Mai 2009, 11:44

geronimo62, wieso fühlst Du Dich angegriffen? Deine Paketzusammenstellung ist wirklich unrealistisch und vor allem widersinnig, das meine ich nicht persönlich, das ist wirklich mal ein Fakt.

Wie setzt man denn als Entwickler insgesamt fünf aktivierte Qt-Quellen ein? Wie kann man ein System, welches lt. Quellen als Mailserver fungiert, gleichzeitig zum debuggen von SuSE-Paketen verwenden? Und noch gleichzeitig als Spiele- und Multimediakiste und zum Virtualisieren? Weshalb sich Packman und Videolan beißen, kannst Du mal bei Packman selbst nachfragen, die können Dir sicher 'ne ganze Reihe von Beispielen liefern, weshalb es da schnell mal zu Inkompatibilitäten kommt. Und das ist ja nicht alles - sorry, aber 44 Quellen, die fast alle scharf geschaltet sind... kann ja sein, dass ich mich täusche und es ein Szenario gibt, innerhalb dessen das sinnvoll ist, aber mir sieht das noch einer extrem unbedachten Auswahl aus. Und ich benutze Linux / SuSE auch nicht erst seit letzter Woche. Worauf ich hinauswollte: Paketmanagement lässt sich nun mal nicht isoliert betrachten, das ist eine ganz essentielle Säule unter Linux. Das dürfte früher oder später noch an anderen Ecken gegen die Wand laufen.

Jedenfalls: das war keine Kritik, sondern eher ein verwundertes Kopfschütteln darüber, wie man mit so einer Quellenauswahl überhaupt den Anspruch hegen kann, ein funktionierendes und transparentes System fahren zu können (und ist diese Transparenz und Verlässlichkeit nicht gerade für eine Entwicklungsumgebung von besonderer Bedeutung?). Das war also durchaus konstruktiv gemeint, wie auch mein Hinweis auf die coreutils. Wenn das alles bei Dir ansonsten prima läuft, auch gut, dann will ich nichts gesagt haben.

Eventuell ist zur Problemeingrenzung auch noch die Ausgabe von

Code: Alles auswählen

zypper locks
interessant.
Zuletzt geändert von gropiuskalle am 25. Mai 2009, 12:12, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Installierte Kernelversion stimmt nicht mit uname -a überein

Beitrag von whois » 25. Mai 2009, 12:11

Hi

Um ehrlich zu sein ich habe das jetzt auch als einen konstruktiven Beitrag zur Problemlösung aufgefasst.
Du hast oder hattest wirklich einige Repos drin die bei uns in der LUG das System mehrfach zum abschmieren gebracht haben und das mit jeweils anderen Fehlerlogs die wir noch nicht ausgewertet haben.
Deshalb die Bitte lasst die Befindlichkeiten etwas beiseite und uns sehen das wir dieses Kuriosum behoben bekommen.
Problemlösungen dieser Art interessieren mich Grundsätzlich deshalb habe ich mich am Wochenende auch etwas mehr dahinter gekniet.
Auch wenn ich jetzt noch keine Lösung weiss....

cu

geronimo62
Newbie
Newbie
Beiträge: 11
Registriert: 21. Mai 2009, 10:41

Re: Installierte Kernelversion stimmt nicht mit uname -a überein

Beitrag von geronimo62 » 29. Mai 2009, 15:28

Also, wie vermutet, stand in YaST nichts drin.
Aber...

Es waren tatsächlich die coreutils, die zwar bereits installiert waren, aber nach einem

# sudo zypper in -f coreutils coreutils-lang

hat's dann tatsächlich - auch ohne Neustart - funktioniert.

Danke Leute, für die tolle Hilfe und der Thread kann als gelöst beendet werden.
Geronimo62

Linux - the better way to...

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Installierte Kernelversion stimmt nicht mit uname -a überein

Beitrag von whois » 29. Mai 2009, 15:35

geronimo62 hat geschrieben:Danke Leute, für die tolle Hilfe und der Thread kann als gelöst beendet werden.
Na Spitze, wieder was gelernt.

Danke für das Feedback.

Thread [gelöst] editieren kannst du selber machen.
http://www.linux-club.de/viewtopic.php?f=41&t=81378

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste