Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] rsync löscht dateien nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Mulambo
Newbie
Newbie
Beiträge: 42
Registriert: 12. Mär 2006, 14:17

[gelöst] rsync löscht dateien nicht

Beitrag von Mulambo » 8. Mär 2009, 17:42

Ich habe gestern ein Backup gemacht und dabei fiel mir auf, dass Grsync die gelöschten Dateien im Zielverzeichnis beibehält (trotz Häckchen bei der Option zum Löschen der Dateien). Ich habe die beiden Verzeichnisse nie verglichen, nur gestern ist's mir aufgefallen, als ich statt 400GB auf einmal 750GB hatte :???:

Die Optionen die ich angeklickt (und dann später auch in das Textfeld für erweiterte Optionen im Grsync gegeben habe) sind:

Code: Alles auswählen

-roptglH --progress --size-only --delete --force
Quelle: /home/
Ziel: /media/backup/
Anfangs hatte ich nur -roptg --progress --delete im Grsync. Da es mit Grsync dann nicht ging, hab ich es auch in der Konsole mit rsync (auch als root, da ich bei manchen Dateien einen permission Fehler bekam) versucht. Gleiches Ergebnis - er löscht keine Dateien.

Liegts vielleicht an den Optionen? Hab ich da etwas angegeben, was das verhindern könnte?
Ich hab auch daran gedacht, ob es vielleicht an der eingebundenen Festplatte liegen könnte, aber wenn er drauf schreibt, warum sollte er nicht auch löschen können :/

Ich weiß jetzt leider auch nicht, ob und wie es vor meinem Upgrade auf SUSE 11.1 funktionierte, da ich nie in den Ordner rein geguckt habe ... aber könnte es auch damit was zu tun haben?

- Alex
Zuletzt geändert von Mulambo am 9. Mär 2009, 07:20, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: rsync löscht dateien nicht

Beitrag von longman » 8. Mär 2009, 20:46

Versuch mal mit der Option --recursive oder mit --dirs (und ohne file masks/wildcards).

Laut man rsync deshalb:

--delete
You must have asked rsync to send the whole directory (e.g. “dir” or “dir/”) without using a wildcard for the directory's contents (e.g. “dir/*”) since the wildcard is expanded by the shell and rsync thus gets a request to transfer individual files, not the files' parent directory. Files that are excluded from the transfer are also excluded from being deleted unless you use the
Prior to rsync 2.6.7, this option would have no effect unless --recursive was enabled.
Beginning with 2.6.7, deletions will also occur when --dirs (-d) is enabled, but only for directories whose contents are being copied.
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

Mulambo
Newbie
Newbie
Beiträge: 42
Registriert: 12. Mär 2006, 14:17

Re: rsync löscht dateien nicht

Beitrag von Mulambo » 8. Mär 2009, 22:39

Danke schon mal... Wildcards hab ich aber eh nicht verwendet. Der rsync Befehl war:

Code: Alles auswählen

rsync -rtogplH --force --progress --delete --size-only /home/ /media/backup/
Ich glaube ich weiß mittlerweile, wo der Fehler lag:
Seit meinem Update von SUSE 11.0 auf 11.1 stimmen manche Dateinamen nicht mehr. Falls ich deswegen nen eigenen Thread aufmachen soll bitte Bescheid geben (und bitte auch wo - kA wo das genau hingehört).

Dateien mit Umlauten und Sonderzeichen werden falsch dargestellt (was ziemlich oft vorkommt bei deutschen Namen). Dolphin zeigt mir diese mit einer Raute mit Fragezeichen drinnen an, und die Konsole macht statt dessen nur Fragezeichen. Per Tab-Vervollständigung sehe ich dann den ASCII-Wert (irgendwo im Bereich \230 glaub ich jetzt).
Ich nehme mal an irgendwas von Windows noch... Kann das auch am Umstieg von Gnome auf KDE liegen. Vorher gings noch einwandfrei :???:

Im Dolphin selber kann ich damit nix mehr machen, aber ich weiß, dass ich sie mit mv umbenennen kann. Kennt irgendwer vielleicht ne Möglichkeit solche Dateien bzw. deren Namen auszufiltern? Die ganze Festplatte händisch durchsuchen wird wohl ewig dauern :D

Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: rsync löscht dateien nicht

Beitrag von longman » 8. Mär 2009, 23:41

Hier gibt es im Forum Konsole etliche Threads zum Thema "Ländercode, Zeichencodierung usw..."
Dort könntest Du mal nach Infos suchen, die Dein Umlauteproblem erklären.

Du kannst mit locale in einer Konsole die eingestellte Zeichencodierung anzeigen und
die Konsoleneinstellungen im Fenster ändern mit: -> Einstellungen -> Kodierung

Hier einige Threads zum Thema.

http://www.linux-club.de/viewtopic.php? ... f8#p521891

http://www.linux-club.de/viewtopic.php? ... hilit=utf8

http://www.linux-club.de/viewtopic.php? ... hilit=utf8
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

Mulambo
Newbie
Newbie
Beiträge: 42
Registriert: 12. Mär 2006, 14:17

Re: rsync löscht dateien nicht

Beitrag von Mulambo » 9. Mär 2009, 07:19

Hmm .. an die Zeichencodierung hab ich bis jetzt noch gar nicht gedacht :ops:

Ich setz das hier mal auf gelöst und geh dem mal nach...
Vielen Dank für die rasche Hilfe und das Suchen der Links!

lg Alex

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast