Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Probleme von XP und Linux 11.1 nach INSTALLATION

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
UliE
Newbie
Newbie
Beiträge: 5
Registriert: 26. Feb 2009, 17:02

Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von UliE » 26. Feb 2009, 17:12

Hallo zusammen,

ich bin neu in diesem Bereich LINUX. Ich wollte PARALLEL zu XP Suse 11.1 installieren. Habe ich auch erfolgreich geschafft. Nach dem ReBoot bekam ich dann den Error 15 und nach Stöbern im Internet habe ich auch viele tolle Anleitungen gefunden, nur leider keine, die mir helfen konnte... Ich habe über die Reparaturkonsole von XP dann den fixmbr gesetzt und stehe nun vor dem Problem ein tolles Linux installiert zu haben, jedoch nicht dranzukommen...

Ich habe auch gelesen, dass ich eine Datei (die für das Booten notwendig ist) von der Linux-Partition auf die Windows-Partition kopieren muss. Nun stellt sich das Problem: Darf von Linux nicht auf HDD C:\ schreiben und Änderungen durchführen. Auch die BOOT.INI darf ich als Win-Admin nicht verändern.

Wie komme ich also weiter, um endlich BEIDE Systeme alternativ starten zu können?

Ich danke für eure Hilfe und ggf. nette Anleitung WAS zu tun ist für einen ABSOLUTEN Neuling auf diesem Gebiet...

Einen Gruß von UliE

Werbung:
Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3892
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von Rainer Juhser » 26. Feb 2009, 22:33

Hier gibt es jede Menge nette Anleitungen zu dem Thema: http://wiki.linux-club.de/opensuse/Bootmanager
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von josef-wien » 26. Feb 2009, 22:41

UliE hat geschrieben:Nach dem ReBoot bekam ich dann den Error 15
Wann? Gleich nach dem Start und ohen Boot-Menü? Als Du im Boot-Menü openSUSE ausgewählt hast? Als Du im Boot-Menü Windows ausgewählt hast?
UliE hat geschrieben:Ich habe auch gelesen, dass ich eine Datei (die für das Booten notwendig ist) von der Linux-Partition auf die Windows-Partition kopieren muss.
Der bessere Weg ist Grub.

UliE
Newbie
Newbie
Beiträge: 5
Registriert: 26. Feb 2009, 17:02

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von UliE » 28. Feb 2009, 15:38

Hallo zusammen,

danke für die Hilfe, jedoch bin ich noch nicht weitergekommen...

@ Rainer: Die angegebenen Links hatte ich auch schon, konnte sie nur leider nicht umsetzen (kenne mich wohl nicht genug aus)...

@ Josef-Wien: Der Ladeprozess bleibt vor einem Bootmenü schon hängen (Error 15). Wenn man das Internet konsultiert, dann hat das wohl damit zutun, das SUSE die notwendigen Dateien auf die Linux-Partition speichert und nicht auf die C:\. Und den Transfer bekomme ich auch nicht hin, da ich von Linux nicht auf C:\ schreiben zugreifen darf (schauen und editieren ja, aber nicht speichern)... Da sitzt ein weiterer Hase begraben...

Danke für eure weiteren Ratschläge, was ich machen kann / muss...

UliE

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von Grothesk » 28. Feb 2009, 15:42

GRUB (vermutlich das, was du mit 'Linux' meinst) muss gar nichts auf C: schreiben.
Wo hast du den GRUB hin installieren lassen?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von josef-wien » 28. Feb 2009, 22:24

Es sollte sich zwar auch über die Reparatur des installierten Systems machen lassen (dabei Grub unbedingt in den MBR installieren), aber ich ziehe den direkten Weg vor: http://www.linux-club.de/viewtopic.php? ... 47#p612947

UliE
Newbie
Newbie
Beiträge: 5
Registriert: 26. Feb 2009, 17:02

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von UliE » 2. Mär 2009, 20:29

Hallo zusammen,

ich bin bei der Installation wie folgt vorgegangen:
- Linux downloaded
- Installation aus Windows heraus gestartet
- Komplette automatische Installation machen lassen. Keine Einstellungen vorgenommen. Wenn ich es richtig verstanden habe, dann ist GRUB automatisch von SUSE installiert worden. Aber leider bei mir nicht funktionabel.

Linux hat dann funktioniert. Jedoch beim erneuten Hochfahren ging es direkt in den ERROR 15 (ohne Bootmenü)...

Ich werde mich jetzt mal den Links von euch widmen und mich dann wieder melden. Hoffentlich verstehe ich SUPERGRUB CD Installation ;). Möchte nämlich auf jeden Fall XP parallel behalten...

Also bis denne und ein Danke an alle Helfer...

Gruß UliE

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von Grothesk » 2. Mär 2009, 20:45

- Installation aus Windows heraus gestartet
Quark.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von Tooltime » 2. Mär 2009, 23:51

Grothesk hat geschrieben:
- Installation aus Windows heraus gestartet
Quark.
Nicht unbedingt!
Da gibt es eine autorun.inf auf der DVD (habe hier gerade die von der ct) mit folgenden Inhalt:

Code: Alles auswählen

[autorun]
label = openSUSE 11.1
icon  =  susego.ico
open  =  openSUSE11_1_LOCAL.exe
Da die Installation nicht von Windows aus funktioniert, wird der Bootmechanismus manipuliert, so das nach einen automatischen Neustart von der DVD gebootet wird. Dummer Weise wird nach der Installation die Sache nicht immer rückgängig gemacht. Habe hier schon ein paar mal davon gelesen, das es schief ging.

Und nun die schlechte Nachricht, ich habe auch keine Ahnung wie man das wieder hin bekommt.

Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von Tooltime » 3. Mär 2009, 00:51

So habe gerade mal den Notstart getestet. Wenn ich das richtig verstanden habe, dein Rechner bootet jetzt wieder immer XP, wie es vor der Linux installation war?

Wenn dem so ist Versuch das System mal so anzuwerfen:
  • Installations-DVD einlegen und von DVD booten.
    Im Bootmenü "Installiertes System reparieren" auswählen.
    Wenn fertig geladen, "Expertenwerkzweuge" --> "Installiertes System neu starten"
Sollte die Fehlermeldung "kann root-Filesystem nicht finden" kommen, dann probiere mal so weiter:
  • Button "Abbrechen", dann kommt eine ziemlich lange Fehlermeldung, einfach auf "OK".
    Weiter mit "Installation starten" --> "Installiertes System starten"
    Dann die richtige Partition für das root-Filesystem auswählen und auf OK.
Wenn bei der Installation noch kein Kernelupdate aufgespielt wurde, sollte Linux sauber starten. Sollte diese Prozedur funktionieren, muss eigentlich nur der Bootmanager richtig installiert werden, damit Linux wieder aus eigener Kraft starten kann.

UliE
Newbie
Newbie
Beiträge: 5
Registriert: 26. Feb 2009, 17:02

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von UliE » 5. Mär 2009, 10:00

Hallo zusammen,

ich habe nun folgendes gemacht / gefunden:

1) Reparatur
* Habe das Reparturprogramm gestartet und den BootMger reparieren lassen. Hatte wohl auch einen Fehler. Dann ein Neustart und Poff: Gleiches Problem wie vorher. Mußte wieder den fixmbr von XP starten, damit ich Internet habe ;)

* Habe dann im Reparturprogramm die Autoreparatur laufen lassen. Hat eine Menge Fehler gefunden und repariert. Dabei auch immer wieder den BootMger. Als letztes dann nochmals den BootMger. Als ich dann einen Reboot starten wollte, kam nur noch eine rote Box: "Bei der Installation ist ein Fehler aufgetreten." Und schon war ich schon wieder bei dem gleichen Problem wie ganz am Anfang => fixmbr :???:


2) HDD Größe
Habe dann im Internet noch Informationen gefunden, dass Linux wohl Problem mit der Installation hat, wenn die HDD >= 160GB hat und sich weiter hinten rein-installiert (geht ja automatisch so). Aber es stand nicht dabei, was ich machen muss, wenn ich die C: und D: von XP vorne habe, sie funktionable halten möchte und wie und wo ich dann die sogenannte Bootpartition anlegen und was ich dort installieren muss, um dann Linux zum Laufen zu bekommen...

Es ist schon frustrierend! :???:

Möchte doch endlich LINUX mal kennenlernen und die Vorzüge ggü. XP ebenfalls... Aber so?

Ein verzweifelter UliE schickt einen Gruß

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von josef-wien » 5. Mär 2009, 12:10

UliE hat geschrieben:dass Linux wohl Problem mit der Installation hat, wenn die HDD >= 160GB hat
Das sehe ich nicht so. Ich habe den Verdacht, daß Dein BIOS mit so großen Platten nichts anfängt. Wie alt ist Dein PC bzw. dessen BIOS? Welche Festplattengröße zeigt Dein BIOS an?

Grub (stage1) ist im MBR installiert und greift über das BIOS auf einen bestimmten Sektor der Platte zu, auf der sich stage1_5 befindet (der "zweite Teil" von Grub, mit dem Grub in der Lage ist, ein bestimmtes Dateisystem zu erkennen und dadurch den "dritten Teil" und eigentlichen Bootmanager stage2 laden zu können).

Wenn mein Verdacht stimmt, daß dein BIOS Platten ab 137 GB nicht unterstützt, und wenn es kein BIOS-Update gibt, mußt Du im "vorderen Teil" der Platte eine eigene Boot-Partition einrichten (auf der dann das Verzeichnis /boot samt Inhalt gespeichert ist).

P.S.
UliE hat geschrieben:rote Box: "Bei der Installation ist ein Fehler aufgetreten."
Das ist ein harmloses Problem, das meistens beim Beenden bzw. Abbrechen der Reparaturfunktion auftritt.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von josef-wien » 5. Mär 2009, 22:55

So, ich habe ein bißchen gesucht und zitiere aus http://de.opensuse.org/Fehler:Grub#Begrenzungen:

Wenn LBA voll unterstützt wird, liegt die BIOS-Begrenzung immerhin bei 120GB. Festplatten die größer sind, müssen eine Erweiterung namens LBA48 unterstützen, um zugreifbar zu bleiben; falls auch das BIOS weiß, wie es damit umgehen soll (gehen Sie nicht davon aus), können die zum Booten benötigten Festplattenblöcke so hoch wie 2^32 Blöcke oder 2TB liegen. Dies ist das zur Zeit von Grub unterstützte Maximum. Abhängig von der aktuell genutzten Geometrie und den potentiell angewendeten BIOS-Zusätzen, können die im System vorhandenen Festplatten unterschiedliche Grenzen für Teile haben, die zum Booten genutzt werden können.

Rein gefühlsmäßig wird es wohl so sein, daß Du um eine Boot-Partition "im unteren Bereich" nicht herumkommen wirst. Besorge Dir von http://gparted.sourceforge.net/ die ISO-Datei und erzeuge eine CD daraus. Falls Du ein paar Tips zum Partitionieren brauchst, brauche ich die Ausgabe von fdisk -l (l = kleines L). Entweder es gelingt Dir, über die Reparaturfunktion/Expertenwerkzeuge das installierte System zu starten, dann öffnest Du eine Konsole, meldest Dich als root an und führst den Befehl aus. Oder aber Du mußt das Rettungssystem starten, Dich als root anmelden (hier ohne Paßwort), den Befehl ausführen und ohne Tippfehler abschreiben.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von josef-wien » 7. Mär 2009, 12:11

Wann es funktioniert (und wann nicht):

Nachdem es draußen stürmt und sehr stark regnet, habe ich einmal das Verzeichnis /boot auf eine logische Partition, die so bei 250 GB beginnt, kopiert, die Datei menu.lst entsprechend angepaßt, Grub installiert, den PC neu gestartet, und siehe da, es funktioniert mit dem Bootmanager aus der logischen Partition.

Da ich hier im Forum schon einige Beiträge betreffend fehlerhaftem Grub bei 11.1 gelesen habe, habe ich dann das Verzeichnis /boot von meiner 11.1-Testpartition kopiert, Grub installiert, den PC neu gestartet, und siehe da, es funktioniert nicht. Der PC hängt bei der Meldung "GRUB loading stage2...". Nachdem die Datei stage2 bei der Installation des Pakets "grub" nicht 1:1, sondern im binären Teil verändert nach /boot/grub kopiert wird, habe ich das Original von /usr/lib/grub kopiert, Grub installiert, den PC neu gestartet, und siehe da, es funktioniert wieder.

Offenbar ist openSUSE 11.1 die Veränderung der Datei stage2 etwas mißlungen, bei 11.0 wird die Datei zwar auch verändert, aber hier paßt es.

UliE
Newbie
Newbie
Beiträge: 5
Registriert: 26. Feb 2009, 17:02

Re: Probleme von XP und Linux 11.1 nach INSTALLATION

Beitrag von UliE » 25. Mär 2009, 21:14

Hallo zusammen,

danke für eure Hilfe soweit... Ich versinke nur gerade im Beruf und komme nicht mehr dazu euren Tipps alle nachzugehen...

Hinsichtlich BIOS Update: Das muss ich wohl irgendwie hinbekommen. Habe mir alles notwendige runtergeladen, aber es wird ein entsprechender Fehler gemeldet. Muss ersteinmal evaluieren, woran es liegt, dass ich momentan KEIN Update machen kann. Im BIOS werden übrigends "nur" 120GB statt 160GB angezeigt. Vermutung ist also von der Warte her richtig...


Also bis denne und einen Gruß allen Lesern und vor allem den Supportern!

UliE

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast