Kernelupdateproblem 2.6.7 / transaction log

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
thoklix
Newbie
Newbie
Beiträge: 3
Registriert: 27. Jun 2004, 12:01

Kernelupdateproblem 2.6.7 / transaction log

Beitrag von thoklix » 27. Jun 2004, 21:20

Hallo liebe Linuxgemeinde,
ich hoffe es kann mir geholfen werden.
Ich habe Suse 9.1 mit dem neuen Kernel 2.6.7 rpm von der Suse-Site upgedatet:
rpm --Uvh --force --nodeps xyz.rpm
mk_initrd
Danach habe ich neu gebootet und der Rechner bleibt in
der Bootsequenz stehen, er checkt angeblich das transaction log (warum eigentlich?) für meine HD (hda3), allerdings bleibt der Rechner stehen (HD blinkt weiter).
dmesg gibt kurz vorher noch an, nicht die /etc/mtab zu finden, die ist aber da.
Das Kernelmodul für ReiserFS ist vorhanden und geladen (gibt auch das mk_initrd aus). Auch über Knoppix ist hda3 ansprechbar.
Blöderweise habe ich upgedatet und den neuen Kernel nicht parallel instaliert,
kann also nicht mehr booten.
Kann ich das ganze noch retten oder muss ich neu installieren, und vorher Daten über Knoppix sichern?
Was habe ich denn falsch gemacht?
Gruss thoklix

Werbung:
Gast

Beitrag von Gast » 28. Jun 2004, 09:12

Probier mal über Knoppix zu booten, die Rootpartition (hda3) mit Schreibzugriff zu mounten, dann ein chroot auf die gemountete Partition machen und das rpm-Paket des alten Kernel installieren (mit rpm oder yast).

tux486
Member
Member
Beiträge: 149
Registriert: 3. Nov 2003, 13:29

Beitrag von tux486 » 28. Jun 2004, 09:30

Transaction-Log

Könnte es sein, daß Du reiserfs (oder ein anderes spezielles Dateisystem, für das ein Filesystem-Treiber (fs) benötigt wird) verwendest und der neue Kernel ohne dieses entsprechende Modul starten will? Dann findet er einiges nicht...
Oder ein Treiber für den Festplatten-Controller wird nicht als Modul geladen...

Irgendwas fehlt, was der alte Kernel "kannte".
Möglicherweise wurde das anzugebende Modul bei mk-initrd "versiebt", das ging mir mit dem aha1542 Modul auch so.
Bis denn
Sven

thoklix
Newbie
Newbie
Beiträge: 3
Registriert: 27. Jun 2004, 12:01

Danke

Beitrag von thoklix » 28. Jun 2004, 12:29

Hallo abisko 00
Werde ich später mal ausprobieren.
Gruss thoklix

thoklix
Newbie
Newbie
Beiträge: 3
Registriert: 27. Jun 2004, 12:01

Beitrag von thoklix » 28. Jun 2004, 12:33

Hallo tux486,
er sagt mir aber in dmesg, dass er das reiserfs modul geladen hat.
Was hast Du denn bei Deiner aha1542 gemacht?
Gruss thoklix

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste