Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Nach Grub-Menu nur Konsolen-Textanzeige

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

[gelöst] Nach Grub-Menu nur Konsolen-Textanzeige

Beitrag von transwarp » 19. Jan 2009, 16:28

Hallo.

Mich nervt eine Kleinigkeit, die ich gerne abstellen möchte.
Nach einer Neuinstallation funktioniert soweit wieder alles. Wenn ich im grafischen Grub-Menü jedoch mein Linux auswähle, bekomme ich nun nicht mehr den Splash-Screen von openSUSE 11.1, sondern gleich die Ausgaben der Textkonsole, die über den Bildschrm laufen, also so, als wenn ich 'ESC' gedrückt hätte.

Frage:
Kann man das irgendwie wieder auf die normale Anzeige zurücksetzen? Als Kernel-Parameter im Grub habe ich lediglich die Konsolenauflösung "vga=0x31a" stehen.

Danke für jeden Hinweis.
Zuletzt geändert von transwarp am 20. Jan 2009, 21:57, insgesamt 1-mal geändert.
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Werbung:
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Nach Grub-Menu nur Konsolen-Textanzeige

Beitrag von admine » 19. Jan 2009, 17:20

Suche in deiner /boot/grub/menu.lst im Linux-Eintrag nach "splash".
Vermutl. steht bei dir:

Code: Alles auswählen

spalsh=verbose
mach daraus:

Code: Alles auswählen

splash=silent
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Nach Grub-Menu nur Konsolen-Textanzeige

Beitrag von transwarp » 20. Jan 2009, 16:47

Tja, ich hatte gedacht das es so einfach wäre.
Leider sehe ich jetzt, das in der 'menu.lst' leider bereits der Kernel-Parameter 'splash=silent' gesetzt ist.

Bevor jetzt Fragen auftauchen: Ja, ich wähle den richtigen Modus beim Booten aus.
Aber sicherheitshalber hier meine 'menu.lst':

Code: Alles auswählen

# Modified by YaST2. Last modification on Sa Jan 17 12:07:47 UTC 2009
default 0
timeout 5
##YaST - generic_mbr
gfxmenu (hd0,7)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.7-9
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJDWQC00089-part8 resume=/dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJDWQC00089-part7 splash=silent showopts vga=0x31a
    initrd /boot/initrd-2.6.27.7-9-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJDWQC00089-part8 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.27.7-9-pae

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Diskette
    rootnoverify (hd0,0)
    chainloader +1
Ich denke da ist nicht viel falsch zu machen, oder?
Um so verwunderlicher, das ich den eigentlichen Splashscreen beim Booten nicht bekomme.

Vielleicht noch 'ne Idee woran's hapert?
Hab erst daran gedacht, das mir die Splash-Screen-Grafik vielleicht durch irgendeinen dummen Zufall abhanden gekommen ist, aber die kommt wenn ich an die normale Anmeldung komme und mich autentifiziert habe. Danach geht's grafisch weiter. :???:
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Nach Grub-Menu nur Konsolen-Textanzeige

Beitrag von admine » 20. Jan 2009, 17:09

Und es gibt die /boot/message?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 295
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Nach Grub-Menu nur Konsolen-Textanzeige

Beitrag von transwarp » 20. Jan 2009, 21:56

Die /boot/message existiert definitiv und ist auch o.k.

Allerdings bekam ich jetzt nach genauerer Analyse die Meldung:

bootsplash 3.1.6-2004/03/31: locking for picture ...
bootsplash: ... no good signature found.

Nach einigem googlen finde ich so manchen Eintrag mit diesem Problem. Kann sein, das er Probleme mit einer der Grafikauflösungen für das Bootimage hat.

Ein

Code: Alles auswählen

mkinitrd
als root-user hat mein Problem dann behoben.

Ich hatte zuvor das lästige Weihnachts-Theme aus der Datei 'gfxboot.cfg' rausgenommen und die Datei /boot/message neu erzeugt.
Wahrscheinlich war ein 'mkinitrd' notwendig, um den neuen Eintrag auch mit in die Initial Ramdisk zu übernehmen.
openSUSE Tumbleweed | Kernel 4.14.2-desktop x86_64 | Plasma 5.11 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast