Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

KIWI-LTSP(5): kein KernelImage

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
juergen&lx
Newbie
Newbie
Beiträge: 45
Registriert: 17. Dez 2007, 20:15

KIWI-LTSP(5): kein KernelImage

Beitrag von juergen&lx » 17. Jan 2009, 23:00

Beim Start eines Clients über PXE bleibt das System hier hängen:
-----> Checking for config file: config.00:30:48:29:0b:62(natürlich mit meiner MAC-Adresse)
-----> Checking for config file: config.C0A80038
-----> Checking for config file: config.C0A8003
-----> Checking for config file: config.C0A800
-----> Checking for config file: config.C0A80
-----> Checking for config file: config.C0A8
-----> Checking for config file: config.C0A
-----> Checking for config file: config.C0
-----> Checking for config file: config.C
-----> Checking for config file: config.default
-----> Including required kernel modules...
-----> Probing module: serverworks
-----> Probing module: aic7xxx
-----> Probing module: ohci-hcd
-----> Mounting NBD root system: 192.168.0.1 2000 [/dev/nbd0]...
Negotiation: ..size = 138484KB
-----> Filesystem of remote root system is: squashfs
-----> Can't find rootfs tarball
-----> Failed to mount root filesystem
-----> rebootExeption: error consoles at Alt-F3/F4
-----> rebootExeption: reboot in 120 sec...

Code: Alles auswählen

kiwi-ltsp-setup -c
ausgeführt.

Pakete:

Code: Alles auswählen

linux2:/ # rpm -qa | grep kiwi
kiwi-desc-netboot-3.05-2.1
kiwi-3.05-2.1
kiwi-ltsp-bootimages-0.5.0-1.1
kiwi-tools-3.05-2.1
kiwi-desc-ltsp-0.5.0-2.1
kiwi-pxeboot-3.05-2.1
kiwi-ltsp-prebuilt-0.5.0-3.1

linux2:/ # rpm -qa | grep ltsp
ltsp-server-5.1.24_080912-4.1
easy-ltsp-0.5_081006-4.1
kiwi-ltsp-bootimages-0.5.0-1.1
kiwi-desc-ltsp-0.5.0-2.1
ltspfs-0.5.4_080912-4.1
kiwi-ltsp-prebuilt-0.5.0-3.1

Code: Alles auswählen

linux2:/ # cat /etc/sysconfig/kiwi-ltsp
## Path: System/Kiwi-ltsp
## Description: kiwi-ltsp setup - Part of KIWI-LTSP as created by CyberOrg
# Copyright (c) 2007 Cyberorg
# This program is free software; you can redistribute it and/or modify it under
# the terms of the GNU General Public License as published by the Free Software
# Foundation; either version 2 of the License, or (at your option) any later
# version.
#
# This program is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
# FOR A PARTICULAR PURPOSE.  See the GNU General Public License for more
# details.
#
# You should have received a copy of the GNU General Public License along with
# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
# Place, Suite 330, Boston, MA 02111-1307 USA
#
# Authors: Cyberorg Cyberorg <cyberorg@cyberorg.info>
#          Magnus Boman <captain.magnus@gmail.com>
#
# Version       Date            Changes
# 0.1.1         2007-08-25      Initial release
# 0.1.2         2007-08-27      Added {SUSE,LTSP}_INSTALL_SOURCE
# 0.1.2         2007-09-05      Image type and nfs chroot paths
# 0.1.3         2007-09-09      Added DHCP_IFACE
# 0.1.4         2007-09-11      Move it to /etc/sysconfig
# 0.1.5         2007-09-24      Added LTSSQUASHPATH="/srv/kiwi-ltsp"
# 0.1.6         2007-11-04      Auto detect server IP address based on specified DHCP interface

## Type:        integer(0:1)
## Default:     0
#Set LTSP_DEBUG "0" logs to file and "1" to log KIWI activity to screen instead of log file
LTSP_DEBUG="1"

## Type:        list(NFS,NBD)
## Default:     NBD
#Set the image type, NFS and NBD supported, NBD is default
IMAGETYPE="NBD"

## Type:        string
## Default:     /mnt/10.3
#Set the installation source path or URL
SUSE_INSTALL_SOURCE="/mnt/10.3"

## Type:        string(yast2,rpm-dir)
## Default:     yast2
#Set the installation source type
SUSE_INSTALL_SOURCE_TYPE="yast2"

## Type:        list(10.3,11.0)
## Default:     11.0
#Set the openSUSE version to use for creating image
SUSE_VERSION="10.3"

## Type:        string
## Default:     10.0.0.50 10.0.0.100
#Range of IP addresses to be used for DHCP setup
DHCP_RANGE="192.168.0.50 192.168.0.100"

## Type:        string
## Default:     10.0.0.0
#Subnet to be used for DHCP setup
DHCP_SUBNET="192.168.0.0"

## Type:        string
## Default:     255.255.255.0
#Netmask to be used for DHCP setup
DHCP_NETMASK="255.255.255.0"

## Type:        string(eth0,eth1,eth2,ANY)
## Default:     ANY
#DHCP Interface connected to ltsp network
DHCP_IFACE="eth1"

## Type:        string
## Default:     10.0.0.254
#Set the IP address of this server that would be accessed by ltsp clients
SERVER_IP="192.168.0.2"

## Type:        string
## Default:     digitalairlines.com
#your domainname for DHCP setup
DOMAIN="llix.de"

## Type:        string
## Default:     $SERVER_IP
#DNS server to be used for DHCP setup
NAME_SERVERS="$SERVER_IP"

## Type:        string
## Default:     $SERVER_IP
#Gateway IP to be used for DHCP setup
GATEWAY="$SERVER_IP"

## Type:        string
## Default:     $SERVER_IP
#TFTP server IP for PXE boot, this is the server where the netboot image is stored
#This is usually same as server IP, do not change this if you don't know what it is.
TFTP_SERVER="$SERVER_IP"

## Type:        string
## Default:     /usr/share/kiwi/image/ltsp/suse-$SUSE_VERSION
#Please do not change this, unless you know what you are doing
KIWIPATH="/usr/share/kiwi/image/ltsp/suse-$SUSE_VERSION"

## Type:        string
## Default:     /srv/kiwi-ltsp
#Please do not change this, unless you know what you are doing
DESTPATH="/srv/kiwi-ltsp"

## Type:        string
## Default:     /srv/tftpboot
#Please do not change this, unless you know what you are doing
TFTPBOOTPATH="/srv/tftpboot"

## Type:        string
## Default:     /tmp/kiwi-netboot
#Please do not change this, unless you know what you are doing
TMPPATH="/tmp/kiwi-netboot"

## Type:        string
## Default:     /srv/kiwi-ltsp
#Please do not change this, unless you know what you are doing
LTSSQUASHPATH="/srv/kiwi-ltsp"

## Type:        string
## Default:     $LTSSQUASHPATH-nfs
#Please do not change this, unless you know what you are doing
LTSNFSPATH="$LTSSQUASHPATH-nfs"

## Type:        string
## Default:     /usr/share/kiwi/image/netboot/suse-$SUSE_VERSION
#Please do not change this, unless you know what you are doing
KIWINBPATH="/usr/share/kiwi/image/netboot/suse-$SUSE_VERSION"
Kann mir jemand sagen was hier noch fehlt?
OS aktuell: Linux 2.6.27.29-0.1-pae i686
AMD Sempron 3400+, 2000Mhz
Mobo K8M890CE. Nvidia GeForce 9400 GT mit 3D

Werbung:
juergen&lx
Newbie
Newbie
Beiträge: 45
Registriert: 17. Dez 2007, 20:15

Re: KIWI-LTSP(5): kein KernelImage

Beitrag von juergen&lx » 18. Jan 2009, 13:22

ich habe nach der KIWI.pdf festgestellt, dass kein Verzeichnis mit den Beispieldateien /usr/share/doc/packages/kiwi/examples angelegt wurde.
Fehlt dazu noch ein Paket :???:
Ferner wurde "NUR" das tftp-Paket installiert. In der Doku wird aber vom atftp-Paket geschrieben. Das wirft aber wieder Abhängigkeitsprobleme mit easy-kiwi auf den Tisch.
Im Moment blick ich nichts :zensur:
Jürgen
OS aktuell: Linux 2.6.27.29-0.1-pae i686
AMD Sempron 3400+, 2000Mhz
Mobo K8M890CE. Nvidia GeForce 9400 GT mit 3D

juergen&lx
Newbie
Newbie
Beiträge: 45
Registriert: 17. Dez 2007, 20:15

Re: KIWI-LTSP(5): kein KernelImage

Beitrag von juergen&lx » 19. Jan 2009, 19:13

So, zu oben genannter Fehlermeldung fand ich folgenden Link: https://bugzilla.novell.com/show_bug.cgi?id=379116#c1
Aber so richtig kann ich nichts damit anfangen

Ich hoffe, man kann es mir erklären
Jürgen
OS aktuell: Linux 2.6.27.29-0.1-pae i686
AMD Sempron 3400+, 2000Mhz
Mobo K8M890CE. Nvidia GeForce 9400 GT mit 3D

einneuer
Newbie
Newbie
Beiträge: 30
Registriert: 8. Jun 2005, 21:22

Re: KIWI-LTSP(5): kein KernelImage

Beitrag von einneuer » 12. Nov 2009, 00:34

Bist Du mit deinem Problem weiter gekommen?
Habe die gleiche Meldung.

Kann jemand weiter helfen?
Gruß
der Neue

juergen&lx
Newbie
Newbie
Beiträge: 45
Registriert: 17. Dez 2007, 20:15

Re: KIWI-LTSP(5): kein KernelImage

Beitrag von juergen&lx » 12. Nov 2009, 21:54

Bist Du mit deinem Problem weiter gekommen?
NEIN :irre:

Die Doku war damals nicht sehr hilfreich. Habe dann "nur" LTSP(4.2) installiert und das funktionierte.

Allerdings ist hier im Forum LTSP(5) wohl auch nicht sehr bekannt. Schade

Bin jetzt mit zu RH gewechselt (ist auch nicht das "gelbe vom Ei"). Mit LTSP(4.2) läuft einwandfrei.

Goog luck
Jürgen
OS aktuell: Linux 2.6.27.29-0.1-pae i686
AMD Sempron 3400+, 2000Mhz
Mobo K8M890CE. Nvidia GeForce 9400 GT mit 3D

einneuer
Newbie
Newbie
Beiträge: 30
Registriert: 8. Jun 2005, 21:22

[gelöst]Re: KIWI-LTSP(5): kein KernelImage

Beitrag von einneuer » 29. Nov 2009, 18:11

Bin auch gerade dabei auf Ubuntu umzusteigen, habe aber immer noch Suse laufen.

Was das Froum angeht stimme ich zu, aber ich habe den Eindruck die Doku ist besser geworden, bin sehr oft mit der Hilfe von http://en.opensuse.org/LTSP weiter gekommen.

Nach deinem feedback bin dann einfach nochmals den Anweisungen von http://en.opensuse.org/LTSP/Configuration#Configuration gefolgt und dann

Code: Alles auswählen

kiwi-ltsp-setup -c
ausgeführt.
Client hat ge-booted musste dann nur noch mein DCHPD.conf wieder anpassen. Deshalb mein vorschlag dies datei vorher sichern.

System läuft jetzt wieder, bin auch gerade dabei meine "Umstellung" auf Ubuntu zu überdenken, Suse ist doch nicht so schlecht, kenne es halt ganz gut.

Gruß
der neue

spoensche
Moderator
Moderator
Beiträge: 7393
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: KIWI-LTSP(5): kein KernelImage

Beitrag von spoensche » 29. Nov 2009, 19:53

Du hast bei dem über das Netzwerk zu bootenden Kernel einen Fehler. Das rootfs hat das Dateisystem SquashFS (Ein read-only Filesystem). Er versucht aber einen rootfs.tar (tarball) zu mounten. Ein gz komprimiertes root Filesystem kannst du nur als initrd oder initramfs verwenden. Ein SquashFS ist bereits komprimiert.

Wie sieht deine default.cfg aus?
juergen&lx hat geschrieben:In der Doku wird aber vom atftp-Paket geschrieben. Das wirft aber wieder Abhängigkeitsprobleme mit easy-kiwi auf den Tisch.
Das atftp paket ist definitiv nicht von easy-kiwi abhängig. Ich verwende den atftp und bei mir ist kein easy-kiwi installiert.

Poste mal bitte die Ausgabe, wenn du mit

Code: Alles auswählen

zypper in atftp
den aftp installierst.

Antworten