Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Laptop schaltet nach runterfahren nicht mehr ab!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
bier200
Member
Member
Beiträge: 83
Registriert: 5. Dez 2005, 21:09

Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von bier200 » 14. Jan 2009, 22:29

Hallo Linux Gemeinde, hab auf einem Medion Notebook MD98100 OpenSuse11.1 installiert und hab das Problem, dass ich das Ding immer noch manuell ausschalten muß, hab sämtliche Foren schon gelesen und irgendwie hat nichts funktioniert! Die letzten Meldungen sind "Sending all processes the term signal....", Sending all processes the kill signal..." und dann kommt noch "The system will be halted immediately." Dann bleibt er stehen!
Kann mir jemand weiterhelfen
Danke
MfG Christian

Werbung:
Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von longman » 14. Jan 2009, 23:17

moin,

eventuell hast Du bzw. Dein NB ein Problem mit ACPI (APIC).
Am besten prüfst Du zuerst mal die Einstellungen in Deinem BIOS . (ACPI=on)

Du könntest in der grub Bootmenü Eingabezeile mal mit verschiedenen Parameterkombination versuchen.

Schau z.B. mal hier:
http://www.linux-club.de/viewtopic.php?f=27&t=91927
http://de.opensuse.org/Spezial:Search?s ... y=0&go=Los
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

bier200
Member
Member
Beiträge: 83
Registriert: 5. Dez 2005, 21:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von bier200 » 15. Jan 2009, 17:11

Hallo, das Problem ist, dass ich BIOS einen solchen Parameter nicht find, ich denk, dass das Standartmäßig irgendwie hinterlegt ist!?

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von admine » 15. Jan 2009, 17:33

Das Problem hatte ich auf einem PC.
Teste mal die Bootoption "acpi=off".
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

bier200
Member
Member
Beiträge: 83
Registriert: 5. Dez 2005, 21:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von bier200 » 15. Jan 2009, 22:25

Das hab ich auch schon probiert, aber irgendwie funktioniert das auch nicht! Ich weiß auch nicht mehr weiter, hab 11.1 auf meinem Fujitsu Siemens Notebook am laufen und kenn solche probleme nicht :-)
Christin

Benutzeravatar
stoker232
Member
Member
Beiträge: 82
Registriert: 3. Sep 2008, 21:39
Wohnort: nicht da wo ich will

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von stoker232 » 16. Jan 2009, 00:30

Hi,
hast du schon mal hier geschaut ist auch ein MD98100
http://www.linux-club.de/viewtopic.php?t=81198

ansonsten Poste doch mal bitte die menu.lst
su
passwort
cat /boot/grub/menu.lst
in einer Konsole eingeben.

msg andi

für einen Moderator ist das nicht ein Thema für Klappdeckel? Wenn ja bitte verschieben.
Suse11,2, Lenovo 3000 N200 TY2BGGE 250GB, 3GB Ram
Suse11.3, Lenovo S10-3, 250GB, 2GB Ram
Suse12.1, 3.1.0-01.2-desktopx86_64, KDE 4.7.2"rel.5"
Gk: GeForce 8800 GTS 512MB
MB: Asrock M3N78D
Cpu: AMD iiX6 1090T 3,2GHz
Ram:16GB

Nihil fit sine causa!

bier200
Member
Member
Beiträge: 83
Registriert: 5. Dez 2005, 21:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von bier200 » 18. Jan 2009, 15:46

Hallo Andi,
hier die menu.lst
# Modified by YaST2. Last modification on Mo Jan 19 15:08:14 CET 2009
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.7-9
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-SAMSUNG_HM160HI_S10UJD0QA71718-part2 resume=/dev/disk/by-id/ata-SAMSUNG_HM160HI_S10UJD0QA71718-part1 splash=silent showopts acpi=force apm=power-off vga=0x317
initrd /boot/initrd-2.6.27.7-9-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-SAMSUNG_HM160HI_S10UJD0QA71718-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe powersaved=off nohz=off vga=0x317
initrd /boot/initrd-2.6.27.7-9-pae

Hab eigentlich schon alles ausprobiert, was ich gefunden habe!
Danke
MfG Christian

Benutzeravatar
stoker232
Member
Member
Beiträge: 82
Registriert: 3. Sep 2008, 21:39
Wohnort: nicht da wo ich will

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von stoker232 » 18. Jan 2009, 21:09

Hi, bier200
du hast ja schon die Option acpi=force eingestellt. Damit zwingst du Linux das acpi zubenutzen.
Mir fällt da nur noch das Bios ein, wenn du da keine möglichkeit findest das Verhalten einzustellen,
bin ich mit meinem Latein am Ende. Tut mir leid. :???:
acpi=on
acpi=off
acpi=force
apm=off
apm=on
alles schon versucht? :???:
Suse11,2, Lenovo 3000 N200 TY2BGGE 250GB, 3GB Ram
Suse11.3, Lenovo S10-3, 250GB, 2GB Ram
Suse12.1, 3.1.0-01.2-desktopx86_64, KDE 4.7.2"rel.5"
Gk: GeForce 8800 GTS 512MB
MB: Asrock M3N78D
Cpu: AMD iiX6 1090T 3,2GHz
Ram:16GB

Nihil fit sine causa!

Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von longman » 19. Jan 2009, 00:39

Hast Du mal ausprobiert, ob er beim starten im failsafe Modus anschliessend ausgeht ?
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

josef-wien
Guru
Guru
Beiträge: 4986
Registriert: 23. Sep 2008, 17:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von josef-wien » 19. Jan 2009, 17:56

longman hat geschrieben:Hast Du mal ausprobiert, ob er beim starten im failsafe Modus anschliessend ausgeht ?
Das kann nicht funktionieren, bei "Failsafe" sind sowohl apm als auch acpi deaktiviert, daher kann sich der Rechner also auch nicht ausschalten.

walsi
Newbie
Newbie
Beiträge: 2
Registriert: 13. Dez 2004, 22:52

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von walsi » 31. Jan 2009, 14:10

Hallo zusammen, habe genau das selbe Problem. Ich habe es im failsafe Modus ausprobiert und tatsächlich hier funktioniert es. Was muss ich also verändern?

josef-wien
Guru
Guru
Beiträge: 4986
Registriert: 23. Sep 2008, 17:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von josef-wien » 31. Jan 2009, 23:48

Erstens: Ich wundere mich sehr, wie sieht Deine menu.lst aus?

Zweitens: Du mußt den oder die bei Dir notwendigen Parameter suchen. Das habe ich schon einmal beschrieben: http://www.linux-club.de/viewtopic.php? ... fe#p609958

walsi
Newbie
Newbie
Beiträge: 2
Registriert: 13. Dez 2004, 22:52

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von walsi » 3. Feb 2009, 21:25

Hallo Josef

Hier meine menu.lst
# Modified by YaST2. Last modification on Di Feb 3 19:16:10 CET 2009
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.7-9
root (hd0,5)
kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-WDC_WD2500BEVS-22UST0_WD-WXCZ07596041-part6 resume=/dev/disk/by-id/ata-WDC_WD2500BEVS-22UST0_WD-WXCZ07596041-part5 splash=silent showopts vga=0x317
initrd /boot/initrd-2.6.27.7-9-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
root (hd0,5)
kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-WDC_WD2500BEVS-22UST0_WD-WXCZ07596041-part6 showopts ide=nodma apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
initrd /boot/initrd-2.6.27.7-9-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,1)
chainloader +1
Wäre echt froh um Hilfe. Mit Opensuse 11.0 hat es übrigens problemlos funktioniert.

Gruss
walsi

josef-wien
Guru
Guru
Beiträge: 4986
Registriert: 23. Sep 2008, 17:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von josef-wien » 4. Feb 2009, 00:07

Bei den Failsafe-Parametern sehe ich nichts von "acpi=off", daher kann das Ausschalten bei dieser Variante funktionieren.

Aussichtsreiche Kandidaten sind "apm=off" und "powersaved=off". Probiere jeweils einen dieser Parameter bzw. auch beide gemeinsam beim "normalen" Starten. Die übrigen Parameter dürften es in diesem Fall nicht sein.
walsi hat geschrieben:Mit Opensuse 11.0 hat es übrigens problemlos funktioniert.
Das wirst Du hier im Forum zu so manchem Thema lesen.

Naseweiss
Newbie
Newbie
Beiträge: 1
Registriert: 20. Mär 2009, 11:47

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von Naseweiss » 20. Mär 2009, 11:50

Bis eben hatte ich mit SuSe 11.1 das gleiche Problem.

Beim Herunterfahren/Neustarten hat er mir zwar angezeigt, daß er Runlevel 0 bzw 6 erreicht hat, aber an der Stelle blieb er dann auch hartnäckig stecken.

Anscheinend bin ich wohl nicht der Einzige, der mit diesem Problem zu kämpfen hat(te) und eine wirkliche Lösung habe ich noch in keinem Forum gefunden. Vielleicht hilft ja mein Tip.

Ganz trivial: Mir ist aufgefallen, daß beim Systemstart plötzlich gemeldet wurde, daß Fehler beim Laden der v4l-libs aufgetreten sind. Nach der Deinstallation selbiger schaltete der Rechner nach dem Herunterfahren auch wieder brav ab.

Mein Verdacht:
Beim shutdown konnte - warum auch immer - mindestens ein Prozeß nicht gekillt werden. In meinem Fall war es wahrscheinlich ein Prozeß, der mit v4l zu tun hatte.

Wenn ich mich recht entsinne, war soetwas bei früheren SuSen kein Problem. Das System ist auch dann heruntergefahren, wenn sich ein Prozeß mal nicht sauber beenden ließ.

Kann es sein, daß daran etwas geändert wurde und beim shutdown jetzt prinzipiell auf das saubere Beenden aller gekillten Prozesse gewartet wird?

In den einschlägigen log-files habe ich leider nichts auffälliges bei mir finden können.

josef-wien
Guru
Guru
Beiträge: 4986
Registriert: 23. Sep 2008, 17:09

Re: Laptop schaltet nach runterfahren nicht mehr ab!

Beitrag von josef-wien » 20. Mär 2009, 18:01

Das könnte mit /etc/init.d/halt zu tun haben: http://www.linux-club.de/viewtopic.php? ... 92&start=0

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast