Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

[gelöst] VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 2. Jan 2009, 18:46

Hallo,
habe VirtualBox auf OpenSuse 11.1 Host. Das Gastsystem ist Vista.
Jetzt würde ich gerne USB benutzen.
In den "Details" habe ich den USB aktiviert

Im laufenden Gastsystem ist dann unten in der Kontrolleist der USB zwar aktiviert aber ich habe keinen Zugriff auf einen angeschlossenen USB-Stick: "Keine USB Geräte angeschlossen."

So, es gibt hier die Anleitung http://www.linuxforen.de/forums/showpos ... ostcount=5

Unter 4.1.4.1 wird erklärt wie es geht. Und genau da haperts bei mir mit der Umsetzung:
Kann mir das mal jemand bitte gaaanz langsam Schritt für Schritt erklären in welcher Reihenfolge ich was machen muss?

Grobian
Zuletzt geändert von Grobian am 3. Jan 2009, 11:12, insgesamt 1-mal geändert.
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Werbung:
Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3892
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Rainer Juhser » 2. Jan 2009, 19:49

Noch mehr Schritt für Schritt als in der Anleitung geht ja wohl kaum. Es würde wahrscheinlich mehr bringen, wenn du mal *genau* beschreibst, was du machst und wo *exakt* du nicht weiterkommst.
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 2. Jan 2009, 20:08

Gut,

also das steht: Damit im Gast USB benutzt werden kann, muss der Linuxkernel mit USBFS übersetzt worden sein und USBFS in "/etc/fstab" aktiviert sein. Z. B. ...
Dann folge der erste Code:
usbfs /proc/bus/usb usbfs devgid=1001,devmode=0664 0 0

Muss ich das nun in der Konsole ausführen oder nicht?
Ich denke mal der ist nicht für mich da ich ja 11.1 habe.
Ich gehe also zum Code für 11.0 und führe diesen in der Konsole aus.....

Was passiert: "bash: /sys/bus/usb/drivers: is a directory" Die Gruppen ID habe ich entsprechend geändert.

Dies ist der Stand der Dinge.... ich begreife wohl was nicht , darum die Bitte um eine Schritt für Schritt-Erklärung....

Gruss Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

dietger
Hacker
Hacker
Beiträge: 625
Registriert: 17. Okt 2005, 10:27

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von dietger » 2. Jan 2009, 23:27

Dann folge der erste Code:
usbfs /proc/bus/usb usbfs devgid=1001,devmode=0664 0 0

Muss ich das nun in der Konsole ausführen oder nicht?
Ich denke mal der ist nicht für mich da ich ja 11.1 habe.
Ich gehe also zum Code für 11.0 und führe diesen in der Konsole aus.....
Diese Zeile musst Du mit einem Editor Deiner Wahl in die Datei /etc/fstab einfügen. "devgid=1001" muss nicht stimmen, dies ist die Benutzerkennung und kann bei Dir durchaus anders lauten, bei mir ist die z.B. "1000"

Dietger

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 08:13

Hallo,

aha, gut zu wissen.....
Hier hab ich mal den Inhalt in meiner "fstab"


/dev/disk/by-id/ata-WDC_WD3200AAJS-07RYA0_WD-WCAPZ0713471-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD3200AAJS-07RYA0_WD-WCAPZ0713471-part6 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD3200AAJS-07RYA0_WD-WCAPZ0713471-part7 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-WDC_WD3200AAJS-07RYA0_WD-WCAPZ0713471-part2 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD3200AAJS-07RYA0_WD-WCAPZ0713471-part3 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0



Jetzt habe ich im HowTo von Stephan Becker oben den ersten Eintrag, nicht speziel zugeordnet:
usbfs /proc/bus/usb usbfs devgid=1001,devmode=0664 0 0

dann einen Eintrag für Suse 11.0:
/sys/bus/usb/drivers /proc/bus/usb usbfs devgid=1001,devmode=664 0 0

dann gibt es noch einen Eintrag auf FAQ Seite : http://www.virtualbox.org/wiki/User_FAQ :
none /proc/bus/usb usbfs auto,busgid=XXX,busmode=0775,devgid=XXX,devmode=0664 0 0

Bitte welchen Eintrag soll ich wählen?
Kommt der Eintrag zusätzlich in meine "fstab" oder muss ich eine Zeile (ich vermute die 2. von unten) übeschreiben?

Natürlich dann mit meiner ID

Habt Geduld mit mir

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Sauerland
Guru
Guru
Beiträge: 3018
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Sauerland » 3. Jan 2009, 08:27

Hi Grobian

Meine fstab sieht so aus und es funktioniert:

Code: Alles auswählen

/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GL909562-part6	swap	swap	defaults 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GL909562-part9	/	ext3	acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GL909562-part8	/home	ext3	defaults 1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1FP829161-part2	/home/Daten	ext3	defaults 1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1FP829161-part5	/home/Musik	ext3	defaults 1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GL909562-part2	/windows/C	vfat	users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GL909562-part5	/windows/D	ntfs-3g	users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
proc	/proc	proc	defaults 0 0
sysfs	/sys	sysfs	noauto 0 0
debugfs	/sys/kernel/debug	debugfs	noauto 0 0
usbfs	/proc/bus/usb	usbfs	noauto 0 0
devpts	/dev/pts	devpts	mode=0620,gid=5 0 0
none	/proc/bus/usb	usbfs	devgid=1000,devmode=664 0 0
linux386:/home/daten	/home/nfs	nfs	user,noauto,nolock 0 0
Gruß
Stephan

PS Sorry das ich Sylvester auf der langen Leitung stand, war etwas müde.
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 09:07

Oje, bitte kein "Sorry" ich bin froh um jede Hilfe die ich bekomme. Da spielt Zeit keine Rolle....

ich habe meine fstab um den folgenden Eintrag ergänzt:
none /proc/bus/usb usbfs devgid=1000,devmode=664 0 0

Der Wert "1000" trifft auch bei mir zu

Leider habe ich keinen USB-Zugang "keine USB Geräte angeschlossen"

Immerhin: In den FAQ http://www.virtualbox.org/wiki/User_FAQ steht folgendes: After the next reboot, there should be a directory /proc/bus/usb/ and the device entries below should be accessible by any user of the vboxusers group.

Diese Ordner habe ich.

PS: Hat eigentlich der Eintrag in der letzten Zeile deiner fstab auch was mit dem Thema zu tun?

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Sauerland
Guru
Guru
Beiträge: 3018
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Sauerland » 3. Jan 2009, 09:20

Hi

Hast Du mal versucht bei eingeschaltetem USB-Gerät Virtualbox zu starten, dann Betriebsystem auswählen, ändern, USB, Filter von einem Gerät hinzufügen und Gerät auswählen?

Der letzte Eintrag mountet ein Verzeichnis per nfs von einem anderen Linux Rechner bei Bedarf, sodaß ich per Dateimanager Krusader über das Netzwerk auf dieses Verzeichnis zugreifen kann.

Bitte verwende beim nächsten mal code-tags, wenn du etwas aus der console oder aus einer Datei postest. Dann wird es lesbarer. Das ist der Button code.

Gruß Stephan
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 09:37

Hallo,

hab ich probiert, "keine Geräte verfügbar".

Aber was anderes: Im HowTo steht am Ende der Anweisungen:
Mit folgendem Befehl werden die installierten USB-Geräte aufgelistet:
Code: cat /proc/bus/usb/devices


Wenn ich diesen Code in der Konsole im Home-System ausführe kommt: cat: /proc/bus/usb/devices: Datei oder Verzeichnis nicht gefunden

Heißt also ich habe zwar den Ordner "/proc/bus/usb" aber keine Einträge
Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 09:47

Am Ende im Howto steht:

Bei manchen Distributionen (z. B. Opensuse 11) muss man stattdessen diesen Befehl beim Booten starten, z. B. bei Suse über die Datei "/etc/rc.d/boot.local". Danach muss man also erstmal neu starten.

Muß ich da was machen? Oder sehe ich das richtig --> Neustart und gut ist's?

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Sauerland
Guru
Guru
Beiträge: 3018
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Sauerland » 3. Jan 2009, 09:49

Was sagt lsusb inder Konsole?
Wenn etwas ausgegeben wird wie

Code: Alles auswählen

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 059b:0370 Iomega Corp.
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 002: ID 04b8:082b Seiko Epson Corp. Stylus DX5050
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
dann su eingeben, passwrt für root blind eingeben und mount -a eingeben.

siehe:http://en.opensuse.org/VirtualBox_USB_Support
and add following line to /etc/init.d/boot.local

mount -a
in die boot.local einfügen
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 10:25

Also, der Reihe nach:

wenn ich in der Konsole eingebe: "lsusb" dann kommt:

Code: Alles auswählen

boss@linux-tza2:~> lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 04d9:1603 Holtek Semiconductor, Inc.
Bus 003 Device 002: ID 0461:4d16 Primax Electronics, Ltd
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 07b8:e004 D-Link Corp. Mass Storage Device
Bus 001 Device 002: ID 04a9:170a Canon, Inc. PIXMA MP170 Scanner
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Dann habe ich die Datei "/etc/init.d/boot.local" geöffnet und "mount -a" hinzugefügt (Ist das egal an welcher Stelle?)
Die sieht dann so aus:

#! /bin/sh
#
# Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.
#
# Author: Werner Fink <werner@suse.de>, 1996
# Burchard Steinbild, 1996
#
# /etc/init.d/boot.local
#
# script with local commands to be executed from init on system startup
#
# Here you should add things, that should happen directly after booting
# before we're going to the first run level.
# mount -a


Wenn ich jetzt in der Konsole mit "su" mount -a ausführe kommt folgendes:

Code: Alles auswählen

linux-tza2:/home/boss # mount -a
NTFS signature is missing.
Failed to mount '/dev/sda3': Das Argument ist ungültig
The device '/dev/sda3' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
Ist wohl eindeutig eine Fehlermeldung, für mich nur leider nicht ganz durchschaubar...

Zwischendurch mal wieder ein "Habt Geduld mit mir"

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Sauerland
Guru
Guru
Beiträge: 3018
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Sauerland » 3. Jan 2009, 10:33

Nimm aus der boot.local vor mount -a das "#" weg, da dies für Kommentar steht.

gib mount -a als root ein und versuch Virtualbox zu starten und nach deinen USB devices zu suchen.

Mit Deine Windows-Partition sda3 stimmt was nicht. Melde mich gleich wieder

Stephan
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Sauerland
Guru
Guru
Beiträge: 3018
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Sauerland » 3. Jan 2009, 10:54

Um den Fehler beim mounten mit deiner Windows Partion wegzubekommen, versuch einmal unter Windows ein chkdsk.

Gruß Stephan
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: VBox USB einrichten Host OpenSUSE 11.1 Gast Vista

Beitrag von Grobian » 3. Jan 2009, 11:01

Es geht, ich habe soeben meinen USB Stick in meinem virtuellen Vista geöffnet.

Nachdem ich die Raute vor "mount -a" entfernt habe, werden in den USB-Einstellungen die Geräte angezeigt.

Jetzt bin ich erstmal zufrieden. Als nächstes werde ich dann versuchen auch den Drucker zu benutzen

Sauerland bzw. Stephan: Ein riesengrosses DANKE an dich!
Gruss
Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast