Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Suse 11.1 Festplatte wird nicht erkannt

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
DonCorleone
Newbie
Newbie
Beiträge: 2
Registriert: 30. Dez 2008, 00:00

[gelöst] Suse 11.1 Festplatte wird nicht erkannt

Beitrag von DonCorleone » 30. Dez 2008, 01:19

Hallo :-)

Ich wollte heute auf meinem Rechner Suse 11.1 installieren.
Meine Hardware:
ASUS A8N SLI Deluxe (nforce 4 SLI)

AMD Athlon 64 3000

ATI/AMD Radeon X550 (Sapphire)

SATA 1: Samsung Spinpoint F1 640 GB - Sata2 (300 Mbps)
SATA 2: Samsung SP2004 200 GB - Sata 2 (300 Mbps)

Ich habe also die Suse 11.1 DVD (32 Bit) heruntergeladen und gebrannt.
MD5 Check war auch ok. Daraufhin habe ich die CD gestartet.
Sie läuft durch bis zum Installer. Ich kann die Lizenz durchlesen und meinen Desktop wählen.
Dann gelange ich zum Partitionierungs-Dialog für die Festplatten.

Dort wird nur eine Festplatte gelistet, nämlich die 200 GB Platte am SATA 2
Sie hat die Bezeichnung /dev/sda. Eigentlich müsste sie doch als /dev/sdb aufgeführt sein?
Die Platte an SATA 1 wird gar nicht aufgelistet. Dummerweise ist dies jene Platte, auf der ich Suse installieren möchte ;-)
Daraufhin wechselte ich in eine Konsole und schaute, was ein fdisk -l ergibt.
Auch hier sehe ich nur die /dev/sda an SATA 2.
Offenbar wird die 640 GB Platte nicht erkannt.
pci=nomsi als Kerneloption beim starten der CD brachte ebenfalls nichts.

Offenbar liegt das Problem an einigen Linux-Kerneln.
Mit einer aktuellen ArchLinux-CD habe ich das gleiche Problem.
Mit Ubuntu 8.10 32 Bit Alternate ebenso.
Mit Ubuntu 8.10 Desktop 64 Bit dagegen läuft die Erkennung der Festplatten und die Installation dagegen reibungslos. :???:

Ich weiß im moment gar nicht so recht, was ich tun soll. Ich bin mit meinem Latein ziemlich am Ende.
Im Moment läuft zwar Ubuntu auf der Kiste, allerdings zickt da der vdr rum, sodass ich eigentlich schon am liebsten Suse haben würde.
Gibt es sonst noch irgendwelche Kernel-Optionen mit denen ich das Problem umschiffen könnte?
generic.all_generic_ide=1 habe ich ebenfalls schon probiert, wobei ich den Tip aus dem Ubuntu lager habe :D

Das lustige ist, dass das bereits installierte Ubuntu 8.10 64Bit auch nur startet, wenn ich diese generic-Option an die Kernel-Zeile in Grub anfüge, daraufhin aber auf der Konsole ausgegeben wird: Option generic.all_generic_ide=1 unknown.
Wenn die Option aber nicht gesetzt ist, startet der Kernel nicht :D :irre:
Naja, was solls :D

mfg
Zuletzt geändert von DonCorleone am 30. Dez 2008, 19:22, insgesamt 1-mal geändert.

Werbung:
DonCorleone
Newbie
Newbie
Beiträge: 2
Registriert: 30. Dez 2008, 00:00

Re: Suse 11.1 erkennt bei Installation S-ATA Festplatte nicht

Beitrag von DonCorleone » 30. Dez 2008, 19:19

Hallo :-)

Ich habe mittlerweile das Problem gelöst.
Mein Fehler war, dass ich als Kernelparameter beim Start generic.all_generic_ide=1 angegeben hatte.
Offenbar funktioniert dieser Befehl jedoch nur bei Ubuntu, bzw. funktioniert er zumdindest bei Suse nicht oder bringt nicht die gewünschte Wirkung mit sich.
Wenn man dagegen all-generic-ide angibt erkennt Suse problemlos beide Festplatten, jedoch erkennt es die Platte an SATA 1 als /dev/sdb und umgekert. :???:
Funktionieren tut jedoch alles problemlos.
:-)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste