Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Animation in Grub abschalten

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

[gelöst] Animation in Grub abschalten

Beitrag von Grobian » 29. Dez 2008, 18:32

Hallo,
ich möchte die momentane Weihnachts- Boot-Animation abschalten und hätte gerne die Standardansicht wenn Grub geladen wird.
In den Bootloader Optionen kann man eine "Datei für Graphisches Menü" auswählen. Kann ich mit dieser Funktion die Standardansicht wieder herstellen? Wenn ja, welche Datei muss ich auswählen.
Oder muss ich die Grub-Datei "/grub/menu.lst" editieren?

Danke
Grobian
Zuletzt geändert von Grobian am 30. Dez 2008, 21:22, insgesamt 3-mal geändert.
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Werbung:
admine
Administrator
Administrator
Beiträge: 8775
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Animation in Grub abschalten

Beitrag von admine » 29. Dez 2008, 18:44

..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: Animation in Grub abschalten

Beitrag von Grobian » 29. Dez 2008, 19:02

Danke für den Tip,
scheint mir ein bisschen kompliziert zu sein. Muss man sich mal vorstellen: Wer gerne die Standardansicht hat muss basteln.....

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

admine
Administrator
Administrator
Beiträge: 8775
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Animation in Grub abschalten

Beitrag von admine » 29. Dez 2008, 19:27

penguin=-1 bewirkt, daß nur rund um Weihnachten das Bild "pback.jpg" angezeigt wird
Also einfach noch ein wenig warten, bis Weihnachten endgültig auch für Pinguine vorbei ist ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4263
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: Animation in Grub abschalten

Beitrag von framp » 29. Dez 2008, 19:30

Grobian hat geschrieben:Danke für den Tip,
scheint mir ein bisschen kompliziert zu sein. Muss man sich mal vorstellen: Wer gerne die Standardansicht hat muss basteln.....

Grobian
Mir ist jetzt erst aufgefallen, dass ich den WeihnachtsBootSplashScreen nicht bekomme :nosmile: - weil bei mir

Code: Alles auswählen

Mit der Angabe "penguin=" wird das Hintergrundbild ausgewählt:

   penguin=-1   bewirkt, daß nur rund um Weihnachten das Bild "pback.jpg" angezeigt wird
   penguin=0    bewirkt, daß immer das Bild "back.jpg" angezeigt wird
   penguin=100  bewirkt, daß immer das Bild "pback.jpg" angezeigt wird
penguin=0 drin steht.
Du brauchst also nur

Code: Alles auswählen

penguin=0
bei Dir reinzubringen und dann hast Du kein Weihnachten mehr ;) Ist eine Sache von 1 Minute - /boot/messages lt Anweisung auspacken, die .cfg Datei editieren und wieder alles lt Anleitung packen. Ist nicht kompliziert. Voila.

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: Animation in Grub abschalten

Beitrag von Grobian » 30. Dez 2008, 07:41

So, habe jetzt wieder die Standard-Ansicht beim Booten.

Um "message" zu entpacken und nach getaner Arbeit wieder zu packen, habe ich folgende leicht verständliche Anleitung benutzt.

http://blog.chip.de/chip-linux-blog/eig ... -20071106/

Alles prima
Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: [gelöst] Animation in Grub abschalten

Beitrag von Grobian » 30. Dez 2008, 20:35

Zu früh gefreut,

Ich habe mein Opensuse frisch aufgesetzt. Ich wollte wieder mein Grub einrichten wie oben beschrieben.
Tja, geht nicht mehr, wenn ich den Wert in "0" ändere wird jetzt gar kein Hintergrund mehr angezeigt mit der Meldung dass "message" beschädigt ist "invalid fileformat".
Selbst wenn ich die vorgegebene Zahl wieder reinschreibe und die "gfxboot.cfg" Datei abspeichere geht das dann nicht mehr.
Ich denke mal da läuft was beim Abspeichern schief....nur was???

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Grobian
Member
Member
Beiträge: 119
Registriert: 21. Dez 2008, 12:17

Re: Animation in Grub abschalten

Beitrag von Grobian » 30. Dez 2008, 21:22

Fehler gefunden, ich habe in der Konsole beim Befehl "ls | cpio -ov > /home/[User]/message" gleich am Anfang das l mit einem grossen i verwechselt.

Grobian
OpenSUSE 13.2
Nvidia GeForce 8400 GS

Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 296
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: [gelöst] Animation in Grub abschalten

Beitrag von transwarp » 1. Jan 2009, 15:48

Es geht aber auch über den Befehl

Code: Alles auswählen

gfxboot
, dessen Parameter ausführlich in den Manpages erklärt sind.

Mit

Code: Alles auswählen

mkdir /tmp/test
gfxboot --expand-archive /tmp/test
werden die Dateien des aktuellen message-Archives in das Verzeichnis '/tmp/test' entpackt.

Danach kann man die Datei 'gfxboot.cfg' anpassen, z.B. durch "Penguin=0" den nervigen Weihnachts-Startbildschirm abschalten,
oder einige der JPG-Dateien gegen andere Grafiken ersetzen.

Mit

Code: Alles auswählen

gfxboot --add-file gfxboot.cfg
wird die angegebene Datei 'gfxboot.cfg' in das message-archiv zurück gespielt.

Damit ist die Änderung im Prinzip vollzogen.
openSUSE Tumbleweed | Kernel 4.16.12-1-desktop x86_64 | Plasma 5.12.5 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste