Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] suse 15.1 in Denglisch.

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

[gelöst] suse 15.1 in Denglisch.

Beitrag von dzug » 9. Okt 2019, 21:02

Hei.
Zur Zeit schlage ich mich mit "Denglisch"herum.
Yast und Konqueror sind teilweise in Englisch.
Alles was ich auf meinem System gefunden habe um Deutsch einzustellen ist auf Deutsch eingestellt.
Was könnte ich noch tun?.
Ich Danke im Voraus für eine Antwort.
Gruss dzug.
Zuletzt geändert von dzug am 13. Okt 2019, 22:44, insgesamt 1-mal geändert.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

Werbung:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 549
Registriert: 19. Sep 2014, 18:22

Re: suse 15.1 in Denglisch.

Beitrag von susejunky » 9. Okt 2019, 21:15

Hallo dzug,
dzug hat geschrieben:
9. Okt 2019, 21:02
... Zur Zeit schlage ich mich mit "Denglisch"herum.
Yast und Konqueror sind teilweise in Englisch.
hast Du die Pakete "konqueror-lang" und "yast2-trans-de" installiert?

Viele Grüße

susejunky

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 9. Okt 2019, 21:47

Danke susejunky.
Sind Installiert.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2071
Registriert: 24. Okt 2005, 14:04

Re: suse 15.1 in Denglisch.

Beitrag von Heinz-Peter » 9. Okt 2019, 22:36

Hallo dzug,

zeige uns bitte die Konsoleausgabe (als user ausführen) von

Code: Alles auswählen

locale
Gruß
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 10. Okt 2019, 14:25

Code: Alles auswählen

peter@Platte-B-15-1:~> locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
peter@Platte-B-15-1:~> [code]
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

abgdf
Guru
Guru
Beiträge: 3207
Registriert: 13. Apr 2004, 21:15

Re: suse 15.1 in Denglisch.

Beitrag von abgdf » 10. Okt 2019, 14:36

Ich merk' das gar nicht mehr, ob ich Deutsch oder Englisch lese.
Vielleicht solltest Du lieber Dein Gehirn umstellen als die Programmpakete. ;)

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2071
Registriert: 24. Okt 2005, 14:04

Re: suse 15.1 in Denglisch.

Beitrag von Heinz-Peter » 10. Okt 2019, 17:24

Hallo dzug,

die Variable LANG ist schon richtig eingetragen. Die Variable LC_ALL hat aber eine noch stärkere Wirkung als LANG. Ich habe hier kein Suse/Leap 15.1 kann also zu der Meldung: locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden nichts beitragen. Vielleicht kann die Konsoleausgabe jemand vergleichen.

Gruß
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 549
Registriert: 19. Sep 2014, 18:22

Re: suse 15.1 in Denglisch.

Beitrag von susejunky » 10. Okt 2019, 18:10

Hallo dzug,
dzug hat geschrieben:
10. Okt 2019, 14:25

Code: Alles auswählen

peter@Platte-B-15-1:~> locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
peter@Platte-B-15-1:~> 
bei meinem System sieht das Ergebnis so aus

Code: Alles auswählen

> locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
> 
Könntest Du bitte die Ergebnisse der folgenden Befehle hier zeigen

Code: Alles auswählen

> echo $LANG

Code: Alles auswählen

> echo $LANGUAGE

Code: Alles auswählen

> cat /etc/locale.conf

Code: Alles auswählen

> cat /etc/bash.bashrc.local

Code: Alles auswählen

> cat $HOME/.bashrc

Code: Alles auswählen

> cat $HOME/.config/plasma-localerc

Code: Alles auswählen

> cat $HOME/.config/plasma-locale-settings.sh

Code: Alles auswählen

> cat /etc/sysconfig/language
Weierhin wäre es hilfreich zu sehen, wie z.B. bei yast, dieser Sprachmix aussieht (screenshot auf susepaste hochladen).

Viele Grüße

susejunky

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 11. Okt 2019, 11:56

Code: Alles auswählen

peter@Platte-B-15-1:~>  echo $LANG
de_DE.UTF-8
peter@Platte-B-15-1:~>  echo $LANGUAGE
de
peter@Platte-B-15-1:~> cat /etc/locale.conf
LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8
peter@Platte-B-15-1:~> cat /etc/bash.bashrc.local
cat: /etc/bash.bashrc.local: No such file or directory
peter@Platte-B-15-1:~> cat $HOME/.bashrc
# Sample .bashrc for SuSE Linux
# Copyright (c) SuSE GmbH Nuernberg

# There are 3 different types of shells in bash: the login shell, normal shell
# and interactive shell. Login shells read ~/.profile and interactive shells
# read ~/.bashrc; in our setup, /etc/profile sources ~/.bashrc - thus all
# settings made here will also take effect in a login shell.
#
# NOTE: It is recommended to make language settings in ~/.profile rather than
# here, since multilingual X sessions would not work properly if LANG is over-
# ridden in every subshell.

# Some applications read the EDITOR variable to determine your favourite text
# editor. So uncomment the line below and enter the editor of your choice :-)
#export EDITOR=/usr/bin/vim
#export EDITOR=/usr/bin/mcedit

# For some news readers it makes sense to specify the NEWSSERVER variable here
#export NEWSSERVER=your.news.server

# If you want to use a Palm device with Linux, uncomment the two lines below.
# For some (older) Palm Pilots, you might need to set a lower baud rate
# e.g. 57600 or 38400; lowest is 9600 (very slow!)
#
#export PILOTPORT=/dev/pilot
#export PILOTRATE=115200

test -s ~/.alias && . ~/.alias || true
peter@Platte-B-15-1:~> cat $HOME/.config/plasma-localerc
[Formats]
LANG=de_DE.UTF-8

[Translations]
LANGUAGE=de
peter@Platte-B-15-1:~> cat $HOME/.config/plasma-locale-settings.sh
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_DE.UTF-8
export LANGUAGE=de
peter@Platte-B-15-1:~> cat /etc/sysconfig/language

## Path:        System/Environment/Language
## Type:        string(ibus,fcitx,gcin,scim,scim-bridge,uim,kinput2,kinput2-canna,kinput2-wnn,nabi,wnn,atokx,xcin,none)
## Default:     ""
#
# A default input method to be used in X11 can be selected here.
# If this variable is set and a script with the same name
# as the value of this variable exists in the directory /etc/X11/xim.d/
# this script is sourced when X11 is started to start an input method.
#
# The special value "none" (/etc/X11/xim.d/none) means:
# Do not use any input method at all.
#
# For more details see the comments at the top of /etc/X11/xim.
#
INPUT_METHOD=""
## Path:        System/Environment/Language
## Description:
## Type:        string(POSIX,ca_ES.ISO-8859-1,ca_ES.UTF-8,cs_CZ.ISO-8859-2,cs_CZ.UTF-8,da_DE@euro,da_DK.ISO-8859-1,da_DK.UTF-8,de_DE@euro,de_DE.ISO-8859-1,de_DE.UTF-8,el_GR.ISO-8859-7,el_GR.UTF-8,en_GB.ISO-8859-1,en_GB.UTF-8,en_IE@euro,en_IE.ISO-8859-1,en_US.ISO-8859-1,es_ES@euro,es_ES.ISO-8859-1,es_ES.UTF-8,fr_FR@euro,fr_FR.ISO-8859-1,fr_FR.UTF-8,gl_ES@euro,gl_ES.ISO-8859-1,gl_ES.utf-8,hr_HR.ISO-8859-2,hu_HU.ISO-8859-2,hu_HU.UTF-8,it_IT@euro,it_IT.ISO-8859-1,it_IT.UTF-8,ja_JP.eucJP,ja_JP.UTF-8,lt_LT.ISO-8859-13,lt_LT.UTF-8,nl_NL@euro,nl_NL.ISO-8859-1,nl_NL.UTF-8,ru_RU.ISO-8859-5,ru_RU.KOI8-R,ru_RU.UTF-8,sk_SK.ISO-8859-2,sk_SK.UTF-8,tr_TR.ISO-8859-9,tr_TR.UTF-8,ko_KR.eucKR,ko_KR.UTF-8,zh_TW.Big5,zh_TW.UTF-8,zh_CN.GB2312,zh_CN.UTF-8)
## Default:     ""
## Config:      OpenOffice.org,groff,ispell,kde,kdm,profiles,susehelp,susewm,tetex,wdm
#
#
# Local users will get RC_LANG as their default language, i.e. the
# environment variable $LANG . $LANG is the default of all $LC_*-variables,
# as long as $LC_ALL is not set, which overrides all $LC_-variables.
# Root uses this variable only if ROOT_USES_LANG is set to "yes".
#
RC_LANG="de_DE.UTF-8"

## Type:        string
## Default:     ""
#
# This variable will override all LC-variables!!
# Again, ROOT_USES_LANG must be set to "yes", if an effect on the superuser
# account is desired.
#
RC_LC_ALL=""

## Type:        string
## Default:     ""
#
# This defines the locale in which messages of programs and
# libraries with i18n-support should appear if a translated
# message catalog for the library or the program is installed.
# This also provides localized yes/no answers.
#
RC_LC_MESSAGES=""

## Type:        string
## Default:     ""
#
# This defines the locale for character handling and classification.
# The libc uses this value in language dependent function calls, such
# as e.g. uppercase/lowercase mapping of foreign characters.
#
RC_LC_CTYPE=""

## Type:        string
## Default:     ""
#
# This defines the locale for sorting strings and characters.
# It is used by the libc to obtain the alphabetical order of characters
# (e.g. for string comparisons).
#
RC_LC_COLLATE=""

## Type:        string
## Default:     ""
#
# This defines the locale for date and time output formats.
# i.e.: 06/09/1999 vs. 09.06.1999
#
RC_LC_TIME=""

## Type:        string
## Default:     ""
#
# This defines the locale for formatting and reading numbers.
# i.e.: 1,234.56 vs. 1.234,56
#
RC_LC_NUMERIC=""

## Type:        string
## Default:     ""
#
# This defines the locale for formatting and reading money values.
#
RC_LC_MONETARY=""

## Type:        string
## Default:     ""
#
# This defines the locale for format of paper.
#
RC_LC_PAPER=""

## Type:        string(ctype)
## Default:     ctype
#
# This defines if the user "root" should use the locale settings
# which are defined here.
# Value "ctype" means that root uses just LC_CTYPE. 
# Value "yes" means that root uses the full settings.. 
#
ROOT_USES_LANG="ctype"

## Type:        yesno
## Default:     no
#
# Workaround for missing forward of LANG and LC variables
# of e.g. ssh login connections.
#
AUTO_DETECT_UTF8="no"

## Type:        string
## Default:     ""
#
# List of installed language supports, use by YaST2
#
INSTALLED_LANGUAGES="de_DE"
peter@Platte-B-15-1:~> 
Hier das Gewünschte.
Ich Lese nur AUTO_DETECT_UTF8="no".
Ist das richtig?
Danke susejunky.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 549
Registriert: 19. Sep 2014, 18:22

Re: suse 15.1 in Denglisch.

Beitrag von susejunky » 11. Okt 2019, 13:33

Hallo dzug,
dzug hat geschrieben:
11. Okt 2019, 11:56
... Ich Lese nur AUTO_DETECT_UTF8="no".
Ist das richtig?
das steht auch in meiner Konfiguration.

Beim Vergleich mit meiner Konfiguration ist mir folgendes aufgefallen:

in der Datei /etc/sysconfig/language steht bei mir

Code: Alles auswählen

RC_LANG=""
(bei Dir RC_LANG="de_DE.UTF-8")

in der Datei /etc/locale.conf steht bei mir

Code: Alles auswählen

LANG=de_DE.UTF-8
(bei Dir LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8)

Ich denke es wäre einen Versuch wert, dass Du von beiden Dateien eine Sicherungskopie anlegst und dann die Einstellungen aus meiner Konfiguration probehalber übernimmst.

Da ich nicht genau weis, wann diese Änderungen wirksam werden, solltest Du im Anschluss an die Änderungen Dein System neu starten.

Viele Grüße

susejunky

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 11. Okt 2019, 17:10

Danke susejunky.
Jetzt habe ich ein Problem.
Um es einfach zu Sagen:
Wie komme ich an die Dateien?
Wie Kopie? und wohin?
Wie ändere ich die Dateien?
Einfach wie mache ich das?
Bitte bitte einfach.
Gruss dzug.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 549
Registriert: 19. Sep 2014, 18:22

Re: suse 15.1 in Denglisch.

Beitrag von susejunky » 11. Okt 2019, 17:46

Hallo dzug,
dzug hat geschrieben:
11. Okt 2019, 17:10
Danke susejunky.
Jetzt habe ich ein Problem.
Um es einfach zu Sagen:
Wie komme ich an die Dateien?
Wie Kopie? und wohin?
Wie ändere ich die Dateien?
Einfach wie mache ich das?
Bitte bitte einfach.
Gruss dzug.
ich gehe davon aus, dass Du KDE als Desktop verwendest.

Öffne eine Konsole (KDE-Menü -> System -> Konsole) und gib folgendes ein (die Befehle kannst Du von hier aus den Code-Fenstern kopieren und in der Konsole einfügen):es erfolgt die Abfrage nach dem Administratorkennwort - bitte eingeben. Dann

Code: Alles auswählen

# cp /etc/sysconfig/language /etc/sysconfig/language.bak
und

Code: Alles auswählen

# cp/etc/locale.conf /etc/locale.conf.bak
Anschließend überprüfst Du mit den beiden folgenden Befehlen, ob die beiden Dateien angelegt wurden

Code: Alles auswählen

# ls -la /etc/sysconfig/language.bak
und

Code: Alles auswählen

# ls -la /etc/locale.conf.bak
Sollten die Dateien NICHT vorhanden sein, kopiere alles was Du bis dahin in der Konsole eingeben hast (und was Dir bis dahin angezeigt wurde) und zeige es hier.

Wenn die Dateien vorhanden sind, dann änderst Du die Dateien mit einem Editor Deiner Wahl (z.B. kwrite)

Code: Alles auswählen

# kwrite /etc/sysconfig/language
Änderung speichern und Editor beenden

Code: Alles auswählen

# kwrite/etc/locale.conf
Änderung speichern und Editor beenden.

Dann startest Du mit

Code: Alles auswählen

# systemctl isolate reboot.target
Deinen Rechner neu.

Viele Grüße

susejunky

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 11. Okt 2019, 18:22

Danke susejunky.
Eine dumme Frage:
Was mache ich denn da eigentlich?
Bei den Befehlen schwant mir eine Neuinstallation.
Gruss dzug.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 11. Okt 2019, 18:40

Code: Alles auswählen

 Password: 
linux-Platte-C-sda1-15-1:/home/peter # cp /etc/sysconfig/language /etc/sysconfig/language.bak
linux-Platte-C-sda1-15-1:/home/peter #  cp/etc/locale.conf /etc/locale.conf.bak
bash: cp/etc/locale.conf: Datei oder Verzeichnis nicht gefunden
linux-Platte-C-sda1-15-1:/home/peter # ls -la /etc/sysconfig/language.bak
-rw-r--r-- 1 root root 3844 Oct 11 18:35 /etc/sysconfig/language.bak
linux-Platte-C-sda1-15-1:/home/peter # ls -la /etc/locale.conf.bak
ls: cannot access '/etc/locale.conf.bak': No such file or directory
linux-Platte-C-sda1-15-1:/home/peter # 
Hier die Ausführung der Befehle.
Störe dich nicht an der Platte C da ist derselbe Fehler.
Gruss dzug.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 549
Registriert: 19. Sep 2014, 18:22

Re: suse 15.1 in Denglisch.

Beitrag von susejunky » 11. Okt 2019, 19:29

Hallo dzug,
dzug hat geschrieben:
11. Okt 2019, 18:40
...

Code: Alles auswählen

...
linux-Platte-C-sda1-15-1:/home/peter #  cp/etc/locale.conf /etc/locale.conf.bak
bash: cp/etc/locale.conf: Datei oder Verzeichnis nicht gefunden
Ups! Entschuldigung, mein Fehler. Da fehlte ein Leerzeichen.

Also hier noch einmal (ohne das, was bereits funktioniert hat):

Code: Alles auswählen

# cp /etc/locale.conf /etc/locale.conf.bak
Anschließend überprüfst Du mit

Code: Alles auswählen

# ls -la /etc/locale.conf.bak
ob die Datei angelegt wurde.

Wenn die Datei vorhanden ist, dann änderst Du die Dateien mit einem Editor Deiner Wahl (z.B. kwrite)

Code: Alles auswählen

# kwrite /etc/sysconfig/language
Änderung speichern und Editor beenden

Code: Alles auswählen

# kwrite /etc/locale.conf
Änderung speichern und Editor beenden.

Abschließend startest Du mit

Code: Alles auswählen

# systemctl isolate reboot.target
Deinen Rechner neu.

Viele Grüße

susejunky

abgdf
Guru
Guru
Beiträge: 3207
Registriert: 13. Apr 2004, 21:15

Re: suse 15.1 in Denglisch.

Beitrag von abgdf » 11. Okt 2019, 20:09

dzug hat geschrieben:
11. Okt 2019, 18:22
Bei den Befehlen schwant mir eine Neuinstallation.
Mit einer Neuinstallation kriegst Du das Denglisch auch nicht weg.

dzug
Guru
Guru
Beiträge: 2130
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: suse 15.1 in Denglisch.

Beitrag von dzug » 11. Okt 2019, 22:01

Code: Alles auswählen

    Password: 
linux-Platte-C-sda1-15-1:/home/peter # kwrite /etc/sysconfig/language
THIS IS POTENTIALLY INSECURE!
To edit files as root please use:
SUDO_EDITOR=kwrite sudoedit <file>
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
"Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"
linux-Platte-C-sda1-15-1:/home/peter # 
      
Kwrite hat ein Problem?
Es geht eine sehr lange Liste auf.
Da weiss ich nicht mehr was ich damit machen soll.
Gruss dzug.
Mein System:15.2+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.2 + 15.1

abgdf
Guru
Guru
Beiträge: 3207
Registriert: 13. Apr 2004, 21:15

Re: suse 15.1 in Denglisch.

Beitrag von abgdf » 12. Okt 2019, 00:16

dzug hat geschrieben:Kwrite hat ein Problem?
Es geht eine sehr lange Liste auf.
Da weiss ich nicht mehr was ich damit machen soll.
Vielleicht einen anderen Editor nehmen?

Sauerland
Guru
Guru
Beiträge: 3491
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: suse 15.1 in Denglisch.

Beitrag von Sauerland » 12. Okt 2019, 05:26

Oder statt als root mit kdesu versuchen zu starten?
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Sauerland
Guru
Guru
Beiträge: 3491
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: suse 15.1 in Denglisch.

Beitrag von Sauerland » 12. Okt 2019, 06:26

Du bist aber nicht grafisch als root angemeldet?

In den Systemeinstellungen---Persönliche Informationen----Regionaleinstellungen--Sprache ---bevorzugte Sprache ist deutsch?
In den Systemeinstellungen---Persönliche Informationen----Regionaleinstellungen---Formate alles auf Deutsch (de_DE) eingestellt?

Yast---System----Sprache---primäre Sprache ist deutsch?
Dort unter Details noch bei Detailierter Locale-Einstellung de_DE?
Ebenso UTF8-Kodierung verwenden

Ausserdem:
https://www.linux-community.de/blog/ope ... eibringen/
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Antworten