cups-client update [Gelöst]

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
ischa
Newbie
Newbie
Beiträge: 10
Registriert: 26. Jan 2008, 16:44

cups-client update [Gelöst]

Beitrag von ischa » 7. Dez 2008, 14:09

Hallo Zusammen

Ich nutze Suse 11.0

Beim update, egal ob per autoupdate oder von Hand ergibt sich mit dem cups-client immer wieder eine fehlermeldung. Diese sagt meiner Meinung nach aus, dass er die eine version nicht deinstallieren konnte weil nicht vorhanden.

Kann ich das "Problem" irgendwie beheben? Funktionieren tut scheinbar alles. Aber die Fehlermeldung stört mich.

cu

ischa

Hier die entsprechende Meldung beim Update:
---
2008-12-07 13:56:44 cups-client-1.3.7-25.1.i586 ordnungsgemäß entfernt
2008-12-07 13:57:56 Fehler beim Entfernen von cups-client-1.3.7-25.2.i586
rpm-Ausgabe:
error: package cups-client-1.3.7-25.2.i586 is not installed

2008-12-07 13:59:24 cups-client-1.3.7-25.4.i586.rpm ordnungsgemäß installiert
2008-12-07 14:01:32 Fehler beim Entfernen von cups-client-1.3.7-25.2.i586
rpm-Ausgabe:
error: package cups-client-1.3.7-25.2.i586 is not installed
Zuletzt geändert von ischa am 10. Dez 2008, 23:02, insgesamt 1-mal geändert.

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7259
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: cups-client update

Beitrag von spoensche » 7. Dez 2008, 15:51

Führe mal den Befehl

Code: Alles auswählen

rpm -qa | grep cups-client
aus. Wenn der Paketname nicht angezeigt wird, ist das Paket nicht installiert. Sollte dies der Fall sein, wo ich nach der Fehlermeldung von ausgehe, installierst du das Paket per Yast oder Zypper nach.

ischa
Newbie
Newbie
Beiträge: 10
Registriert: 26. Jan 2008, 16:44

Re: cups-client update

Beitrag von ischa » 10. Dez 2008, 21:32

Hi

Der cups-client ist installiert in der neuesten Version. Das ist nicht das Problem, den client habe ich auch per yast installiert.

Das ist die Antwort auf obigen Befehl:

cups-client-1.3.7-25.4
cups-client-1.3.7-25.4

Das Problem ist aus meiner Sicht, dass er die alte version nicht findet zum deinstallieren.

Dies schliesse ich aus der Meldung:

error: package cups-client-1.3.7-25.2.i586 is not installed

Danke

ischa

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8746
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Re: cups-client update

Beitrag von admine » 10. Dez 2008, 21:49

ischa hat geschrieben: Das ist die Antwort auf obigen Befehl:
cups-client-1.3.7-25.4
cups-client-1.3.7-25.4
:???: Ähm ... das bekommst du als Ausgabe?
Das würde ja bedeuten, dass cups-client 2x mit identischer Version in der RPM-Datenbank steht.

Mach mal ein

Code: Alles auswählen

rpm --rebuilddb
Wenn das nicht hilft, dann versuche den cups-client zu deinstallieren und neu zu installieren.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

ischa
Newbie
Newbie
Beiträge: 10
Registriert: 26. Jan 2008, 16:44

Re: cups-client update [Gelöst]

Beitrag von ischa » 10. Dez 2008, 23:01

Hallo

Du bist mein Held. Nach dem Befehl hat sich das Problem gelöst.

Danke

ischa

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste