Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

10.3er Automatik-Patch installiert, und booten geht nix mehr

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
rolas
Newbie
Newbie
Beiträge: 8
Registriert: 12. Mai 2007, 11:34
Wohnort: Karlsruhe

10.3er Automatik-Patch installiert, und booten geht nix mehr

Beitrag von rolas » 11. Nov 2007, 17:24

Hallo, vielleicht könnt ihr mir helfen....

Ich habe über die halbautomatische Aktualisierungsfunktion u.a. eine mit anderen Dateien als Sicherheits-Update (Patch) gelistete Datei heruntergeladen und installiert. Am Ende der Aktualisierung gab es den Hinweis, dass diese bewusste Datei sich auf den Kernel beziehe und ein Neustart zu empfehlen sei. Danach war's das....Beim Booten (Anzeige Kernel 10.3.-2.6.22.9-0.4) wurde ein Fehler 15 benannt, eine Datei würde fehlen, bitte Taste drücken....ein Schwarz-Weiss- Grub-Menü erscheint, mit der üblichen Auswahlliste, aber das einzige, was ich daraus tatsächlich starten kann, ist mein Windows-System.....

Meine Lösungssuche:

1 Installations-CD eingelegt, Reparatur-Funktion aufgerufen (das Menü hat die Kernel-Bezeichnung 2.6.22.5.-31 default). Meldung: „An error occurred during the installation“.
2. Ich starte „Installation or Update“ - war wohl verkehrt, es wird dann nach Partitionen gefragt.. Über FTP könnte ich eine IP-Adresse eingeben, um an ein Repo zu kommen, aber das lasse ich mal...
3. 2 Dinge fünktionieren: der Rescue-Zugang (aber was sollte ich am Prompt eingeben?) und der Menüpunkt „Boot installed system“ - gottseidank läuft dann mit CD-Hilfe ein (zäher) Normalstart ab, aber ich bin wieder auf meinem openSuse-Desktop.
4.Ich möchte natürlich nicht dauernd per CD und über eine umständliche Menü-Schlitterei starten – ich vermute, dass ein Kernelversionskonflikt hinter dem Ganzen stecken könnte, und schaue mir erst einmal eine beim Stöbern unter die Finger geratene Boot-LOG-Datei /var/log/boot.msg an. Dort finde ich unter meinem Hilfsstart (= Start mit CD) die auffälligen Einträge

Code: Alles auswählen

Cannot find map file.
No module symbols loaded - kernel modules not enabled.
Cannot build symbol table - disabling symbol lookups
Aber starten tat's dann doch....ist wohl nicht so wichtig.

Obige Einträge finden sich bei der Bootverweigerung ( = Start ohne CD) nicht, aber dafür dann
(ebenfalls nicht so wichtig?):

Code: Alles auswählen

Failed features: boot.apparmor
und dann aber drastisch

Code: Alles auswählen

FATAL: Could not load /lib/modules/2.6.22.5-31-default/modules.dep: No such file or directory
failed
Auf Festplatte unter /lib/modules finde ich Ordner, die mit 2.6.22.12-0.1 default und 2.6.22.9-0.4 default benannt sind (zusätzlich habe ich mir noch nach dem Fehlboot etwas nachinstalliert mit den gleichen Bezeichnungen, aber den Zusätzen debug bzw. bigsmp, aber das spielt hier wohl keine besondere Rolle, weil's natürlich nichts verändert hat).

Habe ich mir mit der von openSuse automatisch empfohlenen Aktualisierung den Kernel verquast? Müsste in /lib/modules nicht ein mit 2.6.22.5-31 bezeichneter Ordner stehen? Anfängerpech. Was nun machen? Ich möchte wieder ein System, das normal startet. Mehr will ich ja garnicht, ich seh' ja schon drüber weg, dass ich am Bildschirmrand einen schwarzen Balken habe, mein Drucker HP930C erst nach etlichen Verrenkungen laufen wollte (unter 10.2 null Probleme), die TV-Karte nicht funktionieren will, meine 3D-Unterstützung auf einmal wieder futsch ist und...und...und... jezz brauch'ich ein bisserl Hilfe.
Sorry, dass der Beitrag so lang geworden ist, aber ich häng' auch schon das ganze Wochenende dran...
rolas

Werbung:
trustkill
Hacker
Hacker
Beiträge: 300
Registriert: 21. Jul 2006, 11:33

Beitrag von trustkill » 12. Nov 2007, 07:32

Hallo,

imho funktioniert die Reparatur Funktion von der 10.3 DVD nicht. Da ist wohl ein klitzekleiner aber nerviger Bug.
Bild
openSuSE 10.3 | KDE | AMD Athlon64 X2 4200+ EE| MSI K9VGM-V | Nvidia Geforce 7100 GS 256MB | CompizFusion

pitfl
Member
Member
Beiträge: 174
Registriert: 20. Jan 2006, 14:26

Beitrag von pitfl » 12. Nov 2007, 09:49

lege mal als root mit dem Befehl mk_initrd die initrd neu an.

viele Grüße
pitfl

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 12. Nov 2007, 18:25

Code: Alles auswählen

Cannot find map file.
No module symbols loaded - kernel modules not enabled.
Cannot build symbol table - disabling symbol lookups
hat nichts mit initrd zu tun, lediglich mit /boot/System.map*

rolas
Newbie
Newbie
Beiträge: 8
Registriert: 12. Mai 2007, 11:34
Wohnort: Karlsruhe

Beitrag von rolas » 13. Nov 2007, 01:12

Danke für die Antworten. Habe nochmals überlegt und herumgelesen, was eigentlich passiert ist:

Das Aktualisierungs-Kernelupdate von Vers 2.6.22.5.-31 nach Vers. 2.6.22.9-0.4 hat nur zum Teil geklappt; im Startbildschirm wird die neue Kernelversion zwar angekündigt, aber die alte steckt noch im System...

Den Tipp mit initrd habe ich umgesetzt, und dabei Meldungen erhalten:

Code: Alles auswählen

mk_initrd

Code: Alles auswählen

Kernel image:   /boot/vmlinuz-2.6.22.12-0.1-bigsmp
Initrd image:   /boot/initrd-2.6.22.12-0.1-bigsmp
Root device:    /dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1MA106357-part5 (/dev/sda5) (mounted on / as ext3)
Kernel Modules: processor thermal scsi_mod libata pata_amd sata_nv fan jbd mbcache ext3 edd sd_mod usbcore ohci-hcd uhci-hcd ehci-hcd ff-memless hid usbhid
Features:       block usb resume.userspace resume.kernel
Bootsplash:     SuSE (1024x768)
17919 blocks

Kernel image:   /boot/vmlinuz-2.6.22.12-0.1-debug
Initrd image:   /boot/initrd-2.6.22.12-0.1-debug
Root device:    /dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1MA106357-part5 (/dev/sda5) (mounted on / as ext3)
Kernel Modules: processor thermal scsi_mod libata pata_amd sata_nv fan jbd mbcache ext3 edd sd_mod usbcore ohci-hcd uhci-hcd ehci-hcd ff-memless hid usbhid
Features:       block usb resume.userspace resume.kernel
Bootsplash:     SuSE (1024x768)
17949 blocks

Kernel image:   /boot/vmlinuz-2.6.22.12-0.1-default
Initrd image:   /boot/initrd-2.6.22.12-0.1-default
Root device:    /dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1MA106357-part5 (/dev/sda5) (mounted on / as ext3)
Kernel Modules: processor thermal scsi_mod libata pata_amd sata_nv fan jbd mbcache ext3 edd sd_mod usbcore ohci-hcd uhci-hcd ehci-hcd ff-memless hid usbhid
Features:       block usb resume.userspace resume.kernel
Bootsplash:     SuSE (1024x768)
17459 blocks
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
Command failed
Nirgendwo taucht die neue Kernelversionsnummer auf, und ganz zum Schluss gibts eine Fehlermeldung. Bei Systemstart erhalte ich wie gesagt einen error 15/Datei fehlt>>>>

Könnte ich den Kernel-Patch von Hand vielleicht nochmal "drüberbügeln" (wie?), oder gibt es eine elegante Kommandozeilenlösung?. Bin gespannt.
Gruß
rolas

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Beitrag von TomcatMJ » 13. Nov 2007, 02:16

Hi!
Du suchst eine Anleitung um das Kernelupdate loszuwerden?
Siehe dazu unter http://www.linux-club.de/viewtopic.php?p=523024#523024 ...

Bis denne,
Tom

rolas
Newbie
Newbie
Beiträge: 8
Registriert: 12. Mai 2007, 11:34
Wohnort: Karlsruhe

Beitrag von rolas » 14. Nov 2007, 19:40

Schäm!
Habe mir die Kernel-Deinstallation nicht so sehr zugetraut (für einen Anfänger dauerts eh' alles länger, und dann noch der Frust eines Misserfolgs, nach etlichen Stunden Herumgefrickel....), d.h. ich hab's grob gemacht und openSuse einfach neu installiert. Allerdings habe ich vor irgendwelchen Konfigurationen zuerst sofort die Repositories eingerichtet und dann als folgende Aktion gleich 35 Updates aufgespielt - auch wieder das bewusste Update, das wegen Kernelbeteiligung einen Neustart verlangte - nach dem dann nichts mehr ging....aber diesmal gings. Vielleicht habe ich mir dadurch ja nicht so viel hart erkämpfte Fertigkeiten erworben, wie nach weiteren möglichen Tagen der Lösungssuche, aber ich muss mit dem PC ein paar dringende Arbeiten erledigen, tja das gibts....mit nun der Kernelversion 2.6.22.12-0.1.
Und woher kam's? Der Herr im Himmel oder openSuse, das einen Update-Fehler inzwischen gepatcht hat, egal!
Danke für Eure Tipps!

rolas

Antworten