Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

libasound.so.2 Fehl

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

libasound.so.2 Fehl

Beitrag von SquirrelFrank » 28. Mär 2007, 17:22

hi!

wenn ich ein Prgramm von mir starten will, kommt folgende Fehlermeldung:

Code: Alles auswählen

/opt/firstclass/fcc: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64
wenn ich mir jetzt anschaue, welche libs firstclass braucht, dann steht da bei libasound:

Code: Alles auswählen

squirrel@linux-3xhv:~> ldd /opt/firstclass/fcc
        libasound.so.2 => not found
Die Datei libasound.so.2 ist im Ordner /user/lib/ (ca. 3MB groß) und /user/lib64/ (ca. 800kb groß) vorhanden, im Ordner /lib/ jedoch nicht.

Das komische ist aber, dass die Datei eine Verknüpfung ist, und ich sie somit irgendwie nicht kopieren kann.

Was kann ich jetzt tun, um das Programm zum Laufen zu bringen?

lg. Squirrel

PS: ich habe schon eine config datei im firstclass ordner gesucht, um einen anderen Pfad für die Datei einzugeben, habe aber keinen gefunden.


[/code]
Bild

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 29. Mär 2007, 06:07

Hi

Sag uns mal welches OS du hast. :wink:

cu

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 29. Mär 2007, 06:14

Code: Alles auswählen

rpm -qa | egrep 'alsa|kernel'
?
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

Beitrag von SquirrelFrank » 1. Apr 2007, 22:45

sry, für die späte Antwort

OS: Suse 10.2

Code: Alles auswählen

 rpm -qa | egrep 'alsa|kernel'
alsa-1.0.13-22
linux-kernel-headers-2.6.18.2-3
alsa-plugins-1.0.12-30
alsa-tools-gui-1.0.13-19
java-1_5_0-sun-alsa-1.5.0_update10-2.1
FA_clalsadrv-1.1.0-21
kernel-default-2.6.18.8-0.1
alsa-plugins-pulse-1.0.12-30
alsamodular-1.8.7-0.pm.1
kernel-xen-2.6.18.8-0.1
alsa-plugins-jack-1.0.12-30
alsamixergui-0.9.0rc1-579
gmerlin-alsamixer-0.3.5-0.pm.1
kalsatools-1.5.0-391
alsa-patch-bay-1.0.0-0.pm.2
alsa-32bit-1.0.13-22
alsa-devel-1.0.13-22
kernel-source-2.6.18.8-0.1
alsa-firmware-1.0.13-17
alsa-tools-1.0.13-19
lg. Franz

PS: ich verwende OSS, weil Alsa nicht funktioniert!
Bild

Antworten