unlogischer Fehler beim installieren von libdvdcss2

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
commander_leberkaes
Member
Member
Beiträge: 76
Registriert: 24. Dez 2005, 01:25

unlogischer Fehler beim installieren von libdvdcss2

Beitrag von commander_leberkaes » 15. Okt 2006, 22:36

Hallo,
hab mir das RPM-Paket libdvdcss2-1.2.9-0.pm.0.nosrc runtergeladen und wenn ich das per YAST installieren will, dauerts erstmal ne Weile und dann kommt die meldung, dass das Paket nicht gefunden wurde. Was soll das denn? Veräppeln kann ich mich selbst.
Hilfe, danke.
leberkäs
root bloody root
Athlon Xp 2000, 512MB,Suse10.1,KDE 3.5

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8744
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 15. Okt 2006, 22:39

Runterladen und per YaST installieren, bedeutet es aus dem Konqueror heraus installieren ?

*kopfschüttel* ... geht nicht ... steht aber auch gepinnt hier im Forum !
http://www.linux-club.de/ftopic60316.html

Installiere es als root in einer Shell mit:

Code: Alles auswählen

rpm -Uhv /pfad/zum/rpm/libdvdcss2-1.2.9-0.pm.0.nosrc
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 15. Okt 2006, 23:03

Fast richtig...

.nosrc.rpm ist ein Source-RPM, d.h. YaST ist überhaupt nicht das richtige Tool dafür. YaST ist ein Installer für Binary-RPMs.

Besuche die Webseite, von der Du das .nosrc.rpm heruntergeladen hast, und befolge genauestens die dortigen Anweisungen.

Falls Du die Webseite nicht mehr weißt, kein Problem, hier ist sie:

http://packman.links2linux.de/package/122
Laden Sie die libdvdcss tar.bz2-Datei in der zum nosrc.rpm passenden Version von videolan, kopieren Sie die Datei nach /usr/src/packages/SOURCES/, laden Sie das nosrc.rpm runter und übersetzen Sie die Bibliothek mit (rpm < 4) rpm --rebuild --target=i686 libdvdcss*.nosrc.rpm bzw. (rpm >= 4) rpmbuild --rebuild --target=i686 libdvdcss*.nosrc.rpm. Die fertigen RPMs finden sich dann unter /usr/src/packages/RPMS/i686/, die sie wie gewohnt installieren können.
=> Nix YaST.
openSUSE Factory - GNOME 2.32.1

Benutzeravatar
commander_leberkaes
Member
Member
Beiträge: 76
Registriert: 24. Dez 2005, 01:25

Beitrag von commander_leberkaes » 16. Okt 2006, 19:05

Aha, ja hab das schon gemerkt, dass das bei keinem RPM geht.
Wann gibts denn da mal ein Update, das ist ja schon lange bekannt?

Und noch was anderes, hab das libdvdcss und win32codecs jetzt per Konsole installiert. Wie kann ich überprüfen, ob das dann auch wirklich vorhanden ist? Bekomme außer "100%" keine Rückmeldung und DVD Wiedergabe mit Kaffeine geht immernoch nicht. Liegt also nahe, dass es nicht geklappt hat, mit der Installation ?!
root bloody root
Athlon Xp 2000, 512MB,Suse10.1,KDE 3.5

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 16. Okt 2006, 23:26

Und hier die Frage des Tages: ist libdvdcss wirklich noch notwendig? xine tut's auch ohne (heißt rpm macht keine Abhängigkeit draus).

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 17. Okt 2006, 00:05

commander_leberkaes hat geschrieben:Aha, ja hab das schon gemerkt, dass das bei keinem RPM geht.
Wann gibts denn da mal ein Update, das ist ja schon lange bekannt?
Für SUSE 10.1 wird es niemals ein Update geben, das dieses Problem löst. Wenn Du diesen Umstand nicht akzeptieren kannst, dann kannst Du SUSE 10.1 nicht verwenden, sondern musst auf 10.2 warten oder eine andere Distribution umsteigen.

So naivlich-einfach wie "das Problem ist ja schon lange bekannt, wo bleibt das Update" läuft es leider nicht. Dieses Update würde einen Backport von einem Ausmaß und vor allem QA-Bedarf erfordern, den Du bei einem kostenlosen bzw. maximal 50€ kostenden Produkt einfach nicht bekommst.

Ich weiß nicht mal, ob der SUSE Linux Enterprise Desktop so einen Backport mit dem nächsten Service-Pack bekommt (wahrscheinlich nicht, weil der Zen-Installer dieselbe Funktionalität bietet und funktioniert). Das Problem steckt wesentlich tiefer, als jemand, der nur den nicht funktionierenden Button sieht, wahrscheinlich vermutet und ist wahrlich nicht durch Umlegen eines Schalters zu lösen.

Ich hab damals schon gesagt, dass dieser verdammte Button einfach entfernt werden muss, wenn er nicht funktioniert, weil Anwender den Button einfach nur sehen und erwarten, dass er funktioniert und es sie nicht sonderlich interessiert, warum er nicht funktioniert. Aber die Bugliste war damals wohl einfach zu lang und der entsprechende Report leider nur "Major" mit zig "Critical"- und "Blocker"-Bugs darüber... :roll:

PS: Ansonsten ist die Bemerkung übrigens auch noch off-topic, weil es zwar wahr ist, dass der Button bei Binary-RPMs nicht funktioniert, es hier aber um Source-RPMs geht, die man grundsätzlich nicht mit YaST, sondern von der Konsole aus installiert, weil man zum Rebuilden sowieso auf die Konsole wechseln muss.

Was Dein Problem mit kaffeine angeht: Probier doch einfach mal die libxine1 aus dem PackMan-Repository. Im Gegensatz zu der von SUSE kann diese nämlich theoretisch eine libdvdcss nutzen, wenn sie installiert ist. Alles immer wieder dasselbe und ewig bekannt: Die xine-lib von SUSE ist aus rechtlichen Gründen ohne libdvdcss-Unterstützung kompiliert, kann keine libdvdcss nutzen, nicht mal wenn sie installiert ist und muss deshalb durch die libxine1 von PackMan ersetzt werden.

@jengelh: libdvdcss wird zur Laufzeit nachgeladen (aber auch dann nur, wenn dies nicht - wie im SUSE-Paket - explizit deaktiviert ist).
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste