[erledigt - aber wie?] YOU meldet nur noch Fehler

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
anna_kaa
Newbie
Newbie
Beiträge: 5
Registriert: 11. Okt 2006, 22:09

[erledigt - aber wie?] YOU meldet nur noch Fehler

Beitrag von anna_kaa » 11. Okt 2006, 22:24

Hallo,
ich wollte vor ein paar Tagen mit YOU updaten (hats mir empfohlen), war irgendein Firefox-Update. Damit gab's irgendein Problem, hab leider vergessen, was. Jedenfalls lief danach Firefox nicht mehr, so dass ich das neu gemacht habe. Da lag das Problem aber anscheinend nicht.
Seitdem kann ich auch keine neueren Updates mehr installieren. Zwei verschiedene Fehlermeldungen gibt's (läuft aber wohl auf das gleiche hinaus):

1. ERROR(Media:Unkown error in subsystem)[/var/lib/YaST2/you/mnt/i386/update/10.0/rpm/i586
2. ERROR(You:Das Verzeichnis konnte nicht angelegt werden.)
/var/lib/YaST2/you/mnt/i386/update/10.0/rpm/i586

Das Verzeichnis konnte ich auch nicht selbst anlegen ("keine Berechtigung", obwohl ich als Root ja doch im Überordner Schreibberechtigung hab...). Außerdem passiert das hier, wenn ich in "rpm" ls mache (als Root):

/bin/ls: i586: Keine Berechtigung
. ..

Ich hab openSuSE 10.0. Vorher hat das immer funktioniert...
Jetzt bin ich mit meinem Latein am Ende, Google hilft auch nix.
Vielen Dank für eure Hilfe.
Zuletzt geändert von anna_kaa am 16. Okt 2006, 15:00, insgesamt 1-mal geändert.

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 11. Okt 2006, 23:12

Das Problem hat nichts mit YOU zu tun, sondern liegt wohl am Dateisystem.

Probier mal folgendes:

Code: Alles auswählen

cd /var/lib/YaST2/you/mnt/i386/update/10.0/rpm
echo *
file *
/bin/ls -la
du
Bitte die Ergebnisse mitteilen (und dabei nichts abkürzen).
openSUSE Factory - GNOME 2.32.1

anna_kaa
Newbie
Newbie
Beiträge: 5
Registriert: 11. Okt 2006, 22:09

Beitrag von anna_kaa » 12. Okt 2006, 06:36

Ui, da wär ich ja nie drauf gekommen.
Also:

k062:/ # cd var/lib/YaST2/you/mnt/i386/update/10.0/rpm
k062:/var/lib/YaST2/you/mnt/i386/update/10.0/rpm # echo *
i586
k062:/var/lib/YaST2/you/mnt/i386/update/10.0/rpm # file *
i586: cannot open `i586' (Permission denied)
k062:/var/lib/YaST2/you/mnt/i386/update/10.0/rpm # /bin/ls -la
/bin/ls: i586: Keine Berechtigung
insgesamt 0
drwxr-xr-x 3 root root 72 2006-10-11 20:33 .
drwxr-xr-x 4 root root 96 2006-10-11 22:27 ..
k062:/var/lib/YaST2/you/mnt/i386/update/10.0/rpm # du
du: Zugriff auf „./i586“ nicht möglich: Keine Berechtigung
0 .

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 12. Okt 2006, 07:10

anna_kaa hat geschrieben:Ui, da wär ich ja nie drauf gekommen.
Wie meinen?

Vielleicht kommt ja jemand auf die Idee, "i586" - was auch immer es sein mag - zu löschen? Am besten gleich zusammen mit dem übergeordneten Verzeichnis

Code: Alles auswählen

rm -rf /var/lib/YaST2/you/mnt/i386/update/10.0/rpm
mkdir -p /var/lib/YaST2/you/mnt/i386/update/10.0/rpm
und dann von YOU neu erstellen lassen.
openSUSE Factory - GNOME 2.32.1

anna_kaa
Newbie
Newbie
Beiträge: 5
Registriert: 11. Okt 2006, 22:09

Beitrag von anna_kaa » 12. Okt 2006, 14:15

So passiert gar nix, der Ordner bleibt da, wo er ist.
Wenn ich das "f" weglasse, passiert das hier:

k062:/ # rm -r var/lib/YaST2/you/mnt/i386/update/10.0/rpm

rm: Aufruf von lstat für „var/lib/YaST2/you/mnt/i386/update/10.0/rpm/i586“ nicht möglich: Keine Berechtigung

Sieht aus, als könnte ich's auch nicht einfach löschen.
Ich dachte, "i586" ist der Ordner, wo YOU die Updates ablegen will, nicht?
(Und ich meinte, dass ich nicht drauf gekommen wäre, dass das Problem woanders liegt). Tut mir leid, falls ich mich irgendwie blöd anstelle. Aber danke schonmal.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 12. Okt 2006, 18:50

Welcher Dateisystem-Typ ist das?
openSUSE Factory - GNOME 2.32.1

anna_kaa
Newbie
Newbie
Beiträge: 5
Registriert: 11. Okt 2006, 22:09

Beitrag von anna_kaa » 12. Okt 2006, 19:06

reiserfs, falls du das meinst...
Aus der /etc/mtab:
/dev/hda2 / reiserfs rw,acl,user_xattr 0 0

anna_kaa
Newbie
Newbie
Beiträge: 5
Registriert: 11. Okt 2006, 22:09

[erledigt - aber wie?]

Beitrag von anna_kaa » 16. Okt 2006, 14:59

Mein Problem ist jetzt so schnell wieder verschwunden, wie es gekommen ist. Nur der Grund ist mir nicht so 100-prozentig klar.
Ich hab gestern mal smart installiert, zum ausprobieren. Das hat mir auch direkt einen Haufen Updates empfohlen. Als ich danach YaST wieder aufgerufen hab, wollte das auch Updaten - wieder alles auf andere Versionen (scheinen sich da nicht ganz einig zu sein). Diesmal hab ich aber YOU nicht vom SuSE-Watcher aus aufgerufen, sondern aus dem YaST-Menü ("Online-Update"). Das hab ich ihn dann mal machen lassen, ging auch. Als ich danach YOU vom Watcher aus gestartet habe, hat es anstandslos die Updates installiert, die vorher nicht gingen. Sieht also gut aus :-) . Wäre aber noch dankbar, wenn jemand wüsste, wo sowas herkommt. Mein Tipp ist ja nun, dass ich irgendwann vorher ein fehlerhaftes Update oder so installiert habe...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast