yast startet nich mehr

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

yast startet nich mehr

Beitrag von lampspace » 10. Okt 2006, 13:36

Hallo,
gerade wollte ich bei meinem rootserver (Suse 10 mit Plesk 8) Imagemagick Perl installieren, dann wollte er noch einige Pakete installieren.
Ich habe ihn gewähren lassen. Es kann sein, dass ich dabei nicht alle Paketabhängigkeiten berücksichtigt habe.
Auf einmal ist er aus yast ausgestiegen.
Als ich yast erneut aufrufen wollte kam die Felermeldung
warning: the ncurses frontend is installed but does not work
You need to install yast2-ncurses to use the YaST2 text mode interface
Wie bekomme ich yast wieder zu laufen ?
Wäre nett wenn Ihr mir ein paar Tipps geben könntet.

Werbung:
lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 14:49

Das sagt die Datei
/var/log/YaST2/y2logRPM

2006-09-22 19:00:06 perl-XML-LibXML remove ok
2006-09-22 19:00:06 perl-XML-SAX remove ok
2006-09-22 20:32:09 glibc-2.4-40.i686.rpm installed ok
2006-09-22 20:35:07 glibc-locale-2.4-41.i586.rpm installed ok
2006-09-22 20:35:14 slang-2.0.5-18.i586.rpm installed ok
2006-09-22 20:35:53 glibc-devel-2.4-40.i686.rpm installed ok
2006-09-22 20:36:19 mc-4.6.1-39.i586.rpm installed ok
Additional rpm output:
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
/etc/permissions
/etc/permissions.easy
/etc/permissions.local
setting /usr/lib/mc/cons.saver to root:root 4755. (wrong permissions 0755)
Finished.

2006-09-24 01:10:47 nano-1.3.12-5.i586.rpm installed ok
2006-09-24 01:10:48 pico-4.63-9.i586.rpm installed ok
2006-09-27 22:51:22 psa-hotfix5 remove ok
2006-09-27 22:51:22 psa-hotfix4 remove ok
2006-10-07 01:05:44 compat-expat1-1.95.8-14.i586.rpm installed ok
2006-10-07 01:05:45 expat-2.0.0-19.i586.rpm installed ok
2006-10-07 01:05:49 libjasper-1.701.0-23.i586.rpm installed ok
2006-10-07 01:05:51 liblcms-1.15-18.i586.rpm installed ok
2006-10-07 01:05:53 libpng-1.2.12-9.i586.rpm installed ok
2006-10-07 01:05:54 xorg-x11-libXau-7.1-12.i586.rpm installed ok
2006-10-07 01:05:57 xorg-x11-libXdmcp-7.1-13.i586.rpm installed ok
2006-10-07 01:05:59 libwmf-0.2.8.4-11.i586.rpm installed ok
2006-10-07 01:06:14 ImageMagick-6.2.8-8.i586.rpm installed ok
2006-10-10 12:11:21 audit-libs-1.2.6-6.i586.rpm installed ok
2006-10-10 12:11:27 compat-openssl097g-0.9.7g-20.i586.rpm installed ok
2006-10-10 12:11:28 libapr1-1.2.7-9.i586.rpm installed ok
2006-10-10 12:11:29 libvolume_id-101-2.i586.rpm installed ok
2006-10-10 12:11:34 libxml2-2.6.26-12.i586.rpm installed ok
Additional rpm output:
warning: /var/adm/SuSEconfig/run-libxml2 saved as /var/adm/SuSEconfig/run-libxml2.rpmsave

2006-10-10 12:11:37 python-xml-2.5-4.i586.rpm installed ok
2006-10-10 12:11:44 db-4.4.20-4.i686.rpm installed ok
2006-10-10 12:11:49 cyrus-sasl-2.1.22-12.i586.rpm installed ok
2006-10-10 12:11:54 iproute2-2.6.15-22.i586.rpm installed ok
2006-10-10 12:12:01 libapr1-devel-1.2.7-9.i586.rpm installed ok
2006-10-10 12:12:04 libxml2-python-2.6.26-12.i586.rpm installed ok
2006-10-10 12:13:38 perl-5.8.8-20.i586.rpm installed ok
Additional rpm output:
Updating etc/sysconfig/suseconfig...

2006-10-10 12:13:44 pam-0.99.6.3-8.i586.rpm installed ok
Additional rpm output:
warning: /etc/pam.d/common-password created as /etc/pam.d/common-password.rpmnew

2006-10-10 12:13:47 webalizer-2.01-752.i586.rpm installed ok
2006-10-10 12:13:48 deltarpm-3.3-19.i586.rpm installed ok
2006-10-10 12:13:55 openssl-0.9.8d-2.i586.rpm installed ok
2006-10-10 12:13:56 perl-Config-Crontab-1.11-18.i586.rpm installed ok
2006-10-10 12:13:58 perl-Data-ShowTable-3.3-590.i586.rpm installed ok
2006-10-10 12:13:59 perl-Digest-MD4-1.5-19.i586.rpm installed ok
2006-10-10 12:14:02 perl-Digest-SHA1-2.11-8.i586.rpm installed ok
2006-10-10 12:14:02 perl-FreezeThaw-0.43-22.i586.rpm installed ok
2006-10-10 12:14:03 perl-Font-AFM-1.19-67.i586.rpm installed ok
2006-10-10 12:14:04 perl-HTML-Tagset-3.10-18.i586.rpm installed ok
2006-10-10 12:14:05 perl-IO-Zlib-1.04-20.i586.rpm installed ok
2006-10-10 12:14:05 perl-MLDBM-2.01-268.i586.rpm installed ok
2006-10-10 12:14:06 perl-Net-Daemon-0.38-67.i586.rpm installed ok
2006-10-10 12:14:09 perl-Net-IP-1.23-20.i586.rpm installed ok
2006-10-10 12:14:11 perl-Parse-RecDescent-1.80-265.i586.rpm installed ok
2006-10-10 12:14:13 perl-PerlMagick-6.2.8-8.i586.rpm installed ok
2006-10-10 12:14:15 perl-Text-Iconv-1.4-20.i586.rpm installed ok
2006-10-10 12:14:16 perl-Tie-Cache-0.17-262.i586.rpm installed ok
2006-10-10 12:14:16 perl-Tie-IxHash-1.21-606.i586.rpm installed ok
2006-10-10 12:14:17 perl-TimeDate-1.16-142.i586.rpm installed ok
2006-10-10 12:14:19 perl-URI-1.35-21.i586.rpm installed ok
2006-10-10 12:14:19 perl-XML-LibXML-Common-0.13-23.i586.rpm installed ok
2006-10-10 12:14:20 perl-gettext-1.05-19.i586.rpm installed ok
2006-10-10 12:14:26 bind-libs-9.3.2-28.i586.rpm installed ok
2006-10-10 12:14:29 openldap2-client-2.3.27-7.i586.rpm installed ok
2006-10-10 12:14:35 opensc-0.11.1-2.i586.rpm installed ok
2006-10-10 12:14:37 perl-Bootloader-0.3.1-3.i586.rpm installed ok
2006-10-10 12:14:38 perl-Crypt-SmbHash-0.12-19.i586.rpm installed ok
2006-10-10 12:14:38 perl-Digest-HMAC-1.01-513.i586.rpm installed ok
2006-10-10 12:14:40 perl-HTML-Parser-3.55-8.i586.rpm installed ok
2006-10-10 12:14:41 perl-MLDBM-Sync-0.30-264.i586.rpm installed ok
2006-10-10 12:14:44 perl-Net_SSLeay-1.30-19.i586.rpm installed ok
2006-10-10 12:14:45 perl-PlRPC-0.2018-19.i586.rpm installed ok
2006-10-10 12:14:46 perl-X500-DN-0.28-139.i586.rpm installed ok
2006-10-10 12:14:48 postgresql-libs-8.1.4-8.i586.rpm installed ok
2006-10-10 12:14:56 yast2-core-2.14.2-2.i586.rpm installed ok
2006-10-10 12:15:00 bind-utils-9.3.2-28.i586.rpm installed ok
2006-10-10 12:15:03 cyrus-sasl-saslauthd-2.1.22-12.i586.rpm installed ok
Additional rpm output:
Updating etc/sysconfig/saslauthd...

2006-10-10 12:15:12 gpg-1.4.5-8.i586.rpm installed ok
2006-10-10 12:15:13 ldapcpplib-0.0.4-21.i586.rpm installed ok
2006-10-10 12:15:14 libapr-util1-1.2.7-10.i586.rpm installed ok
2006-10-10 12:15:16 perl-DBI-1.52-5.i586.rpm installed ok
2006-10-10 12:15:19 perl-HTML-Tree-3.21-8.i586.rpm installed ok
2006-10-10 12:15:23 perl-Net-DNS-0.59-4.i586.rpm installed ok
2006-10-10 12:15:31 perl-libwww-perl-5.805-18.i586.rpm installed ok
2006-10-10 12:15:38 postgresql-8.1.4-8.i586.rpm installed ok
2006-10-10 12:15:44 pwdutils-3.1.1-5.i586.rpm installed ok
2006-10-10 12:16:35 samba-client-3.0.23c-5.i586.rpm installed ok
Additional rpm output:
warning: /etc/samba/smb.conf created as /etc/samba/smb.conf.rpmnew
Updating etc/sysconfig/network/dhcp...

2006-10-10 12:16:38 apache2-prefork-2.2.3-8.i586.rpm installed ok
2006-10-10 12:16:45 bind-9.3.2-28.i586.rpm installed ok
Additional rpm output:
warning: /etc/named.conf created as /etc/named.conf.rpmnew
Updating etc/sysconfig/named...
waiting for named to shut down cp: cannot stat `/etc/named.conf': No such file or directory
..failed

2006-10-10 12:16:50 dbus-1-0.92-10.i586.rpm installed ok
2006-10-10 12:16:52 libapr-util1-devel-1.2.7-10.i586.rpm installed ok
2006-10-10 12:16:53 perl-DBD-mysql-3.0007-5.i586.rpm installed ok
2006-10-10 12:16:54 perl-HTML-Format-2.04-21.i586.rpm installed ok
2006-10-10 12:16:56 perl-IO-Socket-SSL-1.01-5.i586.rpm installed ok
2006-10-10 12:17:02 perl-spamassassin-3.1.4-8.i586.rpm installed ok
2006-10-10 12:17:33 postgresql-server-8.1.4-8.i586.rpm installed ok
Additional rpm output:
Updating etc/sysconfig/postgresql...
..dead

2006-10-10 12:17:55 samba-3.0.23c-5.i586.rpm installed ok
2006-10-10 12:18:03 apache2-2.2.3-8.i586.rpm installed ok
Additional rpm output:
warning: /etc/apache2/httpd.conf created as /etc/apache2/httpd.conf.rpmnew
warning: /etc/apache2/listen.conf created as /etc/apache2/listen.conf.rpmnew
warning: /etc/apache2/mod_mime-defaults.conf created as /etc/apache2/mod_mime-defaults.conf.rpmnew
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
/etc/permissions
/etc/permissions.easy
/etc/permissions.local
setting /usr/bin/gpg to root:root 4755. (wrong permissions 0755)
setting /usr/sbin/suexec2 to root:www 4510. (wrong owner/group root:root permissions 0755)
Finished.
Updating etc/sysconfig/apache2...
looking for old 2.0 modules to be renamed...
auth -> auth_basic authn_file


!!!ATTENTION!!!

If you use basic authentication, you will need to update your
configuration. Typically, you need to add
AuthBasicProvider file
(example for file-based authentication) below "AuthType Basic".

!!!ATTENTION!!!


access -> authz_host
auth_dbm -> authn_dbm
Done.

2006-10-10 12:18:05 dbus-1-glib-0.71-9.i586.rpm installed ok
2006-10-10 12:18:19 spamassassin-3.1.4-8.i586.rpm installed ok
Additional rpm output:
Updating etc/sysconfig/spamd...
Shutting down psa-spamassassin service: ..done
Starting psa-spamassassin service: ..done

2006-10-10 12:18:20 PolicyKit-0.2_git20060822-8.i586.rpm installed ok
2006-10-10 12:18:23 apache2-devel-2.2.3-8.i586.rpm installed ok
2006-10-10 12:18:46 apache2-mod_perl-2.0.2-23.i586.rpm installed ok
2006-10-10 12:18:53 apache2-mod_python-3.2.10-8.i586.rpm installed ok
2006-10-10 12:19:01 hal-0.5.8_git20060927-4.i586.rpm installed ok
2006-10-10 12:19:06 hwinfo-13.5-3.i586.rpm installed ok
2006-10-10 12:19:19 libzypp-2.2.3-2.i586.rpm installed ok
2006-10-10 12:19:20 powersave-libs-0.15.2-5.i586.rpm installed ok
2006-10-10 12:19:26 powersave-0.15.2-5.i586.rpm installed ok
Additional rpm output:
Updating etc/sysconfig/powersave/scheme_acoustic...
Updating etc/sysconfig/powersave/scheme_performance...
Updating etc/sysconfig/powersave/scheme_powersave...
Updating etc/sysconfig/powersave/scheme_presentation...
Updating etc/sysconfig/powersave/scheme_advanced_powersave...
Updating etc/sysconfig/powersave/events...
Updating etc/sysconfig/powersave/thermal...
Updating etc/sysconfig/powersave/battery...
Updating etc/sysconfig/powersave/sleep...
Updating etc/sysconfig/powersave/cpufreq...
Updating etc/sysconfig/powersave/common...
Updating etc/sysconfig/powersave/disk...

2006-10-10 12:19:32 yast2-ncurses-2.13.44-3.i586.rpm installed ok
2006-10-10 12:19:34 yast2-perl-bindings-2.13.11-2.i586.rpm installed ok
2006-10-10 12:19:39 yast2-pkg-bindings-2.13.96-3.i586.rpm installed ok
2006-10-10 12:19:46 yast2-storage-2.14.8-2.i586.rpm installed ok

Jensemann
Newbie
Newbie
Beiträge: 16
Registriert: 29. Apr 2006, 17:19

Beitrag von Jensemann » 10. Okt 2006, 15:04

Das selbe Problem habe ich auch nach einem update von suse 9.3 auf 10.1 geht mein yast nicht mehr und meine confixx auch nicht !

Jensemann
Newbie
Newbie
Beiträge: 16
Registriert: 29. Apr 2006, 17:19

Beitrag von Jensemann » 10. Okt 2006, 15:05

aber apt gibt es wohl auch unter suse könnte man nicht yast mittels apt neu instalieren ?

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 15:26

wenn ich smart, das wohl der nachfolger von apt ist installieren will kommt
smart-0.42-1.24.i586.rpm: V3 DSA signature: NOKEY, key ID 6b9d6523
error: Failed dependencies:
python-elementtree is needed by smart-0.42-1.24
rpm-python is needed by smart-0.42-1.24
also müsste ich wohl erst python installieren und dazu brauche ich wahrscheinlich wieder yast

Jensemann
Newbie
Newbie
Beiträge: 16
Registriert: 29. Apr 2006, 17:19

Beitrag von Jensemann » 10. Okt 2006, 15:33

oder du lädst die die python rpm und instalierst per rpm

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 17:10

Mal wieder das pure Chaos im Thread... :roll:

Leute, welches Problem wollt ihr hier eigentlich lösen? YaST? smart? apt? confixx? Irgendwas anderes?

Das ursprüngliche Problem lautete:

Code: Alles auswählen

warning: the ncurses frontend is installed but does not work
You need to install yast2-ncurses to use the YaST2 text mode interface
Und ist wahrscheinlich sehr leicht zu lösen.

Führe bitte den Befehl

Code: Alles auswählen

ldd /usr/lib/YaST2/plugin/libpy2ncurses.so
aus und kopier die Ausgabe ins Forum oder schreib sie originalgetreu 1:1 ab.
openSUSE Factory - GNOME 2.32.1

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 18:25

die Antwort lautet:
# ldd /usr/lib/YaST2/plugin/libpy2ncurses.so
linux-gate.so.1 => (0xffffe000)
libyui.so.2 => /usr/lib/libyui.so.2 (0x40176000)
libzypp.so.202 => /usr/lib/libzypp.so.202 (0x40219000)
libncursesw.so.5 => /usr/lib/libncursesw.so.5 (0x40759000)
libpanelw.so.5 => /usr/lib/libpanelw.so.5 (0x407a7000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x407ab000)
libm.so.6 => /lib/libm.so.6 (0x40887000)
libc.so.6 => /lib/libc.so.6 (0x408ac000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x409cd000)
libpthread.so.0 => /lib/libpthread.so.0 (0x409d8000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0x409ec000)
libcurl.so.3 => /usr/lib/libcurl.so.3 (0x40b25000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x40b57000)
libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0x40b87000)
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x40bc4000)
librpm-4.4.so => not found
librpmdb-4.4.so => not found
librpmio-4.4.so => not found
libdl.so.2 => /lib/libdl.so.2 (0x40cf8000)
libz.so.1 => /lib/libz.so.1 (0x40cfc000)
libbz2.so.1 => /lib/libbz2.so.1 (0x40d0f000)
libpopt.so.0 => /usr/lib/libpopt.so.0 (0x40d21000)
libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x40d2a000)
libgobject-2.0.so.0 => /opt/gnome/lib/libgobject-2.0.so.0 (0x40d46000)
libglib-2.0.so.0 => /opt/gnome/lib/libglib-2.0.so.0 (0x40d80000)
librt.so.1 => /lib/librt.so.1 (0x40e08000)
libhal-storage.so.1 => /usr/lib/libhal-storage.so.1 (0x40e11000)
libhal.so.1 => /usr/lib/libhal.so.1 (0x40e1c000)
libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x40e28000)
libnsl.so.1 => /lib/libnsl.so.1 (0x40e59000)
libboost_regex.so.1.33.1 => not found
libboost_filesystem.so.1.33.1 => not found
libutil.so.1 => /lib/libutil.so.1 (0x40e6e000)
/lib/ld-linux.so.2 (0x80000000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40e73000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40ea4000)

Jensemann
Newbie
Newbie
Beiträge: 16
Registriert: 29. Apr 2006, 17:19

Beitrag von Jensemann » 10. Okt 2006, 19:16

Also ich habe genau das gleiche Problem hier mach mal meins :

# ldd /usr/lib/YaST2/plugin/libpy2ncurses.so
linux-gate.so.1 => (0xffffe000)
libyui.so.2 => /usr/lib/libyui.so.2 (0xb7daf000)
libzypp.so.0 => /usr/lib/libzypp.so.0 (0xb795d000)
libncursesw.so.5 => /usr/lib/libncursesw.so.5 (0xb7910000)
libpanelw.so.5 => /usr/lib/libpanelw.so.5 (0xb790d000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb782c000)
libm.so.6 => /lib/libm.so.6 (0xb7807000)
libc.so.6 => /lib/libc.so.6 (0xb76e7000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb76dc000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb76c8000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb7598000)
libcurl.so.3 => /usr/lib/libcurl.so.3 (0xb7563000)
libidn.so.11 => /usr/lib/libidn.so.11 (0xb7533000)
libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb74f6000)
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb73d0000)
libblkid.so.1 => /lib/libblkid.so.1 (0xb73c9000)
libuuid.so.1 => /lib/libuuid.so.1 (0xb73c6000)
librpm-4.4.so => not found
librpmdb-4.4.so => not found
librpmio-4.4.so => not found
libdl.so.2 => /lib/libdl.so.2 (0xb73c1000)
librt.so.1 => /lib/librt.so.1 (0xb73b8000)
libz.so.1 => /lib/libz.so.1 (0xb73a5000)
libbz2.so.1 => /lib/libbz2.so.1 (0xb7394000)
libpopt.so.0 => /usr/lib/libpopt.so.0 (0xb738c000)
libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb7373000)
libgobject-2.0.so.0 => /opt/gnome/lib/libgobject-2.0.so.0 (0xb733a000)
libglib-2.0.so.0 => /opt/gnome/lib/libglib-2.0.so.0 (0xb72b4000)
libhal-storage.so.1 => /usr/lib/libhal-storage.so.1 (0xb72ab000)
libhal.so.1 => /usr/lib/libhal.so.1 (0xb72a2000)
libdbus-1.so.2 => /usr/lib/libdbus-1.so.2 (0xb7273000)
libnsl.so.1 => /lib/libnsl.so.1 (0xb725e000)
libboost_filesystem.so.1.33.1 => /usr/lib/libboost_filesystem.so.1.33.1 (0xb724d000)
libboost_regex.so.1.33.1 => /usr/lib/libboost_regex.so.1.33.1 (0xb71ab000)
libutil.so.1 => /lib/libutil.so.1 (0xb71a6000)
/lib/ld-linux.so.2 (0x80000000)
libicui18n.so.34 => /usr/lib/libicui18n.so.34 (0xb708b000)
libicuuc.so.34 => /usr/lib/libicuuc.so.34 (0xb6f85000)
libicudata.so.34 => /usr/lib/libicudata.so.34 (0xb6717000)
Zuletzt geändert von Jensemann am 11. Okt 2006, 17:55, insgesamt 1-mal geändert.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 19:33

Beide Male dasselbe Problem:
Jensemann hat geschrieben:librpm-4.4.so => not found
librpmdb-4.4.so => not found
librpmio-4.4.so => not found
=> Ihr habt kein rpm oder eine falsche Version installiert oder ldconfig wurde nicht ausgeführt.

Bitte die Ausgabe von

Code: Alles auswählen

/sbin/ldconfig -p | grep rpm
uname -a
ls -l /usr/lib*/librpm*
rpm -q rpm
rpm -V rpm
/sbin/ldconfig -p | grep boost
ls -l /usr/lib*/libboost*
rpm -q boost
rpm -V boost
posten.
openSUSE Factory - GNOME 2.32.1

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 20:12

hier meine Ausgabe:

Code: Alles auswählen

# /sbin/ldconfig -p | grep rpm
nfig -p | grep boost
ls -l /usr/lib*/libboost*
rpm -q boost
rpm -V boost    librpmio-4.1.so (libc6) => /usr/lib/librpmio-4.1.so
        librpmdb-4.1.so (libc6) => /usr/lib/librpmdb-4.1.so
        librpmbuild-4.1.so (libc6) => /usr/lib/librpmbuild-4.1.so
        librpm-4.1.so (libc6) => /usr/lib/librpm-4.1.so
# uname -a
Linux h1044061 2.6.13-15.12-default #1 Thu Aug 24 11:23:58 UTC 2006 i686 i686 i386 GNU/Linux
# ls -l /usr/lib*/librpm*
-rwxr-xr-x  1 root root  320240 Sep  9  2005 /usr/lib/librpm-4.1.so
-rwxr-xr-x  1 root root  156572 Sep  9  2005 /usr/lib/librpmbuild-4.1.so
-rwxr-xr-x  1 root root 1028772 Sep  9  2005 /usr/lib/librpmdb-4.1.so
-rwxr-xr-x  1 root root  314868 Sep  9  2005 /usr/lib/librpmio-4.1.so
# rpm -q rpm
rpm-4.1.1-222
# rpm -V rpm
# /sbin/ldconfig -p | grep boost
        libboost_wserialization-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_wserialization-gcc-1_33.so.1.33.0
        libboost_unit_test_framework-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_unit_test_framework-gcc-1_33.so.1.33.0
        libboost_thread-gcc-mt-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_thread-gcc-mt-1_33.so.1.33.0
        libboost_test_exec_monitor-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_test_exec_monitor-gcc-1_33.so.1.33.0
        libboost_signals-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_signals-gcc-1_33.so.1.33.0
        libboost_serialization-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_serialization-gcc-1_33.so.1.33.0
        libboost_regex-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_regex-gcc-1_33.so.1.33.0
        libboost_program_options-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_program_options-gcc-1_33.so.1.33.0
        libboost_prg_exec_monitor-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_prg_exec_monitor-gcc-1_33.so.1.33.0
        libboost_iostreams-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_iostreams-gcc-1_33.so.1.33.0
        libboost_filesystem-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_filesystem-gcc-1_33.so.1.33.0
        libboost_date_time-gcc-1_33.so.1.33.0 (libc6) => /usr/lib/libboost_date_time-gcc-1_33.so.1.33.0
# ls -l /usr/lib*/libboost*
-rwxr-xr-x  1 root root  50253 Sep 13  2005 /usr/lib/libboost_date_time-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root  60397 Sep 13  2005 /usr/lib/libboost_filesystem-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root  32625 Sep 13  2005 /usr/lib/libboost_iostreams-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root  23797 Sep 13  2005 /usr/lib/libboost_prg_exec_monitor-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root 202169 Sep 13  2005 /usr/lib/libboost_program_options-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root 712825 Sep 13  2005 /usr/lib/libboost_regex-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root 423657 Sep 13  2005 /usr/lib/libboost_serialization-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root  69497 Sep 13  2005 /usr/lib/libboost_signals-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root 208077 Sep 13  2005 /usr/lib/libboost_test_exec_monitor-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root  75593 Sep 13  2005 /usr/lib/libboost_thread-gcc-mt-1_33.so.1.33.0
-rwxr-xr-x  1 root root 202709 Sep 13  2005 /usr/lib/libboost_unit_test_framework-gcc-1_33.so.1.33.0
-rwxr-xr-x  1 root root 349101 Sep 13  2005 /usr/lib/libboost_wserialization-gcc-1_33.so.1.33.0
# rpm -q boost
boost-1.33.0-3
# rpm -V boost

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 20:20

Du brauchst das hier:

Code: Alles auswählen

rpm -Uvh http://suse.inode.at/pub/update/10.1/rpm/i586/rpm.rpm
Bitte als root ausführen und bei Fehlermeldungen diese gleich mit posten.

Jensemann braucht außerdem zusätzlich noch boost.
openSUSE Factory - GNOME 2.32.1

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 20:33

bei mir kommt:
aber eigentlich war Suse 10.0 installiert, soll ich da in der URL aus der 10.1 ne 10.0 machen

Code: Alles auswählen

# rpm -Uvh http://suse.inode.at/pub/update/10.1/rpm/i586/rpm.rp
Retrieving http://suse.inode.at/pub/update/10.1/rpm/i586/rpm.rpm
error: Failed dependencies:
        librpm-4.1.so is needed by (installed) psa-autoinstaller-3.0.2-build060704.16
        librpm-4.1.so is needed by (installed) psa-8.0.1-suse10.0.build80060614.16
        librpm-4.1.so is needed by (installed) psa-fileserver-1.0.0-suse10.0.build80060614.16
        librpmdb-4.1.so is needed by (installed) psa-autoinstaller-3.0.2-build060704.16
        librpmdb-4.1.so is needed by (installed) psa-8.0.1-suse10.0.build80060614.16
        librpmdb-4.1.so is needed by (installed) psa-fileserver-1.0.0-suse10.0.build80060614.16
        librpmio-4.1.so is needed by (installed) psa-autoinstaller-3.0.2-build060704.16
        librpmio-4.1.so is needed by (installed) psa-8.0.1-suse10.0.build80060614.16
        librpmio-4.1.so is needed by (installed) psa-fileserver-1.0.0-suse10.0.build80060614.16

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 20:41

Das kommt dabei raus, wenn zwei Leute mit ähnlichem, aber ganz subtil unterschiedlichem Problem in ein und demselben Thread Hilfe suchen. :roll:

Also, sag nochmal möglichst klar, worum es bei Dir geht: Ging yast2 irgendwann einfach so nicht mehr, oder ist das ein Update, und wenn es ein Update ist, von welcher Version auf welche Version?
openSUSE Factory - GNOME 2.32.1

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 20:51

Also ich hab nen Rootserver mit Suse 10 und Plesk 8. Plesk hab ich webbasiert upgedatet und nur die veralteten Pakete per yast. Hat alles soweit geklappt. Heute wollte ich für mein Forum ImageMagick Perl installieren. Also perlmagick instattiert. Dabei wollte er noch einige Pakete mitinstallieren bzw. aktualisieren.
Ich hab ihn machen lassen und dann ist er ausgestiegen.
Danach wollte ich yast wieder aufrufen, ging nicht mehr.
Server rebootet und ich komme nur noch per Remoteconsole rein.
Zuletzt geändert von lampspace am 10. Okt 2006, 21:09, insgesamt 1-mal geändert.

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 20:55

weiter oben hab ich die komplette y2logRPM gepostet, falls das was hilft

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 20:59

Jensemann hat von suse 9.3 auf 10.1 upgedatet

ich müsste eigentlich noch immer Suse 10 haben wenn nichts allzusehr schief gegangen ist.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 21:14

lampspace hat geschrieben:Also ich hab nen Rootserver mit Suse 10 und Plesk 8.
Suse 10 gibt es nicht.

Es gibt:

SUSE Linux 10.0 => rpm-4.1
SUSE Linux 10.1 => rpm-4.4
openSUSE 10.2 => rpm-4.4
SLES 10 => rpm-4.4

Welches dieser Produkte verwendest Du? Poste bitte die Ausgabe des Befehls

Code: Alles auswählen

cat /etc/*-release
Wie ist es dazu gekommen, dass yast2 nicht mehr startet. Was hast Du webbasiert aktualisiert und von welcher Version auf welche Version - das ganze Betriebssystem oder ein einzelnes Paket wie Plesk, oder war das kein System-Update von einer Betriebssystemversion auf eine andere, sondern nur ein normales Online-Update, usw. usf.

Aus Deinem Beitrag vom 2006-Okt-10, 5:25 pm sehe ich, dass Dein System nach rpm-4.4 sucht, und aus Deinem Beitrag vom 2006-Okt-10, 7:33 pm sehe ich, dass irgendein Nicht-SUSE-Paket immer noch rpm-4.1 braucht. Du müsstest Dich dringend zwischen rpm-4.1 und rpm-4.4 entscheiden, deshalb habe ich oben alle Produkte, die einigermaßen auf "Suse 10" passen, einer RPM-Sollversion zugeordnet.
openSUSE Factory - GNOME 2.32.1

lampspace
Newbie
Newbie
Beiträge: 15
Registriert: 20. Jul 2004, 17:58

Beitrag von lampspace » 10. Okt 2006, 21:27

Code: Alles auswählen

# cat /etc/*-release
SUSE LINUX 10.0 (i586) OSS
VERSION = 10.0
2006072401
Der Server solte under Suse 10.0 laufen.
Ich habe nur Plesk webbasiert upgedatet von 8.0 auf 8.01.
Ich habe nur ganz normale Yast online opdates gemacht, kein Versions upgrade.

Bei den Updatesevern habe ich mal einige ergänzt, da die voreingestellten nicht erreichbar waren.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 10. Okt 2006, 22:00

Das ist völlig unmöglich. In keiner einzigen Installationsquelle für SUSE 10.0 gibt es rpm-4.4, und es wird von SUSE niemals rpm-Upgrades für alte Distributionen geben. Dein yast2-ncurses hat aber eine Abhängigkeit zu rpm-4.4 und stammt somit aus einer Installationsquelle, die nicht für SUSE 10.0 ist!

=> Du hast das System mit distributionsfremden Installationsquellen zerschossen. In dem weiter oben geposteten y2log-Auszug sehe ich:

2006-10-10 12:19:32 yast2-ncurses-2.13.44-3.i586.rpm installed ok

Das ist völlig verkehrt, denn die für SUSE 10.0 aktuellste Version von yast2-ncurses ist nicht 2.13.44-3, sondern 2.12.6-2.

Die Version 2.13.44-3 ist zufällig die neueste Version von yast2-ncurses aus dem Factory-Zweig. Kann es sein, dass Du die Factory-Installationsquelle in Deiner Konfiguration drin hast? Poste bitte die komplette Installationsquellen-Konfiguration.
openSUSE Factory - GNOME 2.32.1

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast